19:02:35 <rtheis> #startmeeting openstackclient
19:02:36 <openstack> Meeting started Thu Feb 25 19:02:35 2016 UTC and is due to finish in 60 minutes.  The chair is rtheis. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:40 <openstack> The meeting name has been set to 'openstackclient'
19:02:45 <stevemar> \o/
19:02:57 <rtheis> that's not too bad
19:03:15 <MeganR> o/
19:03:26 <stevemar> rtheis: other commands are #topic #endmeeting, etc..
19:03:39 <terrylhowe> o/
19:03:49 <rtheis> stevemar: any particular order to the meeting?
19:04:11 <stevemar> rtheis: i think we go: 1) open reviews, 2) open bugs, 3) open discussion
19:04:21 <rtheis> #topic reviews
19:04:22 <stevemar> toss in an argument about when to release
19:04:28 <rtheis> sure
19:04:38 <rtheis> Any reviews to discuss?
19:04:59 <stevemar> hmm
19:05:46 <stevemar> seems like the "create" commands are causing some issues with the networking commands, they just not as easy?
19:05:58 <stevemar> i guess delete and show are pretty quick :)
19:06:45 <rtheis> yeah, "create" have a lot more items to sort out, but I think they are coming along fairly well now
19:07:09 <stevemar> there's https://review.openstack.org/#/c/276041/
19:07:17 <stevemar> which seems to have gone on for a while now
19:07:31 <terrylhowe> neutron has a fair number of arrays of dicts, but there is that review out there for that parser action
19:07:46 <terrylhowe> yeh, that one
19:07:48 <stevemar> terrylhowe: that's what i just linked :)
19:07:52 <rtheis> stevemar: yes, that one is holding up a couple create commands
19:08:09 <stevemar> looks like dtroyer is just about convinced
19:08:13 <rtheis> I think it is close
19:08:19 <terrylhowe> yeh
19:08:43 <stevemar> i didn't check that one out, but it looks self-explanatory
19:08:55 <stevemar> there's https://review.openstack.org/#/c/276350/ which is going to be a pain
19:10:06 <rtheis> stevemar: sorry, but I'm not up to speed on that one.  What is the pain point?
19:11:21 <stevemar> rtheis: lots of different projects are going to grapple for handling authentication
19:11:38 <stevemar> i think we need to rip most of it and just pass along everything to os-client-config
19:11:55 <terrylhowe> I foolishly thought the ksa conversion was done
19:12:06 <rtheis> ok
19:12:20 <stevemar> terrylhowe: not even close
19:12:33 <stevemar> terrylhowe: we're still picking up auth plugins from keystoneclient :(
19:13:37 <stevemar> terrylhowe: if you want to work on it, go ahead, i think navid is working on other stuff (partly why it's WIP)
19:14:05 <rtheis> stevemar: is this something needed for mitaka release?
19:14:26 <stevemar> rtheis: it would be nice
19:14:41 <stevemar> rtheis: but clients aren't really bound to the release, they should be backwards compat
19:14:45 <stevemar> so meh
19:14:48 <rtheis> sure
19:16:13 <rtheis> anything more on this one?
19:16:17 <stevemar> rtheis: i also just got added to https://review.openstack.org/#/c/284497/
19:17:00 <rtheis> stevemar: I'll take a look
19:17:06 <stevemar> rtheis: cool
19:17:17 <stevemar> that's all the reviews from me
19:17:32 <rtheis> https://review.openstack.org/#/c/268907/
19:17:57 <stevemar> ah choices
19:18:00 <rtheis> "choices" ... do we have a devref on how to handle?
19:18:33 <rtheis> or an unwritten rule on when to use and when not?
19:18:50 <stevemar> rtheis: i believe we don't use them at all yet
19:19:03 <stevemar> oh wait... we do
19:19:09 <stevemar> https://github.com/openstack/python-openstackclient/search?utf8=%E2%9C%93&q=choices
19:19:42 <rtheis> I think this could impact some of the network create commands
19:19:50 <stevemar> rtheis: i think if the API is mature enough, then we go for it.
19:20:40 <rtheis> if not then we just leave it to the API to validate?
19:20:57 <rtheis> so the cli doesn't have to play catch up
19:21:10 <stevemar> yep
19:21:19 <rtheis> ok
19:21:23 <stevemar> rtheis: but help is much nicer when we have choices
19:21:30 <stevemar> and validation much faster
19:21:39 <rtheis> sure
19:21:40 <stevemar> thats why i say it depends on API maturity
19:22:10 <rtheis> ok
19:22:11 <stevemar> if things hit the fan, we can always whip up a quick patch and release
19:23:54 <rtheis> maybe I'll try capturing this in a deverlopers doc update
19:24:01 <rtheis> think that is worth while?
19:24:39 <stevemar> rtheis: absolutely
19:25:02 <rtheis> #action rtheis write developers doc update for handling choices in arguments
19:25:09 <stevemar> rtheis: we should also document all the steps for creating an OSC plugin, theres a lot of tribal knowledge
19:26:11 <rtheis> stevemar: do you hold the keys to this knowledge and have time to write something for it?
19:26:38 <stevemar> rtheis: i can whip something up over lunch
19:26:42 <rtheis> cool
19:27:08 <rtheis> #action stevemar to document all the steps for creating an OSC plugin
19:27:14 <rtheis> any other reviews ?
19:28:35 <rtheis> #topic bugs
19:28:53 <rtheis> any bugs to discuss ?
19:29:12 <stevemar> #link https://bugs.launchpad.net/python-openstackclient
19:29:16 <stevemar> list of bugs ^
19:29:20 <stevemar> wow, 98
19:29:24 <stevemar> we need to bring that down
19:29:38 <dtroyer> o/
19:29:45 <stevemar> eeeek, that's a lot of *new* ones too
19:29:52 <rtheis> dtroyer: hi
19:29:56 <dtroyer> sorry for being late…thanks for getting things started rtheis
19:30:01 <rtheis> yw
19:30:16 <dtroyer> (i haven't looked yet) how many of those bugs are new single commands?
19:30:28 <stevemar> we need a triage day :)
19:30:38 <stevemar> or week hehe
19:30:51 <stevemar> dtroyer: a good chunk are the new single commands
19:31:02 <stevemar> i'm not crazy about using bugs for that, but whatever gets things done
19:31:06 <rtheis> we may have a dozen that are for new commands
19:31:09 <dtroyer> maybe we can encourage folk to at least do one per resource?
19:31:34 <stevemar> yeah, a bug for pool set and another for pool create seems like overkill
19:31:46 <rtheis> I updated neutron-client blueprint to request future work to be done via blue print
19:31:48 <dtroyer> stackalytics?
19:31:54 <rtheis> https://blueprints.launchpad.net/python-openstackclient/+spec/neutron-client
19:31:55 <dtroyer> thanks
19:32:48 <stevemar> dtroyer: you should add rtheis and tangchen to https://launchpad.net/~python-openstackclient-drivers/+members#active
19:33:16 <dtroyer> thanks for the reminder, I always seem to forget that part
19:33:46 <rtheis> stevemar: what is the result of being added to that list?
19:34:05 <stevemar> rtheis: i think you can mark bugs as invalid, incomplete or fix released
19:34:08 <dtroyer> done
19:34:12 <rtheis> ok
19:34:21 <dtroyer> basically, yeah
19:35:44 <rtheis> dtroyer: is there a way to pass the meeting chair back to you?
19:36:22 <stevemar> rtheis: nope!
19:36:29 <rtheis> ok
19:36:36 <dtroyer> no, but it only really matters when it is time to endmeeting
19:36:42 <rtheis> ok
19:36:44 <stevemar> oh right, bugs...
19:36:47 <dtroyer> you are doing fine though
19:36:58 <stevemar> none seem critical
19:36:59 <dtroyer> .me looking through scrollback
19:37:25 <rtheis> I don't have any specific bugs to discuss
19:38:04 <dtroyer> I am digging in to https://bugs.launchpad.net/python-openstackclient/+bug/1549095 today with John.  I don't know yet who exactly broke —os-token though
19:38:04 <openstack> Launchpad bug 1549095 in Ironic "devstack fails while running Ironic grenade job: init__() got an unexpected keyword argument 'token'" [Undecided,In progress] - Assigned to John L. Villalovos (happycamp)
19:38:23 <dtroyer> but it attempts to use v2Password when both —os-token and —os-url are present.
19:38:35 <dtroyer> we have a hard branch for that combo and it is being bypassed
19:38:58 <dtroyer> part of what I saw in scrollback, I suspect something around o-c-c and it's land grab
19:39:09 <stevemar> there's https://bugs.launchpad.net/python-openstackclient/+bug/1535562 also, which thomas usually reports
19:39:09 <openstack> Launchpad bug 1535562 in python-openstackclient "Unit test failure when buildnig debian package for 2.0.0" [Undecided,New]
19:40:03 <dtroyer> too many dependencies.  we haven't eliminated any yet, only added
19:40:06 <dtroyer> :(
19:41:39 <stevemar> dtroyer: yeah, we should look into minimizing things :(
19:42:29 <dtroyer> I'd love to be able to drop glanceclient for the SDK, it would take a couple of psinful deps with it
19:42:39 <dtroyer> openssl
19:43:30 <dtroyer> #topic open discussion
19:43:38 <stevemar> dtroyer: not so fast!
19:43:41 <stevemar> rtheis: 6
19:43:44 <stevemar> rtheis: ^
19:43:47 * dtroyer hits brakes
19:44:17 <rtheis> stevemar: 6 ?
19:44:22 <stevemar> i meant ^
19:44:29 <stevemar> rtheis:  switch topic :)
19:44:35 <rtheis> ok
19:44:41 <rtheis> #topic open discussion
19:44:42 <dtroyer> oh, right, he has to do that too
19:44:56 <dtroyer> It is summit room allocation time again
19:45:14 <stevemar> fun times
19:45:19 <dtroyer> we've had one of each type for the last couple of summits…I'm wondering if we need to make any changes?
19:45:28 <stevemar> we had 1 of each last time
19:45:32 <dtroyer> 1 fishbowl, 1 workroom, 1 meetup
19:45:57 <stevemar> i'd love it if the darn workrooms and meetups didn't overlap completely with keystone
19:46:13 <dtroyer> the meetup is ususally where we meet new folk so I like keeping that
19:46:30 <stevemar> i think we need to keep one of each at a minimum
19:46:36 <dtroyer> keystone is full day on Friday?
19:46:43 <stevemar> dtroyer: it usually is
19:47:09 <dtroyer> ok, for now I'll stay at 1/1/1
19:47:14 <stevemar> dtroyer: yeah
19:47:17 <stevemar> good call
19:47:32 <dtroyer> there are 23 or 24 projcts looking for space in Austin, wanted to make sure we wanted all three
19:47:45 <breton> friday is usually slow at keystone, so I'm +1 for it
19:47:52 <stevemar> rtheis: have you been to a summit before?
19:48:08 <rtheis> stevemar: I was in Tokyo.
19:48:17 <stevemar> rtheis: great, so you know all this :)
19:48:19 <rtheis> hanging out with neutron folks
19:48:22 <rtheis> :)
19:48:30 <dtroyer> that is all from me
19:48:33 <stevemar> you've come to the dark side, splendid
19:48:37 <stevemar> same
19:48:46 <rtheis> :)
19:48:48 <stevemar> i'm actually ditching early, gotta pick up some food
19:49:03 * stevemar slinks out
19:49:16 <rtheis> At the neutron meetup now and we discuss transition to OSC
19:50:10 <dtroyer> fun times
19:50:15 <rtheis> we discussed where all of the neutron OSC commands should live ...
19:50:53 <rtheis> given the neutron stadium, is it okay to but core neutron in python-openstackclient and advanced services and other plugins have OSC extensions in their projects?
19:50:58 <rtheis> *put
19:51:06 <dtroyer> my take is the resources that overlap with the Compute proxy commands need to be in the OSC repo
19:51:19 <dtroyer> after that, it is judement.
19:51:26 <rtheis> ok
19:51:58 <rtheis> do we have a problem if something is considered extension and then moves to core... can it move projects ok?
19:52:14 <rtheis> or will that bring trouble?
19:52:44 <dtroyer> moving from a plugin into the OSC repo should be easy as long as there isn't a conflict with old plugins still installed
19:53:03 <rtheis> ok
19:53:20 <dtroyer> there might need to be an 'empty' plugin released last to clean out the entry point namespaces
19:53:35 <dtroyer> but if only some commands move, it is just a sync timing issue at worst
19:54:04 <rtheis> sure
19:54:26 <rtheis> I don't have anything else
19:54:55 <dtroyer> me either, we can close early in nobody speaks up soon
19:55:27 <dtroyer> rtheis: thanks again for running the meeting
19:55:27 <rtheis> last call ...
19:55:33 <rtheis> dtroyer: yw
19:55:38 <rtheis> #endmeeting openstackclient