13:01:01 <rtheis> #startmeeting openstackclient
13:01:02 <openstack> Meeting started Thu Jun 30 13:01:01 2016 UTC and is due to finish in 60 minutes.  The chair is rtheis. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:05 <openstack> The meeting name has been set to 'openstackclient'
13:01:10 <rtheis> #topic releases
13:01:22 <rtheis> Looks like we have osc-lib 0.2.0
13:01:27 <RuiChen> o/
13:01:27 <rtheis> #link https://github.com/openstack/osc-lib/releases/tag/0.2.0
13:01:48 <rtheis> Next step is getting to osc 3.0
13:02:19 <stevemar> the fix i had for looking up by ID (without kwargs) is merged
13:02:22 <rtheis> Last week we discussed tangchen's IP commands as one item needed for 3.0
13:02:39 <rtheis> stevemar: nice
13:03:05 <rtheis> stevemar: so we probably want another osc-lib release
13:03:10 <rtheis> ?
13:03:16 <stevemar> rtheis: yep, it's the only one fix: https://github.com/openstack/osc-lib/compare/0.2.0...master
13:03:49 <stevemar> rtheis: we need that since osc would have a regression otherwise
13:04:28 <rtheis> sure, does dtroyer or dhellmann handle the release?
13:04:37 <rtheis> I'm not sure the process for that
13:04:58 <stevemar> rtheis: any one of us can submit a patch to https://github.com/openstack/releases to release it
13:05:16 <rtheis> 0.3.0 or 0.2.1 for this?
13:05:20 <stevemar> if the PTL doesn't submit it, he still needs to +1 it
13:05:33 <stevemar> i'd say 0.2.1 -- it's just a bug fix
13:05:37 <rtheis> okay, I can look at submitting a patch set
13:05:52 <rtheis> #action rtheis submit patch for 0.2.1 osc-lib release
13:06:15 <stevemar> cool, dhellmann or dims will look at it
13:06:22 <rtheis> Anything else for osc-lib?
13:06:26 <stevemar> nope
13:06:34 <rtheis> #link https://review.openstack.org/#/c/300388/
13:06:45 <rtheis> This is tangchen's IP command series start
13:06:50 <rtheis> I think they just need a rebase
13:07:21 <rtheis> and nothing new on role list patches
13:07:42 <rtheis> #link https://review.openstack.org/#/c/283554/
13:07:46 <rtheis> #link https://review.openstack.org/#/c/311460/
13:07:57 <stevemar> i can look at tang's stuff today
13:08:04 <rtheis> thanks stevemar
13:08:23 <rtheis> anything else for osc 3.0 release?
13:08:33 <stevemar> not AFAICT
13:08:44 <rtheis> #topic reviews
13:08:52 <rtheis> any reviews that need attention?
13:09:00 <RuiChen> I can help to review tomorrow
13:09:01 <stevemar> do we want to wait for the roles stuff to merge before 3.0.0'ing?
13:09:34 <rtheis> stevemar: that was my understanding from last week
13:09:51 <stevemar> yeah, i guess we should
13:10:00 <stevemar> it'll give us some more time to find bugs :)
13:10:06 <rtheis> indeed :)
13:10:18 <stevemar> the puppet guys are running off of master
13:10:22 <stevemar> crazy folks
13:10:42 <stevemar> (osc master)
13:10:53 <rtheis> yes
13:11:31 <rtheis> #topic bugs
13:11:42 <rtheis> any bugs to discuss?
13:12:05 <stevemar> i can't think of any, we should totally have a bug triage day :P
13:12:13 <stevemar> the list is getting long
13:12:13 <RuiChen> I have one
13:12:21 <RuiChen> https://bugs.launchpad.net/python-openstackclient/+bug/1596511
13:12:21 <openstack> Launchpad bug 1596511 in python-openstackclient "``volume type unset`` does not accept multiple "--property " arguments" [Medium,In progress] - Assigned to sunyajing (yajing-sun)
13:12:23 <rtheis> stevemar: yes the list is getting long
13:12:40 <RuiChen> might we should merge osc part before cinderclient part is merged
13:13:27 <rtheis> RuiChen: so a cinderclient patch is required first?
13:13:28 <stevemar> i think we have to wait for a fix for cinderclient :(
13:13:35 <rtheis> then we need to wait
13:14:17 <stevemar> i have a bug -- one sec
13:14:19 <RuiChen> ok, I try to push cinder team
13:14:32 <amotoki> hi
13:14:34 <rtheis> RuiChen: thank you
13:14:49 <stevemar> https://bugs.launchpad.net/python-openstackclient/+bug/1592906
13:14:49 <openstack> Launchpad bug 1592906 in python-openstackclient "ensure all delete commands can take multiple objects" [Medium,In progress] - Assigned to aohuanxuan (huanxuan-ao)
13:15:01 <stevemar> someone want to do multi-delete for identity commands? :)
13:15:19 <rtheis> looks like that is making good progress
13:15:32 <rtheis> stevemar: is identity the last remaining commands to fix?
13:15:49 <stevemar> i did the volume ones, huanxuan did the compute ones
13:16:01 <rtheis> and network should be done
13:16:20 <stevemar> yep
13:16:26 <stevemar> oh huanxuan did the identity v2 ones too!
13:16:39 <RuiChen> sounds great!
13:16:44 <rtheis> is huanxuan planning to do v3?
13:16:58 <stevemar> rtheis: i don't know his irc handle :(
13:17:14 <rtheis> me either
13:17:23 <RuiChen> i think aohuanxuan
13:17:29 <stevemar> i think we just want: ec2creds, service, credential, and domain
13:17:43 <stevemar> the other stuff can wait
13:17:59 <stevemar> well, if i'm putting them in order of importance :)
13:18:10 <rtheis> stevemar: sounds good, maybe you could update the bug report and let aohuanxuan know
13:18:15 <stevemar> yep
13:18:18 <rtheis> thanks
13:18:40 <stevemar> ill try and triage the bugs over the weekend
13:18:47 <stevemar> i'm off on fri and mon
13:19:12 <rtheis> okay, i'm off on monday for the us holiday
13:19:31 <rtheis> any other bugs
13:20:04 <RuiChen> aohuanxuan, tangchen and I will work together for China OpenStack bug smash in next week
13:20:05 <stevemar> rtheis: nothing critical, just a lot of un-triaged
13:20:13 <stevemar> RuiChen: nice!
13:20:17 <rtheis> ++
13:20:21 <rtheis> thank you RuiChen
13:20:21 <RuiChen> I think we can clean some bugs :-)
13:20:32 <stevemar> RuiChen: i'm positive you three can!
13:21:07 <RuiChen> thanks
13:21:10 <rtheis> #topic open discussion
13:21:26 <rtheis> any other topics to discuss?
13:21:50 <RuiChen> https://review.openstack.org/#/c/310193/
13:22:06 <RuiChen> --all-property or --all-properties :)
13:22:11 <rtheis> ah, yes ;)
13:22:29 <rtheis> I was hoping to let dtroyer make the call on that
13:23:05 <amotoki> at a first look, 'all-properties' (plural form) sounds natural too me.
13:23:12 <stevemar> --all-properties makes sense (when you say it out loud)
13:23:21 <RuiChen> I had send email to him about these, but no replay :(
13:23:28 <rtheis> agreed
13:24:03 <rtheis> I think the trouble comes when we have to make other names plurals
13:24:08 <rtheis> beyond "property"
13:24:27 <amotoki> is there any consensus on '--no-<singular>' vs '--no-<plural>'?
13:24:29 <amotoki> it is similar one.
13:24:53 <rtheis> --no-<singular> is the consensus
13:25:00 <rtheis> at least in the devref
13:25:20 <RuiChen> exactly
13:25:34 <amotoki> thanks
13:26:24 <stevemar> what is the other use of it? --no-?
13:27:27 <rtheis> So we would have --property, --no-property and --all-<?>
13:27:34 <rtheis> I'm not sure if we have other usages
13:28:13 <rtheis> I proposed --each-property as an alternative but not sure if I like that
13:28:50 <rtheis> it reads better but "each" is not intuitive to me anyway
13:29:19 <RuiChen> "unset --each-property" sounds good to me
13:30:21 <amotoki> "unset --all-properties" sounds better to me because a command unsets all properties.
13:30:38 <stevemar> oh we should probably talk about https://review.openstack.org/#/c/295026/ too
13:30:49 <amotoki> i think we use 'each' when we do something for 'each' thing.
13:31:02 <rtheis> maybe we continue discussion in the devref and give dtroyer time to respond
13:31:11 <rtheis> sorry in the code review
13:31:52 <rtheis> stevemar: yes that's another one
13:32:10 <rtheis> that cinder command is odd and I'm starting to like RuiChen's idea
13:32:52 <stevemar> rtheis: i think that's a good idea for the --no-? --each-?
13:33:01 <stevemar> whats RuiChen's idea?
13:33:11 <stevemar> my gut told me a different command from the beginning
13:33:20 <stevemar> we're going to try and display a list in a list
13:33:39 <rtheis> see his latest comment in https://review.openstack.org/#/c/295026/
13:34:07 <RuiChen> I have no idea about --each-property or --all-properties, both good to me :)
13:35:22 <stevemar> reading
13:35:53 <stevemar> does "cinder type-access-list" work without a --volume-type argument?
13:35:57 <RuiChen> in https://review.openstack.org/#/c/295026/ , I think we can add access info into volume type object in show command
13:36:10 <rtheis> stevemar: it doesn't appear to
13:36:32 <rtheis> but I haven't checked the API
13:36:35 <RuiChen> stevemar: no, --volume-type is required in cinderclient
13:36:40 <stevemar> i'd say "list" in cinderclient was incorrectly named ....
13:37:01 <stevemar> adding it to volume type show sounds good to me
13:37:08 <stevemar> we can show a list in a single command
13:37:17 <stevemar> just like we do with properties
13:37:37 <rtheis> stevemar: do we have any similar examples for this in other commands?
13:38:12 <rtheis> meaning show pulls in additional properties to display for a resource
13:38:15 <stevemar> rtheis: i'm positive we do
13:38:43 <rtheis> thanks
13:39:19 <rtheis> looks like cinder API requires volume type to show access: http://developer.openstack.org/api-ref-blockstorage-v2.html
13:40:52 <rtheis> If anyone has an example to share with sheel in the review, I think that would be good.  I can take a look too
13:41:09 <stevemar> i am looking for one too
13:41:26 <rtheis> anything else to discuss on these 2 reviews?
13:41:34 <stevemar> speaking of sheel and the volume commands, it looks like he's slowed down, maybe more $day_job for him
13:41:50 <rtheis> yeah
13:42:08 <stevemar> we should probably pick up the slack a bit with the volume commands
13:43:00 <rtheis> any other topics?
13:43:25 <stevemar> let's have a midcycle :P
13:43:43 <rtheis> hawaii might be nice
13:43:53 <rtheis> :)
13:44:04 <rtheis> stevemar: has osc had a midcycle in the past?
13:44:04 <stevemar> it's right between us and RuiChen and tangchen :)
13:44:12 <rtheis> indeed
13:44:25 <RuiChen> +1 for hawaii :)
13:44:40 <stevemar> rtheis: we have not, it was dtroyer and myself for the longest time
13:44:52 <stevemar> but now our empire has grown!
13:45:11 <stevemar> we could do a virtual one
13:45:19 <rtheis> it has, so definitely something to consider
13:45:22 <stevemar> trove and ceilometer do that
13:46:35 <stevemar> tangchen, RuiChen and aohuanxuan meeting up during the china bug smash will be like a midcycle for them :)
13:47:10 <stevemar> we could send it to the mailing list
13:47:20 <stevemar> i'll poke dtroyer about it today and see what he says
13:47:27 <rtheis> thanks stevemar
13:47:31 <RuiChen> yeah, we can talk face to face, it's great
13:48:00 <rtheis> Maybe RuiChen could post to mailing list about the bug smash and see if others would like to help virtually
13:48:30 <RuiChen> ok, I will send it
13:48:43 <rtheis> thanks
13:48:58 <RuiChen> my pleasure
13:49:10 <stevemar> looks like google hangouts is mostly used for virtual sprints https://wiki.openstack.org/wiki/Sprints
13:50:39 <stevemar> rtheis: we'd run into a timezone problem
13:50:47 <stevemar> but i wouldn't mind trying it out
13:51:26 <rtheis> right, may have to split it up morning and evening
13:52:12 <rtheis> anything else for today?
13:52:16 <stevemar> nothing from me
13:52:40 <rtheis> last call ...
13:52:42 <RuiChen> maybe we can vote the midcycle time for all the osc team members
13:53:24 <RuiChen> nothing from me too
13:53:41 <stevemar> RuiChen: let's see if dtroyer wants to do it anyway :P
13:53:56 <stevemar> RuiChen: when is the china bug smash?
13:54:04 <rtheis> yep and then we can discuss and work out the details
13:54:10 <RuiChen> 6-8 July in china
13:54:18 <stevemar> nice, 3 days
13:54:51 <stevemar> rtheis: wrap this up!
13:55:00 <rtheis> yes
13:55:07 <rtheis> thanks all
13:55:07 <rtheis> #endmeeting