19:00:07 <raginbajin> #startmeeting operators_ops_tools_monitoring
19:00:08 <openstack> Meeting started Wed Sep 23 19:00:07 2015 UTC and is due to finish in 60 minutes.  The chair is raginbajin. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:12 <openstack> The meeting name has been set to 'operators_ops_tools_monitoring'
19:00:17 <raginbajin> o/
19:00:19 <j^2> o/
19:00:54 <raginbajin> We probably won't have a lot of people other than you and me.. I'm hoping for more.
19:01:00 <j^2> cool no worries
19:01:03 <j^2> i’m here to help :D
19:01:19 <raginbajin> I did create a page off of the wiki to start putting the agenda's and what not like you mentioned.
19:01:21 <raginbajin> #link https://wiki.openstack.org/wiki/Operators_Tools_and_Monitoring
19:01:46 <raginbajin> Then it references agenda items in an etherpad that we had but I apparently forgot about.
19:01:47 <j^2> ah, so you don’t want to be part of the OSOps project?
19:01:48 <raginbajin> #link https://etherpad.openstack.org/p/monitoring-ops-tools-meeting-agenda
19:01:57 <raginbajin> We can.
19:02:07 <j^2> It seem like we are attacking the same vector here
19:02:18 <raginbajin> We are a link off of here - https://wiki.openstack.org/wiki/Operations
19:02:23 <j^2> #link https://launchpad.net/osops
19:02:43 <j^2> #link https://wiki.openstack.org/wiki/Osops
19:02:52 <raginbajin> I'm happy to move this, shut it down, convert it, do whatever is necessary to get some more involvment.
19:03:27 <raginbajin> Hmm. The Osops page almost seems like it would benefit from maybe turning into that Operations page.
19:03:37 <j^2> nice, my goal is to get OSOps in the “big tent” around “N” or “O”s timeframe per the Operators meetus
19:04:06 <j^2> Then Operators get ATC and all that jazz which is the goal of OSOps
19:04:16 <rockyg> ++
19:04:19 <j^2> so it looks like we need to just come together
19:04:53 <drwahl> o/
19:05:04 <raginbajin> ahh. yeah it does. I know in YVR basically this was just a session where people said we should talk about it more, and then no one volunteered, so I said I would do it.
19:05:05 <j^2> I’m willing to help however i can, i just want feedback from the group so i don’t go off and just make something no one’ll use
19:05:20 <j^2> raginbajin: that’s exactly what happened at Palo Alto
19:05:49 <j^2> so i did a table flip and said i’ll make the repos so i can say “look guys commit here you’ll get what y’all want"
19:05:50 <raginbajin> I know many times we've all referenced the osops repo.. Yeah I couldn't make that one but posted a lot in the etherpad about this group and then the next session no one showed up
19:06:00 <raginbajin> Cool
19:06:42 <j^2> so yeah we need to *cough* this meeting *cough* get the stake holders together and just agree how to organize the ?3? groups into one
19:06:51 <rockyg> Do we have a launchpad account for OSOps?
19:06:56 <j^2> rockyg: yep
19:07:06 <j^2> #link https://launchpad.net/osops
19:07:19 <rockyg> Cool.  Perhaps we should mine the etherpad for proposals and create BPs
19:07:27 <j^2> rockyg: great idea
19:07:46 <j^2> can you take the first stab at it? maybe make another etherpad to track it so we can check them off a list?
19:08:04 <rockyg> Also, if there are already tools there, maybe we can get them listed in some catalog
19:08:18 <j^2> we have 3 repos now for osops
19:08:20 <j^2> one sec
19:08:37 <rockyg> I wish I could do it, but I head up logging and my goal for Tokyo is to document the config options for logging
19:08:38 <j^2> #link http://git.openstack.org/cgit/?q=osops
19:09:08 <raginbajin> I'm willing to start creating BP's but I have never done them before, so I think I need some guidance.
19:09:13 <raginbajin> or something to reference.
19:09:22 <j^2> raginbajin: sounds good, i can link ours from Chef
19:09:34 <rockyg> At a minimum, could we check the etherpads into our repository?  Then as we turn ideas into BPs, we modify the etherpad to have the link
19:10:04 <j^2> raginbajin: https://blueprints.launchpad.net/openstack-chef/+spec/refactor-configuration-templates
19:10:12 <raginbajin> thanks
19:10:15 <j^2> just something simple like that ^^
19:10:25 <rockyg> BPs are rather open form.  You write up what you think should be done, put in a descriptive title and we now can track it
19:10:43 <j^2> we shouldn’t worry about specs or anything ATM, that might be worth something down the line, but not till later
19:10:48 <raginbajin> Got it. Can they be updated once they are submited?
19:10:52 <j^2> yep
19:10:59 <rockyg> And commented on.
19:11:34 <rockyg> yup
19:11:37 <j^2> it seems like we should collapse the Wiki pages into one or something too
19:11:47 <raginbajin> Ok, so I'll take the action to put a couple of BPs together by next meeting so we can review them and see if I am on the right track before I do a ton of them and they turn into a mess.
19:11:48 <j^2> but that requires more buy in like i mentioned above
19:11:57 <j^2> raginbajin: :rockon:
19:12:10 <rockyg> \o/
19:12:37 <j^2> there is also bugs/answers for OSOps too
19:12:51 <j^2> so as we get more commits to the repos we can track the bugs in it
19:13:01 <raginbajin> #action raginbajin will create a few BPs before next meeting so the group can review that they are being created as expected.
19:13:16 <rockyg> Once ther are a couple of bps in there, a notice should go to the ML about them and how to comment, add new ones, etc.
19:13:36 <raginbajin> agreed.
19:13:40 <rockyg> Maybe we review the ones we have next week and create the email
19:13:48 <j^2> rockyg: yeah a lot of this will take a while to get off the ground, but if we make it as painless as possible we should get better adoption
19:13:50 <raginbajin> and at the Meetups we can just take a lot of what is being said and create BPs right there.
19:14:04 <j^2> raginbajin: exactly
19:14:19 <j^2> we create tangable goals per mid-cycle
19:14:23 <rockyg> Also, if w use the bugs for Logging bugs, I'm willing to triage to the appropriate projects
19:14:34 <j^2> rockyg: perfect
19:15:06 <drwahl> i'm feeling like a fly on the wall, but i am willing to assist where i can
19:15:14 <rockyg> Maybe we can use this LP group for ops bugs when ops doesn't know the project and triage from here
19:15:20 <drwahl> we (dreamcompute) have some resources we could dedicate to OSOPs efforts as well
19:15:33 <rockyg> drwahl, Kewl!
19:15:48 <j^2> drwahl: nice! Any chance you can commit to any of the tooling repos? useful scripts etc?
19:16:07 <drwahl> i'm working internally on that effort currently
19:16:27 <drwahl> we have a blog post going up this week where i talk about how we are doing some of our public images and stuff
19:16:42 <j^2> hell there’s an ansible playbook in there to restart vms? or something like that. just something that we can show the community so we don’t have to reinvent the wheel over and over
19:16:45 <drwahl> we need to get some of our chef stuff scrubbed before we could publish it publicly though
19:16:54 <j^2> drwahl: makes perfect sense
19:17:00 <rockyg> I'll give a report on this stuff back to Prod_wg and maybe get them to provide triage for bugs plus extra review of BPs
19:17:16 <raginbajin> Prod_wg?
19:17:24 <rockyg> product working group
19:17:48 <rockyg> They are cross project and trying to get user vertical needs incorporated into the projects
19:17:56 <rockyg> and horizontal needs
19:18:32 <raginbajin> Ahh ok. I haven't really step out of the Operators groups to realize what else is happening in most of the projects. So I'm really appreciating the help with all this.
19:19:52 <rockyg> who is the moderator for this meeting?  If you could, could you do some #action  s with what we have planned so far?  #action is first on line.  One action per line
19:19:53 <j^2> cool, this has already gotten us on the correct path, this is great
19:19:59 <raginbajin> #action rockyg will give a report on what is happening here to the product working group to see if there is any support they could provide and report back to us.
19:20:11 <rockyg> \o/
19:20:35 <raginbajin> I only captured those two actions, anything else that I am missing.
19:20:40 <rockyg> action create bps from ethrpads
19:20:46 <raginbajin> got that one
19:20:53 <raginbajin> and then the prod_wg one
19:20:54 <rockyg> cool
19:21:10 <rockyg> submit bugs to this lp group if you don'
19:21:20 <rockyg> t know which project they belong to
19:22:31 <rockyg> ^^ as an #action
19:22:34 <raginbajin> So do we want to do that after the BP's are reviewed in an email that we send to the listserv
19:22:37 <raginbajin> oh ok
19:23:38 <rockyg> we need to come up with tags for stuff that Ops considers bugs that aren't project specific  Such as logs, config, performance, etc
19:23:47 <raginbajin> #action Start working with Operators to have them submit bugs to the OSOps project if they do not know which project they belong to, to help atleast capture the bug.
19:23:48 <rockyg> To put on the bugs
19:24:15 <raginbajin> #action Work on creating tags that Operators consider at bugs that are not project specific. Examples: logs, config, performance, etc
19:24:25 <j^2> +1
19:25:18 <rockyg> Do we have an agenda for this meeting or is this just brainstorming?
19:25:30 <raginbajin> For the last 3 meetings, its been me only at the meetings
19:26:05 <rockyg> Ah.  I just found out about it this week, which is why I jumped in.
19:26:24 <raginbajin> So there wasn't an agenda setup. The only thing was j^2 work he did to bring osops into the mix which jump started everything
19:26:32 <j^2> :D
19:26:40 <raginbajin> So, i think we have a few good things to get working on.
19:27:03 <j^2> getting Action Items and tangible goals out of an IRC meeting is always a win
19:27:05 <rockyg> Lemme introduce myself.  Rocky Grober.  I am an architect with Huawei.  My background is everything other than code that makes a product
19:27:28 <j^2> rockyg: you and i have had a few beers together ;) <— JJ from Chef
19:27:32 <rockyg> So, I'm a QA, Ops, Enduser champion
19:28:00 <drwahl> we doing intros? My name is David Wahlstrom. I am the "Cloud System Engineer" at DreamHost (working on DreamCompute). I spend most of my days in either jenkins, chef, or python code
19:28:05 <rockyg> Ah, yes.  My e key is sticking  there might be missing e's in my typing.
19:28:37 * j^2 waves to drwahl :D
19:28:41 <raginbajin> I'm Joseph Bajin. I lead everything Virtualization and Cloud at Verisign.  My background has been in Operations and System Engineering.
19:28:45 <drwahl> j^2: i have a buddy who is (was?) working at OpsCode. do you know Yvo?
19:29:03 <j^2> drwahl: yep he’s in NL now.
19:29:08 <drwahl> indeed he is
19:29:10 <j^2> he interviewed me too :D
19:29:16 <drwahl> i worked with him for a while at Classmates.com
19:29:19 <j^2> nice
19:29:25 <rockyg> Doesn't Opscode also do Sonar?
19:29:48 <j^2> we aren’t Opscode any more, we are Chef btw ;)
19:30:02 <j^2> Sonar in what context rockyg ?
19:30:48 <rockyg> Forgive me I didn't see that patch merge ;-)  SonarQube
19:31:43 <j^2> never seen it sorry :(
19:31:49 <j^2> yeah i haven’t heard anything about it either
19:32:02 <rockyg> http://www.sonarqube.org/
19:32:15 <j^2> yep, nope, never seen in the context of chef
19:32:37 <rockyg> Really good stuff that I would love infra to get up on the site.  I think I'm confusing Opscode with ...
19:33:45 <rockyg> I think they used to have code in the company name, but now it's SonarSource
19:34:07 <j^2> raginbajin: next topic? :D
19:34:13 <raginbajin> That's it.
19:34:15 <rockyg> Yes please
19:34:16 <raginbajin> don't have another one.
19:34:20 <j^2> ha!
19:34:24 <j^2> then that’s a great meeting :D
19:34:31 <rockyg> more tags for bugs?
19:34:41 <rockyg> Then ownr of lp group could gt thm in
19:34:42 <raginbajin> I added that action item.
19:35:06 <rockyg> Or could just make th initial list....
19:35:18 <rockyg> All the ilities are good
19:36:11 <raginbajin> So I added this as an action, but didn't have anyone associated to it :   Work on creating tags that Operators consider at bugs that are not project specific. Examples: logs, config, performance, etc
19:36:23 <raginbajin> Not sure how we want to do that or if someone wants to take that.
19:36:46 <raginbajin> I dont' think I can do any of that in the project.
19:37:00 <rockyg> Just brainstorm the list here.
19:37:33 <j^2> Yeah it might be a tad bit early to tag bugs for upstream. We only have a small repenitation here; and we need to get more bodies before we can start looking to the larger community
19:37:47 <rockyg> True.
19:38:10 <rockyg> But I'm thinking tag bus in *our* launchpad group.  Not upstream....
19:38:13 <j^2> and the first step is to get operators to commit and show that we want to make things happen, like drwahl :D
19:38:21 <rockyg> Also true.
19:38:41 <j^2> rockyg: tbh, anything that isn’t in the “operators” immediate circle is upstream ;)
19:39:08 <j^2> so we’re on community building and selling ATM. right raginbajin ?
19:39:19 <j^2> then we can look at cross compatibility
19:39:19 <rockyg> Sounds like.
19:39:22 <raginbajin> Definitely..
19:39:28 <rockyg> Excellent.
19:39:44 <raginbajin> We need to get operators submitting work to help us start figuring out how to split it up.
19:40:11 <j^2> btw, we have some cores on OSOps, i’m going to send out a note to all of them saying this is our meeting time now too. Show up or I’ll bring the hammer down  :D
19:40:33 <rockyg> Good.
19:40:40 <j^2> raginbajin: exactly. But first we need submissions then w can figure out what bucket we can put them in
19:40:50 <j^2> can you give me that #action raginbajin ?
19:40:57 <j^2> the note about the cores
19:41:25 <rockyg> FYI  There are two ops groups for OpenStack out there.....
19:41:48 <raginbajin> #action J^2 will communicate with cores that are working within the Operators group to inform them of this meeting time and invite them to join the discussion
19:41:52 <rockyg> https://launchpad.net/~osops
19:42:11 <j^2> crap
19:42:14 <j^2> did i remake this?
19:42:20 <rockyg> and https://launchpad.net/osops
19:42:21 <j^2> https://launchpad.net/osops
19:42:36 <raginbajin> the one with ~ is super old
19:42:37 <rockyg> Actually, this is good.  One is a team and one is a project.
19:42:46 <rockyg> Team is ~osops
19:43:00 <raginbajin> I didn't even know that existed.
19:43:02 <j^2> per the docs: https://launchpad.net/~osops-drivers
19:43:08 <j^2> that’s what the “team” is supposed to be
19:43:20 <j^2> which i can add anyone that wants to be in it
19:43:37 <j^2> raginbajin: email/userid?
19:43:39 <drwahl> j^2: what is it i'm supposed to be commit (to)? the chef stuff we were talking about earlier?
19:43:58 <raginbajin> josephbajin@gmail.com/josephbajin
19:44:00 <j^2> drwahl: anything and everything you’re willing to help out with the osops repos
19:44:13 * drwahl makes a note to pull down osops repos...
19:44:15 <j^2> raginbajin: done
19:44:26 <j^2> drwahl: http://git.openstack.org/cgit/?q=osops
19:44:53 <rockyg> osops, no ~ is the project.  BPs go there
19:45:00 <j^2> yep
19:45:27 <rockyg> Adn the git repository was supplied by j^2
19:45:27 <j^2> rockyg: https://blueprints.launchpad.net/osops
19:45:40 <rockyg> Thnk you
19:45:55 <j^2> just to finish it off:
19:45:58 <j^2> #link https://bugs.launchpad.net/osops
19:46:06 <j^2> #link https://answers.launchpad.net/osops
19:46:15 <rockyg> Beautiful!
19:46:24 <j^2> <— read the docs :P
19:46:25 <drwahl> ah, i have some useful (for us) tools to add to some of these repos
19:46:30 <drwahl> i'll get some stuff up for review soon
19:46:32 <j^2> drwahl: perfect
19:46:38 <j^2> just a start is all we’re asking for
19:46:57 <rockyg> Also, you'r all welcome to stay for the next meeting ... log work group
19:47:06 <j^2> and there is no tests or anything, but eventually i think we should at least think of something; but that’s like 2nd Generation stuff, we’re way to early in thinking on this
19:47:07 <rockyg> Same room;-)
19:47:27 <raginbajin> rockyg: Please just standardize them so I can use a simple logstash filter. That's all I ask
19:47:37 <drwahl> ^^ that
19:47:37 <rockyg> j^2, the tailgaters group may be able to help with the tsts, too
19:47:58 <j^2> hell sharing the log stash filter in the osops-loggint-tools is like PERFECT candidate.
19:48:13 <drwahl> ^^ that too
19:48:22 <raginbajin> I think that's a great idea... I'll look at submitting some of those.
19:48:25 <rockyg> We're trying, but.... we need to get more specific info on standards.  We're trying to use oslo.log as a bludgeon...
19:48:34 <j^2> #link https://github.com/openstack/osops-tools-logging
19:48:37 <drwahl> we started down the logstash road, but gave up after the multi-line traces messed us up
19:48:40 <rockyg> Yessiree
19:49:17 <rockyg> multi-line traces out of the log!  that's a good start.  Unless of course, you have TRACE turned on.
19:49:27 <raginbajin> So, it sounds like we can wrap up today's meeting.  We got a lot of good things to start working on.
19:49:49 <rockyg> Good bug to file.  I need to know which project to bludgeon.
19:49:51 <raginbajin> We have actions for 2 weeks from now and I'll have the agenda up on the etherpad as well.
19:50:00 <rockyg> Excellent
19:50:19 <raginbajin> Anything else?
19:50:25 <rockyg> And I have 10min to prep for the next meeting
19:50:56 <j^2> raginbajin: i can’t stress enough about that format for the name of the etherpad for the agenda
19:51:10 <j^2> it’s nice to only have to change the date; then you can track how things change over time on new files
19:52:01 <raginbajin> ok. Let me change it around to something that works better, and I'll update the wiki site with it
19:52:05 <j^2> cool, i propose a motion to close this meeting early, i think we made progress :)
19:52:06 <rockyg> Yes.  Same goes for the meeting name.  Always the same.  No dates or geis
19:52:13 <rockyg> Agreed.
19:52:44 <j^2> raginbajin: don’t hesitate to PM me if you need help/question/a sounding board, i’m almost always around
19:53:00 <raginbajin> Thanks j^2. Thanks to rockyg and drwahl as well.
19:53:12 <raginbajin> #endmeeting