19:01:43 <raginbajin> #startmeeting operators_ops_tools_monitoring
19:01:44 <openstack> Meeting started Wed Oct  7 19:01:43 2015 UTC and is due to finish in 60 minutes.  The chair is raginbajin. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:47 <openstack> The meeting name has been set to 'operators_ops_tools_monitoring'
19:02:00 <j^2> o/
19:02:10 <raginbajin> o/
19:02:14 <drwahl> o/
19:02:48 <raginbajin> #addchair j^2
19:03:01 <raginbajin> apparently that doesn't work
19:03:07 <j^2> :-O
19:03:15 <j^2> oh the ^ probably breaks it
19:03:33 <raginbajin> #addchair drwahl
19:03:40 <j^2> odd
19:03:41 <raginbajin> #help
19:03:50 <raginbajin> well I guess help doesn't work either.
19:05:19 <raginbajin> Ok well
19:05:24 <raginbajin> Lets get this party started then
19:05:31 <j^2> :D
19:05:33 <raginbajin> #topic Review of last meeting
19:05:45 <Rockyg> o/
19:05:55 <raginbajin> Last meetings notes can be found here
19:05:57 <raginbajin> #link http://eavesdrop.openstack.org/meetings/operators_ops_tools_monitoring/2015/operators_ops_tools_monitoring.2015-09-23-19.00.html
19:06:52 <raginbajin> We had a few action items that we looked to get done.
19:07:12 <j^2> yep
19:07:28 <raginbajin> The first one was for me to create a few BP's for the group to go over. I did add a few and we can review those here in a second
19:07:53 <raginbajin> The next one was rockyg "rockyg will give a report on what is happening here to the product working group to see if there is any support they could provide and report back to us."
19:08:05 <raginbajin> So I say lets talk about that one
19:08:30 <raginbajin> #topic Results from the Product Working Group discussion
19:08:45 <Rockyg> Well, I'm fairly certain that the product wg can provide some support for this.
19:09:04 <Rockyg> they are active in the enterprise wgs including monitoring
19:09:39 <raginbajin> Ok, I guess nothing specific then from them
19:09:47 <raginbajin> atleast at the moment
19:10:56 <j^2> cool
19:11:22 <raginbajin> Ok - I wasn't sure what we were going to get out of this per-sae
19:11:39 <raginbajin> So, it sounds like if we run across something that they can help with we can see what they can do
19:12:21 <raginbajin> Ok so then on to the next item.
19:12:25 <Rockyg> I think what we need to do is get on the agenda and talk about what this group needs/would like and get a response.
19:12:35 <raginbajin> #topic Communicate with the cores
19:12:42 <Rockyg> um, in another meeting.  will catch up shortly
19:13:08 <raginbajin> sounds good rockyg
19:13:38 <raginbajin> I think this was one that you j^2 just sent out an email today, but did you have a chance to talk with some of the other cores
19:14:03 <j^2> yeah not much, but we’ve had progress with the repos and reviews
19:14:25 <j^2> i completely forgot to send out the not till today, but ideally people will start joining as of the next meeting
19:14:49 <raginbajin> No problem. I usually start remembering what i need to do the week of.
19:14:53 <raginbajin> So i totally get it..
19:15:07 <raginbajin> So, I think that really just rolls everything into the BP's and the repo updates we had.
19:15:14 <raginbajin> #topic BPs and Repo updates.
19:15:34 <raginbajin> I was wondering if there was a way to link a blueprint that gets added to the Operators room
19:15:50 <raginbajin> I've seen it in other rooms, just not sure how all that is linked together.
19:15:59 <j^2> i thought the “openstack” bot does it
19:16:28 <raginbajin> well that bot has been slacking then.. But I'm not sure if we have to register that with the bot so it knows how to push those things
19:16:51 <j^2> i dunno :-/
19:17:04 <raginbajin> I say lets make that an action for maybe both you and I to see if we can do that..
19:17:16 <raginbajin> Do you think the Operators group would be ok with that?
19:17:41 <j^2> i dunno, i think so
19:18:03 <j^2> the channel is pretty quite then active then quite so i think they’ll be ok with ti
19:18:05 <raginbajin> ok I'll send out an email to the listserv and see if we get anyone yelling no to that
19:18:22 <j^2> sounds good
19:18:37 <raginbajin> #action raginbajin and j^2 to investigate how to get Blueprints announced within the Operators Channel
19:19:05 <raginbajin> I think that will act as a nice advertisment as well
19:19:10 <j^2> yep
19:19:18 <j^2> to show the activity etc and progress
19:19:24 <raginbajin> exactly.
19:19:41 <raginbajin> Was there any feedback to give about the updates we got from the Repo updates?
19:20:12 <j^2> not much, other than we have some ideas and progress, i don’t think much’ll take off till tokyo, but it’s awesome to see people already commiting
19:20:34 <j^2> and we’re talking about creating a “curating” folder with some coding standards
19:20:55 <raginbajin> Yeah that's good.  I dont' think I will be able to head out to Tokyo. :(
19:21:06 <j^2> :(
19:21:11 <j^2> i’ll report back anything
19:21:14 <j^2> that pops up
19:21:35 <drwahl> i'll be in tokyo as well
19:21:40 <drwahl> and will keep notes relavent to this group
19:21:40 <j^2> nice
19:21:42 <raginbajin> I can probably be online if we have a session and everyone is on the etherpad or irc channel.
19:21:51 <raginbajin> That would be cool for sure..
19:22:36 <raginbajin> Ok.. Did we want to take a look at the BP's. I didn't add a lot of detail to them, I really just found particular issues that were mentioned that had something that could be completed against it
19:22:42 <raginbajin> and copied and pasted that information into it.
19:22:55 <raginbajin> We would definitely need some additional people to add and contribute more detail.
19:23:34 <raginbajin> For example I create this one: https://blueprints.launchpad.net/osops/+spec/tenant-cleanup-evacuation-tools
19:24:05 <raginbajin> That one is probably specific to what the godaddy people are working on.. and maybe we can get them to look into it.
19:24:21 <raginbajin> It did make me think about something, they created a stackforge project called ospurge
19:24:40 <raginbajin> Should/Could that be integrated into osops or should it be a separate project on its own
19:25:44 <drwahl> i think it would also behoov us to create tickets with the other projects to address these sort of things in the mainline stuff
19:25:58 <drwahl> i.e. we shouldn't *need* ospurge type scripts forever
19:26:07 <drwahl> they should fill a gap until it's addressed in the mainline
19:26:30 <j^2> ah nice
19:27:12 <raginbajin> drwahl what do you mean by creating tickets in the other projects? Like a ticket within Nova to address the cleanup effort that this is doing?
19:27:12 <j^2> yeah a couple things have popped up asking if they should be a part of ososps i think we need more discussions about it
19:27:39 <drwahl> raginbajin: ya
19:27:57 <raginbajin> Gotcha..
19:27:58 <drwahl> these are essentially bugs (or feature requests) of other projects (neutron, nova, etc.)
19:29:04 <raginbajin> That makes sense then.  Should we be facilitating that or letting the people working on those scripts do it
19:29:30 <drwahl> i don't have an answer to that exactly...
19:29:46 <drwahl> maybe it would make sense for us to do, since this group kind of represents operators at large
19:30:19 <j^2> :D
19:31:02 <raginbajin> yeah. It makes sense to me then I thought then someone(s) have to really keep on top of those things.
19:31:24 <drwahl> yup, it does create work
19:31:33 <raginbajin> maybe it gets better with more people and the work does get a little more spread out.
19:31:35 <drwahl> but, it's a good way for us to get some good reputation
19:31:42 <raginbajin> true.
19:32:34 <raginbajin> ok well I think I will bring up the idea of the ospurge project maybe working with the osops project for what they are doing to help get us started on something.
19:33:25 <raginbajin> j^2 for the those discussions you mentioned, what if we asked them to come talk more about it here at these meetings.
19:33:25 <Rockyg> just want to note that a dev already commented on one of the cleanup bps on the mailing list.  Said a bug should be filed against, I think, nova.  He wants to reach out.
19:33:41 <drwahl> obviously ospurge is just one example. we have some quota scripts floating around that also seem like bugs in nova/neutron
19:33:53 <j^2> raginbajin: i like that idea, we just need people to show up and buy in
19:34:11 <Rockyg> drwahl, and quotas are big no prod_wg and on the dev agenda for this cycle
19:34:20 <Rockyg> ^no^on
19:34:34 <raginbajin> Yeah sounds like we will need to be out shaking hands and kissing babies to get this going for a while.
19:34:37 <j^2> Rockyg: that’s awesome, i get lost in the mailing lists; and it’s challenging to keep it straight
19:34:46 <j^2> raginbajin: exactly
19:36:30 <raginbajin> Is there ways to link bug tickets within launchpad?  So if I opened a Osops bug to say fix nova quotas
19:36:41 <raginbajin> how can I track that back to bugs over in nova
19:36:43 <j^2> that’s a great question
19:36:56 <j^2> can you link the bug for ososps?
19:37:30 <raginbajin> j^2 I haven't opened anythign.. I was just thinking about it
19:37:36 <j^2> oh
19:37:51 <Rockyg> You can put the link in the bug
19:38:39 <Rockyg> There is a way to add projects to a bug, but I forget how.  I'll get back to you on that....
19:39:11 <raginbajin> #action Figure out how to link bugs from osops to other project in order to keep track of issues.
19:39:15 <raginbajin> just so we don't forget.
19:39:53 <Rockyg> cool
19:40:37 <raginbajin> Ok well I think we have a few things to keep moving.. I think if we can start talking about the osops area for blueprints and bugs before the summit, we can maybe get those guys to start opening tickets while we are there.
19:40:55 <raginbajin> Maybe someone can talk to tom about trying to reiterate that to all the Ops Sessions
19:44:58 <Rockyg> fyi:  product wg user story on Quotas, etc.  If you want to add/change something, just file a patch
19:45:28 <Rockyg> oops.  link: https://github.com/openstack/openstack-user-stories/blob/master/user-stories/draft/capacity_management.rst
19:49:05 <raginbajin> Ok well I think I'll take that as an action item since everyone is fighting over it.
19:49:06 <raginbajin> :)
19:49:46 <raginbajin> #action raginbajin will email Tom and see if the osops links can be included during the summit for all the operator based sessions.
19:50:01 * drwahl doesn't know who tom is...
19:50:23 <raginbajin> Tom Fifield
19:50:26 <Rockyg> Fifield.  foundation community manager
19:50:47 <Rockyg> I think we can get him to put the info at the top of all the ops etherpads
19:51:24 <j^2> yeah, I’ve tried getting OSOps on the docket, didn’t happen
19:51:26 <raginbajin> He is basically the Operators link to the foundation for the most part. He helps put together the Meetups and the Operator Sessions at the summit. keeps the operator cats herded during the week
19:51:30 <j^2> but i’m gonna be fighting for it
19:52:05 <raginbajin> cool That will work too. Figured it was worth a try to see how many people we can get ot just open bugs/bps anything to capture more detail than we get in the etherpad
19:52:35 <raginbajin> The etherpad was a mess to try to go through. Its more of a comment pad than anything else, not much real use to take back from them
19:53:01 <raginbajin> Any new business?
19:53:14 <Rockyg> raginbajin, agreed.  I've been trying to organize the infor from past sessions and its a pain in the butt
19:53:27 <j^2> nope, i’m good :D
19:53:34 <Rockyg> But, having the links for filing bugs and bps at the top will get some notice
19:53:42 <Rockyg> nada from me.
19:54:34 <Rockyg> of course, if you guys have any log stuff in the osops repo, you could talk about it at the log wg meeting that's next (plug for that one)
19:54:56 <raginbajin> cool Then I think we are good. Thanks guys for all the work. We get this much participation next time, it can officially be called a streak.
19:55:12 <j^2> +1
19:55:13 <Rockyg> :-)
19:55:24 <raginbajin> YAY
19:55:26 <raginbajin> #endmeeting