19:00:21 <raginbajin> #startmeeting operators_ops_tools_monitoring
19:00:21 <openstack> Meeting started Wed Nov 18 19:00:21 2015 UTC and is due to finish in 60 minutes. The chair is raginbajin. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:24 <openstack> The meeting name has been set to 'operators_ops_tools_monitoring'
19:00:33 <raginbajin> o/
19:00:34 <j^2> o/
19:01:34 <klindgren> o/ ?
19:01:39 <j^2> hi!
19:02:04 <raginbajin> hello friends.
19:02:21 <j^2> raginbajin: i can run with this if you want
19:02:28 <raginbajin> Sounds like a plan.
19:02:32 <j^2> perfect
19:02:39 <j^2> can you give me #chair?
19:03:11 <raginbajin> #chair j^2
19:03:12 <openstack> Current chairs: j^2 raginbajin
19:03:20 <j^2> rock on
19:03:52 <j^2> #topic Pre-Agenda
19:04:06 <j^2> So i've been putting together a blog post about successful IRC meetings
19:04:15 <j^2> the first thing involved is an agenda
19:04:27 <mdorman> seems like a good start
19:04:35 <j^2> I'd like to propose creating agendas via etherpad and posting them ahead of time
19:04:51 <j^2> i have a template i used for #openstack-chef and we can work off that
19:05:09 <mdorman> +1
19:05:14 <j^2> I also propose using the OSOps wiki page to host storewhatever the agendas
19:05:53 <j^2> anyone object to this? I can run with it if needed
19:06:28 <klindgren> No objection from me
19:06:34 <raginbajin> no objection
19:06:55 <j^2> rock on, i'll give a 20 more seconds before i'll take that action item
19:07:39 <j^2> #action j^2 creates the agendas for the following meetings and adds them to OSOps. Create template and template email to pre announce the meetings
19:07:54 <j^2> #topic Meeting times
19:08:13 <j^2> just to make sure we have it captured here i created two reviews today
19:08:25 <j^2> one to remove the "Team Meeting"
19:08:33 <j^2> and one to add OSOps to this meeting time
19:08:42 <j^2> are there any other thoughts or objections to these actions?
19:09:03 <raginbajin> no objections to it. already +1'ed it
19:09:21 <j^2> awesome
19:09:52 <j^2> and just to verify that this is a good time for all involed and it's every _other_ weeb
19:09:58 <j^2> week*
19:10:59 <j^2> aka "odd weeks"
19:11:02 <j^2> good?
19:11:09 <klindgren> typically I think this time works for me
19:11:19 <raginbajin> I asked for as much input as i could and came up with this to make sure it works for west coast peoples
19:11:31 <j^2> raginbajin: nice
19:11:47 <mdorman> works for me
19:12:13 <balajin> works for me
19:12:19 <j^2> awesome
19:12:33 <j^2> #topic Coding Standards
19:12:42 <j^2> my can o'worms!
19:13:05 <j^2> if yall have seen, the ML post about the coding standards for tools-generic
19:13:17 <j^2> i'd like to open up this and start a discussion around it
19:13:55 <j^2> I'm a rubyist and a sysadmin, so bash and ruby are the only things i have any real opinion on; what are the pythonists thoughts?
19:14:31 <raginbajin> Is there an OpenStack standard for this?
19:14:41 <mdorman> i don’t have any strong opinions on this. but for python why don’t we do the same standards as are on all the other openstack stuff?
19:14:49 <balajin> no preference, some standard is good
19:15:03 <balajin> usually the code i write is only readable by me
19:15:11 <balajin> if we are looking at sharing and reusing, some standard is good
19:16:00 <j^2> raginbajin: from what i've seen there "isn't" but is at the same time. Every project has it's own ability to choose what they want
19:16:01 <mdorman> maybe we just use the same pep8 settings as nova uses, just as an arbitrary starting point
19:16:31 <j^2> mdorman: that's good enough for me
19:16:52 <j^2> and if we stick with the pep8 then the bashpep8 thingy is another good starting point
19:16:58 <mdorman> agreed.
19:17:11 <j^2> does anyone here have a good grasp of the gating system with zuul?
19:17:35 <klindgren> yea - When I brought this up a while back - my only real concern was that the curated scripts functioned the same way. IE they took the same command line options, or read from ENV's for auth
19:17:40 <j^2> i have..an ok relationship with it, but if someone considers themselve an expert, id like to defer to them
19:17:59 <klindgren> no XP here with Zuul
19:18:22 <j^2> klindgren: yeah i think that's deeper then we need to get for the moment. I think just basic linting is a good place to start
19:18:30 <balajin> not me either
19:19:02 <mdorman> no zuul here either
19:19:12 <j^2> ok, i guess i'll take the action item ;)
19:19:50 <j^2> #action j^2 to figure out how to use zuul to validate against the pep8 (python|bash) and rubocop linters
19:20:04 <mdorman> thanks man
19:20:15 <mdorman> happy to help review
19:20:19 <j^2> perfect
19:20:46 <j^2> see when we all decide on things then it's not really a can o'worms, is it :P
19:21:21 <balajin> :)
19:22:07 <j^2> any other thoughts or objections to this topic? I'll give a minute for any extra thoughts or to keep the conversation going
19:23:08 <j^2> nice
19:23:17 <j^2> #topic Open Floor
19:23:35 <j^2> Those were the topics that i would have put on the agenda, what other topics would people like to talk about?
19:24:20 <mdorman> not that i want to talk about this, but any comments/discussion needed around a mid-cycle. sounds like people are mostly congregating around the idea of having the one in manchester
19:24:26 <mdorman> rather than ‘regional’ ones. (which i agree with)
19:24:36 <j^2> yeah that's how i got it too
19:24:55 <balajin> +1 for me, a single midcycle
19:25:17 <raginbajin> yep single midcycle but its going to interestign to see how an international one goes.
19:25:22 <j^2> as i said in my post about it, they have been invaluable to me for the conversations alone. but being out of the country puts another layer of complexity for me to get on it
19:25:31 <mdorman> right.
19:25:43 <j^2> granted i think i can swing this one but i need to talk to my management chain
19:27:06 <klindgren> I dunno if the single meet-up is the best idea
19:27:17 <j^2> klindgren: yeah? whys that?
19:27:26 <klindgren> I think ops is differnt in that instead of having say 20-30 people at a midcycle you have say 200+
19:27:52 <mdorman> i bet there will still be a fair amount of people from north america that will go
19:28:09 <klindgren> just that I think when the midcycle is in a region - you are going to get more of those people in that region at the meetup (not bad)
19:28:10 <raginbajin> I'm not sure about that especially have an international summit.
19:28:19 <klindgren> but I think a number of the same topics are going to get rehashed
19:28:53 <klindgren> Like - monitoring, packaging, tooling
19:29:52 <mdorman> so you’re saying it’s good to have a single meeting, rather than several parallel ones in each region?
19:30:15 <j^2> the challange of a regional meetup though is that you need to find a sponsor of it. If we go through the openstack foundation they do all that stuff to make it happen. It's hard enough for us to get a project together, but a regional meetup that would be murder on logistics
19:31:26 <klindgren> sorry I guess I am mixed on regional vs's single
19:31:35 <mdorman> i agree with the rehashing point
19:32:01 <klindgren> all I know is that the summit seemed rather underattended in the OP's things
19:32:08 <j^2> true, every one we have we talk about a lot of the _same_ things
19:32:44 <j^2> klindgren: it's because it's right at the same time as the other talks are going on. you're constantly at odds with what you want to see/do
19:32:51 <j^2> drove me crazy to be honest
19:33:03 <mdorman> i think the rehashing is a different problem than the location of the meeting
19:33:10 <j^2> mdorman: that's accurate
19:33:21 <mdorman> and yeah i know there was a lot of feedback this summit about trying to keep the tracks from overlapping as much
19:33:39 <mdorman> austin goes back to the 4+1 days format, instead of 3+1, so it should be better
19:33:39 <klindgren> I think re-hashing will occur if you get a bunch of people who could other wise not attend because the meeting is more local
19:33:45 <klindgren> but I would rather more people get invovled
19:33:49 <klindgren> so thats why I am split on it
19:33:53 <mdorman> i see what you’re saying
19:34:11 <mdorman> yeah i mean the reality is no matter where it’s held, it’s going to be prohibitive to some people who are located far away
19:34:47 <klindgren> Eitherway - I don't know if I will be able to make it to the meetup
19:35:00 <klindgren> s/meetup/mid-cycle
19:35:08 <mdorman> right.
19:35:25 <mdorman> anyway i don’t know that we need to discuss extensively more here.
19:35:59 <klindgren> yep yep
19:36:16 <klindgren> I am interested to see if it pans out -even if I can't make it
19:36:27 <klindgren> I would like to see people join more working groups
19:36:29 <mdorman> +1
19:36:37 <klindgren> and we can get more members doing stuff
19:36:50 <mdorman> +1 to that too
19:38:15 <mdorman> anybody else have any other topics?
19:38:23 <j^2> not i
19:39:33 <mdorman> my next topic: lunch!
19:39:35 <j^2> ha!
19:40:01 <j^2> i think we should share this, or at least run with the notes to the ML, raginbajin do you mind doing that or do you want me to?
19:40:01 <klindgren> my next topic: Profile openstack-conductor!
19:40:29 <raginbajin> j^2 Yeah I can do that.
19:40:33 <j^2> awesome
19:40:34 <mdorman> yup notes to ML is a great idea
19:40:48 <j^2> show the community that we're making this happen
19:41:59 <j^2> cool, anything else?
19:42:07 <j^2> i think we've made some great progress already
19:42:17 <mdorman> i’m good
19:43:00 <j^2> raginbajin: want to end the meeting?
19:43:52 <raginbajin> I think that works for me unless anyone has anything else.
19:43:58 <mdorman> thanks j^2 and raginbajin
19:44:06 <j^2> :D
19:45:51 <j^2> #link https://review.openstack.org/#/c/247075/
19:45:59 <j^2> #link https://review.openstack.org/#/c/247070/
19:46:04 <j^2> just so we have them in the notes
19:47:47 <raginbajin> Cool.
19:47:56 <raginbajin> Then sounds like we are good then
19:48:08 <j^2> yep
19:48:09 <raginbajin> #endmeeting