19:00:54 <j^2> #startmeeting operators_ops_tools_monitoring
19:00:55 <openstack> Meeting started Wed Dec 16 19:00:54 2015 UTC and is due to finish in 60 minutes.  The chair is j^2. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:59 <openstack> The meeting name has been set to 'operators_ops_tools_monitoring'
19:01:04 <j^2> #chair raginbajin
19:01:05 <openstack> Current chairs: j^2 raginbajin
19:01:10 <j^2> hey everyone!
19:01:27 <serverascode> hi
19:01:41 <j^2> I'll give everyone 5ish? mins before starting
19:02:45 <j^2> #link https://etherpad.openstack.org/p/osops-irc-meeting-20151216
19:02:50 <j^2> that's the agenda for this meeting
19:06:03 <j^2> :D
19:06:05 <j^2> ok, cool
19:06:28 <j^2> #topic previous business
19:06:40 <j^2> I had an action item to: j^2 to figure out how to use zuul to validate against the pep8
19:06:42 <j^2> (python|bash) and rubocop linters
19:07:23 <j^2> I renabled Christin Benets? gerrit is down so sorry for butchering your name, bashpep8 tests for tools-generic
19:07:42 <j^2> it seems we need to get the second review in before they can reeable it
19:08:01 <j^2> i pushed the last fix that mdorman noticed this morning so ideally we'll make progress today
19:08:09 <j^2> any questions or thoughts on this?
19:09:10 <serverascode> not from me
19:09:13 <j^2> nice
19:09:43 <j^2> mriedem was supposed to get us an old nova spec, i think he posted it to the mailing list, but i don't remember
19:09:54 <j^2> and it seems he's not in the room so :'(
19:10:06 <rockyg> o/
19:10:15 <j^2> xavpaice pushed up his tenant script so that's awesome
19:10:27 <j^2> it got pushed in pretty quickly which is awesome
19:10:41 <j^2> i think that's all for previous business, any questions?
19:10:57 <serverascode> nopers
19:11:08 <j^2> rockyg: :D
19:11:17 <j^2> ok, cool, on to the new stuff
19:11:28 <j^2> #topic Talk about releases for repos other than tools-contrib and tools-generic
19:11:41 <j^2> now this was an interesting request for EmilienM
19:11:50 <EmilienM> o/
19:11:56 <j^2> hi!
19:12:04 <EmilienM> we are building rpms in RDO
19:12:12 <EmilienM> without the release but it would really be a nicetohave
19:12:18 <EmilienM> much easier for maintainers
19:12:22 <j^2> #link https://www.rdoproject.org/packaging/rdo-packaging.html
19:12:44 <EmilienM> do you have release management in your project?
19:12:50 <j^2> #link https://wiki.openstack.org/wiki/Osops
19:13:01 <j^2> the original agreement: We don't plan on having releases, but we do plan on collecting useful resources for anything ranging from Junior to Senior level administrators.
19:13:47 <j^2> which may be thrown out now because of osops-coda, but that's a different discussion
19:14:33 <j^2> There's a challange with this, the repos arn't designed to be rpm friendly
19:14:34 <rockyg> Could we use tags for indicating a specific version?
19:15:00 <j^2> rockyg: what constitues as a version? that's they move really fast
19:15:53 <EmilienM> I think you should release often
19:15:55 <EmilienM> a tag
19:16:00 <EmilienM> and release notes
19:16:02 <j^2> and we've moved the https://github.com/openstack/osops-tools-monitoring/tree/master/monitoring-for-openstack in it's own directory now
19:16:13 <j^2> that won't help with rpms right?
19:16:14 <rockyg> Even just a date tag could do the trick.  Or a version tag that is 0.1.0 if not reviewed, and 1.0 if reviewed and approved?
19:17:19 <j^2> there's another challenge here too, this is putting overhead on the project when we are still in it's infancy. i don't want to scare people away by this not being "painless and automated"
19:17:29 <rockyg> The tag allows a specific set of files (the tagged build) to be checked out, then the package can be made from that
19:17:31 <j^2> hence the reason to NOT put releases in
19:18:33 <j^2> and unfortunatly we don't have quorum here, so we can't make a decision on this :(
19:19:14 <rockyg> we could consider writing up a lightweight tagging process for version identification
19:19:24 <rockyg> Could just be a date tag
19:19:24 <j^2> we need more voices on this, and this is something for Operators to make their life easier, I don't want to make decisions without more input
19:19:42 <rockyg> Agreed.  But we can make a proposal for review
19:19:45 <j^2> rockyg: that seems reasonable; are there other projects with this?
19:20:50 <rockyg> Good question.  I suspect not in OpenStack, but other OS projects do.  I've done some of this before.  I don't think I could write it up this week, but maybe before the first?
19:21:36 <j^2> rockyg: that' would be awesome. just to see the...level of work and process will be useful to see what this would entail
19:21:59 <j^2> and if we do it for one of our "core" repos, then we'd probably do it for them all
19:22:06 <j^2> but that's just me spitballing
19:22:21 <rockyg> ++
19:22:49 <j^2> awesome, any other questions or thoughts? serverascode thoughts?
19:22:57 <rockyg> We can get comments from ops, release and infra once we have the strawman up.
19:23:06 <j^2> rockyg: agreed
19:23:27 <rockyg> could you do a #action for me for this?  So it gets into the minutes
19:24:00 <j^2> #action rockyg will write up a way to tag per day for the repos
19:24:51 <j^2> next topic?
19:25:22 <j^2> #topic Talk about osops-coda
19:25:27 <j^2> we have a new project!
19:25:40 <j^2> HPE has asked us to put coda in our namespace
19:25:49 <j^2> this was a request at the toyko summit
19:26:12 <serverascode> what's a coda?
19:26:25 <j^2> wall of text incoming
19:26:27 <j^2> Coda is a Horizon dashboard and panel (both share the name) that
19:26:29 <j^2> facilitates resource clean up of a project once that project is no longer
19:26:31 <j^2> needed (e.g. A customer cancels their account). It consists of a single
19:26:33 <j^2> text entry box which allows you to search by project ID and will display
19:26:35 <j^2> all resources, project info, and user info for the project. Upon pressing
19:26:37 <j^2> the delete button the user is prompted each time for valid admin
19:26:39 <j^2> credentials (annoying but a purposeful safe-guard) and will then walk the
19:26:41 <j^2> list of resources deleting each one and will display the outcome of each
19:26:43 <j^2> operation in a tabular format. This project started as a stand-alone
19:26:45 <j^2> Django app inside HP and has been very valuable in operating our public
19:26:47 <j^2> cloud. It was originally called Scrubber (because that's what it did) but
19:26:49 <j^2> was renamed to Coda after being ported to Horizon and adapted for Keystone
19:26:51 <j^2> instead of a proprietary Identity service. It is the intent of HP to open
19:26:53 <j^2> source our entire suite of tools using a musical theme. Coda was chosen as
19:26:56 <j^2> the name for this project as a coda in music is a passage that brings a
19:26:57 <j^2> piece to an end. It is particularly apropos for this use because the
19:26:59 <j^2> symbol for a coda resembles a cross hair.
19:27:01 <j^2> i'll give everyone some time to read it
19:28:08 <serverascode> ok, cool, yeah that sounds great
19:28:11 <j^2> :D
19:28:12 <klindgren> Join in the middle of this - iirc HP lightning talk during the tokyo confrence on this.  iirc it only works if the keystone tenant/project has not yet been deleted.
19:28:25 <j^2> klindgren: yeah that sounds right
19:28:33 <j^2> but it's coming to us to make it better :D
19:28:49 <j^2> this will be posted to the ML when we get the code in the repo
19:28:58 <raginbajin> Sorry I'm late.. meeting ran long.
19:29:03 <j^2> no worries
19:29:05 <klindgren> kk
19:29:27 <j^2> but i wanted to give everyone a heads up here, it's a great win for us to grow the project more
19:29:46 <j^2> any questions or thoughts?
19:30:47 <raginbajin> I think that's cool.
19:30:54 <rockyg> A project of this size will need real release process.  Scripts can be lighter weight, but not a full gui plus
19:31:04 <rockyg> And it's really cool.
19:31:21 <j^2> rockyg: agreed it dove tails with the openstack-monitoring slurping too
19:32:36 <j^2> we only have a couple more topics
19:32:41 <j^2> continue on?
19:32:45 <raginbajin> That project makes sense to have releases.
19:32:51 <j^2> raginbajin: yep
19:33:33 <raginbajin> good to move on from me
19:33:41 <rockyg> ++
19:33:43 <j^2> raginbajin: still waiting to get it in our namespace then we can discuss at a macro scale on the release for them
19:34:04 <j^2> #topic Notes4chairs
19:34:17 <j^2> I created a wiki page to help out chairs for this meeting
19:34:31 <j^2> raginbajin and I have been running them but i want to open it up for more of the group
19:34:39 <j^2> #link https://wiki.openstack.org/wiki/OSOpsNotes4Chairs
19:35:15 <j^2> crap, that was supposed to be wiki/Osops/Notes4Chairs in our namespace. screwed that one up :'(
19:35:23 <j^2> oh well
19:35:43 <j^2> so I'd like to ask for volunteers for more chairs and i'll post to the ML asking for more
19:35:55 <j^2> i think we can use it as a way to get more people involed
19:36:15 <j^2> #action j^2 post to ML for more volunteer chairs for osops meeting
19:36:16 <rockyg> ++
19:36:36 <j^2> any thoughts/questions?
19:36:59 <rockyg> we might actually get more devs, too, with the weekly announcement on the ml
19:37:16 <j^2> rockyg: can you explain that?
19:37:19 <j^2> i'm missing something
19:38:33 <rockyg> by sending out weekly meeting announcement on ops ml, it might attract some devs' attention and they would participate
19:38:54 <j^2> ohhh yeah sorry, i thought there was another announcement i was missing :P
19:39:07 <rockyg> np
19:39:19 <j^2> serverascode: any thoughts?
19:39:40 <j^2> otherwise going to the last topic
19:39:41 <serverascode> nope that sounds good to me
19:39:43 <j^2> cool
19:39:54 <j^2> #topic Waiting on so we can add the bashte jobs to tools generic
19:40:18 <j^2> ok, so when gerrit comes up we are one step away from getting tools-genirc with the bashte job working
19:40:24 <j^2> #link https://review.openstack.org/#/c/229031/ -> https://review.openstack.org/#/c/229043/
19:40:38 <j^2> we need those both to pass then we have a gate on tools-generic
19:40:42 <j^2> this is extremely important
19:41:11 <j^2> especially after how, i mentioned our workflow in superuser, thanks to everyone that helped edit the topic
19:41:21 <j^2> #link http://superuser.openstack.org/articles/check-out-this-tool-library-for-openstack-operators
19:41:54 <j^2> but with gerrit down, we are stuck :(
19:42:00 <j^2> any questions or thoughts?
19:42:51 <serverascode> is bashte a tool? I can't find anything about it
19:43:18 <j^2> i may be butchering the name
19:43:33 <rockyg> maybe bashate?
19:43:34 <j^2> http://git.openstack.org/cgit/openstack-dev/bashate/tree/README.rst
19:43:47 <serverascode> ah ok
19:44:00 <j^2> it's the "sane" default we agree for bash
19:44:57 <j^2> #link http://git.openstack.org/cgit/openstack-dev/bashate/tree/README.rst
19:45:48 <j^2> cool anything else on this topic?
19:45:58 <j^2> we are at about 15 mins, which i'd like to open to general discussion
19:46:46 <serverascode> nothing else from me
19:46:53 <j^2> #topic Open Floor
19:47:30 <j^2> klindgren, serverascode, raginbajin, rockyg :D floor is open
19:48:37 <klindgren> I dont think I have everything - due to the holidays and trying to get other work done before EOY
19:48:46 <raginbajin> I don't have anything
19:48:47 <klindgren> s/everything/anything
19:49:10 <serverascode> nothing from me either
19:49:23 <rockyg> me too.  too on my plate  ;-)
19:49:24 <j^2> Sooo.. Star Wars? ;)
19:49:36 <rockyg> Monday.  Freebie tix from netapp
19:49:42 <j^2> nice
19:50:16 <rockyg> That's if I've recovered enough from sinus surgery Friday
19:50:30 <j^2> :D
19:50:43 <j^2> awesome, well if we're good i'll close the meeting and give everyone 10 mins back
19:50:57 <rockyg> ++
19:51:05 <rockyg> Everybody have some good holidays
19:51:21 <j^2> you too rockyg
19:51:24 <j^2> #endmeeting