19:00:46 <j^2> #startmeeting operators_ops_tools_monitoring
19:00:46 <openstack> Meeting started Wed Jan 27 19:00:46 2016 UTC and is due to finish in 60 minutes.  The chair is j^2. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:49 <openstack> The meeting name has been set to 'operators_ops_tools_monitoring'
19:00:58 <j^2> #topic Rollcall
19:01:02 <j^2> Hey everyone!
19:01:05 <docaedo> Hello!
19:01:11 <j^2> please checkin or say hi to track you being here
19:01:11 <raginbajin> Hello
19:01:15 <raginbajin> o/
19:01:50 <mdorman> o/
19:02:42 <j^2> unfortunately i’m being called away at the moment
19:02:47 <j^2> raginbajin: can you run this or mdorman ?
19:02:56 <mdorman> i’m on a call also for another 30 min :(
19:03:03 <raginbajin> I can that's fine.
19:03:07 <j^2> rockon
19:03:09 <j^2> thanks
19:03:11 <j^2> #chair raginbajin
19:03:11 <openstack> Current chairs: j^2 raginbajin
19:03:18 <raginbajin> Let me pull up the meeting agenda
19:03:37 <docaedo> #link https://etherpad.openstack.org/p/osops-irc-meeting-20160127
19:03:51 <raginbajin> Thank you
19:03:53 <docaedo> ^^ agenda (for the logging :) )
19:03:56 <docaedo> np
19:04:17 <klindgren> o/
19:04:30 <raginbajin> #topic Previous Business
19:04:48 <raginbajin> Just want to review previous business from the last meeting to see if there is any additional information that we should discuss
19:04:53 <raginbajin> The first is Talk about releases for repos other than tools-contrib and tools-generic
19:05:15 <mdorman> was there any history on that?
19:05:36 <raginbajin> The discussion was that we would not be doing releases at this point.
19:05:53 <rockyg> o/
19:05:55 <raginbajin> We are still a pretty small group, and to handle releases would be a big task.
19:06:26 <mdorman> yeah i kinda agree
19:06:53 <raginbajin> If there isn't anything additional to this to bring up, then the next would be - paulcz: talk about moving the terriform tooling to it's own repo
19:07:10 <rockyg> Although, it might be worth tagging some of the stuff when it's in a good and reviewed condition
19:07:50 <rockyg> a repo tag/label
19:08:12 <raginbajin> rockyg: Ok good point.. We can review that once we get to a point where we actually have something that is tagged.
19:08:17 <raginbajin> I mean needs tagging
19:08:26 <mdorman> yeah i think something lightweight like that would be appropriate
19:08:27 <rockyg> ++
19:09:05 <raginbajin> The terriform tool wanted to move its tool over to its own repo under osops
19:09:36 <raginbajin> We have done this already for other tools and we didn't see it as any issue to bring it under the umbrella
19:09:59 <raginbajin> Any new comments for this?
19:10:18 <klindgren> none from me
19:10:54 <raginbajin> The final item in the old business then is - balajin: Fixing the ical to reflect correct dates (it shows up on my calendar every week)
19:10:57 <mdorman> so we’d have a osops-terriform repo?
19:11:06 <mdorman> sorry, late to that topic
19:11:15 <raginbajin> Yes, we would have an osops-terriform repo
19:11:32 <raginbajin> and other bigger projects that want to hand these over to osops would use the same naming pattern.
19:11:44 <mdorman> gottcha.   ok makes sense.  thanks for the explanation
19:11:58 <rockyg> ++
19:12:41 <raginbajin> It looks like from the notes that the ical has now been corrected, but I'm not 100% sure if thats the case or not. balajin was the one reporting it and mentioned it was fixed.
19:13:07 <raginbajin> Not sure if anyone has an info on this.
19:13:55 <docaedo> I don't have a link to the review handy, but when I look in my google calendar I do not see the ops meeting noted
19:14:12 <docaedo> #link http://eavesdrop.openstack.org/irc-meetings.ical
19:14:13 <rockyg> me either.  Hi, docaedo!
19:14:18 <docaedo> rockyg: hey!
19:14:48 <raginbajin> and here's the link to the review
19:14:51 <raginbajin> #link https://review.openstack.org/#/c/268326/
19:15:35 <raginbajin> Looks like from the last comment that j^2 was still looking for some confirmation from openstack-infra group on it, but that's the last of the updates.
19:15:40 <docaedo> raginbajin: thanks - then looks like that -1 from Tony needs to go away
19:16:09 <raginbajin> We'll keep it as an action item to follow-up with next meeting to make sure it gets resolved.
19:16:24 <raginbajin> That's it for previous business.   Does anyone have anything that I missed or would like to bring up?  I'll give everyone a minute or two before moving on.
19:17:34 <rockyg> docaedo, want to introduce yourself and your relevant project?
19:18:01 <docaedo> rockyg: sure (but I'll wait 'till the chair moves on to the next topic ;) )
19:18:23 <rockyg> Ah, right.  Sorry.  Still old biz
19:18:50 <raginbajin> #topic New Business
19:18:52 <raginbajin> #topic Talk about finding a place for Operator bits in the Community App Catalog (apps.openstack.org)
19:19:05 <docaedo> raginbajin: thanks!
19:19:12 <raginbajin> yep!!
19:19:29 <raginbajin> The floor is yours I'm guessing
19:19:44 <docaedo> I wanted to bring up the topic (suggested by rockyg) of adding Operator things to the openstack community app catalog
19:19:49 <docaedo> #link https://apps.openstack.org
19:20:09 <docaedo> j^2 has joined our meetings on occasion and has been active in the conversations we've had in the past
19:20:23 <docaedo> the main thing that has come up was what exactly could be put in the catalog
19:20:48 <docaedo> To my mind the easiest way to think about the catalog is as an index of "things" that can be used with an OpenStack cloud
19:21:26 <docaedo> The idea of going to "apps.openstack.org" to find an installer for OpenStack (like fuel for instance) doesn't make much sense to me - BUT seems like there's room for other things that operators can use
19:21:45 <docaedo> anyway, we'd had minor conversations kicking around from a few months back but they were pretty inconclusive
19:21:45 <raginbajin> I guess I see apps.openstack.org as more for the users and not the operators.
19:22:15 <docaedo> raginbajin: yes I mostly agree, but I think there's room (at least potentially) to include things in there for operators too,
19:22:19 <raginbajin> I also wonder if we have another place for people to go, how do we manage that and how do we get operators to be be a part of our community.
19:22:26 <raginbajin> fair enough.
19:22:29 <docaedo> so thought it would be a good idea to get some input from the operators
19:22:37 <rockyg> Well, just like the apple and google stores have categories for music, games, apps, this catalog could have a category for "operations"
19:23:21 <mdorman> my question is how any of hte osops stuff would fit into a glance image, heat template, or murano package
19:23:34 <rockyg> If the osops tagged repo gets tarballed, or just zipped if it's a single utility, then the catalog could point there, maybe?
19:23:35 <docaedo> right - one of the things to keep in mind is that the three categories right now (heat, glance, murano) were just in a sense temporary, for launch, with the intention that they would be expanded upon
19:23:48 <mdorman> i see
19:23:58 <docaedo> we're working to add Mistral and TOSCA assets right now
19:24:26 <docaedo> so the bigger question
19:24:46 <docaedo> is does it make sense to include things for operators too? and if so, what specific things would be there, what might it look like?
19:25:10 <docaedo> (and if you as a group think it unnecessarily fragments the operator community, please say so :) )
19:25:42 <mdorman> yeah i mean aside from the effort needed to maintain such a thing, seems like it might be useful.   i would imagine like a “tools” package that could kind of aggregate the whole tools repo somehow
19:25:54 <mdorman> and another one for “monitors” for all teh monitoring scripts
19:26:02 <raginbajin> I think we as an operators community are struggling to get enough support and/or tools added to our repos now.
19:26:21 <mdorman> but i’m wondering how much that stuff would actually be sourced from the app catalog, vs. operators just pulling them down from git.   i.e. is there actually demand for that stuff in the app catalog
19:26:36 <raginbajin> +1
19:26:38 <mdorman> raginbajin:  i would agree with that as well.
19:26:50 <docaedo> I don't think there's demand for that today, and might not ever be TBH
19:27:03 <docaedo> but that's why I wanted to chat here with you all
19:27:15 <mdorman> yeah probably the focus for now should be on getting more tools that are well-validated and curated in teh repos in the first place
19:27:31 <mdorman> then we could talk more about different ways to package and distribute
19:28:05 <docaedo> seems reasonable to me - also I was not really sure what the current state was with respect to that (one more reason to have a quick conversation about it)
19:28:34 <rockyg> sounds like "not at the moment, but don't do anything to lock us out without first consulting us"
19:28:45 <raginbajin> +1
19:29:33 <docaedo> rockyg: oh no way, it's now or never! if the operator group spurns the app catalog today we'll never work together again!!!! MUAHAHAHA
19:29:44 <docaedo> just kidding :) I feel like IRC meetings need more levity
19:29:53 <mdorman> sounds like a good plan to me
19:29:58 <docaedo> I actually think that perfectly captures it
19:30:21 <docaedo> and I plan to stay in contact with you guys of course, and will keep the operator community in mind all the time
19:30:32 * rockyg laughs but then the cold kicks in an makes me cough
19:31:35 <rockyg> Yeah, I'm just a troublemaker, making sure the devs are aware of the other stakeholders.....
19:31:45 <raginbajin> So, it sounds like we the operators group is going to continue to concentrate on getting more validated and curated tools into our current repos and then look for different ways to package and distribute down the line.  This could include the app.openstack.org area eventually.
19:31:46 <docaedo> rockyg: it's much appreciated
19:31:59 <docaedo> raginbajin: +1
19:32:03 <mdorman> +1
19:32:04 <rockyg> Sounds great.
19:32:12 <docaedo> thanks for the conversation
19:32:27 <raginbajin> Thank you for talking with us for sure.
19:32:36 <rockyg> Thanks!
19:33:02 <raginbajin> That's it for new business.  Does anyone have any additonal new business they would like to bring up?
19:33:12 <rockyg> Midcycle?
19:33:21 <raginbajin> #topic Other new business
19:33:26 <raginbajin> #topic Mid-Cycle
19:33:37 <mdorman> that’s waht i was going to say.  how much presense will we have there?
19:33:56 <rockyg> I'm gonna be there.  I can advertise and promote.  Anything specific you want me and/or others to do?
19:33:58 <raginbajin> I know I won't be able to attend. International trips are hard to get approved.
19:34:51 <raginbajin> I think just reminding people about any tools, monitors, scripts, etc are there for their contribution as well as use.
19:35:21 <mdorman> +1 yeah that’s the main thing.  it’s really easy to contribute to the -contrib repo now, that’s a good first step for people
19:36:36 <rockyg> I'll get Tom to put it in the intro slides...
19:37:00 <mdorman> is j^2  going, anybody know?
19:37:12 <rockyg> Do we have good readme.rst in each of the repos?
19:37:20 <raginbajin> #action rockyg will talk with Tom F. about mentioning the OSOPS group in the introduction slides.
19:37:35 <j^2> mdorman: yeah i couldn’t get the funds for it. :(
19:37:41 <mdorman> ish on readmes
19:38:22 <rockyg> That would be good to have in reasonable shape before the midcycle.  That way, quick reviews by ops to see what's already out there.
19:39:27 <mdorman> someplace there is a wiki page that explains it better.  but i can’t find it now
19:39:38 <raginbajin> Do I have any volunteers to take on the task of updating the readmes
19:40:14 <mdorman> i can do that
19:40:34 <raginbajin> awesome.. Thanks mdorman
19:40:43 <rockyg> Thanks mdorman
19:40:54 <raginbajin> #action mdorman will update the osops repo's readme files to give a better description of their purpose.
19:41:49 <raginbajin> Do we have anything else for the mid-cycle?
19:42:30 <raginbajin> Do we have any other new business?
19:43:32 <raginbajin> Doesn't sound like it... I'll give everyone another 1-2 minutes for any other business. Then close the meeting if there is nothing else to discuss
19:44:16 <rockyg> Thanks!
19:44:27 <docaedo> thank you!
19:44:43 <raginbajin> Sounds like we are all done for today's meeting..
19:44:47 <mdorman> i’m good.  thanks raginbajin
19:44:54 <raginbajin> Thank you everyone for coming and participating.
19:45:08 <raginbajin> We will see everyone again in 2 weeks..
19:45:22 <raginbajin> #endmeeting