18:59:09 <RaginBajin> #startmeeting operators_ops_tools_monitoring
18:59:09 <openstack> Meeting started Wed May  4 18:59:09 2016 UTC and is due to finish in 60 minutes.  The chair is RaginBajin. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:59:13 <openstack> The meeting name has been set to 'operators_ops_tools_monitoring'
18:59:49 <RaginBajin> #link https://etherpad.openstack.org/p/osops-irc-meeting-20160504
19:00:00 <RaginBajin> That's the agenda for today's meeting.
19:00:23 <RaginBajin> o/
19:02:08 <RaginBajin> Just giving it a few minutes for others to join.
19:02:59 <mdorman> o/
19:03:04 <mdorman> here-ish
19:03:27 <RaginBajin> đź‘Ť
19:06:15 <mdorman> ok here for real now
19:06:37 <RaginBajin> Great.. Still only us at the moment.
19:07:07 * mriedem joins late
19:07:08 <mdorman> i always worry i’ll have the UTC offset wrong and be an hour late
19:07:33 <RaginBajin> Hopefully a few more will join.  Yeah I figured out in my Outlook calendar that you can actually enter it as UTC
19:07:44 <RaginBajin> and it will do the conversion for you within the calendar and update all your devices that way
19:08:15 <RaginBajin> Hi mriedem.. Thanks for coming
19:08:17 <mdorman> cool
19:08:30 <mdorman> klindgren is here too
19:08:59 <RaginBajin> perfect..
19:09:09 <RaginBajin> well I guess we can just start and we'll see where it takes us.
19:09:21 <RaginBajin> #topic Summit Recap
19:09:44 <RaginBajin> There are two big sessions we had.. https://etherpad.openstack.org/p/AUS-ops-OSOps and https://etherpad.openstack.org/p/AUS-ops-Requests-for-Enhancement-Process
19:10:02 <RaginBajin> Both of them had some really good discussions going on..
19:10:19 <RaginBajin> The first half of the OSOps had close to the same discussion points as the RFE sessions.
19:11:01 <rockyg> o/
19:11:32 <RaginBajin> I think the biggest action that came out of those sessions was ways that from either direction that feedback can be provided.
19:12:15 <RaginBajin> Ideas around having Liason's that possible work between the groups was laid out. I think a great example of that happening right now is mriedem from the Nova team participating in our group sessions.
19:13:00 <mdorman> did that idea of liasons seem to resonnate with the other projects, too?  i couldn’t come to the RFE session
19:13:26 <RaginBajin> From what I could tell, there wasn't a lot of other projects attending..
19:13:42 <mdorman> ah i see, heh.
19:13:45 <RaginBajin> So, I think in order for it to work, we (osops) would have to find someone that is willing to participate from this side.
19:14:02 <RaginBajin> and go to their meetings to start building that relationship
19:14:33 <mdorman> makes sense
19:15:06 <RaginBajin> We also heard that the OSOps group can be an advocation group for patches, tools, and features that operators would like to see.
19:15:20 <mriedem> fwiw, cburgess is usually always in the nova channel, and is pretty involved with ops questoins when the nova devs have them
19:15:31 <mriedem> b/c he's reasonably familiar with the code
19:15:32 <mriedem> nic too
19:15:37 <mriedem> so we have some of that already
19:16:15 <RaginBajin> Oh that's good to know.. Maybe we can reach out to them to see if they would be willing to bring back what they know here as well.
19:16:16 <mriedem> what we (nova) don't really have a lot of the time is someone from the ops side coming to us saying 'this is a major thing that all of us are dealing with and would like to see it prioritized if possible and this is why'
19:16:36 <mriedem> so we don't know what we don't know
19:17:04 <mriedem> to the point raised in the RFE session, it doesn't mean nova is going to drop everything it's already doing, or planning to do, for anything that's brought up
19:17:12 <mriedem> but it'd be good to know so it's in our heads and potential backlog
19:17:30 <RaginBajin> That to me is the feedback loop I was really interested in.. I see all the mentions in etherpads, and it's like if 20 people are saying yes to it.. Then maybe we need to figure out how to bring it up.
19:18:03 <mriedem> honestly i think if there is just a thing that bubbles up on the ops side, make sure it's mentioned in this meeting or the nova meeting or in the ML
19:18:12 <mriedem> just to get the initial communication ball rolling
19:18:35 <RaginBajin> Gotcha..
19:18:47 <mriedem> btw, communication ball (tm)
19:18:58 <RaginBajin> As long as it comes in different colors.
19:19:36 <mriedem> can do
19:19:49 <RaginBajin> Another item that was mentioned was finding a task to start off with to start figuring out how to groom a list of issues..
19:20:13 <RaginBajin> I think there are two great sessions that a lot of information could be pulled into and maybe summarized into particular problems...
19:20:18 <RaginBajin> https://etherpad.openstack.org/p/AUS-ops-Liberty-upgrades and https://etherpad.openstack.org/p/AUS-ops-informal-meetup
19:20:44 <RaginBajin> I'm wondering if there is anyone out there that would like to take that action on..   I can also raise it to the mailing list as well for additional help
19:21:46 <RaginBajin> We could say just take the Nova side (since we have active representation) and collect all the Nova type of issues.. Work them down into "yeah that's a config problem" to "ooooh that's really broke" and then start with that list.
19:23:14 <RaginBajin> Whoa whoa.. Too many volunteers... :)
19:23:18 <mriedem> i was in the liberty upgrades session and i don't really remember any kind of action items for nova come out of that
19:24:07 <RaginBajin> You are probably right. I just know that there was a lot of discussions around a lot of things.. Maybe another Ops session is a better option.
19:24:28 <RaginBajin> Either way, I'll take the action to go ahead and put something out on the Mailiing List to see if i can wrangle up some help.
19:24:52 <RaginBajin> #action raginbajin will send out an email asking for help to break down an etherpad or two to collect data to share with the group and nova about problems identified.
19:26:09 <RaginBajin> Does anyone else want to maybe send out an email to the list about looking for liasons to work between osops and the project teams?  Are we at that point to take on a few more, should we?
19:27:32 <RaginBajin> Ok. Well I'll take that one as well to keep things moving forward.
19:28:00 <mdorman> yeah we could at least ask.  see if anyone out there is already kinda doing that, anyway, or if folks have interest in particular projects.
19:28:20 <RaginBajin> #action  RaginBajin to email out to the mailing list discussing the idea of liasons working between osops and project teams.  Hopefully this will bring in some feedback.
19:28:49 <RaginBajin> Ok.. I think the feedback will tell us if there is any sort of interest out there at least for now.
19:29:00 <mdorman> agreed
19:29:53 <RaginBajin> The only other actions that were from the summit was to get the Kolla project to maybe add some brief configuration files that could be used for sanity checking.. Right now you don't know what options you should be using for a working model and which ones don't
19:30:29 <RaginBajin> and I need to upload a rally job that I have that creates a vm and then ssh's into it to test end to end connectivity as an example for monitoring.
19:30:46 <RaginBajin> Other than that.. We are on to New business
19:30:50 <RaginBajin> #topic new business
19:31:07 <RaginBajin> I think you added a few things mriedem
19:32:06 <mriedem> yeah
19:32:16 <mriedem> Request for operator review of nova spec https://review.openstack.org/#/c/306647/ Improve Scheduler Logging
19:32:25 <mriedem> cfriesen had a thing in the ops list about this
19:32:38 <mriedem> basically just looking for feedback on how ops would like to see this done/used
19:32:58 <mriedem> i.e. dump debug only on NoValidHost, or always, or configurable, etc
19:33:19 <mdorman> i looked at that this morning, i think it’ll be a great step forward
19:33:24 <mriedem> #help Request for operator review of nova spec https://review.openstack.org/#/c/306647/ Improve Scheduler Logging
19:33:31 <mriedem> the other one is
19:33:32 <mriedem> #help Request for operator review of nova spec https://review.openstack.org/#/c/311529/ Add spec for lower case metadata keys only
19:33:51 <mriedem> this is a spec to add a microversion in the nova api to enforce that metadata keys are only lower-case,
19:34:02 <mriedem> because depending on your database, it treats the values different in the backend
19:34:16 <mriedem> which is a long standing latent bug for things like aggregate metadata, flavor extra specs, and instance metadata
19:34:34 <mriedem> so the idea here is, don't dick around with the db api gorp, and just enforce lower-case in the api after the microversion
19:34:35 <mdorman> makes sense
19:34:41 <mriedem> and anyone below that microversoin has to live with the latent bug
19:34:51 <mriedem> which we'll document in the api-ref
19:35:23 <mriedem> there would be a nova-manage command provided to fold the duplicate metadata keys
19:35:34 <mriedem> so that's a thing deployers can use, but would like feedback on how that might be used
19:35:42 <mriedem> or if we're missing anything and doing this could cause big problems for people
19:36:01 <mdorman> was there a post to the ML about that one, too?   i can’t remember
19:36:05 <mriedem> yeah
19:36:07 <mdorman> kk
19:36:18 <mriedem> it's linked as a reference in the spec
19:36:27 <mdorman> gottcha
19:36:40 <RaginBajin> Is there anything in particular that we can help with on these?
19:36:49 <RaginBajin> My initial thought is sending out some more reminders on the Mailing list to get more feedback.
19:38:09 <mriedem> cfriesen already did on the first one
19:38:16 <mriedem> and that's the one that probably needs more feedback
19:38:28 <mriedem> the metadata keys fix is probably less of an issue,
19:38:35 <mriedem> so just one or two ops being cool with that is good for me
19:38:54 <RaginBajin> Gotcha.. Well lets see what we can do then..
19:39:43 <RaginBajin> Ok.. Is there anything else that anyone would like to bring up.
19:40:10 <mdorman> so question mriedem , when there is a new patchset posted on a spec review, do you all look for additional +1’s at that point?   or if somebody +1’d an earlier patch set as “yes this feature looks good to me and would be useful to ops”, does that sort of “count”?
19:40:30 <mdorman> basically do we need to pay attention to later patch sets and make sure to go +1 again?
19:41:02 <mriedem> mdorman: the former i think
19:41:11 <mriedem> i don't expect ops to be babysitting these
19:41:18 <mriedem> unless they really care about seeing them land
19:41:24 <mriedem> this is really a sanity check
19:41:24 <mdorman> kk, right right.  makes sense.
19:41:29 <mdorman> sounds good
19:42:49 <mriedem> the only other thing i'd say as an fyi which wasn't on the agenda,
19:42:53 <mriedem> nova-network is deprecated again
19:43:07 <mriedem> there isn't a set date for removal though
19:43:11 <mriedem> we have things we have to land in newton first
19:43:13 <mriedem> details are in http://lists.openstack.org/pipermail/openstack-dev/2016-May/093589.html
19:43:46 <RaginBajin> cool
19:43:48 <mdorman> yeah i had heard some rumblings about that.
19:44:31 <mriedem> those were probably just hunger pains
19:44:41 <mdorman> hehehe
19:44:50 <mdorman> i didn’t have anything else to bring up RaginBajin
19:45:05 <mdorman> thanks so much for the time mriedem
19:45:13 <RaginBajin> Yes! Thank you.
19:45:17 <mriedem> sure, np
19:45:20 <mriedem> i don't have anything else
19:45:45 <RaginBajin> Thanks everyone for coming...
19:46:05 <mdorman> thanks RaginBajin.  also appreciate you running the sessions in austin
19:46:29 <RaginBajin> no problem.. Hopefully they were and these are useful.. Time will tell.
19:46:32 <RaginBajin> #endmeeting