14:05:27 <mihalis68> #startmeeting Ops Meetup Team
14:05:28 <openstack> Meeting started Tue Sep 19 14:05:27 2017 UTC and is due to finish in 60 minutes. The chair is mihalis68. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:33 <openstack> The meeting name has been set to 'ops_meetup_team'
14:06:07 <emccormick> 4 looks like
14:06:41 <mihalis68> #link https://etherpad.openstack.org/p/ops-meetups-team agenda
14:08:02 <mihalis68> eric you're updating the wrong meeting, scroll up
14:08:08 <emccormick> oops
14:08:09 <emccormick> :D
14:08:10 <mihalis68> sorry
14:08:15 <mihalis68> but it IS the 19th, pretty sure
14:08:24 <mihalis68> #topic actions
14:08:25 <emccormick> There we go.
14:08:39 <mihalis68> I have one ongoing activity, to launch the Wiki-fied operators guide
14:08:49 <medbrry2> #action me to email ops about ptg
14:08:50 <mihalis68> I have done a little bit of work on that
14:09:27 <mihalis68> Bloomberg had two people at PTG and one of them (David Desrosiers) is helping me with doc issues. We'll try to pull together the TOC page for the guide this week, so this action continues
14:09:30 <smcginnis> Sounded like the message got across at the PTG that older docs were a necessity.
14:09:36 <mihalis68> yeah, quite true
14:09:46 <mihalis68> they seem to have agreed to not delete from Mitaka onwards
14:09:47 <VW> o/
14:09:53 <mihalis68> and also there is a plan for how to make that work
14:09:54 <mihalis68> hi VW
14:10:19 <mihalis68> they are moving code like parts out of the doc files to a separate place so they can be maintained after the docs are locked for a release
14:10:33 <mihalis68> we are upgrading to mitaka soon and then my complaint about vanishing docs will be no more
14:10:34 <emccormick> awesome
14:10:57 <mihalis68> I had another action somewhere to spiff up the team wiki reflecting upcoming events : DONE
14:11:30 <emccormick> I had one from a couple weeks ago to make the etherpad for SYD session planning and send out to the list. That is here. https://etherpad.openstack.org/p/SYD-ops-session-ideas
14:11:44 <emccormick> It's got some things in it, but it's pretty light. Need to send another nag.
14:13:01 <mihalis68> another topic that I was interested in in Mexico City was openstack release cadence and the possibility of long-term support releases of openstack (for example, hypothetically, making every other release maintained for longer)
14:13:11 <mihalis68> This is an infinitely deep rabbit hole
14:13:23 <mihalis68> I had discussions on this with David and eventually just had to grind to a halt
14:13:40 <mihalis68> but I will say that a lot of feedback to the devs amounts to "you are insane"
14:13:59 <mihalis68> the idea that on day 1 we install a new openstack, run it for 6 months, then install the next one is just not realistic
14:14:05 <emccormick> Yeah there's a lot of opposition to it
14:14:08 <smcginnis> On the plus side...
14:14:09 <emccormick> but me wants it.
14:14:18 <medbrry2> driving but will comment on lts hen i park
14:14:28 <smcginnis> I think my whining about vendors needing to support LTS is getting a little bit of traction.
14:14:30 <mihalis68> go ahead smcginnis
14:14:42 <smcginnis> Red Hat is planning an LTS version.
14:14:54 <mihalis68> the developers have valid difficulties in making an LTS happen, but I think they can be solved
14:14:56 <emccormick> *tingle*
14:15:01 <smcginnis> And I think Huawei will follow suite if they listen to our recommendations.
14:15:14 <mihalis68> for example a lot of openstack depends on python bits and pieces and those don't necessarily have LTS either
14:15:25 <smcginnis> So if we have two vendors supporting an LTS release (as long as it's the same release) we may get wider buy in.
14:15:30 <emccormick> will that trickle down to RDO or just RHOS?
14:15:46 <smcginnis> emccormick: Not really sure at this point. I'm guessing RHOS only.
14:15:51 <mihalis68> yes Maria (representing RH) said she has some customers who want an LTS (even whilst emphasizing some still want the maximum velocity - 2 releases per year or more)
14:16:04 <smcginnis> ++
14:16:08 <smcginnis> There's definitely a mix.
14:16:19 <mihalis68> David is a Canonical employee assigned to Bloomberg and so he gets it that we need an LTS too
14:16:25 <smcginnis> NFV users seem to want a feature as soon as it's coded. Other's not so much.
14:16:40 <mihalis68> he's talking to Canonical luminaries such as James Page to get the current picture and thinking about this so far
14:16:44 <medbrry2> cannical has alway suportd an Lts
14:16:57 <medbrry2> tied to their LLTS Ubuntu
14:17:17 <mihalis68> they do, med, but the actual openstack official dev community still only has 2/year as always.
14:17:29 <mihalis68> maintenance of a release (other than security fixes) stops 6 months and a day
14:17:33 <smcginnis> I think the key to this will be getting Red Hat, Canonical, SuSE, Huawei, etc. all working towards the same LTS in the open rather than in their own downstream support teams.
14:17:35 <medbrry2> But the Stable team has no bandwidth or power to o more
14:17:58 <mihalis68> yes, it is clear from the devs that it's resources, not a lack of interest
14:18:06 <medbrry2> mihalis68: agreed.Canonical does backport secu to their LTSs
14:18:06 <mihalis68> or not only the latter :)
14:18:42 <medbrry2> smcginnis: Im not sure how t effectively influence that.
14:18:53 <medbrry2> afai n ops oon the tc
14:19:01 <smcginnis> Me neither, but I'll keep whining about it in public while I can. ;)
14:19:02 <emccormick> Someone put this on the etherpad
14:19:06 <mihalis68> My view is an openstack released today (hypothetically) shouldn't be installed for production for a while even if I had the deployment capability to keep up. Let it get some mileage first
14:19:12 <emccormick> we can talk about it at the Forum with a wider group
14:19:14 <smcginnis> UC has a voice for sure though.
14:19:15 <mihalis68> so then it dies 6 months later? I DONT GET IT
14:19:21 <medbrry2> no operators on the TC
14:19:30 <admin0> mihalis68: it does not die .. you just upgrade it properly
14:19:49 <mihalis68> I can't "just upgrade it"
14:19:57 <emccormick> mihalis68 I"m with you on the letting it bake thing
14:20:02 <admin0> and there are people who are still running icehouse becuse it fits all the needs ..
14:20:02 <smcginnis> I think the topic should definitely be at the forum. The only way we'll get there is to be very vocal to vendors that can make it happen.
14:20:15 <mihalis68> if I'm running it in production and it has a bug I need to fix that not just unleash a newer version and possibly break more stuff
14:20:31 <emccormick> +1
14:20:48 <mihalis68> Unfortunately I cannot make Sydney
14:21:26 <mihalis68> so people who will be there will need to push this issue
14:22:07 <mihalis68> med is the TC makeup deficient, not having operators?
14:22:19 <mihalis68> obviously asking for an opinion
14:22:28 <mihalis68> understanding that others may have a diff view
14:23:01 <mihalis68> or anyone else?
14:23:02 <emccormick> ok it's on the etherpad
14:23:15 <medbrry2> nsorry driving gain
14:23:32 <smcginnis> mihalis68: It's an interesting question.
14:23:37 <medbrry2> not sure about what it should have
14:23:43 <smcginnis> Current policy is TC needs to be ATC.
14:23:50 <medbrry2> ill think about it
14:23:53 <mihalis68> I think that openstack proudly mentions maturity and stability, right>
14:23:55 <smcginnis> And there are some ops that actually do qualify.
14:23:55 <mihalis68> I think that openstack proudly mentions maturity and stability, right?
14:24:07 <medbrry2> you cn be ops and atc. i am
14:24:15 <smcginnis> But rules would need to be tweaked to open it up to wider ops representation.
14:24:17 <mihalis68> isn't there a cost to that that isn't being paid?
14:24:36 <smcginnis> medbrry2: I'll vote for you. ;)
14:24:39 <medbrry2> restate please mih
14:24:46 <emccormick> me 2!
14:25:01 <mihalis68> "it's very stable"
14:25:01 <mihalis68> "great can I run it for a year"
14:25:01 <mihalis68> "sorry no can has"
14:25:36 <mihalis68> is Med willing to be considered?
14:25:44 <medbrry2> COST TO WHAT mihalis68
14:26:06 <mihalis68> as a software project "matures" it has to devote more resources to supporting long-term usage'
14:26:11 <medbrry2> mihalis68: sure
14:26:29 <medbrry2> sure to being considered
14:26:31 <mihalis68> openstack has run on 2/year and nothing else for, what, 7 years?
14:26:57 <mihalis68> I would support med on TC (huge proviso, not familiar with definitions of UC nor TC as I should be)
14:27:38 <mihalis68> med on TC, fifield on board
14:27:44 <mihalis68> but you didn't hear me say this
14:27:50 <VW> TC governs how things become a project and the rules they must play by
14:28:03 <smcginnis> Some reference: https://governance.openstack.org/
14:28:10 <mihalis68> so is release cadence strictly an OS board issue?
14:28:17 <VW> UC looks after Ops/End users in the community, organizes their events and looks to further engage them into the development lifecycle process
14:28:25 <admin0> mihalis68: i worked on a production public openstack cloud that went from icehouse to now ocata .. wtih production customers and clients and we love the new releases as it brings up new features
14:28:37 <admin0> so i do not see why this cycle needs to be changed or different
14:29:07 <mihalis68> we are running openstack liberty and we have an engineering hill to climb to get off nova-network before we can go to newer releases than mitaka
14:29:32 <admin0> if you are happy with a release, no one forces you to upgrade it .. it can be your LTS
14:29:34 <mihalis68> it's not a question of not liking the new releases and new features, we just can't get to them as fast as is assumed by the release cadence
14:29:41 <mihalis68> with respect, no
14:29:44 <mrhillsman> Sorry I'm tardy :)
14:30:07 <admin0> “we just can't get to them as fast as is assumed by the release cadence” — lack of resources or manpower ?
14:30:07 <mihalis68> admin0 example the devs deleted liberty docs from the docs website because EOL
14:30:14 <mihalis68> that's just wrong and is being fixed
14:30:22 <mihalis68> liberty is *not* EOL for our vendor
14:30:32 <medbrry2> welcome mrhillsman
14:30:40 <emccormick> hi mrhillsman
14:30:55 <mihalis68> it is already established over the past many meetings that there exists an important part of the community that cannot keep up with 2 releases per year
14:31:02 <mihalis68> hi mrhillsman
14:31:26 <admin0> mihalis68: its an open source project on best effort by the community .. we keep a backup of all repo and docs .. .. yuo can’t blame them for deleting due to lack of resources just because you diddn’t think it was necessary to backup the docs your organization run on ?
14:31:37 <mihalis68> by the way, the request is not to stop doing the normal releases, it is to support some of them for longer
14:31:49 <mihalis68> you're lacking some context here I think
14:31:57 <admin0> i guess i am :)
14:32:17 <mihalis68> they deleted the docs because they couldn't maintain them any more. After discussion they agreed that was wrong and they are fixing that
14:32:38 <admin0> yes, but that still does not change that if you should have backed up yourself
14:32:51 <mihalis68> their previous answer was "you can just build from tag". That is not a good answer, since we tried and reported to them how deficient the result is and how hard it was to do
14:33:08 <mihalis68> No, i don't accept that for a minute
14:33:12 <admin0> if you are running something on prod and its not “guaranteed/paid” by vendor, then it should be your organization doing the backup
14:33:13 <mihalis68> I don't back up openstack.org at all
14:33:25 <mihalis68> oh we have a paid vendor
14:33:27 * medbrry2 is done driving and reads sb
14:33:34 <admin0> aha !
14:34:07 <mihalis68> but we (us+vendor) discussed. Instead of using openstack documents in some Canonical portal, we want a solution which helps the community. That has been agreed
14:34:36 <mihalis68> the idea that we just get a private openstack from canonical is simplistic and misleading
14:35:04 <mihalis68> yes sure we do get our apt packages from cloud-archive, but I think the openstack docs should live on openstack.org for the release life of the software it relates to
14:35:28 <medbrry2> #action med to read tc bylaws and comme t on ops ml
14:35:31 <emccormick> And from what was said here earlier, that is now going to happen.
14:35:43 <emccormick> per discussion at PTG
14:35:47 <mihalis68> yep. as I say the context is we have won this debate
14:36:07 <smcginnis> medbrry2: Next TC election is coming up soon. Just saying... :)
14:36:12 <mihalis68> the docs team didn't really even fight it. They deleted them for minor reasons to do with branching and javascript security fixes
14:36:20 <mihalis68> o/ med for tc
14:36:41 <mihalis68> docs are just one bit though
14:36:55 <mihalis68> the larger issue of openstack LTSes continues to swirl around
14:37:04 <mihalis68> it seems the vendors need to unite around it
14:37:18 <mihalis68> I've typed a lot
14:37:37 <mihalis68> is there things we need to discuss re: Sydney and/or tokyo that we didn't touch on yet?
14:38:13 <mihalis68> I think for example Tokyo will mark the start of the foundation officially owning and running even planning for a mid-cycle meet up if mrhillsmans brief update last week is true
14:38:16 <emccormick> Sydney I think we just need to get people putting more sessions in
14:38:39 <mihalis68> counting on you to be the benevolent dictator for sydney, erik!
14:38:55 <mihalis68> "event planning" not even planning
14:39:23 <emccormick> jajaja
14:40:01 <mihalis68> #agreed emccormick to chivvy along the planning for Sydney ops meetup
14:40:38 <emccormick> mrhillsman Anything more to add about upcoming foundation support?
14:40:40 <mihalis68> by the way, backing up the docs was not the issue anyway
14:40:55 <mihalis68> you can build a set of docs from EOL-LIBERTY tag or whatever it is, but they are broken
14:41:11 <mihalis68> they are not clean w.r.t. being all relative links etc
14:41:20 <mihalis68> I actually got the code and built it
14:41:35 <mihalis68> but probably more than enough about docs for one day
14:41:57 <shintaro> mrhillsman, if we can get Foundtion support for Tokyo, I like to know who to contact. fifieldt?
14:42:03 <mihalis68> it will not be tom
14:42:26 <mihalis68> he's moving roles, but I can't say more
14:42:40 <shintaro> oh ok.
14:43:13 * med_ rejoined from desk
14:43:36 <VW> The foundation will plug someone in, I'm sure until an official replacement is found
14:43:41 <med_> so stupid parliamentary procedure question: this is the ops meetup planning meeting not the operators take over the world meeting. I'm happy to find out and report on the #o-o mailing list about TC but it takes more than this meeting's support to make that happen. (fyi)
14:43:45 <mihalis68> yeah, haven't heard who though
14:44:01 <mihalis68> quite right
14:44:09 <mihalis68> (if you have the bylaws please forward :)
14:44:16 <med_> roger.
14:44:32 <mihalis68> I believe the right procedure would be to breach the topic of an operator for the TC
14:44:44 <mihalis68> and mention that Med qualifies by being ATC as well
14:44:52 <mihalis68> and then perhaps see if anyone else would like to be considered
14:44:55 <med_> so smcginnis is TC.
14:44:58 <mihalis68> then announce a vote?
14:45:08 <mrhillsman> Sorry in a dead spot
14:45:23 <mrhillsman> shintaro I will start a thread
14:45:35 <shintaro> thanks mrhillsman
14:45:47 <med_> mihalis68, probably not going to get an additional vote. Nothing on bylaws other than the tech-committe page. Again, I'll summarize/discuss on ML.
14:45:49 <mihalis68> a thread about OS foundation contact for event planning?
14:46:07 <mrhillsman> yep
14:46:16 <mihalis68> #action med_ to bring up adding an operator to the TC on the operators mailing list
14:46:24 <mrhillsman> And more specifically structure of the event
14:46:27 <med_> my atc quals may have expired, I'll make sure I have commits in on Q to re-qual.
14:46:29 <mihalis68> cool
14:46:45 <mrhillsman> I think opendev is a great example of how we can provide value
14:47:18 <mrhillsman> Personally, being realistic, ops midcycle needs to feed back into the ecosystem better
14:47:19 * med_ missed that event
14:47:58 <mihalis68> another action I had (talking of feedback) is see if the local team has any thoughts about the mexico city event
14:48:01 <mrhillsman> So I would like to start a thread on this in general
14:48:31 <mihalis68> I sent a list of fairly standard Q.s to the slack channel. Gloria says she will respond. Depending on how that goes there might be another superuser article that could be made from that
14:49:01 <mihalis68> I think we should somehow send a mid-cycle "digest" back to the community
14:49:15 <mihalis68> and make it more prominent than "here is the URL of some ether pads"
14:49:37 <med_> +1 on digest
14:49:55 <med_> +1 on Superuser. (I think they target very different readers, so both are good)
14:49:58 <mrhillsman> What i liked about opendev was it being focused
14:50:03 <mihalis68> #action mrhillsman volunteered to kick off discussion of feedback from mid-cycles back to wider operators community
14:50:30 <mrhillsman> I think ops midcycle is too wild west like per se
14:50:30 <mihalis68> #action mihalis68 to pull together a sample/proposed digest for next meeting
14:50:43 <med_> mrhillsman, folks I talked to (devs) at PTG had no idea OpenDev was truly an OpenStack event. with that name, it wasn't entirely obvious.
14:50:47 <mrhillsman> So incorporating focus and freedom
14:50:56 <mihalis68> I had no idea until this very second
14:51:32 <mihalis68> not having been, I can't comprehend what opendev had that we lack at mid-cycles
14:51:32 <VW> I'm not saying that mid-cycle meetings for Ops couldn't use more structure, but remember the primary focus of them is to get operators engaged in the community at large
14:51:35 <mrhillsman> That's reasonable assessment, I think that was on purpose
14:51:40 <mihalis68> can you provide detail?
14:52:00 <emccormick> I had no idea it was an openstack event either
14:52:09 <mihalis68> ok we are missing something right here
14:52:13 <VW> so, we don't want to re-engineer them to be sessions that create copious amounts of blueprints, etc
14:52:16 <emccormick> I just saw a few people start tweeting about it
14:52:39 <VW> I have to run to an in person meeting. Take care all - see you next week
14:52:43 <mrhillsman> I'm on my phone, thread I can type more, but pulling out 2-3 things to focus on
14:52:47 <mihalis68> bye VW thanks!
14:53:04 <mrhillsman> I'm not suggesting losing the spirit/mandate
14:53:22 <mrhillsman> But if we are honest, we have the same discussions
14:53:50 <mrhillsman> And we have more than blueprints
14:54:15 <mrhillsman> I will create thread ;)
14:54:35 <mihalis68> just over 5 minutes
14:54:59 <mihalis68> last week we discussed the possibility of a NE USA meet up before end of year or possibly early next year
14:55:13 <mihalis68> given that not everyone can get to australia or japan
14:55:30 <smcginnis> Someone told me there was going to be an ops meetup in NY in Oct or Nov.
14:55:31 <mihalis68> and openstack days east was cancelled due to lack of interest
14:55:59 <mihalis68> anyone know where that came from? or is that my suggestion last week bouncing around and echoing back here?
14:56:00 <mrhillsman> smcginnis I heard the same but for next year
14:56:22 <mihalis68> a meetup in NY in Oct sounds ... surprising?
14:56:35 <smcginnis> I was surprised.
14:56:40 <mrhillsman> I heard Bloomberg, Verizon, and someone else involved
14:56:58 <smcginnis> mrhillsman: Same. Maybe we were both there when the person said it. :D
14:57:05 <mihalis68> heh. Well I haven't seen one of my internal contacts since PTG
14:57:12 <mihalis68> juan negron
14:57:18 <mrhillsman> Possibly :)
14:57:31 <mihalis68> he might be able to swing some level of backing for such a thing
14:57:45 <mihalis68> he's in our CTO arm, they have discretionary funds
14:57:54 <med_> saw juan. Didn't discuss this.
14:58:07 <mihalis68> I just run the team that runs the prod openstack stuffs, but no soft money
14:58:16 <mrhillsman> I think the guy that said it was from Verizon
14:58:23 <mihalis68> ok
14:58:34 <mihalis68> 2 minutes
14:58:42 <mihalis68> if someone has a lead on that please share
14:58:47 <mihalis68> otherwise, any other business?
14:58:47 <mrhillsman> I don't know his name but his face I do
14:59:15 <emccormick> any Tokyo needs / updates shintaro?
14:59:21 <mihalis68> Ill ask around within Bloomberg
14:59:34 <shintaro> not for this week. meeting venue people next week
14:59:50 <mihalis68> excellent
15:00:01 <mihalis68> so let's meet next week same time same place
15:00:16 <med_> +1
15:00:21 <mihalis68> but bear in mind mike perez said other similar groups have moved to meeting when there's something to discuss
15:00:38 <mihalis68> recognizing a fixed schedule is hard for volunteers to make
15:00:40 <med_> +2
15:00:56 <mihalis68> ok. any last comments?
15:01:10 <mrhillsman> Have a great day!
15:01:10 <mihalis68> #endmeeting