14:01:55 <mihalis68> #startmeeting Ops Meetup Team
14:01:56 <openstack> Meeting started Tue Sep 26 14:01:55 2017 UTC and is due to finish in 60 minutes.  The chair is mihalis68. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:00 <openstack> The meeting name has been set to 'ops_meetup_team'
14:02:11 <emccormickva> Good morning.
14:02:13 <mihalis68> #link https://etherpad.openstack.org/p/ops-meetups-team
14:02:13 <shintaro> o/
14:02:23 <mihalis68> hello everyone
14:02:26 <mihalis68> thanks for joining us
14:02:33 <mihalis68> #topic review actions from last week
14:02:34 <shintaro> hi all
14:02:53 <mihalis68> I have no progress on my action (creating a digest of the material from mexico)
14:03:03 * smcginnis lurks
14:03:10 <mihalis68> I was hoping to hear from the local team there, but for obvious reasons they have other things on their mind.
14:03:51 <mihalis68> Erik and I did check on their wellbeing via twitter and slack, have only heard limited responses but I know for example William is ok as he's already at a conference, and Alvaro responded he's ok
14:04:06 <mihalis68> other actions are on the agenda. David (med_) gave himself a few
14:04:11 <mihalis68> I don't think he's here
14:04:19 <shintaro> good to hear they are okay
14:04:30 <shintaro> I hope mrhillsman has some update on Foundation support
14:04:32 <mihalis68> indeed. It feels very personal having just been there
14:05:27 <mihalis68> still making the agenda presentable
14:06:06 <mihalis68> I don't see mrhillsman here so can't hear about that just yet
14:06:16 <mrhillsman> No update yet unfortunately but plan on having something next meeting
14:06:29 <mrhillsman> I just finished 2 weeks of traveling
14:06:45 <mihalis68> seems like we have 3 attendees plus Sean hiding in the corner, Hi Sean!
14:06:55 <mihalis68> ah, hello mrhillsman, thanks for joining
14:06:58 <mrhillsman> At home until Sydney unless something else comes up
14:07:32 <mihalis68> so one nice thing I'm sure people saw, Shintaro and colleagues appear in a SuperUser article
14:07:42 <shintaro> :) thanks
14:07:44 <mihalis68> #link http://superuser.openstack.org/articles/openstack-operator-spotlight-ntt/
14:08:11 <mihalis68> Seems like that is it for actions, unless/until David turns up
14:08:16 <shintaro> Foundation is polling some operators for updates and we had online interview
14:08:17 <mihalis68> #topic Sydney
14:08:36 <mihalis68> yes I was hoping to offer the material for an article about mexico to superuser editor
14:08:42 <mihalis68> based on some questions I sent gloria
14:08:46 <mihalis68> bad timing
14:08:48 <mihalis68> :|
14:09:06 <mihalis68> Erik I think you volunteered to be chief troublemaker for Sydney. How is that going?
14:09:38 <emccormickva> Well all I can really do is nag people about sessions. There's not a lot on the etherpad, and submissions are due this week
14:09:56 <emccormickva> I will put out a last call today and then see if I can convert them to abstracts
14:10:06 <emccormickva> I'll at least get our Ops meetup session in there this morning
14:10:14 <VW> hi folks
14:10:21 <emccormickva> There's only 11 sessions proposed so far which is pretty darn light
14:10:40 <mihalis68> hi VW
14:10:42 <smcginnis> Deadline for topic submission is this Friday. Any topics would be good.
14:10:54 <mihalis68> can someone post that link?
14:11:06 <shintaro> I saw some similar proposal already exist in the Forum proposal, e.g. NFV
14:11:12 <emccormickva> ours is https://etherpad.openstack.org/p/SYD-ops-session-ideas
14:11:24 <emccormickva> forum one is http://forumtopics.openstack.org/
14:11:52 <mihalis68> Thanks!
14:12:04 <smcginnis> emccormickva: They may be able to combine the two. Or if there is enough different to discuss, still have both.
14:12:10 <smcginnis> Not sure on the number of open slots.
14:12:20 <emccormickva> I might redo the metal -> containerized session from MEX as that drew a fair bit of interest. Maybe this will bring in a bigger crowd
14:12:27 <mihalis68> Bloomberg is sending a couple of people, one dev focused, one with a mix of ops and dev. I will see if the latter has anything he wants to talk about that's not on that list
14:13:30 <mihalis68> is that all there is to say about Sydney?
14:14:02 <mihalis68> not that I am going, but those who do might like to work out a time for an operators social gathering
14:14:06 <emccormickva> Sort of on Sydney topic, I"ve found myself in posession of a 2BR apartment 0.2 miles from the conference and it's just me so far
14:14:17 <mihalis68> it's a short conference this time for some reasons. Only one keynotes day
14:14:20 <emccormickva> if anyone needs a room and doesn't feel like paying $400 per night for a hotel room
14:14:56 <emccormickva> Berlin is going to be 3 days also. Not sure why we're shortening the overseas ones. Vancouver is 4
14:15:38 <VW> Berlin you say
14:15:45 * VW missed that bit of data
14:15:55 <mihalis68> YEAH!
14:16:10 <mihalis68> I came across that, forget where, probably twitter
14:16:20 <emccormickva> Yep. Pretty stoked about that. I haven't been back there in a long time.
14:16:21 <mihalis68> i have a friend in berlin. Will try to make the one
14:16:23 <mihalis68> that one
14:16:34 <mihalis68> sounds like Matt is interested :)
14:16:34 <emccormickva> Like so long there was a wall there the last time.
14:16:53 <mihalis68> but you escaped the erik containment system?
14:17:05 <VW> I am always interested mihalis68 - that's usually not the limiting factor ;)
14:17:19 <mihalis68> right
14:17:46 <VW> anyway - sorry - juggling a few things this moring.  I will be in Sydney, so is there anything I need to do on behalf of this group while I am thre
14:18:42 <emccormickva> VW You wanna run our catchup session for this group at the forum?
14:18:50 <VW> sure thing!
14:18:55 <mihalis68> grest
14:18:59 <mihalis68> great
14:19:12 <mihalis68> #agreed VW to run ops catch-up in Sydney
14:19:18 <emccormickva> Cool. Might bug you to moderate something else too. We'll see how these sessions get picked up. If I submit them all, I don't want to end up moderating them all too ;)
14:19:51 <emccormickva> shintaro Are you up for being a moderator of something also?
14:20:03 <emccormickva> well, any of you really
14:20:09 <shintaro> not yet so I can do some
14:21:10 <VW> I can probably take more.  I have to get one working group sessions scheduled and don't know what all UC things I'll have to do
14:21:13 <VW> but will help cover what I can
14:21:29 <emccormickva> Thanks!
14:22:10 <mihalis68> obviously VW you will run the meeting as you see fit, but I would suggest trying to see if we can improve how we do this. The number of people who attended the catch-up in Boston vastly exceeded the attendees here, despite this being a simple cost-free location independent IRC meeting. I must admit I don't quite understand...
14:22:42 <VW> indeed
14:23:07 <mihalis68> maybe we need to send out an agenda each week that has interesting topics? Provide a reason to attend?
14:23:09 <VW> I'd like to have as much info about Tokyo too so we can work on that while we have a larger audience
14:23:23 <VW> yeah - prepublishing an agenda might help
14:23:24 <mihalis68> Shintaro has provided an update on the agenda etherpad
14:23:55 <shintaro> not much info yet. but visited the venue with my organiser
14:24:08 <smcginnis> Maybe a reminder on the openstack-operators mailing list within a day/hours before the meeting?
14:24:46 <mihalis68> Ok. I appreciate all suggestions on this
14:25:08 <mihalis68> #action mihalis68 to try out reminder with agenda before next weeks meeting
14:25:58 <emccormickva> ok, put the catch-up in the system.
14:26:25 <emccormickva> I put it in rather.
14:26:33 <mihalis68> great!
14:26:54 <mihalis68> we have touched on almost everything on the agenda
14:27:28 <mihalis68> I have one note, not even an update, but I have our Canonical engineer working on the docs, in particular to see if he can produce a more complete conversion of the operators guide to markdown
14:28:15 <mihalis68> that document has been agreed by everyone as something that needs to become community maintained on the wiki, however if we can get the tools to build links and TOC that will save a lot of work
14:28:37 <mihalis68> when we see the results, I will update the material on the openstack wiki and then I will share with the mailing list
14:29:14 <mihalis68> #action mihalis68 to share updates to operators guide on the openstack wiki as soon as the conversion work is done (as best it can be)
14:29:36 <shintaro> if mrhillsman is still here, any update on Foundation support?
14:30:08 <emccormickva> mihalis68 Do you want a session done for it at the forum? Kind of recruitment session?
14:30:09 <mihalis68> I think he said no update yet, but that he had been travelling
14:30:21 <shintaro> oh I missed that line...
14:30:29 <mihalis68> for the operators guide wiki version?
14:30:35 <emccormickva> yeah
14:30:40 <mihalis68> yes
14:30:57 <emccormickva> If it's ready for edits by then we can show it off and beg for help updating it
14:31:08 <mihalis68> I was about to modestly say let's wait and see if it turns out well enough, but the truth is we'll get something posted and usable by our community between now and sydney
14:31:23 <emccormickva> OK I'll plop that in there then.
14:31:35 <mihalis68> our canonical engineer is good. The docs team was in need of a link checker and instead of debating he just wrote one for them
14:31:39 <mihalis68> cool thanks
14:32:14 <mihalis68> #action mihalis68 to ensure operators guide wiki document is at least minimally usable before session voting closes for Sydney
14:32:30 <mihalis68> nothing like a self-imposed deadline to provide "clarity" :)
14:33:03 <mihalis68> #action mihalis68 to email med_ for an update on his actions
14:33:33 <mihalis68> rationale: David was considering running for TC, which I think was a welcome suggestion
14:34:08 <emccormickva> OK it's in there. Now you're stuck.
14:35:36 <mihalis68> The other topic I have a special interest in is already there. The "OpenStack LTS release" issue.
14:35:51 <mihalis68> I assume Sydney attendees will make sure that carries the debate forwards from mexico?
14:36:53 <emccormickva> They should make that a double session
14:37:00 <mihalis68> yeah
14:37:11 <mihalis68> I will be sorry to miss that
14:37:18 <shintaro> we probably need to invite major distributors there
14:37:23 <emccormickva> You'll be able to hear it from New York
14:37:35 <mihalis68> shintaro that is an excellent point
14:38:08 <VW> sorry - desk walk up - reading scroll back
14:38:24 <mihalis68> I can do some of that. Maria from redhat, jill from canonical, perhaps network with suse to get a representative from them
14:38:48 <mihalis68> not saying I expect those people to attend, but I know they acknowledged interest in this topic in mexico
14:39:12 <mihalis68> #action mihalis68 to highlight the openstack lts session to major distro vendors
14:39:16 <emccormickva> There should be sufficient bodies there to have each of them send a rep.
14:39:45 <smcginnis> mihalis68: I can track someone down in Huawei. They will have interest in the LTS discussion too.
14:40:00 <emccormickva> maybe whoever is in charge of stable branch and someone from infra would be good too
14:40:07 <mihalis68> mike perez (thingee) represented the openstack developers in that session in mexico and ... it was grim to hear
14:40:24 <mihalis68> something like "this has been proposed many times, nothing ever changes, people don't show up to do the work needed"
14:40:37 <emccormickva> Yeah I made him mad :D
14:40:43 <smcginnis> :)
14:40:52 <emccormickva> Well, that was more the skip level discussion
14:40:55 <mihalis68> #action smcginnis to seek a representative from Huawei re: OpenStack LTS
14:40:58 <emccormickva> sorry, "fast-forward"
14:41:08 <smcginnis> If the ops and distros can lead the discussion, I think we can get someone from the "stable" team to be present too.
14:41:13 <mihalis68> I felt we didn't hear what Sean had to say on the topic, sadly
14:41:34 <mihalis68> he was the moderator but not the loudest voice
14:42:04 <smcginnis> We'll get there. Or at least keep trying. ;)
14:42:19 <mihalis68> Shintaro you said something about NTT not being able to keep up with current openstack release cadence too, right?
14:42:46 <shintaro> right. updating is one of our biggest wall
14:42:46 <mihalis68> yeah, I think that session was unruly because we really hit the motherlode, it's a very hot topic
14:42:57 <admin0> lts is a good idea, but should that be only vendor specific ?
14:43:00 <mihalis68> can you or a colleague make sure to represent in that session?
14:43:06 <emccormickva> Kind of interesting. Ceph is going through a discussion now to slow their release cadence but make all their releases LTS
14:43:24 <mihalis68> the problem with vendor specific is duplication of work
14:43:25 <smcginnis> If ops can keep making noise and putting pressure on their vendors, I think we will start to see some progress.
14:43:47 <smcginnis> mihalis68: ++ vendors really need to work together on this, IMO.
14:43:53 <mihalis68> Shintaro makes a very good point in the above-linked superuser article that NTT move to "upstream first" which avoids duplication of effort. Makes sense to me
14:44:13 <mihalis68> seems to be the modern way
14:44:34 <mihalis68> as an example, even Dell, a company that I didn't necessarily love when it comes to Linux, now works that way
14:44:48 <mihalis68> when they fix drivers for Dell laptops, they upstream the fixes
14:45:22 <mihalis68> (I can now say Dell looks pretty great for linux, e.g. the 13" developer edition with ubuntu preinstalled - not knocking them at all)
14:46:01 <mrhillsman> I don't think you made Mike mad emccormickva
14:46:41 <mrhillsman> I agree with smcginnis operators with vendors need to get together and push them
14:46:49 <mrhillsman> In general
14:46:51 <emccormickva> We drank on it later. It's all good. He just got frustrated and I can be a bit...animated when I'm passionate about something.
14:47:20 <mrhillsman> These folks will do what the majority of their customers want
14:47:33 <VW> alright - I have to jet to a meeting here.  I'll see you all next week
14:47:46 <mihalis68> I thought it was good for Erik to speak bluntly. I did something similar in NYC meet up just over a year ago. Sean Dague said something like "well why aren't you keeping up" and so I told him
14:47:51 <mihalis68> cheers VW
14:48:40 <mihalis68> one thought I had is that if an LTS was announced, it might encourage operators to try to keep up with that
14:48:47 <mihalis68> I mean, we just can't do 2/year
14:48:52 <mihalis68> so we don't even try to be honest
14:49:24 <smcginnis> mihalis68: Good point.
14:49:47 * jproulx will likely default to LTS=UbuntuLTS starting in 18.04 (since I'm still on mitaka ffs)
14:50:12 <mrhillsman> Why don't we work to gather enough operators voicing this to the captains of the ships ;)
14:50:13 <mihalis68> I could certainly make the case that the project now catered to us and we need to make an effort to stay on that train
14:50:36 <mihalis68> hi proulx I am still working on the update TO Mitaka...
14:50:45 <mihalis68> jproulx I mean
14:51:07 <jproulx> I have a relatively small & nimble ship here...
14:51:11 <mihalis68> mrhillsman seems like we are gearing up to do just that
14:52:06 <mihalis68> jproulx reminiscent of John Paul Jones ("I wish to have no connection with any ship that does not sail fast; for I intend to go in harm's way") perhaps? :)
14:52:19 <jproulx> +1
14:52:46 <mihalis68> Ok. Is there any other business? I think we covered a lot, and I certainly picked up a few actions
14:53:46 <mihalis68> mrhillsman I think a lot of us are anxious to hear an update on the foundation support for the ops events etc
14:54:26 <mihalis68> we seem to be done. Thanks everyone. I will publicize next weeks meeting better
14:54:30 <mihalis68> #endmeeting