14:02:20 <mihalis68> #startmeeting Ops Meetup Team
14:02:21 <openstack> Meeting started Tue Oct 17 14:02:20 2017 UTC and is due to finish in 60 minutes.  The chair is mihalis68. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:23 <mihalis68> hello everyone
14:02:27 <openstack> The meeting name has been set to 'ops_meetup_team'
14:02:31 <shintaro> hi
14:02:32 <VW> o/
14:02:40 <mihalis68> #link https://etherpad.openstack.org/p/ops-meetups-team today's agenda
14:02:55 <mihalis68> please add your name to the attendees list if you are here for the meeting
14:03:39 <mihalis68> #topic review last weeks actions
14:03:58 <mihalis68> no progress on a new article about Tokyo, but the Eventbrite will be done soon and then that can start
14:04:25 <mihalis68> an older article was submitting a blog post about the document retention policy and upstream LTS releases discussion. I submitted that today!
14:04:34 <mihalis68> shintaro I emailed you a question about that just now
14:04:44 <shintaro> yes, I need to check if $20 is ok and 150 cap for registration is ok, too
14:05:04 <mihalis68> $20 is just right in my opinion
14:05:15 <mihalis68> and 150 is more than enough, again IMO
14:05:23 <mihalis68> thoughts from others?
14:05:28 <shintaro> once they are fixed I can ask for Eventbrite
14:06:03 <shintaro> I believe $20 would affect attendance from Japan
14:06:08 <shintaro> would not
14:06:19 <mihalis68> med_ was here a few minutes ago. He had an action to report back from the TC meeting
14:06:31 <mihalis68> he is attending those for "surveillance" :)
14:06:50 <mihalis68> I'll assume no progress there unless he pops up. Any other progress towards previous actions?
14:07:06 <smcginnis> I can answer TC stuff if there are any specific questions.
14:07:49 <mihalis68> thanks smcginnis. med was suggesting we lack interaction with those folks, he considered running for TC but settled on attending those meetings and these and forwarding essential info
14:08:07 <smcginnis> I was kind of hoping he would run.
14:08:09 <mihalis68> so I guess the question is has TC been talking about things the operators community should know of?
14:08:16 <smcginnis> But we did get a lot of candidates this time around.
14:08:22 <mihalis68> I think he just missed the deadline
14:08:27 <shintaro> TC voting is now in progress
14:08:34 <mihalis68> I did chase him but it was very close to submission deadline
14:08:46 <smcginnis> Nothing overly operator impacting the last week or so.
14:08:47 <emccormick> hola
14:08:58 <emccormick> sry for lateness
14:08:59 <mihalis68> hello emc thanks for joining
14:09:04 <smcginnis> Do any of you pay attention to the tags projects assert?
14:09:07 <mihalis68> any actions progress to report?
14:09:22 <emccormick> sort of related to one
14:09:41 <mihalis68> smcginnis I heard thierry announce that, it sounded insane
14:10:03 <mihalis68> I understand what he's talking about but it sounded wildly unrealistic for small sites/teams
14:10:12 <smcginnis> Maybe the only think from the TC side is removing things like tripleo from stable:follows-policy and maybe creating a new tag for deployment projects to follow as they have slightly different restrictions and expectations.
14:10:13 <mihalis68> I count my team in the latter
14:10:14 <emccormick> re: social planning stuff, I spoke with Lauren and Erin. Apparently there is a foundation effort to throw a little party for Tom on Wednesday night and once details are set I will be inviting Ops to attend
14:10:30 <emccormick> I was trying to set up something myself and then it occurred to me to ask if they were doing something
14:10:35 <emccormick> so we're joining forces
14:10:37 <mihalis68> excellent. I am so disappointed I won't be there
14:11:19 <shintaro> thanks emccormick I want to join that too
14:11:39 <VW> I'm in for that one as well
14:11:39 <emccormick> I'll be sending something out to the list once I have info from them.
14:11:58 <mihalis68> nice. Glad to hear of more cooperation between operators, foundation etc
14:12:07 <emccormick> tentatively it's going to be in the club at the Star Casino. Karaoke night :D
14:12:17 <mihalis68> smcginnis I'll go review that discussion and try to get more with it on tags
14:12:40 <smcginnis> mihalis68: Cool, let me know if you have any questions I might be able to answer.
14:12:40 <mihalis68> someone buy tom drinks until he's captured on video doing Back in Black
14:12:50 <smcginnis> :)
14:12:55 <mihalis68> yeah I should review and then if I have specific confusions email
14:13:07 <mihalis68> I will fund those drinks, and I am serious
14:13:20 <shintaro> smcginnis which ML was that discussion on? openstack-dev?
14:13:41 <emccormick> Foundation is funding drinks, at least to a point ;)
14:13:51 <mihalis68> well deserved
14:13:57 <mihalis68> I feel Tom contributed hugely
14:14:00 <emccormick> but I'm sure we will buy him many other drinks that week. He's gonna have a 3 day hangover
14:14:01 <mihalis68> I miss his input here
14:14:17 <VW> I'll make sure he has at least a couple on "your dime" throughout the week, mihalis68
14:14:27 <mihalis68> it's a deal
14:14:29 <VW> I'm sure he and I will cross paths a couple of times
14:14:36 <smcginnis> shintaro: I'll see if I can find the link.
14:15:03 <mihalis68> #action smcginnis to point out where the tags policy discussion landed (re: deployment systems)
14:15:07 <shintaro> thanks smcginis
14:15:08 <mihalis68> helle emagana
14:15:12 <mihalis68> *hello
14:15:18 <emagana> Hello!  Sorry, I am late.
14:15:30 <smcginnis> shintaro: Starts here: http://lists.openstack.org/pipermail/openstack-dev/2017-October/123624.html
14:15:37 <mihalis68> no worries. We are still covering any progress on previous actions
14:15:43 <smcginnis> With links in there to the proposed changes that are having ongoing discussion.
14:16:11 <shintaro> I will check the thread
14:16:45 <smcginnis> I am curious how much things like that really have meaning in the "real world". :)
14:16:54 <mihalis68> #link https://etherpad.openstack.org/p/ops-meetups-team repeated for latecomer. Please sign up on attendees list
14:17:41 <mihalis68> my initial reaction to Thierry's announcement was "they are out of their minds, if we can't even find the stable stuff without reviewing a whole bunch of legalistic definitions then it's going to be a shit show"
14:18:14 <mihalis68> I will acknowledge this isn't very nuanced
14:18:21 <smcginnis> :)
14:18:45 <mihalis68> At the time I feel like the big tent was full to overflowing, now the picture seems very different
14:19:02 <mihalis68> several projects just went away
14:19:20 <mihalis68> is it really infeasible to have a core stable set of components?
14:19:25 <smcginnis> I think the intent of the stable:* tags is just to see a list of projects that you can expect to handle stable updates in reasonable ways.
14:19:55 <smcginnis> But we know how the upstream stable support doesn't really work with the operator needs for stable releases at this point.
14:20:11 <med_> \o very late
14:20:19 <mihalis68> the whole thing depends on python and from what I hear that does not "handle stable updates in reasonable ways"
14:20:23 <mihalis68> welcome med_
14:20:42 <med_> sorry, trouble driving in.
14:20:43 <emccormick> No worries med_. We're on side topics ;)
14:20:56 <emccormick> snow?
14:20:59 <med_> tc election is on-going.
14:21:03 <mihalis68> specific feedback about "upstream LTS updates" states that they are near impossible without first doing something about the underlying python foundation
14:21:13 <med_> emccormick, stupid android client flaking whilst I was commuting.
14:21:33 <mihalis68> med_  you were actioned to report back from TC. Any news on that?
14:21:50 <med_> nothing to report other than elections under way
14:21:53 <smcginnis> I'm not sure if it's really a python issue. My stance is still what I was saying in Mexico that we need more vendor involvement to maintain those longer stable releases.
14:22:10 * med_ can't grok how python foundation would be involved
14:22:47 <mihalis68> ok, well I am not a python developer, so take this with a pinch of salt, but...
14:23:08 <mihalis68> you can't maintain openstack components for 3 years if they depend on something that is not maintained for 3 years
14:23:09 <mihalis68> right?
14:23:29 <mihalis68> wel python itself doesn't have LTS, so you can't necessarily even rebuild the stuff 2 years later
14:24:01 <mihalis68> this is from my canonical contacts, both my contractor and a bunch of other staff that I took out for dinner recenely
14:24:09 <med_> curious
14:24:24 <mihalis68> maybe someone who is a python developer can explain this in more detail
14:24:34 <smcginnis> mihalis68: There can be issues as far as required packages no longer being maintained, or things like distros moving from python 3.4 to 3.5 to 3.6.
14:24:55 <mihalis68> the python that underpins OpenStack Liberty is no longer actively maintained
14:25:05 <mihalis68> for example
14:25:20 <smcginnis> There are a lot of moving pieces with LTS. That's part of the need for maintenance, because even though something is working now, it doesn't mean something won't change in the runtime three years from now that breaks it.
14:25:28 <shintaro> That conversation reminded me of polling Allison Randal for Forum sesison from Suse
14:25:31 <mihalis68> I realize many things underpin a "stack" that big, but it's quite intimate when it comes to python specifically
14:25:49 <smcginnis> mihalis68: Good points.
14:26:36 <mihalis68> ok. I guess I should be a good chair and move on to next agenda item. This topic will be discussed in Sydney, however, as the upstream LTS releases talk was accepted onto the draft session list (see email from thing)
14:26:40 <mihalis68> *thingee
14:26:45 <mihalis68> #topic Sydney
14:27:04 <mihalis68> did everyone see that list?
14:27:34 <mihalis68> look for email entitled "[Openstack-operators] [forum] Draft Schedule - Deadline Oct 13 Friday 20:00 UTC"
14:27:50 <mihalis68> from Mike Perez (thingee)
14:27:52 <shintaro> I guess the Forum schedule is now open
14:28:06 <shintaro> I mean on the official schedule already
14:28:21 <mrhillsman> o/
14:28:24 <emagana> mihalis68: I was expecting a lot more Forum sessions from the Ops prespective
14:28:26 <thingee> http://lists.openstack.org/pipermail/openstack-dev/2017-October/123699.html
14:28:43 <thingee> hey all sorry, I meant to send this to the ops list too. I'll do that right now.
14:28:57 <med_> thanks mike
14:29:19 * med_ has seen THAT one
14:29:21 <smcginnis> Here's a nice session: What do operators want from the stable policy?
14:29:29 <mihalis68> very apropos
14:29:53 <mihalis68> hi mrhillsman, thingee
14:30:46 <emccormick> emagana Operators really slacked proposing things, but lots of the project teams have crossover things in there.
14:30:54 <emccormick> It worked kinda that way in Boston too
14:31:01 <emagana> emccormick: fair enough
14:31:50 <mihalis68> is there anything else we need to try to get organized for Sydney? I forget where the idea of an evening event got to
14:32:41 <mihalis68> any more on Sydney? I imagine that schedule of talks will take a while to digest
14:33:05 <mihalis68> ok
14:33:12 <mihalis68> #topic Tokyo mid-cycle meetup
14:33:20 <mihalis68> shintaro had two questions on the agenda
14:33:30 <mihalis68> is $20 admission fee acceptable to all?
14:33:34 <shintaro> yes. need that for Eventbite
14:33:38 <mihalis68> and is 150 person capacity enough?
14:33:45 <mihalis68> in my view yes and yes
14:33:49 <mihalis68> thoughts?
14:33:53 <med_> +1 +1
14:34:06 <mrhillsman> ++
14:34:06 <mihalis68> any objections to either?
14:34:17 <shintaro> seems not.
14:34:20 <mihalis68> I find it very unlikely
14:34:34 <shintaro> ok I will move on with those numbers.
14:34:37 <mihalis68> #agreed $20 admission fee and 150-person capacity are both suitable for this event
14:34:54 <mihalis68> great
14:35:05 <mihalis68> we can get the eventbrite issued, then start promotion
14:35:12 <emccormick> good on both fronts
14:35:18 <mihalis68> #action mihalis68 to submit blog about tokyo meetup
14:35:24 <shintaro> one bad news is that the beer place emccormick suggested may not be available for reservation on week days. but still confirming
14:35:52 <mihalis68> shintaro do you want to update the event landing page on the openstack.org wiki with the eventbrite when it's created?
14:36:12 <emccormick> Tell them lots of Americans with big livers will be coming. They'll make lots of money.
14:36:13 <mihalis68> we run openstack, so we can certainly organize a beer outing on tokyo
14:36:22 <mihalis68> *in tokyo
14:36:23 <shintaro> I will. and we will get graphics from the Foundation after Sydney.
14:36:29 <smcginnis> The beer place is pretty big from what I remember. May be able to still just drop in there.
14:36:33 <mihalis68> #action shintaro to update Tokyo event landing page
14:36:39 <emagana> can somebody remind me the dates?
14:36:45 <med_> pro-tip: If you have limited time in Tokyo, skip the Robot Restaurant.
14:36:53 <smcginnis> :)
14:37:03 <smcginnis> March 8-9, right?
14:37:11 <mihalis68> I'm going to book tokyo once the evenbrite comes up
14:37:14 <shintaro> March 7-8
14:37:20 <mihalis68> I keep forgetting that I'm going!
14:37:21 <smcginnis> Ah, I was close. :)
14:37:29 <shintaro> Wed and Thursday
14:38:12 <shintaro> no more update on Tokyo for now
14:38:22 <mihalis68> Hmmm, I wonder if I can work from Tokyo on friday and then take Saturday for tourism. We have an office there
14:38:28 <med_> +1
14:38:30 <mihalis68> ok thanks shintaro. I am excited about this one
14:38:44 <mihalis68> #topic future events
14:38:45 <emagana> Thanks!
14:38:46 <med_> I can recommend the tokyo tower
14:39:14 <emccormick> Skytree? +1
14:39:16 <shintaro> I would recommend new Sky-Tree tower :)
14:39:21 <mihalis68> Vancouver is set to be next Summit, but too early to plan for. After that we thought the next mid-cycle would be Europe?
14:39:39 <med_> yep that one
14:39:48 <med_> sorry, had the wrong name
14:39:50 <mihalis68> there was agreement to try and agree the geo-region for that meet up this week, IIRC
14:39:56 <emccormick> I thought our next would be NAM east
14:40:05 <emccormick> following pattern anyway
14:40:23 <smcginnis> I like the idea of having the ops midcycle colocated with the next PTG. Though my schedule conflicts there are already bad enough, could help getting some other ops-dev interaction.
14:40:49 <mihalis68> where will the PTG be then?
14:40:59 <mihalis68> geographically, not precisely
14:41:17 <shintaro> Lauren said the location is not fixed yet
14:41:17 <smcginnis> Dublin is the one right before the Tokyo ops midcycle. Next after that should be somewhere North America.
14:42:41 <mihalis68> well, NAM would be convenient but mexico just happened, so if we do tokyo and then NAM again that seems off to me
14:42:41 <emagana> smcginnis: PTG in Dublin, Ireland?  When?
14:43:03 * med_ just asked Fdn for dates. nothing on website I can see
14:43:11 <smcginnis> February I believe emagana
14:43:16 <emccormick> NA East and NA West are considered separate regions
14:43:17 <aprice___> it is going to be announced soon
14:43:22 <aprice___> re: Dublin.
14:43:23 <smcginnis> Probably a week or two before Tokyo.
14:43:29 <aprice___> still finalizing contracts
14:43:36 <emagana> smcginnis: cheers!
14:43:44 <smcginnis> emagana: ;)
14:43:47 <smcginnis> aprice___: Thanks!
14:43:50 <emccormick> so NA West, Asia, NA East, EU, rinse and repeat
14:43:55 <med_> ah, it leaked out in some Queens PTG wrapup emails
14:43:59 <mihalis68> emc this is more precise a definition than I am aware of. I thought the idea was to rotate NAM, EUR and APAC
14:44:04 <emccormick> summit flip flops the NA regions
14:44:20 <emccormick> That's what Summits do
14:44:22 <smcginnis> Yeah, I think Thierry officially stated it, just not a firm "when".
14:44:24 <mihalis68> and which bit is mexico city in?
14:44:29 <emccormick> Portland, Hong Kong, Atlanta, Paris
14:44:45 <mihalis68> has it been stated that ops mid cycles follow that policy? I hadn't seen that
14:44:51 <emccormick> Vancouver, Tokyo, Austin, Barcelona
14:44:52 <emccormick> see?
14:45:02 <mihalis68> yes I see that's the one for summits
14:45:08 <med_> emccormick, but I think this group wanted the 3 region rotation. This group/team/etc sets their own policy
14:45:14 <mihalis68> but also I see that openstack is weak in the NE USA now
14:45:28 <mihalis68> sorry, but I think it is
14:45:30 <emccormick> if only by accident we have
14:45:41 <mihalis68> openstack days east was cancelled due to lack of interest
14:45:53 <med_> lack of vendor support I think
14:46:08 <mihalis68> thanks med_ I am not against EMC's suggestion, it's just not how I remember it!
14:46:10 <med_> also why I didn't try for a Rocky Mountain OpenStack Days.
14:46:14 <mihalis68> obviously for me NE USA is GREAT!
14:46:25 <emccormick> it shouldn't be
14:46:36 <mihalis68> oh I see openstack days needs vendors? It's one of *those things* :|
14:46:47 <emccormick> We've got a huge Redhat presence here and in Raleigh
14:46:49 * med_ would have to look through meeting logs to see if we every #actioned or #decisioned 3 way rotation
14:46:59 <emccormick> Comcast and Walmart are here and in Philly
14:47:02 <med_> mihalis68, it's kind of expensive.
14:47:06 <mihalis68> even if it was hash agreed, it could be changed
14:47:11 <med_> truly
14:47:23 <mihalis68> I think Comcast openstack is near death
14:47:29 * med_ is fully ambivalent but unlikely to travel beyond USA/Canada for Ops Midcycle
14:48:05 <mihalis68> proposal : email the list and ask for interest level in a mid-cycle in europe in that slot?
14:48:23 <mihalis68> or is it likely that these events will merge with PTG and just go where they go?
14:49:15 <shintaro> I think giving a shot for europe is a good idea and if we can't find the host, then we can go for co-location with PTG or something
14:49:23 <mihalis68> maybe a better idea is to get the community to express a view on joining PTG cycle/location?
14:49:31 * med_ knows some people relatively recently joined Comcast OpenStack and don't think it's going away
14:49:40 <emccormick> mihalis68 They are still hiring Openstack people here and in Philly both. Doesn't seem too dead yet ;)
14:50:08 <mihalis68> maybe I am guilty of repeating the biased view from the Walmart folks (formerly at ComCast)
14:50:19 <emccormick> RE: joining PTG, this still makes me kinda squirmy on the Devs behalf.
14:50:20 <mihalis68> I am glad to hear it's not pining for the fjords
14:50:31 <emccormick> I would basically want an invite from them as a group
14:51:01 <mihalis68> I'm ambivalent, to reuse med_s great description. I like the independent spirit of separate mid-cycles
14:51:15 <mihalis68> but then I think of how difficult it was to get the mexico event off the ground
14:51:41 <emccormick> It's not pining, it's passed on!
14:51:45 <emagana> +2
14:51:49 <mihalis68> ok, as chair I think I can safely say no consensus, debate continues
14:52:02 <emccormick> whoops, wrong python
14:52:36 <emccormick> So we have 2 open questions I guess.
14:52:49 <emccormick> 1) Do we or do we not colocate with the PTG beyond Tokyo
14:53:05 <emccormick> 2) If not, do we have a 3 region or 4 region rotation?
14:53:13 <VW> I'm still leaning towards no
14:53:15 <mihalis68> I believe it's 3
14:53:21 <VW> but I can be convinced.
14:53:40 <mihalis68> it's weird to colocate but not on same days
14:53:53 <mihalis68> (I think that's the idea, or am I wrong?)
14:54:08 * med_ is more and more confused but is patient and waits for a summary
14:54:12 <emccormick> PTG runs a whole week. How would we avoid overlap?
14:54:28 <smcginnis> The risk with 1 is they wanted the PTG to get away from the issues of the summit of "oh, I need to leave this important design discussion to give a presentation". Some risk of reintroducing that with colocation.
14:54:33 <mihalis68> It would be interesting to find out if the foundation expects to do every other summit in NA, viewing it as two regions going forward
14:54:39 <med_> agreed, you have to overlap with either the first two days or the last three days (or right in the middle and overlap both)
14:54:46 <emagana> It will be easy to justify a trip to week and days for two events, than two trips to different locations.
14:54:56 <smcginnis> mihalis68: Maybe aprice___ can answer that?
14:55:11 <med_> thingee, aprice___ pretty sure NA is every other for both Summits and PTGs
14:55:13 <emagana> Does the PTG need the whole week?
14:55:14 <med_> is that about right?
14:55:20 <mihalis68> I think perhaps I have not read a good enough definition of what is actually being proposed re: PTG
14:55:30 <emagana> I would think that 3 days for PTG and 2 days for Ops
14:55:32 <med_> emagana, they use the whole week as there are so much going on
14:55:33 <smcginnis> emagana: Yeah, we filled the week and really could have used more.
14:55:53 <mihalis68> so after Berlin, Summit is due in NE NAM?
14:55:58 <smcginnis> 2 days of cross-project stuff, 3 days of project specific.
14:56:10 <emagana> smcginnis: understand it.. I used to be a developer!  :'(
14:56:18 <emccormick> mihalis68 yes
14:56:22 <mihalis68> let me just squeeze in my last agenda item
14:56:25 <aprice___> I don't think that anything is finalized re: Summits post Berlin, but to date, we have alternated NA every other Summit, yes
14:56:38 <med_> I'm not sure "NE NAM" just NAmerica
14:56:47 <mihalis68> can everyone who appears on #link https://wiki.openstack.org/wiki/Ops_Meetups_Team please affirm they still want to be on the team or not?
14:57:05 <shintaro> o/
14:57:08 <VW> yes - the PTG is where the devs shuould really be diving in to blueprints and the HOW of new features/fixes that were discussed at the forum (the what).  The Ops mid-cycle is much more about getting Operators engaged in the larger community
14:57:09 <emccormick> <aprice___> is the east / west alternating just an accident?
14:57:13 <mihalis68> med_ it is EMC's contention that  NAM is two zones for planning purposes
14:57:20 <VW> I worry about trying to put them together and risk losing their purpose
14:57:24 <VW> I'm still in mihalis68
14:57:28 <mihalis68> thanks guys
14:57:34 <mihalis68> I will email matt jarvis and tom and ask this question
14:57:39 <VW> but I have to run to my next meeting here
14:57:42 <VW> see you all next week
14:57:47 <mihalis68> it might seem harsh, but I want to see the real team size
14:57:49 <aprice___> emccormick: I wouldn
14:57:51 <mihalis68> thanks VW
14:57:58 <med_> mihalis68, team or team organizers?
14:58:01 <emagana> Thanks for leading the conversations mihalis68
14:58:06 <mihalis68> my pleasure
14:58:18 <aprice___> I wouldn't say accident as we try to change the location in NA to accommodate different areas and communities
14:58:23 <mihalis68> team organizers
14:58:25 * med_ is not much of an organizer, obviously
14:58:28 <mihalis68> like I think Matt is out, right?
14:58:36 <mihalis68> best clean that page up
14:59:01 <mihalis68> I'm going to do it based on responses here and email
14:59:06 <emccormick> So it would be unlikely to do the next NAM in, say, Seattle.
14:59:07 <mihalis68> last call for input
14:59:20 <mihalis68> I think the rotation discussion has to carry on
14:59:35 <med_> thanks mihalis68 all.
14:59:42 <mihalis68> thanks everyone
14:59:43 * med_ goes to next meeting
14:59:49 <mihalis68> #endmeeting