14:00:21 <mihalis68> #startmeeting Ops Meetup Team
14:00:24 <openstack> Meeting started Tue Nov 21 14:00:21 2017 UTC and is due to finish in 60 minutes.  The chair is mihalis68. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:28 <openstack> The meeting name has been set to 'ops_meetup_team'
14:00:28 <mihalis68> I don't see any regular attendees
14:00:37 <mihalis68> perhaps people are already on vacation
14:00:51 <mihalis68> #link agenda https://etherpad.openstack.org/p/ops-meetups-team
14:01:50 <mihalis68> hello
14:02:02 <shintaro> hi
14:02:07 <mihalis68> there's nobody around
14:02:26 <shintaro> oh. shall we wait for few minutes
14:02:39 <mihalis68> yeah
14:02:44 <mihalis68> thanks for filling out the agenda
14:03:00 <mihalis68> so sponsoring breakfast is estimated at $2k?
14:03:16 <shintaro> yes. including morning coffee
14:03:23 <mihalis68> nice. I'll ask if we can cover that
14:03:43 <mihalis68> the question about the eventbrite funds will have to go to a foundation member.
14:03:52 <med_> \o
14:03:56 <mihalis68> hi!
14:04:02 * med_ just woke up, not a work day
14:04:18 <shintaro> I will ask Clair about the eventbrite funds
14:04:23 <mihalis68> you beat all but 2 here!
14:04:35 <shintaro> hi
14:04:57 <mihalis68> #topic actions
14:05:18 <mihalis68> last week we only had one - emccormick to join the LTS debate on the mailing list. COMPLETE
14:05:33 <mihalis68> that debate has taken off on the mailing list, and on an ether pad (see link in agenda)
14:05:52 <mihalis68> there's talk of converting the topic into a SIG instead of spanning operators mailing list and developers mailing list
14:05:52 <med_> that they dragged that discussion to -sig was kind of annoying.
14:06:24 <mihalis68> somebody else commented privately to me that is sometimes a way to play nice but effectively bury an issue
14:07:20 <shintaro> I wonder how many people are in the SIG-ML
14:07:25 <med_> well, just meant I had another ml to join and also didn't have older messages in my mail queue.
14:07:31 <mihalis68> if anyone else had older actions, feel free to put them on the agenda. It's too hard to go back and scrape old meeting minutes to find incomplete actions
14:07:45 <mihalis68> I wasn't subscribed, certainly (now fixed)
14:08:35 <mihalis68> #action shintaro is going to contact foundation (Clair) about using Eventbrite funds for T-Shirts
14:08:36 <shintaro> I need to check the Foundation about the graphics and logos for the OpsMeetup
14:09:24 <shintaro> I will also ask how many have registered so far.
14:09:42 <mihalis68> seems we've moved on to the tokyo event, so #topic Tokyo Ops Mid-Cycle Meetup
14:10:07 <mihalis68> is breakfast+coffee the main sponsorship opportunity?
14:10:10 <med_> #topic must be first on the line I think
14:10:33 <mihalis68> #topic Tokyo Ops Mid-Cycle Meetup
14:10:36 <mihalis68> thanks!
14:10:58 <shintaro> yes mihalis68. breakfast+morning coffee is the main sponsorship so far.
14:11:00 <mrhillsman> o/
14:11:05 <mihalis68> good morning!
14:11:09 <shintaro> hi
14:11:38 <mihalis68> #mihalis68 to confer with colleagues over whether Bloomberg can pick up breakfast+coffee sponsorship for Tokyo
14:12:03 <mihalis68> I have not checked in with the planning ether pad. How are we doing for technical agenda planning?
14:12:24 <mihalis68> Have you firmly decided on two tracks called Telecom and Other, respectively?
14:12:55 <mihalis68> As I recall there's only 3 rooms, so it can't be very parallelised
14:13:14 <shintaro> right one large and two small
14:14:21 <shintaro> if we are going to do hackathon-like documentation session, we will be needing one room for that.
14:14:42 <mihalis68> #link https://wiki.openstack.org/wiki/Operations/Meetups/TYO-ops-meetup
14:15:08 <mihalis68> #link https://etherpad.openstack.org/p/TYO-ops-meetup-2018
14:15:41 <shintaro> no update on NFV track
14:16:03 <mihalis68> That seems to need some clarification. Is it "NFV" and "General" tracks and that's it?
14:16:15 <mihalis68> Themed track is vague if you've called it NFV previously
14:17:04 <shintaro> I was thinking to have two themed track, one is NFV and one is Enterprise. one day each
14:17:17 <mihalis68> it's your company's event as host, so I think you should just decide and represent the decision in that ether pad. Then It think we should try go get the community's attention
14:17:35 <mihalis68> hmm, interesting. In my imagination, tracks imply parallel
14:18:00 <mihalis68> if it's themed days I'd call them days, not tracks
14:18:15 <mihalis68> everyone else please weigh in here, it feels like typing at shintaro right now :|
14:19:10 <med_> I'd agree--tracks indicates parallelism, days is what I would call distinct focuses of each day
14:19:49 <shintaro> ok it would be themed days then.
14:19:53 <med_> and I think having that type of focus is fine--not at all concerned whether we do tracks or days.
14:19:56 <med_> sounds fine.
14:20:03 <mrhillsman> I'm indifferent...potatoe potahto
14:20:36 <mrhillsman> agreed with med_
14:20:40 <mihalis68> think of it like software requirement stories : I am a telecom focused attendee and I wish to attend all the telecom-focused sessions
14:20:45 <mihalis68> is that person only attending 1 day?
14:21:59 <shintaro> if that person is not interested in any other topic, maybe yes, but general and enterprise sessions will cover many topics that may interest telcos as well, IMHO
14:23:13 <mihalis68> so it's two days with some mixed-audience sessions on each but in addition day 1 is focused on NFV?
14:23:37 <mrhillsman> not sure we have to get that specific
14:23:43 <shintaro> that's my idea
14:24:24 <mrhillsman> comment was meant to go further up
14:24:25 <mihalis68> I think when people look at such events, it's very important for them to understand clearly what it will be like
14:25:06 <mrhillsman> agreed
14:25:20 <mihalis68> let me see if I have it, shintaro. The event is 2 days of general operators related technical sessions. In addition, day 1 has an NFV focus
14:26:04 <shintaro> yes and day 2 have another track which I now think would be "Enterprise track"
14:26:29 <mihalis68> so day one is general+nfv, day 2 is general+enterprise?
14:26:40 <shintaro> yes
14:26:45 <mihalis68> ok! I like that
14:27:00 <mihalis68> perhaps that's what the google doc intended to convey but I didn't quite grasp it
14:27:13 <shintaro> we have another room if anyone want to do some work
14:27:17 <mihalis68> cool
14:27:26 <mihalis68> seems like all the business for tokyo. I
14:27:43 <shintaro> I will update the etherpad
14:27:49 <mihalis68> I'll look at the google doc and try to help clarify. I can't edit it from my desk unfortunately (google docs is very locked down here)
14:28:40 <mihalis68> once it's good I propose this: email the meetups team for final comments. Unless there's an objection then share the planning doc again with the operators mailing list and ask people to start submitting session ideas
14:29:19 <mihalis68> taking silence as assent. Please object strenuously if I'm wrong
14:29:32 <shintaro> do you mean share planning etherpad?
14:29:43 <shintaro> or google doc?
14:29:44 <med_> concur
14:29:46 <mihalis68> #topic future mid-cycles - to co-locate or not that is the question
14:30:13 <mihalis68> yes I meant the ether pad. google doc for precise agenda comes later
14:30:22 <shintaro> okay got it
14:30:30 <mihalis68> #link https://docs.google.com/document/d/1BgICOa-Mct9pKwjUEuYp_BSD1V_GdRLL_IM-BU0iPUw
14:31:00 <mihalis68> The link I just posted is a discussion document about co-location
14:31:19 <mihalis68> it needs more work to capture the different views
14:31:43 <mihalis68> As I understood it, originally the idea revolved around some inter-working between the operators and the developers
14:31:54 <mihalis68> however the PTG is 5 solid days already filled with content
14:32:12 <mihalis68> last week after the meeting, I learned that there's some support for a separate event that just happens to be in the same facility
14:32:24 <mihalis68> this I (to be honest) don't really grok
14:33:05 <med_> well, they probably get the rooms/whatevs at the already discounted rate.
14:33:17 <med_> btw, how did you learn this? Lauren?
14:33:19 <mihalis68> I understand the bit about leveraging foundation logistics expertise to only have one venue to acquire
14:33:29 <med_> kk
14:33:35 <mrhillsman> tie in support from foundation as ops meet up need
14:33:41 <mihalis68> mrhillsman was telling to stop worrying about the PTG part of it
14:33:51 <med_> nods.
14:33:52 <mrhillsman> may grok better then
14:34:04 <mihalis68> but it raises as many questions as it answers
14:34:18 <mihalis68> would it be two separate events in evenbrite? Two teams doing agendas?
14:34:18 <mrhillsman> that's perfectly ok
14:34:34 <med_> V W was concerned about lack of focus and lack of ... pureness if they were concurrent.
14:34:38 <mihalis68> would it still be "PTG" or would it be called something more inclusive
14:34:54 <mrhillsman> sure, should be different as it is now
14:35:01 <mriedem> pureness?
14:35:20 <mrhillsman> the only point is, can this reduce some costs
14:35:41 <med_> I don't want to "wake" him, but something about keeping Operators as a discipline distinct from Devs mriedem
14:35:55 <mihalis68> unleash the Krake... the VW!
14:35:56 <mriedem> i'm not sure why we should be silo'ed
14:35:56 <med_> but I'm poorly representing his POV.
14:36:23 <mriedem> just because you're in the same venue doesn't mean you have to talk to each other
14:36:32 <mrhillsman> or not :)
14:36:33 <mriedem> it just makes it easier if you have agenda items that overlap
14:36:43 <mihalis68> that's true, but does the venue have to have multiple rooms with AV capabilities?
14:36:45 <mriedem> or need operator (or dev) input to something
14:37:06 <mihalis68> the sessions where we get the ether pad up on a big screen seem helped by that
14:37:15 <mrhillsman> talk in the evening :)
14:38:35 <mrhillsman> surely there is A/V caps in multiple rooms at a hotel
14:38:45 <mriedem> there was at the place in denver for the last ptg
14:38:46 <mriedem> yes
14:39:00 <mrhillsman> ^
14:39:04 <mihalis68> yeah but think about NYC. There was clearly one main room
14:39:06 <med_> many actually
14:39:17 <mriedem> who coordinated NYC
14:39:18 <mriedem> ?
14:39:20 <mihalis68> I did
14:39:27 <mriedem> the foundation scouts out the location for the ptg
14:39:40 <mriedem> they obviously didn't scout the train noise in denver, but...
14:39:47 <mrhillsman> hehe
14:39:49 <mriedem> the venue itself was ok for the actual work part
14:39:51 <med_> yep, they look for the place with the most train horns
14:39:57 <mihalis68> I think for the event to be a combined PTG and ops Meetup it would need to be redefined as that
14:40:05 <mihalis68> and then foundation would plan a combined event
14:40:12 <mihalis68> we'd be a "track" effectively
14:40:19 <mrhillsman> it's not combined my friend
14:40:31 <mihalis68> it is combined from their point of view
14:40:34 <med_> collocated is what you are thinking mrhillsman
14:40:38 <mihalis68> same dates same location
14:40:54 <mihalis68> they are doing logistics - people, rooms, catering
14:40:56 <mrhillsman> who's viewpoint?
14:41:00 <mihalis68> the proposal combines those things
14:41:00 <med_> I think that's a matter of marketing/splitting hairs.
14:41:05 <mrhillsman> ^
14:41:11 <med_> the devs define the content, tracks in ptg
14:41:14 <med_> not the foundation
14:41:15 <mrhillsman> which is not our concern
14:42:05 <mihalis68> the definition of PTG is on the foundation website. The definition should be expanded if the venue is hosting an operators meet up at the same time as the PTG, surely?
14:42:20 <smcginnis> This might help as far as putting on the event. But I'm concerned on whether it would help having devs involved in more ops discussions.
14:42:26 <mrhillsman> we are only discussing costs and man/woman hours on making the event happen by including staff for ops logistics needs
14:42:39 <mihalis68> we are discussing the whole thing
14:42:50 <mihalis68> because as a proposal it hasn't been accepted by the community
14:42:56 <mrhillsman> let the foundation be concerned with foundation concerns
14:43:10 <mihalis68> hi smcginnis, by the way!
14:43:16 <smcginnis> mihalis68: o/
14:43:17 * med_ notes that he would be able to get more out of his travel dollars if they were co-located and get more from the event....
14:43:42 <smcginnis> med_: That would be a benefit for sure.
14:43:55 <mihalis68> smcginnis I think it wouldn't help that, since the devs are at an event dedicated to dev issues, by definition
14:44:06 <mihalis68> I don't see random bar encounters as a substiture
14:44:11 <mihalis68> substitute
14:44:15 <mriedem> it depends on the topic in the room at the time,
14:44:17 <smcginnis> mihalis68: Yeah, I agree.
14:44:25 <mriedem> in denver, the first two days were cross-project things
14:44:33 <mriedem> like fast forward upgrades, interop, API SIG, etc
14:44:44 <mriedem> wed-friday are traditional meetup-style silo'ed roms,
14:44:46 <mriedem> *rooms,
14:44:52 <mriedem> but we do overlap for scheduled topics,
14:44:54 <smcginnis> During the PTG I was double booked almost the entire week as far as discussions I wanted to be in. This wouldn't help me, but it may help others.
14:44:56 <mriedem> like nova/neutron, nova/cinder, etc
14:45:27 <mihalis68> maybe PTG is defined too narrowly in the foundation page. At risk of repeating myself, having read it closely, it's not for me
14:45:41 <mriedem> from my pov, i can't travel to ptg and summit *and* an opts midcycle, so colocating 2 of those would be helpful
14:45:53 <lbragstad> ++
14:45:54 <mriedem> mihalis68: yes they'd have to redefine that probably
14:46:06 <smcginnis> mihalis68: As it is right now, yes, it is not really meant for ops.
14:46:10 <mihalis68> PTG says you should be either on a dev team, or a subject matter expert where the subject is one of the development activities
14:46:17 <mihalis68> this is what I am getting at
14:46:37 <lbragstad> having some operator representation during the PTG would be nice - otherwise we're waiting two months to share what we came up with at the PTG with operators for feedback
14:46:37 <mihalis68> we now seem to have a view that co-location would be for inter-working
14:46:39 <med_> ah, but if they schedule another event simultaneously, that changes.
14:47:06 <med_> it could be another event at the same place -OR- they could change the definition. I think either approach would be fine.
14:47:06 <mihalis68> I'd totally attend PTG if I felt remotely encouraged
14:47:10 <mriedem> lbragstad: well you wait 2 months for the summit, in australia, where no ops have budget to travel anyway :)
14:47:23 <lbragstad> or that
14:47:23 <mihalis68> at least those two days which seem set up for cooperation
14:47:48 <mrhillsman> lbragstad PTG should be based on previous Forum discussions
14:48:03 <mriedem> mrhillsman: not necessarily
14:48:14 <mriedem> the ptg replaced the midcycle and dev summit,
14:48:18 <mrhillsman> According to the change yes
14:48:20 <mriedem> so it's part planning for the upcoming release
14:48:27 <med_> I've been at both PTGs. Knowledgeable, contributing operators were very welcome.
14:48:36 <smcginnis> med_: ++
14:48:37 <mriedem> and it's part talking about shit that is still broken and needs work, w/o 40 minute time boxed sessions
14:48:38 <mrhillsman> Looking at the lifecycle graphic and explanations
14:49:04 <mrhillsman> It is supposed to move towards that
14:49:48 <smcginnis> I think in reality we want to have some dev representation at ops events and some ops representation at dev events. The Summit is really what's conceived as the focus for full interaction at this point, but there should probably always be a little mix.
14:49:51 <mihalis68> well this is much easier for me to understand : first two days of PTG become officially slightly broader and we declare those to be effectively the mid-cycle meetup
14:49:56 <lbragstad> not sure if we were supposed to - but our project spent a significant amount of time redesigning some stuff that has cross-project implications... that's where we really wanted operator feedback (like 10,000 ft view of what we came up with)
14:50:53 <mihalis68> the question for those who in any way represent the dev teams is : is that acceptable to them?
14:51:00 <med_> mihalis68, if you want a 2d on that idea, I'm the 2d
14:51:17 <med_> thingee, ^
14:51:21 <mrhillsman> the issue with that change is what VW was alluding to
14:51:28 <mihalis68> thanks med_ ... am I wrong or is this idea quite different from where we ended last week?
14:51:32 <mrhillsman> losing ops focus mihalis68
14:51:51 <med_> mihalis68, it's different from where we ended but closer to where we started a few weeks/months ago.
14:51:58 <mriedem> "first two days of PTG become officially slightly broader and we declare those to be effectively the mid-cycle meetup" - describes, to me, what used to be the old dev summit format
14:52:12 <med_> the folks endorsing this idea SEEM TO BE KEY DEV LEADERS and it seems like they approve.
14:52:13 <mriedem> except it's not mid-cycle at all, since it's at the beginning of the cycle
14:52:23 <mrhillsman> exactly
14:52:39 <mrhillsman> if we stop trying to put the two events together we can move forward
14:53:06 <med_> and understand that we (ops) won't have even kicked the tires on the just released bits, that feedback will have to come at the Forum in the summit still.
14:53:07 <mrhillsman> it comes down to ops midcycle asked foundation for logistical support
14:53:23 <mrhillsman> this is an option to ease foundation work, costs, etc etc
14:53:25 <mrhillsman> in doing that
14:53:27 <mihalis68> mrhillsman you've communicated your opinion on this, but there are others
14:53:39 <mrhillsman> if it will not, we should not
14:53:56 <mrhillsman> because we will lose the "pureness" of ops, as VW mentioned
14:54:13 <mihalis68> what I'm seeing above is a desire to get ops into PTG, at least on days 1 and 2 from several people
14:54:24 <mihalis68> not just at same hotel, but in same room, discussing shared challenges
14:54:36 <mrhillsman> yes, that makes sense, the PTG site you referenced covers this no?
14:55:12 <mihalis68> no PTG *as defined on openstack foundation website* seems to specifically welcome just dev team and software SMEs
14:55:12 <smcginnis> I think collocation could be useful as long as it's not intended as combination. It at least gives the opportunity for cross-collaboration. And being around each other for evening drinks can definitely have benefits too, even if the daytime sessions have too many conflicts.
14:55:42 <smcginnis> mihalis68: I consider you all SME's. :)
14:56:00 <mihalis68> the S is not any specific chunk of software
14:56:01 <mriedem> i think he means SME on a particular project
14:56:05 <mihalis68> yeah
14:56:09 <mriedem> like cburgess on nova
14:56:09 <med_> fwiw, entire teams (cinder/nova) frequently join together for an hour or two (same any time during the week) as well as individual stakeholders/experts cross pollinating on an as needed/as owned basis
14:56:21 <med_> ie, the etherpad says: Grab Jay Pipes for this one
14:56:29 <med_> or grab miihallis68 when we talk about this
14:56:30 <smcginnis> Yes, but still subject matter experts in general on a lot of things.
14:57:03 <mihalis68> I run an openstack team and in the past I built all our clusters, but I wouldn't consider myself an expert on any specific topic in the list
14:57:07 <mrhillsman> how many operators attend ptg, i think we mentioned 5 or six
14:57:21 <mihalis68> we sent nobody who actually does things here.
14:57:29 <mrhillsman> if the content of the overlap days is still ptg specific
14:57:34 <mrhillsman> how does that change?
14:57:35 <mihalis68> Literally if any people represented bloomberg they do not participate in on-call support at any level
14:57:52 <mriedem> for nova, we generally get 2 ops
14:57:57 <mriedem> med_:  and cbrugess
14:58:00 <med_> but you could have--I think there was a tradeoff/self-selection
14:58:01 <mriedem> *cburgess
14:58:40 * med_ nods, was there all week, but it was also "local"
14:58:41 <mrhillsman> my point i guess is, if there is no change in content right now, and no change in content if we go this route, how is there a change in attendance
14:58:45 <mihalis68> I could have attended, but it seemed not for me. My team all came to same conclusion (I asked them to consider going)
14:58:51 <med_> but traveld to atlanta for same reasons
14:59:00 <med_> kk
14:59:02 <mihalis68> we're gonna run out of time here.
14:59:09 <mrhillsman> right mihalis68 so why push combining the content/schedule/days
14:59:15 <mihalis68> on the agenda I reminded people of the converted Operators Guide
14:59:17 <mriedem> we do get better ops attendance at the forum for sure
14:59:41 <mihalis68> mrhillsman it was suggested as a possible good thing by PTG attendees during this very meeting
15:00:12 <mihalis68> e.g. sean
15:00:20 <mrhillsman> i think that was an evolution of the focus on combining events
15:00:39 <mihalis68> no, I don't think so at all
15:00:43 <mrhillsman> vs staying on the focus of ops midcycle needing help on logistics
15:00:51 <mihalis68> there is one viewpoint that says get ops in for days 1 and 2
15:01:30 <mrhillsman> i think last meeting we spent quite a bit of time trying to keep the conversation on the latter
15:01:39 <mihalis68> out of time
15:01:41 <mihalis68> #endmeeting