14:01:59 <mihalis68> #startmeeting Ops Meetup Team
14:02:00 <openstack> Meeting started Tue Nov 28 14:01:59 2017 UTC and is due to finish in 60 minutes.  The chair is mihalis68. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:04 <openstack> The meeting name has been set to 'ops_meetup_team'
14:02:16 <mrhillsman> o/
14:02:17 <mihalis68> #link https://etherpad.openstack.org/p/ops-meetups-team
14:02:32 <mihalis68> formative agenda and attendees list in that link
14:02:47 <emccormick> o/
14:03:10 <mihalis68> hi all
14:03:14 <med_> \o
14:03:19 <shintaro> hi
14:03:26 <mihalis68> I haven't had time to prepare a very detailed agenda.
14:03:33 <mihalis68> Do people want to self-report on their actions?
14:04:06 <mihalis68> I see I didn't action myself, but I did take the topic of co-location to the mailing list
14:04:16 <emccormick> I missed last week, so I had none unless someone volunteered me
14:04:39 <mihalis68> and for an older topic, the OpsGuide is ready to be announced with a blog which I'm helping out with (it's up on the openstack wiki already)
14:04:47 <shintaro> I've updated the Tokyo agenda planning etherpad and spreadsheet skeleton so please everyone check it
14:05:07 <mihalis68> #link https://wiki.openstack.org/wiki/Documentation/OpsGuide
14:05:18 <shintaro> #link https://etherpad.openstack.org/p/TYO-ops-meetup-2018
14:05:32 <mihalis68> shintaro I see you contacted the foundation about the use of eventbrite funds, thanks
14:05:58 <mihalis68> did everyone see the thread about co-location on the mailing list?
14:06:07 <shintaro> yes we will get OpsMeetups logo in few weeks
14:06:19 <emccormick> yeah. It kinda went quiet though
14:06:42 <emccormick> I tried to stay out of it to start with. Perhaps we should stoke the flames again.
14:06:55 <mihalis68> any other comments on previous actions?
14:07:12 <mihalis68> #topic actions
14:07:18 <mihalis68> all previous actions appear complete
14:07:22 <mihalis68> #topic Tokyo
14:07:30 <mihalis68> what's to be done still for tokyo?
14:07:56 <mihalis68> I recall that breakfast+coffee is open for sponsorship, as well as swag, is that right?
14:08:15 <mihalis68> and also the evening event venue is not yet locked in
14:08:25 <shintaro> yes. I'm asking if the Foundation can provide Tshirts
14:08:26 <smcginnis> Could someone add the Eventbright registration link to the etherpad? I know I have it somewhere, but might be good to have it in there.
14:08:58 <emccormick> yeah
14:09:34 <emccormick> https://www.eventbrite.com/e/openstack-ops-midcycle-tokyo-tickets-39089912982
14:09:55 <smcginnis> emccormick: Thanks!
14:10:20 <shintaro> added to the etherpad
14:11:25 <shintaro> 7 people have registered as of yesterday.
14:11:36 <smcginnis> I'll probably register today.
14:11:40 <mihalis68> cool, thanks. I see the link in our agenda for today and on the tokyo planning page
14:12:46 <emccormick> We're already at 20% of what we had 2 weeks before MEX so good start :D
14:12:56 <mihalis68> are the event planning team for Tokyo ready to talk about precise cost figures for breakfast+coffee?
14:13:15 <mihalis68> as I can ask for my company to pick that up, but only when it's a firm quota
14:13:20 <mihalis68> quote I mean
14:13:47 <mihalis68> maybe I can work on that offline with shintaro (i.e. via email)
14:13:53 <shintaro> I'll create sponsor prospectus as edger did in Mexico
14:14:01 <mihalis68> ok good, thanks!
14:14:16 <mihalis68> will you ask for swag and social-event sponsors too?
14:14:52 <shintaro> Foundation may be able to provide swag (T-shirt)
14:14:55 <mihalis68> #action shintaro to provide sponsor prospectus for Tokyo sponsorship opportunities
14:15:35 <mihalis68> I hope we can manage some items in western sizes. A real 2X for example
14:16:03 <mihalis68> we had a problem with some in-house swag such that a hoodie marked 2X was a tight squeeze even for my arms :|
14:16:42 <mihalis68> i'm sure I'm not alone in mostly liking the t-shirts, as opposed to knick-knacks
14:17:01 <mihalis68> any news about the social event for Tokyo?
14:17:30 <shintaro> no update on the event venue.
14:18:03 <mihalis68> Ok, so I think the biggest priority going forward is that and the technical agenda
14:18:19 <mihalis68> I added some +1s to topics on your ether pad. I assume that's what you're after to assess interest?
14:19:13 <mihalis68> One thing we might do is scrape the topics from Mexico and see which ones were popular sessions. Thoughts?
14:19:28 <shintaro> thank you. we still need input from the community so I'll email the ML once the track idea is good with this team
14:19:38 <emccormick> I generally tend to cherry pick like that. Hence the top 4 that are there already ;)
14:19:47 <smcginnis> mihalis68: Good idea.
14:19:52 <emccormick> If you had favorites from other meetups that you'd like to see continued, by all means put them in
14:19:59 <mihalis68> #action shintaro to stir things up on the mailing to get participation in the technical agenda planning for tokyo
14:20:29 <shintaro> I will also add the popular topics from the past Meetups
14:20:39 <mihalis68> openstack LTS releases was so "popular" in mexico we didn't finish and instead ran out of time during a fierce debate
14:20:48 <mihalis68> ok great!
14:20:59 <mihalis68> #action shintaro to bring forward "greatest hits" topics from previous sessions
14:21:30 <mihalis68> I'll also look at the mexico stuff and try to remember which ones were "live wire" sessions
14:21:35 <smcginnis> If there's anything I can contribute for Cinder, TC, or general
14:21:42 <smcginnis> "dev input" let me know.
14:22:05 <mihalis68> thanks sean!
14:22:26 <mihalis68> ok, feels like tokyo is moving nicely.
14:22:48 <mihalis68> #topic possible co-location of ops meetups with PTG
14:23:10 <mihalis68> It seems to me that Thierry was against
14:24:11 <mihalis68> https://www.irccloud.com/pastebin/2H9PAX4A/ttx
14:24:18 <med_> agreed, he's protecting his time and his agenda.
14:24:52 <mihalis68> I hope it's not a breach of protocol to extract his message this way. It is a public and archived mailing list after all
14:24:57 <med_> rather, the dev's time and his dev agenda
14:25:07 <med_> no, should be totally fine
14:25:30 <smcginnis> The feeling I got from a lot of past PTG attendees was they already have a hard time managing their schedule and they are afraid of making that worse.
14:25:36 <smcginnis> And losing focused dev time.
14:26:38 <VW> hey guys - sorry I'm late
14:26:40 <smcginnis> I forget, did we discuss having it post-Summit? Since those are 3-4 days, might be easier to piggy back on that event instead.
14:26:55 <med_> welcome VW
14:27:01 <mihalis68> hi vw!
14:27:38 <med_> smcginnis, the Forum at the summit is more or less an Ops event already (by design) so I'm not sure I follow your suggestion.
14:27:46 <mrhillsman> post-summit could be interesting but possibly that same, "after x days my brain"
14:27:48 <mihalis68> I don't recall the idea of drafting behind the main event, however the event we're talking about is traditionally mid-way between them
14:27:49 <med_> a different type of event right after/adjoined?
14:28:20 <mihalis68> although as pointed out last week, it is no longer "mid-cycle" since the cycle now starts at PTG
14:28:32 <VW> well, one of the things we talked about in the session at the last summit was an ideal output of midcycle sessions would be submissions for sessions at the next summit
14:28:37 <VW> or at least folks tasked to do so
14:28:53 <VW> so, putting it right after the summit might make that tricky
14:29:00 <mihalis68> yeah, agreed for my part
14:29:40 <mihalis68> I think there are a couple of propositions I was confusing last week. My potential attendance at PTG (especially the first 2 days) and "official co-location"
14:30:06 <mihalis68> I quite agree that the former is likely to work. I'm sure I'd be welcome to attend the first couple of days and work on dev/operator common goals
14:30:09 <smcginnis> med_: Yeah, thinking the Forum would be the combined dev/ops discussions. Ideally pre-Forum/Summit have a day or two of focused ops sessions just to share the war stories and come up with a few key points to bring into the Forum.
14:30:24 <mihalis68> but "official co-location" of ops meetups and PTG seems dead in the water to me
14:31:02 <smcginnis> mihalis68: I think you are right.
14:31:24 <mihalis68> if I put my meetups team member hat on, I can't invite the operator community to PTG, we're not really welcome en masse
14:32:08 <mihalis68> I'd like to hear everyone's thoughts on this
14:32:19 <VW> I would say it's probably that we aren't as effective en masse there versus not welcome, but yeah
14:32:20 <emccormick> Yeah, it pretty much violates my non-interference rule.
14:32:37 <smcginnis> To be clear, ops-focused folks are welcome at the PTG to provide input during the design discussions. It just can't turn into a mini-Forum.
14:32:37 <shintaro> PTG is not for ops, I agree
14:32:38 <emccormick> I want to do it, but I also don't want to disrupt and cause angst among devs.
14:33:24 <mihalis68> I accept VWs refinement but I think it amounts to the same thing
14:33:30 <mihalis68> co-location seems dead. Agreed?
14:33:31 <mrhillsman> it is just a matter of what you are discussing as lbragstad mentioned last week
14:33:35 <mihalis68> Please object if you don't agree
14:33:54 <mihalis68> or at least official co-location as I'm calling it
14:33:54 <emccormick> +1 dead
14:34:13 <emccormick> sad but true
14:34:39 <mihalis68> #agreed "official co-location" of ops meetups and PTG appears to be at least inefficient and possibly unwelcome
14:34:46 <med_> so my point has been the nature of PTG would have to change/expand for it to succeed.
14:34:52 <mihalis68> individual operators attending PTG is still fine
14:34:59 <mihalis68> yes I agree entirey
14:35:15 <mihalis68> +1 med if they expanded the definition, I'd reconsider my vote on this
14:36:07 <med_> well, I think we'd have to lobby for it (even more so) to change the definition and I'm not seeing the momentum here to do that, so fait accompli
14:36:16 <emccormick> So with this topic banked for the time being...do we discuss region rotation schedule and proposal solicitation?
14:36:20 <mihalis68> this leads to the conclusion that we should try for an ops-focused event between vancouver and the summit after
14:36:49 <smcginnis> Probably August/September again.
14:36:53 <mihalis68> yes I think we are back to an intended north american event in the second "slot" of 2018
14:36:57 <emccormick> *nod*
14:37:19 <mihalis68> and perhaps attempting to bring in openstack logistics assistance earlier in the process
14:37:33 <med_> +1
14:37:37 <shintaro> +1
14:37:42 <mihalis68> so we should invite hosting offers!
14:38:07 <emccormick> +1
14:38:14 <VW> yes
14:38:26 <VW> we need to put the call out for potential hosts
14:38:29 <mihalis68> is anyone itching to do this? If not I can request that
14:39:15 <VW> I'll draft a note
14:39:24 <VW> you'be been doing the lion's share of emailing
14:39:33 <VW> we have an etherpad template for them to fill out, don't we?
14:39:34 <mihalis68> #action VW to issue the official request for hosts for slot 2 meet up in 2018, on behalf of Ops Meetups Team
14:39:51 <mihalis68> yes, it's ... somewhere. I will dig it out
14:39:55 <mihalis68> I'll get that to you today
14:40:07 <mihalis68> I think it would be great coming from VW
14:40:13 <VW> perfect - thanks mihalis68
14:40:30 <mihalis68> wow lots of progress
14:40:42 <mihalis68> I want to make another plea for feedback on the newly converted Ops Guide
14:41:13 <mihalis68> #link https://wiki.openstack.org/wiki/OpsGuide
14:41:24 * med_ takes an action to review it
14:41:36 <mihalis68> as I briefly alluded to, I'm helping with a log submission for super user which will announce this
14:41:47 <shintaro> #link https://etherpad.openstack.org/p/ops-meetup-venue-discuss-1st-2018
14:41:51 <mihalis68> and then I suppose there should be a task to check and modernize it
14:41:59 <mihalis68> thanks Shintaro!
14:42:30 <mihalis68> the conversion was content-neutral (i.e. if the openstack CLI commands were dated, they still are, for example)
14:42:46 <mihalis68> and I think that would be a separate team
14:42:49 <mihalis68> ops docs team
14:42:52 <mihalis68> thoughts?
14:43:41 <mihalis68> rationale: documentation is a LOT of work and involves lots of trivia e.g. spacing spelling etc. Would completely clutter this meeting I feel
14:44:22 <mihalis68> well, I'd be on that team (I think i recall volunteering, effectively, in mexico city)
14:44:47 <mihalis68> #action med_ to review ops guide
14:44:47 <smcginnis> Docs can always use more eyes and more contributors.
14:44:49 <mihalis68> thanks!
14:45:00 <mihalis68> yeah
14:45:13 <emccormick> I would participate as well.
14:45:22 <mihalis68> ok great.
14:45:39 <emccormick> I think for the start though, it would be nice to get a larger group to look it over and either fix issues or report them.
14:46:06 <emccormick> we could have a core team, but it shouldn't be so restrictive as other project teams.
14:46:08 <mihalis68> yep. to start with feedback can be addressed to me if you like (email on agenda)
14:46:23 <emccormick> I think that's why the docs team struggles to keep people.
14:46:42 <mihalis68> as a practical matter, I have wiki edit privileges and so can definitely wade in and fix the doc
14:47:05 <mihalis68> note that so far the wiki version is as-converted from the source
14:47:20 <VW> my ride is here - have to run
14:47:25 <mihalis68> if we need any large scale changes, we still have a one-time option of going  back, editing in source and reconverting
14:47:28 <VW> send me that info mihalis68 and I'll get a note out
14:47:29 <mihalis68> thanks VW!
14:47:32 <mihalis68> will do
14:47:52 <mihalis68> once the wiki is being edited in place, however, it will have to be edited that way forever after
14:47:55 <emccormick> It was suggested to use something like this
14:47:56 <emccormick> https://wiki.openstack.org/wiki/Documentation/QueensDocTesting
14:48:01 <emccormick> to do reviewing.
14:48:12 <emccormick> That way work isn't duplicated so much
14:48:23 <emccormick> it was also suggested to use Launchpad to file bugs
14:48:36 <mihalis68> I'm not sure about that last idea
14:48:49 <mihalis68> this document was ejected from the codebase due to lack of updates
14:49:01 <emccormick> not talking about the full workflow. Just a standalone launchpad
14:49:15 <mihalis68> ah ok. that sounds fine if we can build one (no idea)
14:49:32 <emccormick> basically a place for people who see things broken to report problems. It could be something more simple *shrug*
14:49:36 <mihalis68> I was just thinking aloud that the openstack docs team, having shed this doc, don't want to see bug reports for it, I would think
14:49:44 <emccormick> I don't know how, but I can ask around
14:49:53 <emccormick> yeah they won't
14:50:01 <emccormick> it'd be our new "team" such as it is
14:50:37 <mihalis68> #action emccormick to investigate a launchpad just for ops docs, starting with OpsGuide
14:50:42 <mihalis68> thanks!
14:51:36 <mihalis68> one thing we need to start thinking about: our "ops mid-cycle meetup" events are no longer mid-cycle
14:51:48 <mihalis68> so what are they for?
14:52:22 <med_> as VW said, maybe they are for planning what to say/advocate at the Forum
14:52:27 <mihalis68> we can all answer that, of course, but when we invite people from the wider operator community, some who haven't been before, I think we should try to have a good definition of these events for those people
14:52:31 <med_> ^ discussed in Sydney I think
14:52:41 <mihalis68> unfortunately I wasn't there
14:52:49 <med_> also, for catching up on best practices and pain points
14:52:57 <med_> then converting ^ into Forum actions
14:52:59 <mihalis68> someone want to take a crack at redefining the mission of mid-cycles?
14:53:31 <mihalis68> if nothing else, if we don't fix nomenclature, it appears we're not even paying attention
14:53:36 <med_> but also clearly to have some focus on a tech/need such as shintaro has a track for in Tokyo
14:54:32 <med_> I won't take an action but I'll noodle it a bit and if I come up with a strawman I'll mail it out.
14:54:48 <mihalis68> ok. I'll put it on the agenda for next week and we can pick up this debate then
14:54:55 <med_> seems like we can have a more transparent/obvious short name, description fo rthis.
14:54:57 <med_> +1
14:55:32 <mihalis68> <insert inspiration here>
14:55:45 <mihalis68> any other business, or we can close 5 minutes early
14:56:09 <med_> fyi, I will be afk next tues meeting.
14:56:20 <med_> so if I come up with something it will hit the ML.
14:56:32 <mihalis68> works for me! Thanks!!
14:56:34 <mihalis68> last call
14:56:46 <mihalis68> #endmeeting