15:00:43 <mihalis68> #startmeeting Ops Meetup Team
15:00:44 <openstack> Meeting started Tue Feb 20 15:00:43 2018 UTC and is due to finish in 60 minutes.  The chair is mihalis68. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:48 <openstack> The meeting name has been set to 'ops_meetup_team'
15:00:56 <mihalis68> #link https://etherpad.openstack.org/p/ops-meetups-team
15:00:59 <emccormick> o/
15:01:06 <mihalis68> Greetings, Programs!
15:01:15 <mihalis68> #topic actions
15:01:47 <shintaro> hi
15:01:47 <smcginnis> o/
15:01:49 <mihalis68> I was due to update the ops guide wiki with the first round of feedback. I haven't done it but I have the feedback right here (from David Medberry) and I will update today
15:02:05 <mihalis68> any other comments on actions from previous meetings?
15:02:29 <emccormick> I spammed the list for more sessions / moderators.
15:02:30 <shintaro> I was to ask the Foundation for admin access to the eventbrite page waiting response from the foundation
15:02:36 <emccormick> Will do again for moderators
15:02:45 <mihalis68> agreed, that's urgent
15:02:57 <shintaro> I am asking some attendees in Japan to do some moderation
15:03:08 <mihalis68> I don't think the attendees would appreciate us doing all the moderation
15:03:24 <mihalis68> #topic Tokyo meetup
15:03:32 <shintaro> 60 people so far
15:03:37 <mihalis68> I just saw the invoice about Bloomberg's sponsorship of coffee and snacks
15:03:41 <mihalis68> somehow I missed it first time
15:03:44 <mihalis68> I will get that paid today
15:03:51 <shintaro> thanks mihjalis68
15:03:56 <mihalis68> #action mihalis68 update opsguide wiki
15:03:58 <shintaro> mihalis68 I mean
15:04:11 <emccormick> Give me the list of attendees. I'll volunteer people for them. :D
15:04:12 <mihalis68> #action mihalis68 pay invoice for tokyo sponsorship
15:04:36 <mihalis68> it's linked from last week's minutes IIR
15:04:38 <mihalis68> IIRC
15:05:06 <mihalis68> anything else to discuss about Tokyo? with my payment I think the food and drink is all taken care of
15:05:16 <mihalis68> we already agreed to try and get more moderators.
15:05:35 <mihalis68> are we ready to fill out the actual time slots with sessions?
15:06:00 <emccormick> I think we should go ahead and take a first run at it
15:06:12 <shintaro> I can create the draft
15:06:16 <mihalis68> excellent
15:06:21 <mihalis68> want to email this team?
15:06:26 <mihalis68> when there's something to look at?
15:06:31 <shintaro> I will
15:06:50 <mihalis68> #action shintaro to create a draft timetable (putting sessions in time slots) and email the team
15:07:15 <mihalis68> anything else for Tokyo?
15:07:34 <mihalis68> #topic meet up number 2 2018
15:08:00 <mihalis68> I was due to conference call with verizon and walmart (andrew mitry) last week about the possibility of a joint hosting offer
15:08:00 <VW> hey folks - here
15:08:07 <VW> I just had to step away a second
15:08:13 <mihalis68> however I was too sick to speak for more than 2 minutes so I pushed it
15:08:14 <mihalis68> hey matt
15:08:20 <mihalis68> so I'm due to speak to the soon
15:08:27 <mihalis68> We're already talking about meet up 2 2018
15:08:41 <VW> sweet!
15:09:04 <mihalis68> The very fact that this meeting is still on implies there's decent interest
15:09:28 <mihalis68> If Andrew is interested, perhaps they would like it to be down there (reston VA/Wash DC area). That would also work as far as I am concerned
15:09:46 <VW> that might be a cool spot
15:09:58 <emccormick> I would do a snoopy dance if that happened
15:09:58 <mihalis68> (andrew is on the walmart openstack team for those who don't know him, he literally presented in a Walmart 'associates vest' in Boston IIRC)
15:10:04 <emccormick> MItry?
15:10:08 <mihalis68> yep
15:10:20 <emccormick> He also helped organize the Philly meetup when he was with Comcast
15:10:21 <mihalis68> the clue was given above
15:10:26 <emccormick> Didn't know he was getting involved :)
15:10:26 <mihalis68> that's right
15:10:42 <mihalis68> here's the clue from earlier "I was due to conference call with verizon and walmart (andrew mitry) last week about the possibility of a joint hosting offer"
15:10:44 <mihalis68> :)
15:10:59 <mihalis68> I was at the philly one, that seems like a long time ago
15:11:02 <emccormick> oh, I missed the "and wal-mart" the first time ;)
15:11:11 <mrhillsman> o/
15:11:19 <mihalis68> hey mrhillsman!
15:11:32 <emccormick> Hi Melvin!
15:11:56 <mihalis68> we are discussing meet up #2. I am due to conf. call with verizon and walmart later this week about it
15:12:02 <emccormick> ok, so good traction for meetup #2 in the Northeast.
15:12:10 <mihalis68> seems so
15:12:27 <VW> sweet
15:12:29 <emccormick> If it's here I can certainly help Andrew and crew with things.
15:12:38 <mihalis68> cool
15:12:57 <mrhillsman> got it, just read through backlog, great news
15:13:17 <mihalis68> I think for anyone outside of NE USA, DC area and NYC area are equally convenient, and for those of us here, the trip is fine
15:13:24 <mrhillsman> apologies for my tardinress
15:13:35 <mihalis68> no.. thanks for joining. I think this time slot is working better
15:13:44 <mihalis68> any more about meet up 2 for now?
15:13:56 <mihalis68> #topic ops guide wiki
15:14:05 <mihalis68> as mentioned I'll make a start updating it soon
15:14:39 <mihalis68> the other question that popped into my mind - do we need to coordinate with any openstack docs team? Now it's a community wiki is it just up to whoever wants to improve it?
15:15:00 <mihalis68> I guess that was the point? It was ejected from their formal process due to no input?
15:15:31 <smcginnis> They would probably be open to providing input, but I think for the most part, the docs team doesn't need to be involved in this one.
15:15:40 <mrhillsman> yeah, the issue was not enough folks providing feedback/fixes
15:16:00 <mrhillsman> more feedback than fixes, they were willing to make the corrections
15:16:02 <mihalis68> The guy who helped with the conversion asked me if any other dead documents should be wikified. For example he said the "architecture guide"? Maybe others?
15:16:36 <mrhillsman> yes, i believe the boston forum we discussed additional ones, i think the high availability one as well was on the list
15:17:06 <mrhillsman> maybe reach out to docs team on which ones are "dead"
15:17:22 <mrhillsman> some of them are no longer listed on docs.o.o i believe
15:17:34 <shintaro> Archi guide and HA guide is still alive I think.
15:17:37 <mihalis68> if you have links, please send them to me. If the conversion process is the same as for the OpsGuide, we could do that work too. I'm not setting up as a general document processing facility, but for this one-off process, it's kind of fiddly and we have it working (well, my contractor really)
15:17:44 <shintaro> #link https://docs.openstack.org/queens/
15:17:53 <emccormick> HA guide needs a complete redo
15:18:14 <emccormick> I think it even predates DVR, L3-HA and a bunch of other stuff. It's all pacemaker-oriented.
15:18:17 <mihalis68> TBH I've never read it
15:18:18 <mrhillsman> ok, they are there :)
15:18:43 <mihalis68> I think the other candidates were not officially dead, but perhaps looking like heading that way
15:18:56 <mrhillsman> ha guide folks have not had any meetings since last july
15:18:58 <mihalis68> (ops guide was pronounced dead by docs team)
15:19:02 <emccormick> zombie docs.
15:19:16 <mrhillsman> as an example to confirm your statement
15:20:04 <mihalis68> well, it's an offer, if the community sees docs that have fallen off the wagon of the official process but might live on as wiki content, and if they are in a similar technical state to the Operators Guide, then we could get that done
15:20:40 <emccormick> I definitely think we should bring it up with the docs team.
15:20:50 <emccormick> They are pretty clearly stale.
15:20:55 <mihalis68> does anyone here attend their regular meeting?
15:21:05 <mrhillsman> --
15:21:17 <mihalis68> I dropped in once but it was mostly about tools and a CI/CD system that I don't know anything about
15:21:46 <emccormick> Any PTG attendee want to pay them a visit next week?
15:21:48 <mihalis68> is that code for "i do" mrhillsman?
15:21:55 <mrhillsman> i don't lol
15:22:02 <mrhillsman> ++ < i do
15:22:33 <smcginnis> I would try to, but I already know I'm triple booked most of the time.
15:22:39 <mihalis68> well that segues into a topic I have for any other business
15:22:43 <mihalis68> #topic any other business
15:23:02 <VW> sorry - distracted
15:23:06 <VW> I'll be at the PTG emccormick
15:23:14 <VW> what do you need
15:23:23 <mrhillsman> well, uc elections are happening now, just a reminder, you and your constituents should have a ballot
15:23:28 <mihalis68> that topic would be good to mention to PTG attendees - any other official docs that need to be converted to wiki and released to the community
15:23:32 <mrhillsman> voting started yesterday
15:24:06 <mihalis68> and the other topic that affects us strongly and might be discussed at PTG is release cadence and LTS releases. Sean remind me is that on the agenda?
15:24:33 <smcginnis> Yes, I believe that will be discussed Monday.
15:24:49 <smcginnis> I will try to be there as much as possible and bring what I can to Tokyo.
15:24:58 <mihalis68> excellent
15:26:13 <emccormick> vw just talk to the docs team about whether the HA Guide and Architecture guide should go the way of the Ops guide.
15:26:53 <mihalis68> can you do that VW?
15:27:44 <mihalis68> I'd like to action him if he can
15:29:03 <mihalis68> in the meanwhile, does anyone know if the distro vendors will represent at the meeting on monday re: release cadence, lts etc?
15:29:21 <VW> yeah - I can do that
15:29:24 <mihalis68> cool
15:29:50 <mihalis68> #action VW to ask openstack docs folks whether OS Arch Guide and HA Guide documents should be wikified as per the operators guide
15:30:14 <VW> if so, I can try to bring that thumbs up/thumbs down back to ehre
15:30:34 <mihalis68> in Mexico we had both Redhat and Canonical representation and they definitely added their weight behind serious discussions of change in cadence and support for LTS releases
15:30:52 <mihalis68> however I am not sure as much was heard in the email thread from Thierry
15:31:21 <mihalis68> as much as I could follow that, it seemed to be "ugh, that's more work, and we have fewer people, it will never work" almost whatever it" was
15:32:02 <emccormick> The last takeaway from the forum was that people wanted and were willing to provide their own CI to maintain releases beyond EOL
15:32:17 <emccormick> to include RH / Canonical / Suse
15:32:27 <emccormick> and several large groups.
15:32:48 <emccormick> the change of release cadence seemed to go over like a lead balloon though
15:32:53 <mihalis68> that seems halfhearted to me, sorry
15:33:19 <VW> still think we are focused on the wrong problem.  We should be making the releases much less painful/more transparent to tenants
15:33:28 <emccormick> well, the main reasons for no foundation-led LTS were several.
15:34:14 <smcginnis> The main focus in the community now is making fast forward upgrade easier.
15:34:26 <smcginnis> I still think any kind of LTS needs to be a vendor led effort.
15:34:38 <emccormick> Lack of stable branch resources (both people and equipment), escalating broken dependencies were the big ones.
15:34:47 <mihalis68> yeah, the reason I mention redhat is they are the biggest contributor now I believe
15:35:01 <emccormick> Stable branch agreed not to delete Newton though
15:35:15 <emccormick> so even though it may not be supported, it's still going to be there.
15:35:31 <mihalis68> I missed that, that's good
15:35:34 <emccormick> so now we need to get to: Who's going to maintain it and how.
15:36:06 <emccormick> I agree it should be vendor led.
15:36:14 <emccormick> They are already doing it.
15:36:36 <emccormick> Lots of big companies carry their own patches though, and many of those could be pushed upstream.
15:36:44 <mihalis68> maybe they need to work together more - if a release is still available "upstream" they can just upstream a fix, so much easier
15:37:21 <mihalis68> emccormick are you going to PTG?
15:38:32 <mihalis68> for the record, VW, I don't think reducing friction in fast forward updates is all that's required, not at all
15:38:48 <mihalis68> but then I'm trapped behind the nova-network->neutron change
15:39:22 <emccormick> sadly no
15:39:31 <emccormick> I wish I was. I love Ireland.
15:39:41 <emccormick> Tokyo is taking all my money
15:40:19 <mihalis68> Well, I think that may be it this week. At least two of us will be in PTG next week, should we omit next week's meeting?
15:40:50 <VW> probably
15:41:00 <VW> but I'm happy to try and jump on if you have it
15:41:11 <VW> depending on where I am on Tuesday at this time
15:41:32 <emccormick> 5 straight openstack trips that are a minimum 6 hours flight from home and all international. $$$
15:41:34 <mihalis68> let's just leave it unspecified for now. I'll see if there's enough people for a real meeting. if not I'll call it early
15:41:36 <emccormick> woof
15:42:02 <emccormick> VW You'll be at a pub
15:42:02 <mihalis68> final call for comments this week, or we can give back almost 20 minutes to everyone
15:42:03 <emccormick> :D
15:42:18 <mihalis68> that's where the best openstack business happens AS YOU WELL KNOW
15:42:27 <emccormick> indeed
15:42:33 <mihalis68> #endmeeting