14:05:51 <mihalis68> #startmeeting ops-meetup-team
14:05:51 <openstack> Meeting started Tue Jun 19 14:05:51 2018 UTC and is due to finish in 60 minutes.  The chair is mihalis68. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:55 <openstack> The meeting name has been set to 'ops_meetup_team'
14:06:20 <smcginnis> Hey!
14:06:31 <mihalis68> agenda https://etherpad.openstack.org/p/ops-meetups-team
14:06:40 <mihalis68> please add your name to the attendees list if you're here for the meeting
14:06:44 <shintaro> o/
14:07:17 <mihalis68> #topic actions
14:07:32 <mihalis68> I was due to reawaken the debate about the way forward on docs
14:08:02 <mihalis68> for those who weren't in Vancouver or not in the session, there was strong support for a change of plan on the three docs that look most relevant to operators
14:08:10 <spotz> o/
14:08:13 <mihalis68> the docs are the operators Guide, the HA guide and Arch guide
14:08:33 <blake> o/
14:08:39 <mihalis68> the operators guide was converted to wiki with the intent that it would be community edited, however there's no enthusiasm for that approach it seems
14:09:03 <mihalis68> compared to reverting to the source code method of maintinaing it and simply moving it to a different repo where it can have new owners
14:09:32 <mihalis68> meanwhile the arch guide is also in a similar state of being due for removal from the core openstack doc set and arguably needing the same ownership change
14:09:44 <mihalis68> same for HA guide
14:09:52 <mihalis68> for HA guide there's even an offer to rewrite
14:10:20 <mihalis68> adam speirs IIRC
14:10:36 <mihalis68> I haven't done this action, but I'll try to get to that this week - on the mailing list
14:10:37 <spotz> If it's a matter of tooling, I'm willing to run the Git and Gerrit Lunch and Learn at the Ops Meetup
14:11:02 <mihalis68> yes I think the tooling is a concern for those who might like to jump in
14:11:43 <shintaro> that sounds great idea
14:11:48 <mihalis68> at least, it is a concern for me
14:11:55 <smcginnis> Adam seemed keen to get that rewritten, so he may just need a poke to get going on that.
14:12:24 <mihalis68> I think we need to show it will land somewhere welcoming. The mailing list thread faltered over the exact details of the plan
14:12:52 <smcginnis> If I remember right, there was some confusion about the scope of what this team would be taking on there.
14:13:05 <mihalis68> yes agreed
14:13:44 <mihalis68> I didn't understand some of the jargon in that thread about where the code should be kept and what the process should be
14:14:33 <smcginnis> Sorry, I think I was catching up on other things then. If we get that started again and there are any issues like that, just let me know and I can try to clarify things.
14:14:48 <mihalis68> #action mihalis68 to try to reawaken the ops docs thread on the operators mailing loist
14:14:58 <mihalis68> that assistance will be much appreciated smcginnis!
14:15:14 <spotz> And one last point I think was how the repo needed to be set up without agreements?
14:15:18 <mihalis68> any other actions from past meetings people care to  update us on. We have to use the honor system for actions these days
14:16:02 <jamesmcarthur> Total of 15 operators registrar
14:16:09 <jamesmcarthur> For ptg
14:16:32 <jamesmcarthur> Which is a little less than 10% of total
14:16:49 <smcginnis> jamesmcarthur: I forget, was there a registration option where they could identify themselves as that?
14:17:04 <mihalis68> There will most likely be two of us from Bloomberg and we're not registered. In fact I only just mentioned it to my boss
14:17:31 <jamesmcarthur> Yeah. Expecting late registrants
14:17:34 <mihalis68> seems like that's it for actions updates.
14:17:38 <mihalis68> #topic PTG
14:17:47 <mihalis68> #info 15 registered operators so far
14:17:59 <mihalis68> #info operators seem to always register fairly late on
14:18:22 <jamesmcarthur> S smcginnis  no. We are counting based on names of registrants
14:18:31 <jamesmcarthur> Sorry all. In my car.
14:19:03 <smcginnis> jamesmcarthur: I hope you're not driving and IRCing. :D
14:19:14 <shintaro> I should be one of those 15 :)
14:19:32 <spotz> If he's back in Austin he's sitting in traffic:)
14:20:17 <jamesmcarthur> In traffic. Trim g to type at lights
14:20:25 <smcginnis> Hah
14:20:35 <mihalis68> is there any concept of defined days for operators within the PTG?
14:21:20 <mihalis68> We're on the hook for a big release of our openstack product for a big infra project at my employer and that time (september 10-14th) is likely to be fraught
14:21:26 <spotz> I think the thought was to allow it to run as normal with the ability to have merged days?
14:21:57 <mihalis68> it was proposed as a co-located ops meetup, but I don't see any sign of that
14:22:28 <spotz> mihalis68: How would you like to see that impression fixed?
14:22:42 <smcginnis> Yeah, last I heard specific format was still being worked out dependent on attendance and space arrangements.
14:23:17 <spotz> I know I can do git and the folks who did the suse troubleshooting session at summit are willing to do it at the ops meetup if content is needed
14:23:19 <mihalis68> well I'm not sure I'm right, as i haven't really explored the PTG website, but if it's true, then a way forward would be to decide which days should be considered if you can do 2 days but not 5
14:23:20 <smcginnis> But I believe the plan (or at least hope) was to have a separate clearly identified Ops Meetup portion that would be there.
14:23:37 <smcginnis> mihalis68: ++
14:24:09 <mihalis68> I will try and be there for the entire thing, but it might be possible to send additional people from my team for specific ops meetups stuff whereas the full 5 days is a long time
14:24:23 <spotz> mihalis68: Ok so a big thing would be to pick dates, that makes sense so folks can get travel approval before buying tickets
14:24:34 <aprice> yes, that is still the plan and the team is trying to plan so that it doesnt overlap with other sessions that would benefit from operator participation. I think it's still a work in progress.
14:24:47 <mihalis68> ok, good to hear.
14:24:56 <smcginnis> Somewhere Wed-Fri?
14:25:22 <mihalis68> I was present for a discussion on this somewhere at the summit and there wasn't a clear consensus
14:25:36 <smcginnis> I think there was some talk of making it when the project teams are more silo'd so ops can attend some of the cross project on Mon-Tue if desired.
14:25:41 <spotz> mihalis68: yeah I think that was Mondayy I was there for that
14:25:43 <mihalis68> some said have ops and devs meetup separately then join together at the end to exchange findings
14:26:09 <smcginnis> Separate Wed-Thurs, join back up Friday?
14:26:24 <mihalis68> I like this for sure
14:26:25 <spotz> I think the one downside of wed-fri is folks leaving on Friday
14:26:35 <shintaro> smcginnis +1
14:27:04 <mihalis68> it also seems to be in line with the very original impetus for the "merger" in that days 1-2 are very appropriate for operators to join in, but days 3,4 less so (in the previous definition of PTG)
14:27:11 <smcginnis> That could work well. Mon-Tue for cross project things that could use operator input, Wed-Thur everyone goes to their corners, then Fri (if able to stay the whole time) get back for any kind of follow up activities and discussions.
14:28:00 <aprice> i can share this concept with our team as they are working on space planning and scheduling now
14:28:06 <spotz> aprice jamesmcarthur - would that work you think?
14:28:29 <aprice> we should be able to provide an update before the next meeting, but I dont want to say yay or nay until I have had a chance to talk to them since they're much closer to it
14:29:25 <shintaro> thank you aprice
14:29:34 <jamesmcarthur> Sorry. Finally stopped. Yeah there was a lot of debate at the forum whether Monday-Tuesday would be better or We’d-Thur
14:30:16 <jamesmcarthur> Some folks thought it would be best to meet early in the week so they could deliver operator opinions to the projects ahead of their meeting
14:30:49 <jamesmcarthur> Others thought it would be better to listen in to project goals and then discuss during operator meetings
14:31:18 <jamesmcarthur> We would love to hear a consensus from the Ops and then. We will do our best to try to make that happen
14:32:02 <mihalis68> sounds like a job for the meetups team :)
14:32:07 <smcginnis> :)
14:32:09 <mihalis68> what should we do? email threads don't really connect
14:32:16 <mihalis68> maybe email and a poll?
14:32:43 <mihalis68> (ok now I'm starting to recall prior discussion of a poll, maybe I was already supposed to be polling them about PTG)
14:32:55 <smcginnis> Or informal with the team here? Any preferences?
14:32:57 <spotz> Polls are good:)
14:33:32 <shintaro> mihalis68 that poll was meant to find out how many ops would attend ptg
14:33:33 <mihalis68> we don't even have all the meetups team here, so I hardly think we can decide - no Van Winkle, no Hillsman, no McCormick
14:33:43 <mihalis68> oh right, thanks for jogging my memory
14:34:00 <smcginnis> Yeah, we need input from the whole team.
14:34:00 <spotz> vw is finally back online and is catching up
14:34:27 <VW> oh hai!  sorry -was cleaning out the inbox and didn't see the tie
14:34:28 <VW> time
14:34:52 <mihalis68> we could expand it to "1. Are you interested in PTG  2. If so would you prefer ops focused days on days 1,2 or on days 3,4?"
14:35:02 <spotz> :)
14:35:06 <VW> love it
14:35:28 <spotz> mihalis68: Just make sure they understand PTG is also Ops Meetup?
14:35:28 <VW> actually, wait
14:36:02 <shintaro> 1. Are you interested in OpsMeetup at PTG? isn't it?
14:36:11 <mihalis68> we'd have to preview any survey to make sure both the wording and the overall message is proper
14:36:19 <VW> no no no. it's more do the want to attend the Ops meetup (TBD as days 1,2 or 3,4 above) or do they want to attend the PTG AND Ops mid-cycle
14:36:43 <mihalis68> the even in Denver is a done deal. It's both
14:36:48 <spotz> But don't we want them to pick days to?
14:36:59 <VW> argh -no - BOTH are there, but they are two events
14:37:10 <VW> it is perfectly fine for someone to come for just two days of ops
14:37:21 <VW> at least that is how I have understood it to date
14:37:41 <spotz> vw correct
14:38:17 <VW> but to an underlying point in mihalis68's comments, we need to understand if cost is an issue blocking people from even coming to at least that
14:38:20 <smcginnis> I think we do need to see which days work best for those that can't do the full week.
14:38:26 <mihalis68> the poll mentioned previously (and not yet done) was to ascertain ops community interest in the 5 days, in the 2 days
14:38:29 <VW> totally agree
14:38:39 <VW> awesome - that's a huge data point, mihalis68
14:38:50 <smcginnis> The ship has kind of sailed on whether they are interested in it being colocated.
14:39:21 <mihalis68> yes that's a done deal for September
14:40:11 <VW> yeah - I'm not saying we ask about co-location.  I'm curious if A. folks are coming and B. if they might do both and c. what blockers/misconceptions might be out there still
14:40:24 <mihalis68> https://www.irccloud.com/pastebin/xZWOcpvl/
14:40:56 <spotz> And I think add which days they would prefer as it sounds like we still might have the option to shift around
14:41:46 <smcginnis> spotz: ++
14:41:55 <mihalis68> hope people can see my snippet there, it covers that
14:42:04 <smcginnis> mihalis68: Yep, that looks good to me.
14:42:11 <jamesmca_> OK - just a heads up, the big thing is we're trying not to schedule Ops during Cross-Project discussions so Ops people that are there for the full time can attend those events.
14:42:27 <mihalis68> cross-project is mostly during days 1,2 right?
14:42:29 <spotz> #link https://www.irccloud.com/pastebin/xZWOcpvl/
14:42:36 <spotz> just to get that logged right
14:42:45 <mihalis68> thanks!
14:42:50 <jamesmca_> The schedule is not yet fully formed, so we're looking for an Ops preference on days, but none of the days are guaranteed until we see how that matches up with the rest of hte schedule.
14:43:13 <kendallwaters> most likely cross-projects stuff will be day 1 & 2 but that is not set in stone yet
14:43:22 <kendallwaters> we are doing a lot of schedule build and space allocation this week
14:43:27 <jamesmca_> That said, the sooner we can get the schedule together and communicate it to all the communities, the better it will be for folks planning travel.
14:43:31 <spotz> If I remember part of the talks in that one session was the need to have the first day atleast all ops to get things off their chest?
14:43:57 <spotz> In which case overlap on cross-project day wouldn't be awful
14:44:09 <mihalis68> this got summarised as the need to "vent" or something like that
14:44:20 <mihalis68> I no longer feel that as an operator I need to do that
14:44:24 <spotz> yeah, nicer way of wording:)
14:45:01 <spotz> I know things have come a long way since my first deployment
14:45:03 <mihalis68> I think many things that used to be an issue that ops felt they needed to raise are now conversations - long-term support, release cadence, deletion of docs "too soon" etc
14:45:24 <mihalis68> anyway, should I put a poll together as above?
14:45:56 <mihalis68> if someone really wants to do it, that'd be great, but if not I'm willing to
14:46:21 <spotz> mihalis68: I say go for it
14:46:34 <jamesmca_> I almost think it's best for this meetup group decided.
14:46:53 <jamesmca_> Most people just want to know when to book travel.
14:47:24 <jamesmca_> Personally, I think y'all would be best for Ops to plan Wed for venting, Thur-Fri for meetings. (or just Thursday)
14:47:45 <mihalis68> we don't even have half the meetups team here today, no way can this be "just decide"d
14:47:49 <jamesmca_> That would jive w/ cross-project work and would allow Ops in attendance to hit those days
14:48:08 <jamesmca_> (sorry - I'm having a terrible time typing today)
14:48:43 <spotz> jamesmca_: Just go get breakfast at Torchey's?:)
14:48:49 <jamesmca_> mihalis68: understood. I was thinking maybe a vote/discussion by email
14:48:57 <jamesmca_> spotz: that might be in order
14:49:02 <mihalis68> I'll put it to the community. If there's no response, the ops meetups team can certainly do its best to decide a good itinerary working with the foundation
14:49:17 <spotz> Just give it a deadline for responding
14:49:59 <mihalis68> yeah. I understand we can't delay on this but there was quite good backing for at least trying to get input on the PTG, from the ops community, last time this team met
14:50:48 <shintaro> +1 mihalis68 sending out the poll would raise awareness to the ops community about the event, too.
14:50:48 <mihalis68> and, again, I'm not planning an event to start with "venting". We didn't do that in tokyo or mexico city
14:51:50 <shintaro> I don't think we need "venting" either. we need specific topic to discuss which is more productive
14:51:50 <smcginnis> That might set the wrong tone. At least if it is positioned as that.
14:51:58 <smcginnis> shintaro: ++
14:52:54 <mihalis68> yeah. think we're good for now. I'll do a poll and we'll see if we can get a response. If not this team will work with foundation to try to make the ops part of PTG as good as possible. It's all we can do and as a first attempt we expect to learn adn improve for a followup
14:53:17 <mihalis68> only 7 mintes left, so if I may...
14:53:22 <mihalis68> #topic possible regional meetup
14:53:39 <mihalis68> i've been researching the possibility of using Bloomberg facilities for a smaller regional ops meetup, after PTG
14:53:51 <mihalis68> It may be possible for us to host something for NE USA
14:54:06 <mihalis68> it's not easy to arrange any random event due to strict guidelines
14:54:19 <mihalis68> however from my research, ops meetups fit entirely within them!
14:54:25 <spotz> sweet
14:54:30 <mihalis68> so I just wanted to mention this and see if there might be interest
14:54:42 <mihalis68> as a reminder, openstack days east stopped happening
14:54:46 <smcginnis> That might be great.
14:54:46 <mihalis68> that was our regional event for a bit
14:55:01 <mihalis68> I think the multi--purpose room is 70 people
14:55:15 <mihalis68> so it couldn't meet the guidelines for a global event where we expect 100-150 capacity
14:55:18 <smcginnis> Single room so one track?
14:55:31 <mihalis68> might be able to get a much smaller second room
14:55:52 <mihalis68> but only one full AV-wired "keynote" style room
14:56:08 <spotz> Or if done right depending on the setup you could put different subject in corners?
14:56:40 <mihalis68> yes, although I don't think we can reconfigure it to anything other than cinema style seating (everyone facing the screen)
14:56:51 <mihalis68> there are other more reconfigurable smaller rooms
14:57:16 <mihalis68> it all depends on : if there's interest I can look into it and if I book far enough ahead maybe even get our events staff to helpp
14:57:19 <mihalis68> *help
14:58:07 <mihalis68> if there's interest, speak up or email me or ... smoke signals
14:58:11 <mihalis68> #topic any other business
14:58:15 <mihalis68> 2 minutes left!
14:58:40 <aprice> mihalis68: would this meetup be between the ptg and the forum?
14:58:47 <aprice> and would it be for folks local to that city?
14:58:50 <mihalis68> unknown at present
14:59:02 <mihalis68> My tentative idea is a NE USA meetup
14:59:07 <aprice> we have gotten feedback on too many events / too much travel so I want to take that into consideration before asking ops folks to attend another event.
14:59:11 <mihalis68> there's people I know in DC area, for ecample
14:59:55 <mihalis68> DC->NYC is just a train ride, so it's not the super expensive globetrotting that following summits and Ops midcycles has been, at least not for people in the region
15:00:17 <mihalis68> the next ops meetup was going to be in NE USA before it merged into PTG and moved to Denver
15:01:20 <smcginnis> mnaser: If interested... ^
15:01:26 <spotz> Maybe check with the OpenStack Ambassadors, maybe do a combined meeting day?
15:01:29 <mihalis68> as mentioned above, I am saying upfront that it wouldn't be a global event
15:01:34 * mnaser reads buffer
15:01:37 <aprice> i understand, but I do want to encourage as many ops to attend the PTG and Forum if possible, but would love community feedback as well.
15:02:05 <smcginnis> I think a smaller regional event would be useful in that area. But knowing the PTG/Ops meetup is the "big event"/
15:02:25 <mihalis68> yep.
15:02:36 <mnaser> as an operator, traveling all the way out to just meet with other ops is expensive.  colocating it is very useful
15:02:41 <shintaro> agree. regional ops meetup works well for us
15:02:55 <mihalis68> out of time
15:02:57 <mihalis68> thanks everyone
15:03:06 <smcginnis> Thanks!
15:03:08 <mihalis68> #endmeeting