14:02:03 <mihalis68> #startmeeting ops-meetup-team
14:02:04 <openstack> Meeting started Tue Jul  3 14:02:03 2018 UTC and is due to finish in 60 minutes.  The chair is mihalis68. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:07 <openstack> The meeting name has been set to 'ops_meetup_team'
14:02:17 <mihalis68> I'm not sure if there's anyone here.
14:02:23 <mihalis68> ohai
14:02:25 <jamesmcarthur_> O/
14:02:34 <smcginnis> o/
14:03:08 <mihalis68> as some of you saw, I closed the poll, collected the results and posted them to the mailing list
14:03:19 <smcginnis> Interesting results too.
14:03:40 <mihalis68> those responding are interested in the event, in a 5-day stint, and having the ops events first so they can also join the dev teams
14:03:43 <mihalis68> by a strong majority
14:03:48 <smcginnis> Not surprising most said they planned to attend since those that don't plan on it are not likely to complete the survey.
14:03:53 <mihalis68> Sean is that a reasonable summary?
14:04:00 <smcginnis> mihalis68: Yeah, I think so.
14:04:18 <mihalis68> I agree that the respondents were self selecting
14:04:36 <mihalis68> I am also surprised that they want ops events first
14:04:50 <shintaro> hi
14:04:52 <smcginnis> Yeah, that leaned a different way than I expected too.
14:05:01 <jamesmcarthur> Thanks mihalis68 for organizing this!
14:05:08 <smcginnis> ++
14:05:32 <mihalis68> survey monkey worked well, but my idea of possibly paying for it was rapidly dropped. The non-free tiers are expensive!
14:05:43 <jamesmcarthur> I’ll work with kendallwaters today to get the schedule updated with the operators added to the schedule.
14:05:44 <mihalis68> I don't know if there's a fully free alternative
14:06:12 <mrhillsman> o/
14:06:13 <mihalis68> if anyone would like to see the output, I captured it as a pdf but I felt that sharing that to the internet might be considered copyright infringement, not sure
14:06:18 <mihalis68> I can email it to anyone though
14:06:23 <smcginnis> I think infra might have actually been toying with hosting our own survey platform.
14:06:27 <jamesmcarthur> Survey Monkey is losing a lot of business too because they aren’t GRDP compliant
14:06:50 <mihalis68> One ops meetups location question was resolved with a doodle poll
14:07:10 <mihalis68> surveys.openstack.org feels like it would be a good thing to exist, but then again I try not to invent work for other people
14:07:53 <mihalis68> closing that and sharing results was one action I had
14:08:10 <mihalis68> another one was picking up the thread about the 3 docs that operators are looking to pick up
14:08:33 <mihalis68> Sean actually helped out in a big way there. I need to get my gerrit creds so I can start poking about there
14:08:44 <mihalis68> thanks for that sean!
14:08:57 <mihalis68> oh yeah...
14:09:00 <mihalis68> #topic actions
14:09:01 <smcginnis> No problem! If someone wants to take a look:
14:09:11 <smcginnis> https://review.openstack.org/578946
14:09:13 <mihalis68> mihalis68 to close the poll and share the results - complete
14:09:23 <mihalis68> mihalis68 to pick up the docs thread - in progress
14:09:47 <mihalis68> anyone else wish to report on actions (we use an honor scheme now, nobody will chase you for your actions)
14:10:12 <mihalis68> #link https://etherpad.openstack.org/p/ops-meetups-team
14:10:17 <mihalis68> today's agenda as always
14:10:25 <mihalis68> pretty skimpy today (I blame this heat)
14:10:32 <mihalis68> ok. Moving on
14:10:38 <mihalis68> #topic PTG
14:11:01 <mihalis68> I think we've answered the questions that the foundation had about the ops part. Is that correct Jimmy?
14:11:40 <mihalis68> There was brief discussion about facilities, but they amount to : one large room with a screen and capability for laptop hookup, good wifi, seats, power
14:11:42 <mihalis68> that's about it
14:11:47 <jamesmcarthur> Yes sir
14:12:06 <smcginnis> And semi-secluded hallway with round tables for side conversations.
14:12:19 <mihalis68> yes, good point
14:12:43 <mihalis68> the next thing I think the ops meetups team needs to tackle, then, is the technical agenda
14:13:14 <mihalis68> the challenge will be that "our" days are also the cross-team parts of traditional (non-ops-focused) PTG
14:13:52 <mihalis68> I'll be honest, I don't have a feel for how this works right now
14:14:34 <mihalis68> I think we did establish last week that we'll view this one as a single track, 2-day event
14:14:36 <smcginnis> I guess we can start by collecting and brainstorming topics.
14:14:38 <mrhillsman> i would not think of previous ptg sessions on the first two days as non-ops-focused or even dev-focused as they are just whatever you want focused
14:15:27 <mrhillsman> that being said, there are ops focused sessions that need to be had in the tradition of the ops meetup
14:15:37 <mihalis68> I wasn't saying that. I was just saying previous PTGs weren't ops-inclusive
14:15:45 <smcginnis> How the ptg has worked with the development team side so far as there is a list of topics and maybe an preliminary order that the topics would be discussed in, but no specific scheduled times for the topics.
14:16:02 <smcginnis> That allowed longer discussions to keep going and shorter ones not to waste time.
14:16:25 <smcginnis> And new topics that pop up during those discussions to get included in where it makes sense.
14:16:34 <mihalis68> is that how days 1 and 2 worked?
14:16:43 <mihalis68> not having been to one, this is new to me
14:16:52 <mrhillsman> are there any sessions based on past ops meetups that are for sure shoo-ins?
14:17:09 <smcginnis> To keep everyone informed what is currently being discussed there is an IRC PTGBot that takes commands and updates a web page that people can reference to see where they should be.
14:17:10 <mrhillsman> or must haves anyone can think of?
14:17:33 <emccormick> o/
14:17:38 <mihalis68> I can say that long-term support, upgrades and docs were popular
14:17:45 <mrhillsman> i think there will be some explaining to be done rather than just putting out there on the list as before, here's an etherpad, drop session ideas
14:17:47 <smcginnis> So the ops team could also use that, and also check there if there are any other cross-project subjects that we may want to break for to be able to run over and sit in on
14:17:52 <mihalis68> and then many incarnations of containerisation
14:18:29 <mihalis68> hi emccormick
14:18:56 <emccormick> hiya. Apologies for the tardiness.
14:18:58 <mihalis68> in case you didn't see, the poll is closed and ops prefer to have ops sessions in days 1 and 2 and then be able to attend dev team sessions
14:19:30 <emccormick> I saw that. Can't say I agree with it, but I saw it ;)
14:19:47 <mihalis68> I can think of two extremes here. One we "dissolve" the ops meetup into the establish community planning process for days 1 and 2
14:20:26 <mihalis68> the other we plan an ops silo as if people will attend that all day 1 and day 2 and not go to the other events
14:21:07 <emccormick> That's why I thought it better to have the ops "silo" later in the week
14:21:15 <mihalis68> I think I'd like to understand how planning for those days has been done - maybe take a look at PTGBot
14:21:17 <mrhillsman> from my understanding of the ptg, sounds like we have one dedicated room, the large one, and there should be sessions, two days worth, of hey, we want to def have these as an ops community
14:21:49 <mrhillsman> then in keeping with the way the ptg operates there's opportunity to schedule available space for something
14:23:43 <mihalis68> here's my concern. If we completely ignore other stuff going on during those days, we may create a lot of work for ourselves trying to make a comprehensive "ops meetup" event for that room, and then a lot of the operators will be torn between that and all the other stuff such as SIGs
14:23:44 <mrhillsman> like, oh, these 12 folks of various day-jobs (op, dev, pm, etc) want to further talk about or spark new conversation about x
14:23:52 <emccormick> So the short of it is, we still need to go through our normal collection, review, and scheduling process
14:24:04 <emccormick> for the big room
14:24:17 <emccormick> and then the "parlor" or whatever it was called is for those types
14:24:27 <emccormick> the ad-hoc PTGbot things
14:24:40 <jamesmca_> emccormick: it's basically just a small room that holds 30 people
14:24:56 <jamesmca_> So there is a 100pax and a 30pax room.
14:24:56 <emccormick> *nod*
14:25:36 <mrhillsman> so, what i mean is like, that big room is open for all right, but there are some sessions that def should be had to speak to the keeping the ops meetup
14:26:04 <jamesmca_> That big room is specifically reserved for Ops
14:26:08 <mrhillsman> we've hashed that out quite a bit over the past months
14:26:09 <jamesmca_> For as long as you all want it
14:26:22 <jamesmca_> Both rooms, actually
14:26:41 <mihalis68> the 100 and 30 the are both earmarked for ops?
14:26:44 <mrhillsman> sorry, i mean for all sessions that we get from ops community
14:26:47 <jamesmca_> Yes sir.
14:26:49 <mrhillsman> yep
14:27:24 <mihalis68> how is the planning done for the rest of PTG on days 1 and 2? Is there a doc I can read?
14:27:32 <jamesmca_> mihalis68: if you all decide you'd like to extend to all or part of another day, just let us know and we'll reserve it.  But the 2 days specifically are reserved just for Ops
14:27:56 <jamesmca_> mihalis68: one sec, i'll send it
14:28:14 <mrhillsman> the 2 spaces for the 2 days are specifically reserved for ops is what you mean yes?
14:28:24 <mihalis68> yes
14:28:25 <jamesmca_> mrhillsman: yes, correct
14:29:18 <jamesmca_> mhalis68: http://lists.openstack.org/pipermail/openstack-operators/attachments/20180628/bb5c0e18/attachment-0001.png
14:29:42 <jamesmca_> The schedule itself is pretty fluid and project dependent.
14:30:05 <jamesmca_> Some projects set out bullet points to cover each day, or each part of the day.  Others keep a very tight schedule.
14:30:22 <jamesmca_> For the case of Ops, you can organize however best suits your needs
14:31:10 <jamesmca_> I would check out some of the etherpads developing for the projects
14:31:31 <mihalis68> yeah, we know how to organise a 2 day event in isolation. What I'm struggling with is how to make that mesh with other things happening on the same days at the same location (if in different rooms)
14:32:09 <mihalis68> for example, just to make something up. If we did a ceph session for ops, and then there was a ceph sessions for other PTG attendees, should they merge?
14:32:33 <mihalis68> I'm with emccormick in that this is not how I expected the community to vote
14:33:50 <smcginnis> That's really the reason for the ptgbot. To find out if there are other sessions going on that are of interest.
14:34:35 <emccormick> Also, given the placement of the upgrade sig in that diagram, and given that that is the biggest operator pain point, it'd be kind of silly to overlap the meetup with that
14:34:38 <mihalis68> Thanks for the picture, jamesmca
14:34:50 <emccormick> That could be the #1 most productive room in the whole week
14:35:15 <mihalis68> I feel like people who plan to help plan the ops meetup need to cogitate on the structure already shown and work out a way forward
14:35:30 <emccormick> We may just need to benevolently dictate on that one ;)
14:35:33 <mihalis68> I don't suppose there's anyone here who wishes to be the benevolent dictator for our part of this event? :)
14:36:01 <emccormick> I nominate Chris!
14:36:04 <emccormick> :D
14:36:05 <smcginnis> :)
14:36:10 <mihalis68> I'm not sure I should take that role this time. We are going to be extraordinarily busy between now and then
14:36:47 <spotz> shoot I'm late!!!!
14:37:19 <emccormick> I've had a lot of trouble making meetings lately. Not sure I"m the best choice either. I'm happy to herd the cats as much as I can though.
14:37:27 <emccormick> Hi spotz!
14:37:35 <smcginnis> So we all agree spotz is in charge of that? :)
14:37:49 <emccormick> +1
14:39:03 <mihalis68> we can try team-work for now. As it gets nearer, though, my experience is someone needs to take ownership
14:39:11 <mihalis68> we can see how it goes for now
14:39:27 <spotz> I can definitely help but time is always a limit for me:(
14:39:31 <smcginnis> Yeah, let's start with topic brainstorming. Then we can figure out scheduling once we get a little closer and have topics.
14:39:45 <mihalis68> agreed
14:39:57 <mihalis68> I think we start with a simple etherpad for that right?
14:40:09 <smcginnis> I think that works well.
14:40:11 <spotz> One comment after reading the scroll back though, I think ops wants the silo as that's how life generally is in companies and they want to have something of their own and not be swollowed by dev
14:40:12 <mihalis68> and then we implore the list to add more and/or +1 existing entries
14:40:49 <mihalis68> yes I think we'll start by assuming a completely silo'd day, but then tactically merge just individual sessions when they truly are ops-critical
14:40:54 <mihalis68> such as upgrades
14:41:08 <mihalis68> if I'm summarising erik's point correctly?
14:41:27 <mihalis68> and hey maybe the way the merge works is inviting the devs into our romper room?
14:42:08 <mihalis68> I've got it! Arrange the room like a battlefield, one side ops, one side devs. Have stirring debate AND NERF GUN WAR!
14:42:18 <jamesmca_> +1
14:42:21 <mihalis68> just kidding on that!
14:42:42 <spotz> +1, and I definitely think we need to encourage forse folks to get together at least 1 night
14:42:57 <mihalis68> yep
14:43:18 <mihalis68> so we need the benevolent dictator AND a social secretary. Got it
14:43:21 <spotz> And mixed teams for a nerf war actually isn't a bad idea...
14:44:00 <spotz> But yes both wouldn't be a bad idea
14:44:44 <mihalis68> dev teams turn up with an incredibly complicated high tech nerf gun. It works for 2 minutes and is then obsolete. ops try to keep it working for another 9 years
14:45:03 <mihalis68> again just kidding folks. I think I'm high on pollution, pollen and the heat
14:45:06 <emccormick> duct tape ftw
14:45:39 <mihalis68> I'll volunteer to make the etherpad and seed it with the obvious stuff
14:45:55 <mihalis68> #action mihalis68 to kick off the topic selection etherpad for the PTG ops days
14:46:10 <mihalis68> I will share on the operators list and to the regular attendees here directly
14:47:12 <mihalis68> Erik do you want to take on a first pass to identify possible session-merge ideas?
14:47:49 <mihalis68> one question for I guess jamesmca : what's the commute like from the ops rooms to the other rooms?
14:48:06 <mihalis68> would we need to allow any travel time?
14:48:37 <smcginnis> Depending where the other session is, could take a few minutes from what I remember of this venue.
14:48:48 <emccormick> session merge ideas as in combined ops / dev sessions?
14:48:51 <mihalis68> ok good to know
14:49:01 <mihalis68> yeah, you already said we should join the upgrade one
14:49:23 <mihalis68> upgrade sig, to be exact
14:49:28 <emccormick> I can give it a go
14:49:33 <mihalis68> cool
14:49:54 <mihalis68> #action emccormick to look for possible session-merge candidates, such as upgrade sig
14:50:11 <mihalis68> I don't have anything for the other agenda topics
14:50:33 <spotz> smcginnis: Do you remember how close rooms were? Cause I don't think they're gonna really put OPS far away to segregate
14:50:58 <smcginnis> spotz: From the map, this is on the far side of the hotel.
14:51:20 <smcginnis> The hotels not that big, so that's fine, but still a little walk between this and the rest of the sessions.
14:51:23 <spotz> bah, so at most a 5 minute walk
14:51:31 <smcginnis> Yeah, probably.
14:51:56 <mihalis68> I just want to not make the mistake of having ops join a non-exclusively-ops session but all barging in 7 minutes after it gets going
14:52:25 <mihalis68> 8 minutes left
14:52:26 <smcginnis> Fashionably late.
14:53:10 <emccormick> I think once the PTG etherpads start to coalesce it will present specific opportunities for us to pop in as well.
14:53:12 <spotz> Well we can plan on our sessions ending a few minutes early, won't mean folks won't be late to ours but that would allow a walking buffer to the others?
14:53:29 <emccormick> often times I see them broken down into subtopics with a time attached to them within the etherpad
14:53:30 <jamesmca_> The rooms are still really close. I wouldn't think more than a couple of minutes
14:53:51 <jamesmca_> That hotel is pretty small unless you have to go from first to third floor
14:53:54 <mihalis68> I'm partially thinking of Vancouver Convention Center which is big enough to have long commutes in same building
14:53:54 <emccormick> so there may be some of those sections to be cherry-picked as ops-friendly
14:54:17 <jamesmca_> It is no Vancouver Convention Center
14:54:33 <mihalis68> yeah, I said that as in I may be seeing problems that aren't real
14:55:14 <mihalis68> so we'll get a topic etherpad going and look for what other sessions we might join, so meet again next week same time slot?
14:55:51 <smcginnis> Nice cozy hotel for sure.
14:56:02 <mihalis68> is it going to snow us in?
14:56:05 <mihalis68> I DO HOPE SO
14:56:22 <smcginnis> :)
14:56:25 <spotz> I'd like snow....
14:56:35 <spotz> jamesmca_: Make that happen!
14:56:37 <smcginnis> It's kind of like it was in Dublin, just without the actual trapped part.
14:56:51 <emccormick> IF I see it coming, I may or may not head for the nearest ski resort
14:57:15 <mihalis68> ok I will assume meeting next week and do outlook invites again
14:57:21 <mihalis68> in the meanwhile 3 minutes left
14:57:23 <emccormick> they always have a competition out there to see who can get open first.
14:57:27 <mihalis68> #topic any other business
14:58:06 <smcginnis> No more topics from me.
14:58:16 <mihalis68> ok then. Thanks everyone. Good meeting
14:58:24 <spotz> Sorry I was late!
14:58:25 <mihalis68> #endmeeting