14:05:50 <mihalis68_> #startmeeting ops-meetup-team
14:05:51 <openstack> Meeting started Tue Aug 28 14:05:50 2018 UTC and is due to finish in 60 minutes.  The chair is mihalis68_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:55 <openstack> The meeting name has been set to 'ops_meetup_team'
14:06:12 <mihalis68_> how is everyone
14:06:34 <shintaro> o/
14:07:04 <mihalis68_> I think there's really only one topic, which is pulling together the technical agenda for the PTG
14:07:26 <smcginnis> Last I looked at the planning etherpad, we were getting a good list of topics at least.
14:07:36 <shintaro> I see 12 proposals
14:07:44 <smcginnis> #link https://etherpad.openstack.org/p/ops-meetup-ptg-denver-2018
14:09:29 <mihalis68_> also #link https://etherpad.openstack.org/p/ops-meetups-team
14:10:24 <mihalis68_> I'm hopelessly backlogged due to vacation and then production emergencies. I'm really pleased to see all this progress. What we need now, I would suggest, is a volunteer to map the proposals to slots
14:11:25 <mihalis68_> well volunteered, Erik
14:11:31 <mihalis68_> ok just kidding, he's not here
14:11:38 <smcginnis> I would volunteer, but until we get the rocky release out and I catch up on some other things, I'm a little backlogged too.
14:12:12 <mihalis68_> Ok I can have a go at this, but I would need people to give some feedback. If some names are put forward for that bit, I'll try to pull together the agenda and I would say we should review before this time next week
14:12:33 <mihalis68_> anyone object?
14:12:52 <mihalis68_> alright #action mihalis68 to convert the planning etherpad into a proposed agenda
14:13:13 <smcginnis> +1
14:13:19 <mihalis68_> attendees here today please add your name to the team etherpad (second link above)
14:13:28 <shintaro> #link https://docs.google.com/spreadsheets/d/1EUSYMs3GfglnD8yfFaAXWhLe0F5y9hCUKqCYe0Vp1oA/edit#gid=102346086
14:13:55 <shintaro> past planning spreadsheets are here if you like to use it.
14:13:57 <smcginnis> shintaro: Oh right, I forgot about that.
14:14:01 <mihalis68_> Thanks Shintaro. I'll start there
14:14:18 <mihalis68_> how would we gather to review? Here? email?
14:15:03 <mihalis68_> hey emccormickva!
14:15:08 <smcginnis> mihalis68_: Maybe ops mailing list, then try to finalize here next week?
14:15:27 <mihalis68_> yeah, that works for me
14:15:47 <mihalis68_> at least email doesn't tell me I'm wrong every week and force me to fiddle with nicknames
14:15:47 <emccormick> o/
14:15:58 <emccormick> sorry, having a war with IRC this morning :(
14:16:05 <mihalis68_> me too, me too
14:16:34 <emccormick> wonder why it thought I was still logged on when my client had been closed for days :P
14:16:38 <mihalis68_> so summarising what you missed, I'm going to try and put up a *proposed* agenda on the google docs sheet and then get people's feedback via operators mailing list
14:16:56 <emccormick> super
14:17:02 <mihalis68_> (note to self, maybe should book travel and accomodation to denver also :|
14:17:19 <mihalis68_> we are sending just two people and the other guy already booked!
14:17:23 <emccormick> just bought my plane ticket yesterday. Last piece of the puzzle complete
14:17:38 <mihalis68_> I mean already in the sense that I've had weeks and he had a day
14:17:48 <emccormick> slacker
14:18:07 <mihalis68_> totally
14:18:23 <mihalis68_> I don't see any foundation folks here, so I guess we can't check on numbers etc
14:18:31 <emccormick> I need to put it in the etherpad still, but I asked the Kayobe PTL to come talk to us.
14:18:42 <emccormick> Needs to be Tuesday sometime
14:19:04 <emccormick> Thought it'd be a good chance for him to get some feedback and people to ask him why his project is necessary ;)
14:19:31 <emccormick> it's a new deployment project that bolts on to Kolla.
14:19:40 <smcginnis> In case anyone else had to look that up like me - https://kayobe.readthedocs.io/en/latest/
14:19:41 <emccormick> My first question is: Why isn't it part of Kolla
14:19:42 <emccormick> :)
14:19:53 <mihalis68_> I had to look it up, and I'm not ashamed to admit it!
14:20:02 <emccormick> I did as well
14:20:10 <mihalis68_> seems like a really good topic for Denver, emccormick!
14:20:15 <emccormick> but it looks interesting. I thought maybe others would like to know also
14:20:24 <emccormick> He clearly needs some PR
14:20:27 <mihalis68_> We're still not containerised *hangs head in shame*
14:20:41 <mihalis68_> what else should we discuss for Denver?
14:21:07 <mihalis68_> make Kayobe the "keynote" for Tuesday?
14:21:17 <emccormick> Other than agenda, I think Denver is pretty well good to go
14:21:21 <mihalis68_> i.e. fun first substantive session?
14:21:29 <emccormick> Yeah sounds like a good plan.
14:21:34 <mihalis68_> is there a plan for ops related monday night social?
14:21:46 <emccormick> I told him he didn't have to get fancy with it or anything. Just an overview and Q&A
14:21:53 <mihalis68_> sorry I'm so out of the loop, driving up mountains last week
14:22:17 <emccormick> There is desire for it, but no plan. I have a request out to a friend for local suggestions.
14:22:32 <mihalis68_> Could you be point person for that then?
14:22:37 <emccormick> Since we have no sponsor, it'll probably be an organic formation that day
14:22:43 <emccormick> yeah ok
14:22:49 <mihalis68_> and again I would say coordinate that via operators mailing list
14:22:50 <mihalis68_> ok cool
14:22:53 <shintaro> some proposals on the etherpad already.
14:23:06 <mihalis68_> #action emccormick to pull together ideas for monday night ops related social in Denver
14:24:25 <mihalis68_> the other topic I had in mind was the operators-related openstack docs
14:24:29 <mihalis68_> #topic operators docs
14:25:08 <mihalis68_> smcginnis I see we had a patch proposed for the operators guide, and then lots of +1s, then he abandoned it, and now questions about having to sign something?
14:25:19 <mihalis68_> Can you comment on whether that process is working? I am confused.
14:25:27 <mihalis68_> I managed to get to the point of +1ing the change
14:25:31 <smcginnis> mihalis68_: We had a few patches go through. I didn't look at that abandoned one.
14:25:42 <smcginnis> mihalis68_: I think you should be able to +2 and approve as well.
14:25:48 <mihalis68_> is it the low-drag process we hoped for?
14:26:11 <smcginnis> There was the question on the ML about whether contributors needed to sign the Contributor License Agreement and it was confirmed they do not for this repo.
14:26:17 <smcginnis> Which I think is good.
14:27:07 <mihalis68_> I guess I'll watch it and learn more about how it works
14:27:31 <mihalis68_> It's still on my mind that we were considering pulling the HA guide into this process and encouraging Adam Speirs(?) to do the rewrite he offered
14:27:34 <emccormick> spotz has agreed to help with getting people set up in Denver
14:27:38 <mihalis68_> maybe it was speith?
14:27:42 <emccormick> definitely going to avail myself of that
14:27:48 <mihalis68_> me too
14:28:37 <smcginnis> mihalis68_: Adam Speirs (sp?) I believe.
14:28:48 <smcginnis> Not in this channel at any rate.
14:29:42 <mihalis68_> I'm sure I had his name in prior meeting logs from these meetings
14:29:47 <shintaro> Hes Adam Spiers (aspires(
14:30:04 <mihalis68_> I'm going to try and work on the document we have in this pipeline first to understand it better before contacting Adam
14:30:08 <mihalis68_> Thanks shintaro
14:30:09 <shintaro> aspieres
14:30:12 <shintaro> no
14:30:20 <shintaro> aspiers
14:31:30 <mrhillsman> Does mihalis68_ not have +2 for the docs repo?
14:31:54 <mihalis68_> I'm told I do. I thought it would be really presumptuous to +2 something as my first action
14:31:55 <mrhillsman> Sorry catching up
14:32:01 <mihalis68_> welcome back!
14:32:25 <mihalis68_> I did +1 a patch and I think that worked.
14:32:32 <mrhillsman> Not at all :) especially since you're probably most familiar with how it is setup
14:32:35 <mrhillsman> thx
14:32:53 <mihalis68_> oh other people did all the work (smcginnis in particular)
14:33:15 <smcginnis> mihalis68_: If you want to +2 but not approve, you can just ping me if you think something is ready to be approved for now until you're more comfortable.
14:33:24 <mihalis68_> that's a good idea
14:33:25 <mihalis68_> thanks!
14:33:39 <smcginnis> Good to have real operator experience since I only play one on TV.
14:33:45 <mihalis68_> ok I sense there's not much more to be had from this meeting
14:33:49 <mihalis68_> so #topic any other business
14:34:13 <mihalis68_> oh yes early-bird pricing on Berlin expires soon
14:34:21 <emccormick> We shouldn't need it
14:34:36 <emccormick> though I'm not sure how we go about registering for Berlin with our PTG pass?
14:34:58 <smcginnis> After the PTG you will get a code to allow free registration.
14:35:26 <shintaro> +1
14:35:28 <smcginnis> It's a little confusing with bad timing since they send out these emails saying "register now!" but really if you are going to the PTG you should wait.
14:35:58 <mihalis68_> this is really good info!
14:36:17 <mihalis68_> Ill probably try to make Berlin, can't say for sure
14:36:40 <mihalis68_> I've gone from never travelling on business to like 5-6 times/year. Wife not thrilled
14:37:04 <spotz> sorry I'm late
14:37:04 <smcginnis> I know how that goes.
14:37:16 <mihalis68_> hi there
14:37:23 <mihalis68_> how are PTG numbers?
14:37:27 <smcginnis> emccormick did you want to pair up with spotz and PTG outing?
14:38:09 <emccormick> sure!
14:38:44 <emccormick> mihalis68_ bring wifey to Berlin with you :)
14:38:54 <mrhillsman> ++
14:38:57 <emccormick> Christmas markets might even be started by then
14:39:15 <mihalis68_> I think we're done here, work moves to mailing list for immediacy over the next week and hopefully in one weeks time we'll be able to confirm the agenda and tell everyone where the beer... I mean social event will be
14:39:38 <emccormick> I put the Kayobe thing on the etherpad
14:39:44 <mihalis68_> great, thanks!
14:39:50 <spotz> I'm still trying to get confirmation from SUSE on whether they can do the troubleshooting session. We have a deadline to know by?
14:40:19 <emccormick> spotz: we can always shuffle at the last minute
14:40:22 <mihalis68_> well we can only do one more IRC meeting before being in Denver, so it would be nice at least to know by this time next week
14:40:43 <spotz> Ok I'll poke again
14:41:09 <emccormick> I guess we need to determine how the agenda is getting printed, or if it is at all.
14:41:32 <emccormick> Maybe the google doc is sufficient and more fluid
14:41:36 <spotz> If anyone'll be at Open Source Summit this week be happy totouch base on anything
14:41:44 <smcginnis> We could just put the agenda up on the screen at the start of the event and during breaks. That could allow us to be a little flexible if we need to shift things around.
14:41:46 <spotz> emccormick: etherpad:)
14:41:47 <mihalis68_> previously it was nicely designed and printed, that's a good point
14:41:53 <emccormick> *nod*
14:41:57 <mihalis68_> however that process was ... painful
14:42:19 <mihalis68_> almost by definition the deadline for going to print is before when you know that all sessions really are going to happen
14:42:27 <mihalis68_> (it was painful for the NYC one)
14:42:29 <emccormick> spotz or etherpad ;)
14:42:41 <emccormick> agreed
14:42:45 <emccormick> keep it electronic then
14:42:51 <mihalis68_> works for me
14:43:11 <smcginnis> With past PTG sessions, it's worked well to have a rough agenda and just work our way through the topics. Then if something only ends up taking 10 minutes, we can take a break and move on. And if something ends up being a bigger discussion than planned we are flexible enough to not have to kill a productive conversation.
14:43:18 <mihalis68_> we can at least break it out from the google doc when it's close to done. At least for me, google docs access is difficult
14:43:42 <mihalis68_> (blocked entirely on my employers network)
14:43:58 <mihalis68_> smcginnis I like that
14:44:10 <spotz> I know some countries have trouble with google
14:44:18 <mihalis68_> this again moves towards working sessions, not presentations
14:44:25 <emccormick> keeps from having a moderator standing up there talking to a dead room for 40 minutes also ;)
14:44:38 <mihalis68_> although that would never happen, right? RIGHT?
14:44:42 <smcginnis> :)
14:45:11 <emccormick> no never
14:46:07 <mihalis68_> #agreed ops meetup agenda for PTG will be a) electronic b) more flexible
14:46:24 <smcginnis> Worth a shot to see how it goes.
14:46:42 <shintaro> +1
14:46:49 <emccormick> +1
14:46:50 <emccormick> :)
14:46:58 <mihalis68_> oh ... darnit... just realised we're going to have to round up moderators for all these sessions and that's even harder than putting together a topic list on the sheet
14:47:11 <spotz> heheh
14:47:15 <smcginnis> Another plea to the ML?
14:47:36 <emccormick> yeah. There's a few volunteers on there at least
14:47:36 <mihalis68_> yes, I think with a link to the rough draft agenda
14:48:03 <mihalis68_> containers: erik
14:48:03 <mihalis68_> ffwd upgrades: erik
14:48:03 <mihalis68_> docs: erik
14:48:09 <mihalis68_> I'm getting the hang of it already
14:48:25 <emccormick> *snort*
14:48:55 <emccormick> Simon volunteered for containers. One less for me. Wheeee!
14:49:00 <mihalis68_> excellent
14:49:15 <mihalis68_> alright, any more business?
14:49:31 <emccormick> fyi my intent is to just go down the hall monday afternoon for upgrades
14:49:53 <emccormick> I see no reason we shouldn't just do that as a group since it's always the hot topic of the meetups
14:50:18 <emccormick> if you think it's a terrible idea just say so, but I think that'd be most productive all around.
14:50:30 <spotz> I think some of the projects like OSA might like to meet with OPs folks
14:51:39 <emccormick> I think some of those were after our meetup is done?
14:51:49 <emccormick> lost the damn schedule again.
14:52:05 <mihalis68_> I can tell this is going to be like 9-D chess
14:52:17 <spotz> emccormick: Yeah but if we don't have a full agenda, offering to meet with the deployment projects might not be a bad idea
14:52:20 <emccormick> oh yeah
14:52:26 <mihalis68_> two events side by side, related communities, variable length sessions
14:52:37 <emccormick> spotz yes I'm all for it
14:53:11 <emccormick> we're going to need so run the agenda through CI
14:53:36 <emccormick> ok, Chris do the draft
14:53:42 <mihalis68_> there's a tension here. A single track can compress some sessions and lengthen others
14:53:46 <emccormick> we'll see what it looks like and massage as needed
14:53:55 <mihalis68_> but a multi-track event can't allow that, or nobody will be able to switch tracks
14:54:18 <emccormick> well, we can pull some folks in to our track
14:54:28 <emccormick> and in the case of upgrades we'll take our track to them
14:54:32 <mihalis68_> you wont be able to say "after ceph I'm going to designate" if ceph can run long and maybe overlap the other
14:54:38 <emccormick> otherwise it'll be things after the meetup
14:55:03 <spotz> Well we could time our sessions to the same lengths as PTG
14:55:27 <emccormick> we definitely should sync it as much as possible
14:55:32 <emccormick> it's like half day blocks though, right?
14:55:45 <mihalis68_> yeah, but sean was saying we can cut some sessions down in length if they're not working. That flexibility has a cost if nobody can actually know when later sessions will start
14:55:51 <smcginnis> The PTGbot helps with tracking cross-track things.
14:56:21 <emccormick> mihalis68_ The flexibility is within a large block
14:56:25 <smcginnis> Since most of them don't have set time blocks, there's a bot in the #openstack-ptg channel that folks can state their current topics and what they plan to talk about next.
14:56:36 <smcginnis> The bot takes care of updating that on the PTG web page.
14:56:55 <smcginnis> There's still some old data from the last PTG - http://ptg.openstack.org/ptg.html
14:57:08 <emccormick> where is that web page btw?
14:57:32 <shintaro> cool
14:57:35 <mihalis68_> maybe we should think about going "full PTG"? (you never go full ptg!)
14:58:01 <mihalis68_> i.e. throw away the rigid scheduling style of previous independent ops meetups
14:58:22 <mihalis68_> (although... I've never done PTG nor used PTGbot and there will be lots like me)
14:58:28 <emccormick> mihalis68_ Let's at least do a draft the old way
14:58:38 <mihalis68_> ok
14:58:39 <emccormick> call it a suggested guide if you want
14:58:53 <emccormick> we need some structure. Maybe just not so much as before
14:59:00 <smcginnis> ++
14:59:26 <emccormick> you could say topics A - E Monday morning
14:59:37 <emccormick> AFternoon is all upgrades with the upgrade SIG
14:59:57 <emccormick> Tuesday morning G - K, Tuesday afternoon L - P
15:00:32 <spotz> That should work
15:00:53 <emccormick> and then we can flex within those blocks if needed, or shift something to another block, but at least we make sure everything has a place and gets covered
15:00:53 <mihalis68_> well, we're out of time! Thanks all and I suggest we carry this onwards on the mailing list
15:01:17 <smcginnis> Thanks!
15:01:23 <mihalis68_> #endmeeting