16:02:24 <dhellmann> #startmeeting oslo
16:02:25 <openstack> Meeting started Fri May  9 16:02:24 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:28 <openstack> The meeting name has been set to 'oslo'
16:02:34 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
16:02:51 <dhellmann> today should be a pretty quick meeting
16:03:04 <dhellmann> #topic action items from last meeting
16:03:31 <dhellmann> I have a review up to create the oslo-specs
16:03:32 <dhellmann> #link https://review.openstack.org/92614
16:03:44 <markmc> cool
16:03:46 <dhellmann> thanks to bnemec for giving the inputs a quick sanity check
16:04:03 <dhellmann> we may want to think about tweaking the template, but we can do that using gerrit
16:04:17 <bnemec> +1
16:04:35 <YorikSar> dhellmann: It means that I'll have to rewrite rootwrap blueprint there, right?
16:04:49 <dhellmann> I'll bug the infra team a bit later today to see if they can merge that before the summit
16:05:07 <dhellmann> YorikSar: yes, it would be good to do that
16:05:16 <YorikSar> dhellmann: ok
16:05:17 <dhellmann> I also need to write up the oslo.i18n graduation blueprint
16:05:47 <YorikSar> dhellmann: Will there be subdirs for every project in oslo?
16:06:02 <dhellmann> YorikSar: we talked about that, but I don't know if we really need to go that far
16:06:11 <dhellmann> so I haven't created them, yet
16:06:26 <dhellmann> if the group thinks having separate directories is really needed, we can add them as we add blueprints
16:06:38 <bnemec> Are the oslo* blueprints segregated on launchpad?
16:06:42 <YorikSar> dhellmann: Ok. I guess we can create them if the number of specs in all projects combined becomes too big.
16:06:55 <dhellmann> bnemec: it depends on the library, at this point
16:07:39 <bnemec> I'm not too worried about it yet.  I'm sure there will be some iteration on the process as we get going.
16:07:40 <dhellmann> we have oslo.messaging, taskflow, stevedore, and cliff in separate launchpad projects
16:07:45 <dhellmann> the others are all in the oslo project
16:07:52 <dhellmann> bnemec: exactly
16:08:04 <dhellmann> does anyone else feel strongly one way or the other?
16:08:20 <markmc> nope, I'm up for giving it a shot and evolving
16:08:22 <YorikSar> nope
16:08:30 <dhellmann> such an easy-going crowd :-)
16:08:37 <dhellmann> #topic Red flags from liaisons
16:09:19 <dhellmann> are there any blocking issues with adopting existing oslo libs in any projects?
16:09:35 <bknudson> what are the libs?
16:09:56 <dhellmann> bknudson: excellent question!
16:09:58 <dhellmann> #link https://wiki.openstack.org/wiki/Oslo#Libraries
16:10:19 <dhellmann> everything on that list except oslo.db and oslo.i18n should be ready to be used, if appropriate
16:10:51 <bknudson> I think keystone is using all the ones that we can
16:11:23 <bknudson> we should be able to use oslo.db and oslo.i18n when they're ready
16:11:24 <dhellmann> bknudson: I need to update my patch to make keystone use stevedore for plugins. At this point, that'll have to wait until after the summit, I think.
16:11:33 <dhellmann> excellent
16:11:49 <bknudson> dhellmann: talk to ayoung at the summit!
16:11:56 <dhellmann> ok, if there are no serious new issues, let's move on
16:12:02 <dhellmann> #topic oslotest adoption status
16:12:37 <bknudson> keystone is using oslotest -- we've got the base test class and a couple fixtures
16:12:38 <dhellmann> as we push out new libs, I want to focus on each for a couple of weeks, in addition to asking about the general red-flags
16:13:02 <dhellmann> so I'll try to keep up with which ones need to stay on the agenda
16:13:03 <bknudson> I think we're still using the config fixture from oslo-incubator... maybe we need a new release of oslo.config?
16:13:31 <bnemec> Yeah, that should be graduated in git now.
16:13:32 <dhellmann> bknudson: yes, bnemec weren't you working on graduating that? did the change land?
16:13:34 <dhellmann> cool
16:13:52 <bnemec> https://review.openstack.org/91397
16:14:04 <dhellmann> I can tag a new release, though I'm tempted to wait until we decide on the pre-release testing strategy at the summit
16:14:37 <dhellmann> #action dhellmann look into tagging oslo.config release
16:14:47 <markmc> yeah, tagging a new release now would expose it immediately to icehouse users - the thing I've always been skeptical about
16:14:56 <dhellmann> markmc: right
16:16:07 <dhellmann> I'll look into what changes would be included in the release
16:16:21 <dhellmann> #topic oslo.messaging adoption status
16:16:42 <bknudson> I think keystone has been using this for a while
16:16:59 <markmc> I'm not sure what hasn't adopted it at this point
16:17:07 <markmc> e.g. I know ceilometer and ironic patches recently landed
16:17:11 <dhellmann> is cinder done? I know they ran into some issues
16:17:12 * markmc starts to check
16:18:32 <dhellmann> while markmc does that, we can move on and come back to this in a few minutes
16:18:42 <dhellmann> #topic summit prep
16:18:49 <dhellmann> #link https://wiki.openstack.org/wiki/Summit/Juno/Etherpads#Oslo
16:19:00 <dhellmann> we have etherpads for most of our sessions already
16:19:24 <bknudson> are there sessions that you especially expect the liasons to show up at?
16:20:08 <dhellmann> bknudson: there's a cross-project session Tues 14:00-14:40 "New Oslo Library Releases and Your Project"
16:20:25 <dhellmann> and then the opening session for oslo: Wed 9:00 - 9:40 Release Plan for Low-level Libraries
16:20:31 <markmc> I'll get an oslo.messaging etherpad up tomorrow
16:20:40 <dhellmann> you may also be interested in Thu 9:50 - 10:30 Testing pre-releases of Oslo libs with apps
16:20:43 <dhellmann> markmc: thanks!
16:21:18 <dhellmann> a lot of the other sessions are more "internal" work, and may be of interest, but those 3 are probably the most important ones
16:21:26 <bknudson> ok, I don't have conflicts with those.
16:21:28 <dhellmann> for liaisons, that is :-)
16:21:30 <dhellmann> excellent
16:22:44 <dhellmann> I think we're ready for the summit, other than those missing etherpads, but let me know if you spot something I've missed
16:23:12 <dhellmann> is everyone going to be in town for the whole week?
16:24:09 <bnemec> Yep
16:25:14 <dhellmann> good -- I'm looking forward to this one :-)
16:25:28 <dhellmann> #topic Review status for graduating libs
16:26:00 <dhellmann> we have 2 graduations in progress now (funny, since it's graduation day here in Athens for the local university, too)
16:26:38 <dhellmann> the repo for oslo.i18n has been created, and I have a series of patches up for review for a few minor cleanup issues spotted in the code that was imported
16:26:40 <dhellmann> #link https://review.openstack.org/#/c/92678/
16:26:44 <dhellmann> that's the first review in the series
16:27:20 <dhellmann> there are quite a few in progress for oslo.db as well
16:27:21 <dhellmann> #link https://review.openstack.org/#/q/project:openstack/oslo.db+status:open,n,z
16:28:09 <dhellmann> let's prioritize these reviews so we can get both of those libraries into shape and create an initial release soon after the summit
16:28:51 <dhellmann> for both, I think we ought to be focusing on cleanup for "librarification" and bug fixes over new features, to start, does that seem reasonable?
16:29:16 <bnemec> +1
16:29:28 <bnemec> They have to work before we can add more stuff.
16:30:46 <dhellmann> right
16:31:07 <dhellmann> that's all we have on the official agenda today
16:31:11 <dhellmann> #topic open discussion
16:31:19 <dhellmann> does anyone have anything else they would like to bring up?
16:31:41 <markmc> ok, got oslo.messaging status
16:31:49 <markmc> ported: nova, glance, keystone, cinder, ceilometer, ironic, barbican
16:31:49 <markmc> not ported: neutron (https://review.openstack.org/75861), heat (https://review.openstack.org/70633), trove
16:31:49 <markmc> n/a: swift, marconi, sahara
16:31:59 <markmc> the neutron and heat ports were abandoned
16:32:16 <markmc> haven't found a trove one yet
16:32:16 <YorikSar> I was told that my work on rootwrap will be tracked in oslo instead of Neutron.
16:32:45 <YorikSar> So I guess after summit we'll have it in the agenda here, right?
16:32:51 <bnemec> YorikSar: Yes, that makes sense
16:33:13 <dhellmann> YorikSar: yes, if there's anything you need to discuss we can add it to the agenda
16:33:18 <markmc> dhellmann, ok, no review I can find for trove
16:33:35 <dhellmann> markmc: ok, I'll poke the trove liaison
16:33:35 <markmc> so, need to poke neutron and heat again, find someone to do the trove port
16:33:50 <YorikSar> dhellmann: Well. I mostly just reported status there
16:33:56 <dhellmann> #action dhellmann contact neutron, heat, and trove liaisons about oslo.messaging adoption
16:34:57 <dhellmann> YorikSar: ok, that makes sense
16:35:11 <YorikSar> dhellmann: If that's not needed here I think there won't be much to discuss after summit
16:35:21 <markmc> other observation - I see ceilometer using a whole bunch of internal oslo.messaging config options
16:35:46 <dhellmann> YorikSar: let's see how things go, and adjust as needed
16:35:47 <markmc> rpc_backend, notification_topics, transport_url, control_exchange
16:35:57 <YorikSar> dhellmann: Sure.
16:36:27 <dhellmann> markmc: are they using those for subscribing to all of the notifications?
16:36:41 <markmc> dhellmann, don't know yet
16:37:05 <markmc> dhellmann, whatever the reason, they're not part of the public API - need to examine the use case and add APIs
16:37:46 <dhellmann> markmc: right, maybe we can chat with jd__ at the summit
16:38:07 <markmc> sileht more likely
16:38:15 <markmc> one of those usages he's been working on a new API for
16:38:24 <markmc> adding retry param to rpc client
16:38:25 <dhellmann> ah, ok, jd__ is listed as our liaison
16:39:16 <markmc> ah
16:39:48 <dhellmann> if sileht is already working in this area, that's fine, but this is an example of why I wanted a contact for each project :-)
16:41:38 <dhellmann> I think that about covers it for this week, so unless there's anything else to discuss we can stop a little early.
16:41:52 <bnemec> About https://review.openstack.org/#/c/86930/
16:42:11 <bnemec> We're basically treating incubator db code as a stable branch now, so to backport to Icehouse he'll need to go oslo.db -> incubator -> incubator icehouse
16:42:39 <dhellmann> yes, that's right
16:42:44 <bnemec> Should I leave the -2 until the oslo.db change merges, or drop it and mark it WIP?  Or a third option I'm not considering? :-)
16:42:52 <dhellmann> and we need to make sure we approve the patches in that order
16:43:49 <dhellmann> I'm not sure which is the better way to ensure that, the -2 or the WIP. Maybe the -2?
16:44:29 <bnemec> -2 is the definitely won't merge option.  WIP can be changed.
16:44:46 <bnemec> I guess I can just leave a comment for him to ping me when the oslo.db change merges and I can drop it then.
16:44:46 <dhellmann> ok, let's stick with that until the oslo.db change merges
16:44:53 <dhellmann> that sounds good
16:45:09 <bnemec> Okay, that's all I had.  Thanks.
16:45:52 <dhellmann> ok, let's all go enjoy a few minutes of free time then :-)
16:46:05 <dhellmann> thanks, everyone, and I'll see you next week at the summit!
16:46:23 <bnemec> Until then!
16:46:33 <YorikSar> dhellmann: "pretty quick meeting", aha :)
16:46:42 <markmc> later :)
16:46:51 <dhellmann> YorikSar: hey, we're getting out in < 1hr :-)
16:46:59 <dhellmann> safe travels, everyone
16:47:01 <dhellmann> #endmeeting