16:01:02 <dhellmann> #startmeeting oslo
16:01:03 <openstack> Meeting started Fri May 23 16:01:02 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:06 <lcheng> o/
16:01:07 <openstack> The meeting name has been set to 'oslo'
16:01:10 <sileht> o/
16:01:18 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:01:19 <bknudson> hi
16:01:39 <dhellmann> lots to cover today, so I'm going to dive right in
16:01:44 <dhellmann> #topic Review action items from previous meeting
16:01:52 <dhellmann> 1. dhellmann look into tagging oslo.config release with new fixtures module
16:02:36 <dhellmann> at the summit we agreed we want to publish alpha releases as wheels, and mordred has a change up for infra to make that work
16:02:37 <dhellmann> #link https://review.openstack.org/#/c/56760/
16:02:54 <dhellmann> it needs a rebase, which I've offered to do
16:03:07 <dhellmann> #action dhellmann rebase wheel publishing change
16:03:17 <dhellmann> 2. dhellmann contact neutron, heat, and trove liaisons about oslo.messaging adoption
16:03:27 <jd__> o/
16:03:38 <dhellmann> I did this, and discovered that there are patches in process
16:03:42 <dhellmann> #info ihrachyshka is working on the neutron patch for oslo.messaging
16:03:46 <dhellmann> #info ihrachyshka is also working on a trove patch for oslo.messaging
16:03:52 <dhellmann> #info sdake is working on the heat patch for oslo.messaging
16:03:58 <bnemec> \o/
16:04:11 <dhellmann> ihrachyshka or sdake, do you happen to be around to report on progress?
16:04:44 <dhellmann> afaict, everyone wants these to land but they happened too close to the end of the last cycle
16:05:08 <dhellmann> so no major blockers, although ihrachyshka did email about some trouble with the neutron unit test behavior
16:05:10 * bnemec looks forward to rm -rf rpc in oslo-incubator
16:05:18 <dhellmann> indeed
16:05:29 <dhellmann> #topic Juno Schedule
16:05:41 <dhellmann> ttx published the link on the -dev list, but just in case:
16:05:42 <dhellmann> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
16:05:51 <dhellmann> we have about 3 weeks before J1
16:06:01 <dhellmann> in that time, we need to be working on blueprints and specs, as well as the libraries we said we would graduate early
16:06:39 <dhellmann> I would like to have the specs for all our current blueprints done by some time next week, so ttx and I can organize the launchpad end of things for tracking
16:06:47 <dhellmann> does anyone foresee any issues with that?
16:07:11 * dhellmann has the HVAC guy here for service, so may have a meat-space interruption coming up soon
16:07:22 <bnemec> I see a lot of spec reviews in my near future.
16:08:07 <dhellmann> bnemec: that's true, and I was going to talk about review priorities later on in the meeting
16:08:34 <dhellmann> this time around I think we've talked about most of the blueprints already, so it's just a matter of making sure the details are clear
16:09:25 <dhellmann> something that came up in the ceilometer meeting was to make sure, when reviewing specs, to focus on content and not style -- don't quibble over punctuation unless it makes the meaning unclear, for example
16:10:06 <dhellmann> I think the only exception there would be if the rst formatting is broken so rendering doesn't work, but I'm inclined to let that sort of thing be fixed after the initial review is done if necessary
16:10:40 <mkoderer> isn't the rst formating checked by jenkins?
16:11:00 <dhellmann> mkoderer: it should be, but I don't know if it's reported as a failure or not
16:11:25 <mkoderer> dhellmann: ok
16:11:35 <bnemec> I thought someone in tripleo mentioned having issues if their rst wasn't good, but I haven't run into it myself.
16:11:56 <dhellmann> looking at https://review.openstack.org/#/c/95002/ I see that a docs job ran and built html output at http://docs-draft.openstack.org/02/95002/2/check/gate-oslo-specs-docs/8ed3efd/doc/build/html/
16:12:21 <dhellmann> we can keep an eye on it, and fix issues if needed
16:12:54 <dhellmann> does anyone have any concerns about the schedule? we haven't committed blueprints to any milestones, yet, so that question may be premature. :-)
16:13:20 * morganfainberg is here now (running a little late today)
16:13:27 <dhellmann> hi, morganfainberg
16:13:33 <dhellmann> ok, moving on
16:13:34 <dhellmann> #topic red flags from liaisons
16:13:41 <dhellmann> there’s probably not much to report here, yet, but I want to leave this section on our agenda every week
16:13:54 <mkoderer> what is this topic about?
16:14:04 <bnemec> Surfing? ;-)
16:14:15 <gcb_> dhellmann, any approved blueprint before should be reviewed in oslo-specs, right ?
16:14:20 <mkoderer> we had some problems with oslo.test and mocking time.time in tempest
16:14:26 <mkoderer> is it the right place? ;)
16:14:49 <dhellmann> if there are any issues with blueprints, landing changes in projects, designs, etc. -- anything that the oslo core team needs to be aware of and address that is blocking use of oslo libraries -- this is the time to bring it up
16:15:08 <dhellmann> gcb_: yes, please file a spec for any blueprint you plan to work on in juno
16:15:16 <dhellmann> mkoderer: yes, that's exactly it
16:15:44 <bnemec> mkoderer: I commented on the review, but will it break with OS_DEBUG=1 too?
16:15:44 <dhellmann> gcb_: I think you bounced and missed my reply: yes, please file a spec for any blueprint you plan to work on in juno
16:16:01 <gcb_> dhellmann, thanks
16:16:04 <mkoderer> bnemec: yep you are right so we still have an issue
16:16:09 <bnemec> Ugh
16:16:17 <dhellmann> I don't necessarily want to solve issues here in the meeting, but I want to make sure we're all aware of them
16:16:18 <mkoderer> I fixed it in tempest itself
16:16:29 <dhellmann> mkoderer: do you have links to the related reviews?
16:16:34 <mkoderer> sure
16:16:50 <mkoderer> #link https://review.openstack.org/#/c/94176/
16:17:12 <mkoderer> #link https://review.openstack.org/#/c/94027/
16:17:30 <mkoderer> so we fixed it in tempest and just get rid of the time.time mock
16:17:48 <dhellmann> mkoderer: is everyone generally happy with that approach, or do we need to work on another one?
16:18:05 <mkoderer> dhellmann: maybe we should put it in the documentation
16:18:19 <dhellmann> mkoderer: that sounds like a good idea
16:18:26 <mkoderer> dhellmann: since it's not really obvious that using a oslo.test lib can cause problems in logging ;)
16:18:36 <mkoderer> I will do it
16:18:41 <dhellmann> great, thanks
16:18:57 <dhellmann> #action mkoderer add a doc patch for oslotest warning about mocking time.time
16:19:14 <dhellmann> do we have any other issues we need to raise here?
16:20:08 <dhellmann> mkoderer: also, don't forget that the oslo.test repo is likely to be renamed today during the gerrit downtime, so watch for that when you submit a patch
16:20:17 <dhellmann> it's moving from "oslo.test" to "oslotest"
16:20:27 <mkoderer> dhellmann: ok cool thx
16:20:34 <dhellmann> #topic adoption status
16:20:48 <dhellmann> liaisons should be looking at oslotest and oslo.messaging at this point, how is that going (aside from the issue mkoderer just reported)?
16:21:02 <dhellmann> and, well, all the stuff I reported earlier about oslo.messaging
16:21:10 * dhellmann wonders who wrote these agenda notes
16:21:36 <bknudson> keystone is still using oslo-incubator oslotest ... I think we're waiting on config fixture in oslo.config
16:21:36 <dhellmann> I've really only been tracking the integrated and incubated projects for oslo.messaging, do we have any liaisons from other projects here today?
16:21:49 <mkoderer> tempest oslotest integration is in review
16:21:51 <dhellmann> bknudson: ok, that's good to know
16:21:53 <mkoderer> #link https://review.openstack.org/#/c/77747/
16:22:06 <bknudson> also, we've got a review to switch to oslo.db -- https://review.openstack.org/#/c/77210/
16:22:24 <dhellmann> bknudson: nice, getting a head start :-)
16:23:36 <dhellmann> ok, we can come back during open discussion if there is more to report
16:23:38 <dhellmann> #topic discuss next steps for osprofiler
16:23:53 <dhellmann> boris-42, I think this was your topic so the floor is yours
16:24:40 <dhellmann> hmm, I wonder what time it is there and if boris-42 is actually around
16:25:05 <dhellmann> at the summit, we talked about the fact that boris would like osprofiler to be an oslo library
16:25:30 <dhellmann> the other projects have expressed an interest in using it, and I have no objection to adopting it, but I didn't want to say yes without discussing it with the team
16:25:44 <dhellmann> perhaps we should do that via the mailing list, since I'm not sure we have quorum here today
16:26:06 <bnemec> Yeah, probably makes sense.
16:26:11 <bknudson> projects have to do something to use it?
16:26:16 <bnemec> I'm good with it though.
16:27:09 <dhellmann> bknudson: they have to call the functions to set it up
16:27:24 <dhellmann> there are a couple of ways to turn it on/off at runtime, I think
16:27:35 <bknudson> rest api?
16:27:39 <dhellmann> #action dhellmann suggest boris-42 send email about having oslo adopt osprofiler
16:27:45 <morganfainberg> bknudson, i think it was config
16:27:46 <bnemec> Wasn't it implemented as middleware?
16:27:59 <dhellmann> bknudson: it currently looks for a value in the incoming request, but that is going to be changed
16:28:05 <dhellmann> morganfainberg: yes, I think there's a config flag, too
16:28:09 <mkoderer> Does it require to have ceilometer in place?
16:28:11 <bknudson> if it's middleware and a library and no setup then there's nothing to do
16:28:28 <morganfainberg> bknudson, yeah it was very straightforward as i recall
16:28:31 <dhellmann> mkoderer: it does send notifications intended for ceilometer to collect
16:28:51 <mkoderer> ok got it
16:29:08 <dhellmann> #topic keep or drop run_tests.sh
16:29:13 <dhellmann> bnemec, this one is yours
16:29:38 <bnemec> Okay, so we have an open review to fix up run_tests.sh.
16:29:49 <bnemec> But we've also talked about dropping it entirely.
16:30:03 <bnemec> So I thought this might be a good time to revisit that discussion.
16:30:14 <dhellmann> do any of the infra jobs depend on it?
16:30:24 <dhellmann> or is this just a local dev tool?
16:30:36 <bnemec> I don't think so.  Infra uses tox everywhere AFAIK.
16:30:40 <morganfainberg> dhellmann, iirc infra uses tox for everything
16:30:45 <dhellmann> to be honest, I don't think I even realized we had a copy of the script, I always just use tox directly
16:30:52 <bnemec> I think it's just a local dev tool.
16:31:00 <bnemec> dhellmann: Although you mentioned maybe rackspace was using it for something?
16:31:16 <dhellmann> oh, hmm, what was that...
16:31:22 <morganfainberg> in the keystone team there is desire to keep it, but we've hacked it up ourselves to suit our needs
16:31:39 <dhellmann> ah, yeah, something to do with the way they were building a package and then using it to run tests in the packaged code
16:31:45 <bnemec> morganfainberg: What is the reason for keeping it?
16:31:58 <dhellmann> bnemec: do you have the link to that review handy?
16:32:03 <bnemec> I know there were some feature deficits in tox before, but I thought at least some of those were resolved now.
16:32:10 <morganfainberg> bnemec, a few of our developers like it's interface better than remembering tox
16:32:15 <bnemec> dhellmann: https://review.openstack.org/#/c/85637/
16:32:24 <dhellmann> #link https://review.openstack.org/#/c/85637/
16:32:25 <bnemec> morganfainberg: What about making it a wrapper around tox?
16:32:26 <morganfainberg> bnemec, and we do some magic w/ it to handle fail-fast, which can't be done until tox 1.7
16:32:39 <morganfainberg> bnemec, it is for the most part going that way
16:32:54 <bnemec> morganfainberg: Ah, okay.
16:32:59 <dhellmann> a/c guy is here, brb
16:33:12 <bnemec> So we do still have things that run_tests can do and tox can't for the moment.
16:33:18 <morganfainberg> bnemec, i don't mind maintaining our desires in keystone as a wrapepr to tox even if everyone else wants to drop it.
16:33:30 <bnemec> Although it sounds like Keystone isn't actually using the stuff from oslo?
16:34:11 <morganfainberg> bnemec, no - but if you want it i'm happy to work to contribute our wrapper changes up to your script
16:34:28 <morganfainberg> bnemec, https://github.com/openstack/keystone/blob/master/run_tests.sh#L87 the failfast (iirc) is the one feature we can't replicate with tox specifically
16:34:35 <bnemec> morganfainberg: I think in general there has been support for keeping run_tests.sh as a wrapper everywhere.  As you noted, it's much easier to discover than tox.
16:34:48 * dhellmann returns
16:34:58 <morganfainberg> bnemec, i submitted a pull request to fix it but we're behind on tox versions due to posarg changes
16:35:30 <dhellmann> it seems like if the other projects want to keep it, we should keep the version in the incubator
16:35:40 <morganfainberg> bnemec, so 1.7.<something> will provide that fix eventually. not sure if we (openstack) will get there or not. there was discussion about moving away from tox
16:35:56 <dhellmann> although I don't think we need the script in the new library repos
16:36:08 <bnemec> Yeah, it doesn't sound like we're ready to drop run_tests, so we should go ahead and fix it up.
16:36:14 <dhellmann> ok
16:39:31 <bnemec> That's all I had on this topic then.
16:39:31 <dhellmann> #agreed we will continue maintaining the copy of the test script in the incubator for other projects to use
16:39:32 <dhellmann> #topic priorities for this week
16:39:32 <dhellmann> I mentioned some of this already
16:39:32 <dhellmann> we need to review the graduation template in specs, write specs for all blueprints, and focus reviews on the specs, oslo.db, and oslo.i18n repos
16:39:32 <dhellmann> #info specs, oslo.i18n, oslo.db
16:39:33 <dhellmann> the graduation spec template just needs one more +2
16:39:33 <dhellmann> #link https://review.openstack.org/94906
16:39:45 <dhellmann> if there are no questions, that's the last formal topic I have for this week's agenda
16:39:45 <bnemec> dhellmann: Do we have the section header test in oslo?
16:39:57 <bnemec> Just wondering if having multiple templates is going to be a problem.
16:40:06 <dhellmann> bnemec: ah, no, I saw that someone was working on a test like that
16:40:26 <dhellmann> good point, we would have to adjust the tool to know which template was used
16:40:53 <bnemec> Yeah, there are some reviews open in Nova that should make it easier.
16:41:10 <morganfainberg> dhellmann, some general comments i can provide relating to similar changes we did in keystone
16:41:18 <bnemec> https://review.openstack.org/#/c/94381/
16:41:40 <morganfainberg> dhellmann, if you're interested. makes the template a little bit better (wording), but if there is a rush i don't want to block (Can submit a followup review)
16:41:47 <dhellmann> bnemec: can you keep an eye on those, and propose some tooling for us when it's ready? I think oslo owns the cookiecutter repo for specs, so we should probably put the tools there, too
16:42:22 <dhellmann> morganfainberg: please comment away -- keep in mind this is the template just for graduations, there's a separate one for "normal" changes
16:42:24 <bnemec> dhellmann: Sure, I'm already subscribed to that one.
16:42:48 <morganfainberg> dhellmann, correct - it's just some similar phrasing we cleaned up (you used the same wording in some of the sections)
16:42:58 <dhellmann> I'm also open to the idea that we should only have one template, but there were a lot of sections that just didn't apply to graduations
16:43:10 <morganfainberg> dhellmann, ++
16:43:39 <gcb_> should we add oslo-specs section in  https://wiki.openstack.org/wiki/Oslo#Review_Links
16:43:50 <morganfainberg> dhellmann, not sure how to resolve one template vs applicable sections
16:44:10 <dhellmann> gcb_: good point, I'll do that
16:44:19 <dhellmann> #action dhellmann add oslo-specs to the review links section of the wiki
16:44:48 <bnemec> Given the variety of stuff in Oslo I think it probably makes sense to support multiple templates.
16:45:04 <bnemec> I reserve the right to change my mind if the tooling around that turns out to be obnoxious. :-)
16:45:08 <dhellmann> heh
16:45:26 <dhellmann> I think we've already moved on from priorities...
16:45:27 <dhellmann> #topic open discussion
16:46:41 <dhellmann> if we're done, everyone can go take the extra 15 minutes to write their specs :-)
16:47:43 <morganfainberg> yay
16:48:03 <bnemec> +1 :-)
16:48:09 <morganfainberg> dhellmann, i'll post my comments on the template in a couple minutes. all minor.
16:48:10 <dhellmann> ok, let's do that, then :-)
16:48:15 <dhellmann> morganfainberg: sounds good
16:48:31 <dhellmann> thanks everyone!
16:48:45 <dhellmann> #endmeeting