16:00:07 <dhellmann> #startmeeting oslo
16:00:07 <openstack> Meeting started Fri Jun  6 16:00:07 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <openstack> The meeting name has been set to 'oslo'
16:00:13 <dhellmann> who's around for the oslo meeting?
16:00:20 <markmc> hey
16:00:23 <viktors> hi
16:00:34 <dhellmann> our agenda:
16:00:35 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:01:03 <dhellmann> beekneemech, dims, flaper87|afk ?
16:01:44 <bknudson> hi
16:01:47 <morganfainberg> dhellmann, o/
16:02:11 <dhellmann> let's go ahead and start with old business
16:02:15 <dhellmann> #topic Review action items from previous meeting
16:02:16 <beekneemech> o/
16:02:22 <dhellmann> #info the wheel publishing change is merged, and some kinks are being worked out
16:02:24 <rpodolyaka> o/
16:02:31 <dhellmann> with the current gate issues I’m not sure infra has time to help test, though we're going to try today
16:02:45 <dhellmann> harlowja_away, if you want to test that taskflow release again go for it :-)
16:02:54 <sileht> o/
16:03:01 <dhellmann> mkoderer - add a doc patch for oslotest warning about mocking time.time
16:03:07 <dhellmann> mkoderer: any update on that?
16:03:28 <markmc> nice work on the wheel publishing dhellmann
16:04:00 <beekneemech> I seem to recall seeing the doc change.  Let me see if I can find it.
16:04:02 <dhellmann> the infra team did a lot of the work, I just pushed it the last step or so
16:04:09 <dhellmann> beekneemech: ok, thanks
16:04:13 <dhellmann> #info dhellmann talked with boris-42 about sending email about having oslo adopt osprofiler
16:04:26 <dhellmann> I think boris-42 has been busy, but he does intend to do that so I'm going to stop tracking it
16:04:36 <dhellmann> #info updated the review links section of the wiki based on sdague’s new dashboard creation tool
16:04:40 <jd__> o/
16:04:41 <boris-42> dhellmann sorry=)
16:04:43 <dhellmann> #link https://github.com/sdague/gerrit-dash-creator
16:04:48 <dhellmann> boris-42: no worries :-)
16:05:11 <boris-42> dhellmann I think probably it is better to start from stack forge & global requirements
16:05:15 <dhellmann> I copied the dashboard sdague created as an example, so if you think we need other queries please feel free to bring them up
16:05:25 <dhellmann> boris-42: ok, that makes sense
16:05:36 <dhellmann> I think that's it from last week
16:05:39 <boris-42> dhellmann after it will be ready & stable we can move it to the oslo
16:05:51 <dhellmann> boris-42: that sounds like a good approach
16:05:54 <beekneemech> time.time mocking patch: https://review.openstack.org/#/c/95411/
16:06:01 <beekneemech> dhellmann: dashboard +1!
16:06:01 <dhellmann> beekneemech: thanks!
16:06:29 <dhellmann> oh, look, I even reviewed that once
16:06:52 <dhellmann> #topic Red flags from liaisons
16:06:55 <beekneemech> And strangely, I didn't.  Even though I distinctly remember looking at it. :-)
16:07:07 <dhellmann> does anyone have any issues to raise this week?
16:07:20 <dhellmann> beekneemech: I'm not sure which is worse, remembering and not reviewing or the other way around
16:08:19 <bknudson> no red flags here, but no visible progress either.
16:08:20 <dhellmann> could I have the liaisons present say "nothing for $project" in this section, so I know we're getting feedback?
16:08:30 <bknudson> (keystone)
16:08:32 <jogo> made a little progress with syncing this week
16:08:36 <dhellmann> bknudson: ok, thanks -- this week has been slow with the gate issues
16:08:52 <dhellmann> jogo: good!
16:08:59 <jogo> (nova) fianlly got the new policy code synced
16:09:09 <jogo> finally*. also been blocked by gate
16:09:21 <bknudson> I'll try a sync again today to see if anything's changed.
16:09:25 <dhellmann> jogo: did you run into anything that we need to be aware of as we think about graduation for the policy code?
16:09:31 <bknudson> if morganfainberg doesn't beat me to it
16:10:19 <dhellmann> anyone else, before we move on?
16:10:24 <jogo> dhellmann: not yet, sync landed afew days agao.
16:10:35 <jogo> dhellmann: so no
16:10:37 <dhellmann> jogo: ok, good
16:10:59 <morganfainberg> bknudson, heh.
16:11:03 <dhellmann> policy probably won't graduate until K, but it's always good to be looking ahead
16:11:41 <dhellmann> let's keep going
16:11:43 <dhellmann> #topic Blueprint approval process
16:11:48 <dhellmann> beekneemech, this was your topic
16:12:35 <beekneemech> Yeah, so we talked about this briefly in #openstack-oslo this week, and the conclusion was we should discuss it at the meeting with more people present.
16:12:59 * beekneemech finds the meeting agenda
16:13:16 <dhellmann> we might not have quorum for the core team, but let's talk about it and then move the decision to the mailing list
16:13:34 <beekneemech> Some options that were discussed, in no particular order:
16:13:34 <beekneemech> 2 +2's
16:13:34 <beekneemech> 3 +2's
16:13:34 <beekneemech> $ALL_OF_CORE +2's (!)
16:13:34 <beekneemech> Only dhellmann can +A
16:13:35 <beekneemech> Like governance - no -2 at all, only ttx has +2
16:13:50 <dhellmann> in that last one, I think sub "oslo-ptl" for "ttx" in our case
16:14:02 <beekneemech> I guess the last two would be kind of the same thing.
16:14:13 <beekneemech> Yeah
16:14:19 <dhellmann> the difference is the lack of the -2 for cores, to avoid vetos
16:14:33 <dhellmann> I don't think that's really an issue, but it was a variation so I thought I'd bring it up
16:14:37 <beekneemech> Ah, true.
16:14:37 <markmc> so only oslo-core could +2/-2 ?
16:14:41 <markmc> sorry
16:14:48 <markmc> so only oslo-core could +1/-1 ?
16:14:56 <dhellmann> right
16:14:57 <markmc> in the last option
16:15:06 <markmc> reckon veto is valid for oslo-core
16:15:18 <markmc> not valid for any one person on the TC though
16:15:24 <markmc> that's the difference
16:15:45 <markmc> given oslo-core can -2 the patch ... :)
16:15:55 <dhellmann> well, that's a good point :-)
16:15:55 <beekneemech> True :-)
16:16:13 <markmc> I like "dhellmann can +A"
16:16:18 <dhellmann> I was having trouble coming up with an example where a veto on a blueprint was the right way to go
16:16:46 <beekneemech> "Ungraduate oslo.messaging" ;-)
16:16:54 <markmc> "make an incompatible change to oslo.config API"
16:17:36 <dhellmann> I like the "ptl approves" model, too. We work on consensus well enough that I don't think we need to codify it in the gerrit ACLs.
16:18:08 <beekneemech> I don't have a problem with that, as long as it's not going to be excessive work for you.
16:18:45 <dhellmann> I review the bp list once a week with ttx anyway, so I can approve them then when it looks like we have consensus.
16:19:10 <dhellmann> just to be clear, that doesn't mean you all are off the hook for doing reviews :-)
16:19:17 <beekneemech> Heh
16:19:38 <dhellmann> I think I'll want at least 2 +2s and no -1s. More is better.
16:20:24 <dhellmann> our active reviewer list is fairly small, though
16:20:49 <dhellmann> we need some recruiting slogans
16:21:21 <dhellmann> do we need to take this to the ML, or should we just go ahead with that plan and revisit if someone complains?
16:21:28 * beekneemech is not good at marketing
16:21:47 <dhellmann> "Oslo, we incubate more code before 9:00 AM than most people do all day."
16:22:07 * rpodolyaka likes that one
16:22:21 <beekneemech> We'll need something on the ML to announce it, so maybe say that this is the plan and if nobody objects we'll go with it.
16:22:31 <rpodolyaka> +1
16:22:33 * dhellmann saw a lot of US army recruiting commercials watching cartoons in his youth
16:22:42 <dhellmann> beekneemech: can you do that?
16:22:50 <beekneemech> dhellmann: Sure
16:23:07 <dhellmann> #action beekneemech send email to openstack-dev with oslo spec approval policy
16:23:44 <viktors> dhellmann: so we are keep the old policy for now?
16:23:54 <beekneemech> Oh look, my calendar just decided to remind me of the oslo meeting.  How helpful.
16:23:57 <dhellmann> #agreed oslo-specs approvals are left up to the PTL, after consensus is reached, with an option to delegate to the lead maintainer for each library
16:24:18 <dhellmann> viktors: well, we didn't have an old policy, really
16:24:44 <viktors> dhellmann: got it :)
16:24:53 <dhellmann> ok, speaking of specs:
16:24:54 <dhellmann> #topic Blueprint priorities
16:25:09 <dhellmann> #link https://blueprints.launchpad.net/oslo/juno
16:25:09 <dhellmann> #link https://blueprints.launchpad.net/oslo.messaging/juno
16:25:09 <dhellmann> We need to set the priorities and milestones for all of the blueprints for juno by EOD Monday, 9 June
16:25:28 <dhellmann> please look over the blueprints we already have listed and make sure none are missing
16:25:47 <dhellmann> I did remove some for specs that weren't written yet, so if that applies to one of yours go ahead and retarget it when you write the spec
16:26:04 <dhellmann> also please look at the priorities and let me know if you see anything out of whack
16:26:42 <beekneemech> oslo.log is a dep for a lot of other libs, should that be higher?
16:26:52 <dhellmann> I think ttx is working on a script to sync the specs and blueprints lists, but I don't know how smart it is so I'm trying to keep it up to date by hand for now
16:26:52 <beekneemech> Or are we planning to keep using incubator log until it graduates?
16:27:39 <dhellmann> that's a good question
16:28:24 <dhellmann> looking at https://blueprints.launchpad.net/oslo/+spec/graduate-oslo-log, I see the things it depends on having high priorities and the things that depend on it being out of scope, except the middleware library we talked about but for which we don't have a spec yet
16:29:38 <dhellmann> a "high" priority item is a strong commitment to finish, so if you're comfortable with that I can change it
16:30:33 <dhellmann> I guess I was being a little conservative with the commitment, until we saw how the first couple of smaller libs went
16:30:42 <dhellmann> esp. because there are several API changes in oslo.log
16:30:58 <beekneemech> Yeah, I guess so.  A lot of high priorities, but hopefully we've got enough people signed up to work on them that we can do it.
16:31:16 <beekneemech> It's definitely not a trivial graduation.
16:31:23 <dhellmann> right
16:31:49 <dhellmann> we can adjust as we go along, too
16:31:51 <beekneemech> I guess the big question is: are we going to block the other libs on oslo.log, or just have them keep syncing incubator log.
16:32:06 <bknudson> so is the plan something like -- make oslo.log a lib, then change oslo-incubator to use oslo.log?
16:32:13 <dhellmann> do we have any libs for juno that depend on oslo.log other than oslo.db?
16:32:19 <beekneemech> If the former then I think it's high, but if the latter we can leave it medium.
16:32:22 <bknudson> or does the api change make that not work?
16:32:46 <beekneemech> excutils does logging.  I'm pretty sure oslo.concurrency does too.
16:32:57 <dhellmann> bknudson: we could do that. The API change planned will make the log library a "log configuration" library that an app uses, and other libraries can ignore.
16:33:05 <rpodolyaka> actually, oslo.db doesn't depend on oslo.log
16:33:09 <beekneemech> So that's two planned for this cycle that need some sort of logging.
16:33:16 <rpodolyaka> we use python logging module
16:33:41 <beekneemech> Although maybe all the libs should do that.^
16:33:58 <rpodolyaka> probably yes
16:34:08 <dhellmann> yeah, that's the direction we want to go, the question is whether the incubator version gives us everything we need to make it work
16:35:02 <beekneemech> My thought is that we'd stop using either oslo.log or incubator as part of the graduation.  Just use stdlib logging.
16:35:03 <markmc> I can't remember exactly why, but I know I concluded oslo.messaging didn't need to use openstack.common.log
16:35:06 <markmc> just python logging
16:35:43 <rpodolyaka> right. It probably only makes sense to consuming projects to use oslo.log, as they actually *configure* logging, not libs
16:35:50 <dhellmann> I think the thing we might lose is having context details in the log messages, but that should only be in cases where the ContextAdapter is used but the ContextFormatter is not
16:35:56 <dhellmann> right
16:36:00 <beekneemech> Once remove-context-adapter is done all the third-party libs will be getting the oslo logging stuff for "free".
16:36:19 <dhellmann> that's right, so maybe that one needs to be high priority
16:36:36 <markmc> dhellman, sorry, I gotta run - so I'll just dump oslo.messaging adoption status here
16:36:43 <dhellmann> markmc: ok, thanks
16:36:44 <markmc> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/oslo-messaging,n,z
16:36:45 <markmc> https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/oslo-messaging,n,z
16:36:48 <markmc> that's neutron and heat
16:37:02 <markmc> some progress on neutron - ihar has split up the patches - but not so much on heat
16:37:11 <markmc> don't think there's anyone working on it for trove yet
16:37:20 <dhellmann> :-/
16:37:31 <markmc> yeah, ok ... later
16:37:33 <markmc> thanks
16:37:36 <dhellmann> thanks, markmc
16:38:08 <dhellmann> ok, I changed https://blueprints.launchpad.net/oslo/+spec/remove-context-adapter to have high priority
16:38:38 <dhellmann> we have a few more topics, so look over the rest of the list and bring up changes in #openstack-oslo or on the ML
16:38:41 <dhellmann> #topic oslotest adoption status
16:38:47 <beekneemech> Sounds good.  Maybe we should add a step to the graduation checklist to use stdlib logging.
16:38:56 <dhellmann> we have one more review to update oslo-incubator to use our own library
16:38:56 <dhellmann> #link https://review.openstack.org/87727
16:39:04 <dhellmann> beekneemech: that's a good idea, will you do that?
16:39:12 <beekneemech> dhellmann: Sure.
16:39:36 <dhellmann> #action beekneemech update the graduation checklist to include a step to remove use of oslo logging in favor of stdlib logging
16:40:01 <dhellmann> ok, so please go review that change so we can say we're at least using our own libraries :-)
16:40:07 <rpodolyaka> :)
16:40:32 <dhellmann> #topic oslo.messaging adoption status
16:40:39 <dhellmann> markmc reported on that above
16:40:46 <dhellmann> therve, salv-orlando, vipul: are there any other updates?
16:41:25 <dhellmann> I don't see most of them here today
16:41:27 <dhellmann> #topic oslo.db graduation status
16:41:32 <dhellmann> victors, rpodolyaka: how do things look?
16:41:43 <rpodolyaka> I have a bunch of review for you :)
16:41:46 <rpodolyaka> *s
16:41:47 <rpodolyaka> https://etherpad.openstack.org/p/oslo.db-release-blockers
16:41:56 <viktors> #link https://etherpad.openstack.org/p/oslo.db-release-blockers
16:42:06 <rpodolyaka> most of them have been approved, but gates...
16:42:27 <dhellmann> yeah, we're all at the mercy of the gates
16:42:39 <rpodolyaka> https://review.openstack.org/#/c/96468/ - the spec we need to get approved
16:42:56 <rpodolyaka> waiting for the consensus, probably?
16:43:16 <viktors> this spec related to patch https://review.openstack.org/#/c/96467/ - eventlet.tpool
16:43:40 <beekneemech> rpodolyaka: You're +1 on that spec, right?
16:43:52 <beekneemech> I think that would make 4 people with +2 on oslo.db in favor.
16:44:01 <rpodolyaka> beekneemech: should I? I'm the author :)
16:44:10 <beekneemech> Oh, whoops. :-)
16:44:16 <dhellmann> rpodolyaka: I think it's safe to assume the author is +1 :-)
16:44:23 <rpodolyaka> hehe
16:44:27 <beekneemech> I was thinking of the oslo.db patch where Andrey was the author. :-)
16:44:29 <dhellmann> so yeah, that one looks settled
16:45:07 <dhellmann> rpodolyaka: I'll approve that later today
16:45:19 <beekneemech> \o/ our first approved spec!
16:45:23 <rpodolyaka> dhellmann: ack, thanks!
16:45:29 <dhellmann> :-)
16:45:50 <dhellmann> #topic oslo.i18n graduation status
16:45:50 <dhellmann> we need some spec and code reviews
16:45:50 <dhellmann> #link https://review.openstack.org/#/q/status:open+project:openstack/oslo.i18n,n,z
16:45:50 <dhellmann> I have one rather large one up to clean up the public API of the librarythe documentation review is blocking the library being added to the main doc site
16:46:26 <dhellmann> we do have 2 +2 on the spec https://review.openstack.org/#/c/95002/
16:46:32 <dhellmann> so maybe that one is ready to go in as well
16:47:00 <beekneemech> 2 +2's on an i18n spec?  Ship it!
16:47:11 <dhellmann> #action dhellmann approve graduate-oslo-db and graduate-oslo-i18n specs in that order
16:47:22 <beekneemech> That's almost as many people as showed up to the i18n sessions at summit. :-)
16:47:26 <dhellmann> heh
16:47:43 <dhellmann> #topic review priorities for this week
16:47:59 <dhellmann> I think this week is the same as last. specs, oslo.db, oslo.i18n
16:48:14 <dhellmann> I haven't looked at the bug list in a couple of days, are there any critical issues we need to add to that list?
16:48:55 <beekneemech> I haven't noticed anything coming through launchpad.
16:49:17 <beekneemech> And I get notified of every update to every oslo bug. :-)
16:49:23 <dhellmann> yeah, I hadn't noticed either
16:49:43 <dhellmann> careful, beekneemech, you sound like you're volunteering to be the lead bug triager :-)
16:50:25 <beekneemech> Heh, oslo-coresec seems to have subscribed me so I don't have a lot of choice in the matter. :-)
16:50:33 <dhellmann> heh
16:50:38 <dhellmann> that's all we had on the formal agenda this week
16:50:42 <dhellmann> #topic open discussion
16:50:54 <dhellmann> does anyone have anything else to raise?
16:51:04 <beekneemech> Oh, I wanted to note that https://review.openstack.org/#/c/95281 would be good for liaisons to look at.
16:51:11 <jogo> shameless plug for finaly review before hacking 0.9 can be released https://review.openstack.org/#/c/97988/
16:51:23 <dhellmann> beekneemech: very good point
16:51:30 <beekneemech> Since it involves trying to make context work for everyone, we should try to get as broad input as possible.
16:51:31 <dhellmann> #action liaisons review https://review.openstack.org/#/c/95281
16:51:42 <jogo> found a regression in hacking 0.9.0 so want to fix it before announcing it
16:51:52 <dhellmann> #action dhellmand send email to the dev list asking for liaisons to review https://review.openstack.org/#/c/95281
16:52:02 <beekneemech> jogo: I'll take a look
16:52:15 <dhellmann> jogo: on my list now
16:52:22 <jogo> thanks
16:53:03 <dhellmann> if there's nothing else, I think we'll continue our trend of ending a few minutes early
16:53:46 <beekneemech> Nothing for me
16:53:56 <dhellmann> going once...
16:54:12 <dhellmann> 2...
16:54:31 <dhellmann> ok, thanks every one!
16:54:34 <rpodolyaka> thanks all, have a nice weekend!
16:54:52 <beekneemech> +1
16:55:18 <dhellmann> #endmeeting