16:00:27 <dhellmann> #startmeeting oslo
16:00:27 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:00:27 <dhellmann> who’s around for the oslo meeting?
16:00:27 <openstack> Meeting started Fri Jun 13 16:00:27 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:30 <openstack> The meeting name has been set to 'oslo'
16:00:33 <bknudson> hi
16:00:47 <dhellmann> hi, bknudson
16:00:53 <GheRivero> o/
16:01:07 <dhellmann> hi, GheRivero
16:01:13 <viktors> o/
16:01:14 <wendar> o/
16:01:18 <malor> o/
16:01:56 <markmc> hey
16:02:15 <dhellmann> bnemec, dims_ , flaper87 : around?
16:02:18 <dstanek> hi
16:02:27 <dhellmann> jd__, haypo?
16:02:30 <flaper87> o/
16:02:34 <bnemec> o/
16:02:58 <dhellmann> I think we have quorum :-)
16:03:04 <dhellmann> #topic review action items from previous meeting
16:03:12 <dhellmann> beekneemech send email to openstack-dev with oslo spec approval policy
16:03:22 <dhellmann> that's done
16:03:31 <morganfainberg> o/
16:03:31 <bnemec> Yep
16:03:43 <dhellmann> beekneemech update the graduation checklist to include a step to remove use of oslo logging in favor of stdlib logging
16:03:51 <dhellmann> I think I remember talking about that, too
16:03:52 <bnemec> http://lists.openstack.org/pipermail/openstack-dev/2014-June/037068.html
16:03:55 <bnemec> Also done
16:04:00 <dhellmann> cool
16:04:11 <dhellmann> #info graduate-oslo-db and graduate-oslo-i18n specs were approved
16:04:22 <dhellmann> I approved those 2 specs since the last meeting, as we agreed
16:04:28 <dhellmann> #action dhellmann send email to the dev list asking for liaisons to review https://review.openstack.org/#/c/95281
16:04:32 <dhellmann> I have not done that one
16:04:48 <dhellmann> could I get a volunteer to take that over?
16:05:21 <bnemec> dhellmann: Yeah, I can do that.
16:05:47 <dhellmann> #undo
16:05:48 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x1f2ef90>
16:05:51 <dhellmann> #action bnemec send email to the dev list asking for liaisons to review
16:06:02 <dhellmann> thanks, bnemec
16:06:14 <bnemec> np
16:06:15 <dhellmann> I think that's it for old business
16:06:28 <dhellmann> #topic Red flags from liaisons
16:06:44 <dhellmann> does anyone have any concerns to raise this week?
16:06:56 <bknudson> none for keystone that I can think of
16:07:17 <dhellmann> GheRivero, how are things in ironic?
16:07:21 <bknudson> ran into a question about sqlite_db and posted an update to oslo.db for it
16:07:40 <bknudson> and also slave_connection -- keystone doesn't use it so it's confusing if it's in our config file
16:07:43 <dhellmann> bknudson: good, was there a bug associated or just a patch?
16:07:54 <bknudson> dhellman: I also opened a bug
16:07:56 <GheRivero> dhellmann: still looking with the db migrations, but so far so good
16:08:01 <dhellmann> bknudson: ok, thanks
16:08:03 <dhellmann> GheRivero: good
16:08:57 <dhellmann> bknudson: on the slave_connection, I think we're going to find cases like that from time to time. We might need to make some adjustments to the config generator to let us filter unused options
16:09:02 <viktors> folks from Nova found a bug, related to common test_base module
16:09:13 <dhellmann> or we could update keystone to use the feature :-)
16:09:15 <bknudson> https://bugs.launchpad.net/oslo/+bug/1329086
16:09:16 <uvirtbot> Launchpad bug 1329086 in oslo "sqlite_db option is unused" [Undecided,In progress]
16:09:31 <malor> viktors: actually, base opportunistic db test case ;) (https://launchpad.net/bugs/1328997)
16:09:32 <uvirtbot> Launchpad bug 1328997 in nova "Unit test failure: openstack_citest" is being accessed by other users\nDETAIL:  There are 1 other session(s) using the database." [Critical,In progress]
16:10:02 <dhellmann> viktors: do you have a link?
16:10:06 <malor> ^
16:10:06 <viktors> in #link https://bugs.launchpad.net/nova/+bug/1328997
16:10:12 <dhellmann> ah, same one, ok
16:10:34 <viktors> We with malor made fixes for this bug in oslo.db, oslo-incubator, and nova.
16:11:03 <dhellmann> viktors: is this one related to the intermittent gate failures in any way?
16:11:03 <dstanek> i'd love to get https://review.openstack.org/#/c/99753/ rolling as there may be a Keystone change that depends on it
16:11:07 <malor> no that it's our bug... but it's easier to improve base opportunistic test case a bit than fix nova
16:11:29 <dhellmann> dstanek: thanks for that fix; subtle
16:11:54 <dhellmann> malor: ok
16:12:00 <malor> dhellman: 18 fails in 14 days
16:12:05 <dhellmann> we should put those reviews on our priority list for this week, team
16:12:30 <malor> dhellmann: so it's kind of an unpleasant race condition in unit tests :(
16:12:40 * bnemec already got one of them. :-)
16:12:43 <dhellmann> this is good feedback, and exactly what I was hoping to have in this section of the meetings :-)
16:12:58 * flaper87 too
16:13:07 <dhellmann> go, team! :-)
16:13:08 <viktors> links for oslo-incubator - https://review.openstack.org/#/c/99592/ oslo.db - https://review.openstack.org/#/c/99608/  nova - https://review.openstack.org/#/c/99614/
16:13:21 <dhellmann> viktors: great, thanks
16:13:35 <dhellmann> we're on a roll, anything else?
16:14:19 <dhellmann> ok, moving on then
16:14:21 <dhellmann> #topic adoption status
16:14:29 <dhellmann> I’ve started an etherpad, instead of pasting the details into the meeting logs every week
16:14:30 <dhellmann> #link https://etherpad.openstack.org/p/juno-oslo-adoption-status
16:14:47 <dhellmann> as we add libraries, we can include them on that etherpad
16:14:56 <dhellmann> a few items of note
16:14:58 <dhellmann> we are now using oslotest in oslo-incubator
16:15:12 <bnemec> \o/
16:15:20 <dhellmann> indeed
16:15:32 <dhellmann> I think that means we can stop tracking its adoption
16:15:46 <dhellmann> there are chains of patches to add oslo.messaging to neutron and heat, with reviews in process
16:16:13 <dhellmann> I think we're hindered a bit there by unrelated gate issues, but it's early enough that I'm not worried yet
16:16:30 <dhellmann> there’s a blueprint for trove, but I don’t see any patches yet, which is more worrying
16:16:40 <flaper87> yeah
16:17:00 <flaper87> I tried to follow up on that, not success yet
16:17:09 <flaper87> I asked in the blueprint and right after that, someone took the blueprint
16:17:12 <dhellmann> :-/
16:17:16 <dhellmann> well, I guess that's a start
16:17:23 <flaper87> I was giving it a week or 2 before poking people again
16:17:25 <flaper87> yeah
16:17:40 <dhellmann> ok, thanks for tracking that for us flaper87
16:17:42 <flaper87> np
16:18:08 <dhellmann> #topic oslo.db graduation status
16:18:12 <dhellmann> #info we’re ready for our first alpha release!
16:18:28 <bnemec> \o/ again
16:18:29 <dhellmann> congratulations viktors, roman, and the rest of the team
16:18:37 <flaper87> YAY!
16:18:59 <malor> yeah, let's just wait for this race fix to be merged first :)
16:19:05 <viktors> dhellman: thanks! Just after bugfix will be merged, we'll tag a release
16:19:12 <dhellmann> viktors: excellent
16:19:42 <dhellmann> I look forward to the announcement email on the openstack-dev list :-)
16:20:24 <viktors> dhellman there are a few more items in blueprint
16:20:25 <dhellmann> #topic oslo.i18n graduation status
16:20:27 <dhellmann> #undo
16:20:28 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x1e84790>
16:20:55 <dhellmann> viktors: I'm sure this is just the first of many alphas for this cycle
16:20:58 <dhellmann> :-)
16:21:13 <malor> yep :)
16:21:16 <viktors> :)
16:21:38 <viktors> we need add oslo.db to requirements and patch to manuals
16:21:55 <viktors> *link to manuals
16:22:08 <dhellmann> true
16:22:30 <dhellmann> this is a nice milestone to celebrate, though
16:22:46 <viktors> dhellman yes :)
16:23:20 <dhellmann> #topic oslo.i18n graduation status
16:23:26 <dhellmann> #info we need some more reviews on the first series of changes before we can release
16:23:44 <dhellmann> I saw some approvals, and I hope those merge over the weekend as the gate quiets down
16:23:53 <bnemec> I held off on approving some of those because of the gate stuff.
16:23:58 <dhellmann> #link https://review.openstack.org/#/c/92681/5
16:24:29 <dhellmann> yeah, I don't mind waiting a bit
16:24:55 <dhellmann> I think I've replied to the latest comments on all of those patches but I'll check again later today
16:25:33 <dhellmann> if you want to +2 and not approve, I'll keep an eye on the gate and approve them when things calm down
16:25:46 <dhellmann> I won't do that without 2 +2, of course
16:25:55 <bnemec> Yeah, that's what I've been doing.
16:26:04 <dhellmann> ok
16:26:30 <dhellmann> #topic approving specs
16:26:36 <dhellmann> I think we have 3 specs ready for approal this week
16:26:39 <dhellmann> graduate-oslo-log https://review.openstack.org/#/c/95929/
16:26:47 <dhellmann> oslo-cache-using-dogpile https://review.openstack.org/#/c/97155/
16:26:51 <dhellmann> fix-import-cycle-log-and-versionutils https://review.openstack.org/#/c/95273/
16:27:04 <dhellmann> unless anyone objects, I'll approve those later today
16:27:27 <bnemec> Dang, I still haven't gotten to the cache one.  Will try to look quick today.
16:27:52 <dhellmann> ok, I'll give you time to do that
16:28:04 <dhellmann> I added mike bayer, too, but haven't pinged him directly to ask for comments
16:28:16 <flaper87> I'd like to review the cache one too
16:28:26 <dhellmann> ok, I'll hold off on doing anything with that one until monday
16:28:31 <flaper87> since I originally worked on the oslo.cache thing and I was waiting for this rfc to show up
16:28:34 <flaper87> thanks
16:28:42 <dhellmann> bnemec, flaper87 : why don't you go -1 with a comment that you'd like a chance to look at it, so I don't forget :-)
16:28:49 <bnemec> To be clear, I don't expect to have any objections.
16:28:54 <flaper87> dhellmann: sounds good
16:29:18 <dhellmann> that's ok
16:29:46 <dhellmann> flaper87: what was the final decision on merging the text and utils libraries?
16:29:55 <morganfainberg> don't hesistate to bug me about the cache one if you have questions
16:30:03 <flaper87> dhellmann: that we would do it
16:30:15 <flaper87> I'll help dsim to write the utils rfc
16:30:20 <flaper87> and add the text part
16:30:33 <flaper87> we need to figure out how we want to split strutils, though.
16:30:42 <flaper87> I abandoned the oslo.text spec
16:31:07 <dhellmann> flaper87: ok, if you want to take over the existing utils spec and update it that would be fine with me -- you can keep me on as a contributor :-)
16:31:20 <dhellmann> I think there were 3 categories of functions in that file, let me look again
16:31:29 <flaper87> dhellmann: ok, I'll do that. Do you have the review handy ?
16:31:39 <dhellmann> https://review.openstack.org/98431
16:31:46 <flaper87> thanks
16:32:11 <dhellmann> the funcs for converting strings to ints and bools is one type
16:32:23 <dhellmann> the encode/decode functions are another
16:32:40 <dhellmann> str_to_bytes can go in the first group
16:32:54 <flaper87> yeah, I agree
16:33:00 <flaper87> we can have an oslo.utils.encoding ?
16:33:01 <dhellmann> and to_slug is sort of off on its own
16:33:08 <flaper87> for the encod things
16:33:14 <flaper87> I'll put some thoughts there
16:33:21 <flaper87> we can iterate on the spec
16:33:24 <dhellmann> yeah, maybe pull the encoding stuff out and leave the rest in strutils? or maybe just leave it all in one file, it's not that long
16:33:24 * salv-orlando apologizes for delay
16:33:25 <dhellmann> sort of a grab-bag
16:33:42 <dhellmann> ok, thanks flaper87
16:33:47 <flaper87> np :)
16:34:40 <dhellmann> I see there's a new taskflow spec from harlowja_away, too
16:34:55 <dhellmann> bnemec: did you figure out what the comment about neutron meant in the concurrency notes?
16:35:20 <bnemec> dhellmann: Not yet :-(
16:35:27 <bnemec> This week has been...complicated.
16:35:35 <dhellmann> I wonder if their version of that module has drifted from the incubated version
16:35:58 <dhellmann> ok, no rush on that one I think -- we can always address it as a follow up if we have to
16:36:02 <salv-orlando> I’m trying to catch up on eavesdrop, but which module are you taling about?
16:36:55 <dhellmann> salv-orlando: in https://review.openstack.org/#/c/97296/3/specs/juno/graduate-oslo-concurrency.rst there's a note about "some changes from the rootwrap calling code in neutron need to be added to the lib"
16:37:17 <dhellmann> we made that note at the summit, but none of us remembers the context (and I probably just typed what was said at the time)
16:38:13 <dhellmann> iirc, bnemec copied the comment directly from the etherpad into the spec, so that's literally all of the detail we have to work from :-/
16:38:23 <bnemec> yep
16:38:52 <salv-orlando> idk if these note refers to the fact that neutron was thinking about having a rootwrap daemon or something like that? idk anyway - I wasn’t at the summit
16:39:00 * salv-orlando is going to use that excuse for the next 5 months
16:39:03 <dhellmann> heh
16:39:25 <dhellmann> that's possible, although there's a separate spec to create a daemon mode for rootwrap
16:39:56 <dhellmann> maybe the thing to do is move ahead and split that issue out into a separate task
16:40:17 <salv-orlando> ok
16:40:30 <bnemec> Maybe just leave a note under Alternatives.
16:40:44 <dhellmann> yeah, something like that would work
16:41:15 <bnemec> Okay, will get that updated.
16:41:17 <dhellmann> ok, I think that's it on specs
16:41:18 * salv-orlando will look at neutron’s usage of rootwrap and will comment if he finds the differences
16:41:26 <dhellmann> excellent, thank you both
16:41:37 <dhellmann> #topic review priorities for this week
16:41:47 <dhellmann> #info items mentioned during the red flag section earlier
16:41:49 <dhellmann> #info oslo.i18n
16:41:58 <dhellmann> does anyone have anything they want added to that list?
16:42:30 <bnemec> There were the oslo.db patches.
16:42:38 <dhellmann> good point, yes
16:42:44 <dhellmann> #info oslo.db
16:43:43 <dhellmann> I won't repeat the list from above, but those bugs should be our priorities
16:44:09 <i159_> \q
16:44:13 <dhellmann> #topic open discussion
16:44:26 <dhellmann> we have a few minute left, if anyone has questions or suggestions to bring up?
16:45:39 <dstanek> i have a quick question before i tumble down the wrong path
16:45:44 <dhellmann> sure
16:46:32 <dstanek> i saw the spec for the config file validator...is it worth it to work on a spec/impl to allow services to do some level of config file validation at runtime?
16:47:22 <dstanek> i know it's not completely possible to do it a startup time because of the dynamic nature extensions, but right now there are no tools to do it either
16:47:26 <dhellmann> dstanek: I like that a little better than the stand-alone idea anyway, and there's someone else who has a blueprint (but not spec) about it
16:48:02 <dhellmann> dstanek: https://blueprints.launchpad.net/oslo/+spec/service-validation
16:48:07 <dstanek> the bp seems to be about custom validators - right now i was just going to piggyback off of the current types
16:48:27 <dstanek> i only skimmed it yesterday, so i may have missed something
16:49:08 <dhellmann> dstanek: I like the blueprint above, which allows application and library level validation that isn't tied directly to individual options, since it would let you look at options in combination to say "you can't ask for 5 foos and only give me 2 bars" or whatever
16:49:48 <dhellmann> the spec in https://review.openstack.org/93149 doesn't go that far
16:50:29 <dstanek> dhellmann: i'll read it in more detail then - i was simply thinking something like http://dpaste.com/310QG7J
16:51:02 <dstanek> i'll take a look at how my ideas match up with the spec and blueprint; then either submit my own spec or contribe to the existing
16:51:26 <dhellmann> dstanek: that sounds good -- I definitely think we can be doing more in this area, so I'm glad to see so much interest in it
16:52:05 <dhellmann> is there anything else, or shall we continue our trend of releasing early (and often)?
16:53:06 <dhellmann> going once
16:53:24 <dhellmann> going twice
16:53:55 <dhellmann> ok, thanks again for your hard work this week, everyone!
16:54:14 <malor> thanks everyone! have a nice week end!
16:54:22 <bnemec> +1
16:54:48 <dhellmann> #endmeeting