16:01:01 <dhellmann> #startmeeting oslo
16:01:01 <openstack> Meeting started Fri Jun 20 16:01:01 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:05 <openstack> The meeting name has been set to 'oslo'
16:01:05 <dhellmann> who's around for the oslo meeting?
16:01:07 <salv-orlando> aloha
16:01:12 <viktors> o/
16:01:17 <jecarey> o/
16:01:26 <dstanek> o/
16:01:29 <markmc> hey
16:01:33 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:01:43 <sileht> o/
16:01:47 <bknudson> hi
16:02:04 <dhellmann> bnemec_away told me he was likely to miss today
16:02:07 <i159> Hi
16:02:29 <dhellmann> dims, flaper87|afk, victors, rpodolyaka : ping?
16:02:49 <zzzeek> hello
16:02:49 <jd__> o/
16:02:50 <wendar> o/
16:02:53 <viktors> dhellmann: here
16:03:10 <dhellmann> ok, let's get started
16:03:17 <dhellmann> #topic review action items from previous meeting
16:03:25 <dhellmann> #info bnemec sent email to the dev list asking for liaisons to review app-agnostic-logging-parameters https://review.openstack.org/#/c/95281
16:03:30 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-June/038027.html
16:03:40 <dhellmann> I think that's it for old business
16:03:59 <dhellmann> #topic red flags from liaisons
16:04:05 <dhellmann> do we have any urgent issues this week?
16:04:16 <bknudson> can't think of anything for keystone
16:04:30 <markmc> dhellmann, hit refresh on your wiki page
16:04:42 * dhellmann reloads
16:04:45 <dhellmann> thanks, markmc
16:04:49 <markmc> np
16:04:54 * markmc just added a few things
16:05:02 <i159> so I have the blocker patch https://review.openstack.org/#/c/93398/ needed by Keystone )
16:05:03 <morganfainberg> dhellmann, o/ here as well
16:05:09 <dhellmann> hi, morganfainberg
16:05:12 <markmc> asking liasons to take a look at oslo-config-generator
16:05:27 <markmc> #link https://review.openstack.org/100946 - oslo-config-generator
16:05:31 <markmc> will get a spec up next week
16:05:33 <dhellmann> thanks, markmc
16:05:46 * dhellmann fights the cat away from his sandwich so he can type again
16:06:06 <dhellmann> we had some good feedback on https://review.openstack.org/95281 - Add spec for app-agnostic-logging-parameters
16:06:12 <dhellmann> I think I've replied to jogo's comments
16:06:15 <bknudson> I think now that oslo.db is lib keystone can make progress with i159 patches (I assume that's Ilya)
16:06:28 <dhellmann> bknudson: excellent
16:06:41 <i159> bknudson: yes it's me
16:07:27 <dhellmann> so, if the liaisons could review those two specs again, that would help us get them approved by the end of next week
16:08:01 <dhellmann> #topic adoption status
16:08:02 <dhellmann> #link https://etherpad.openstack.org/p/juno-oslo-adoption-status
16:08:26 <i159> That patch is Roman's code. Keystone could become better soon with this test case.
16:08:27 <dhellmann> it looks like there has been some progress in neutron on oslo.messaging
16:08:29 <markmc> neutron oslo.messaging, yay ihar ! :)
16:08:37 <dhellmann> indeed!
16:08:53 <salv-orlando> dhellmann: main patch merged, there is a string of minor patches to merge yet
16:08:55 <dhellmann> #info making progress on neutron/oslo.messaging
16:09:14 <salv-orlando> completion of blueprint for juno-2 is on target
16:09:14 * jogo walks in late
16:09:23 <dhellmann> salv-orlando: do you foresee any issues aside from reviewer bandwidth?
16:09:24 <dhellmann> ok, good
16:09:53 <salv-orlando> not really. And me mestery and markmcclain are regurarly reviewing these patches
16:10:06 <markmc> dhellmann, I suspect it's pretty much functionally done now
16:10:11 <markmc> i.e. neutron works with oslo.messaging
16:10:12 <dhellmann> great, that makes me happy :-)
16:10:22 <dhellmann> next up, heat
16:10:23 <markmc> the patches looks like they're just unwinding some compat layering
16:10:29 <markmc> salv-orlando, right ?
16:10:40 <salv-orlando> markmc: correct
16:10:45 <salv-orlando> the main port has been done.
16:10:47 <markmc> salv-orlando, awesome
16:11:10 <dhellmann> \o/
16:11:33 <markmc> therve asked me to look at https://review.openstack.org/#/c/100457/
16:11:42 <markmc> (Use oslo.messaging to publish log errors)
16:11:49 <markmc> suspect that's related to the heat port
16:11:52 <markmc> didn't get to it today
16:12:14 <dhellmann> ok, we should add that to our review priority list if it's blocking heat
16:13:12 <dhellmann> do we have a trove patch series, yet?
16:13:33 <markmc> not that I've seen
16:13:36 * markmc looks again
16:13:47 <dhellmann> yeah, I don't see anything attached to the blueprint
16:14:04 <markmc> oh, https://review.openstack.org/#/c/94484/
16:14:16 <markmc> "Updates RPC API to use oslo.messaging"
16:14:33 <markmc> for this blueprint? https://blueprints.launchpad.net/trove/+spec/rpc-versioning
16:14:35 <markmc> hmm
16:14:49 <dhellmann> I was looking at https://blueprints.launchpad.net/trove/+spec/oslo-messaging
16:15:32 <markmc> https://wiki.openstack.org/wiki/Trove-rpc-versioning
16:15:56 <markmc> "Get Trove on the same page w/ other projects + oslo"
16:16:05 <markmc> seems like some blueprint overlap alright
16:16:12 * markmc adds to etherpad
16:16:24 <dhellmann> yeah, I've added those links to the etherpad to make them easier to find again
16:16:30 <markmc> cool
16:17:16 <dhellmann> I think that's it for oslo.messaging, so pressing on...
16:17:19 <dhellmann> #topic oslo.db graduation status
16:17:20 <dhellmann> #info version 0.2.0 was released this week!
16:17:29 <dhellmann> congratuations victors and rpodolyaka !
16:17:31 <zzzeek> woop
16:17:31 <bknudson> when's 1.0
16:17:37 <rpodolyaka> \o/
16:17:38 <rpodolyaka> :)
16:17:39 <dhellmann> oops, viktors, sorry
16:17:45 <viktors> np :)
16:17:52 <bknudson> also, is this one good for projects to use?
16:18:07 <rpodolyaka> bknudson: it should be
16:18:10 <dhellmann> bknudson: this version is suitable for projects to start adopting, and we'll release a 1.0 at the end of this cycle
16:18:29 <i159> https://review.openstack.org/#/c/77210/ looks good here
16:18:29 <rpodolyaka> bknudson: don't hesitate do file any bugs you run into, though :)
16:18:30 <bknudson> I assume nobody's using it?
16:18:32 <dhellmann> https://wiki.openstack.org/wiki/Oslo/VersioningPolicy
16:18:35 <salv-orlando> dhellmann: good to know. Neutron has already a dev lined up for the porting.
16:18:50 <viktors> bknudson: not yet, it was release only yesterday :)
16:18:53 <dhellmann> bknudson: it's brand new, so I don't think there's anything official yet, but some projects have started working on the port
16:19:21 <bknudson> i159: were you planning to do the changes for keystone to use oslo.db?
16:19:42 * dhellmann adds oslo.db to https://etherpad.openstack.org/p/juno-oslo-adoption-status
16:19:46 <bknudson> we should probably have a spec in keystone to track it
16:20:37 <dhellmann> that makes sense
16:21:02 <zzzeek> i do have a goal to do a more deep and detailed review of oslo.db, but I’m waiting to get to it somewhat organically as I am just learning to use openstack and get into nova’s source
16:21:04 <bknudson> i159: oh, that's the review you pointed to!
16:21:11 <i159> bknudson: There is the patch which done some critical changes, which I mentioned a few lines ago
16:21:16 <viktors> bknudson: are you lookin for this i159 patch https://review.openstack.org/#/c/77210/ ?
16:21:27 <i159> bknudson: yes
16:21:32 <dhellmann> zzzeek: thanks, that's good to hear
16:21:34 <zzzeek> certainly if neutron or nova port to it that will make it easier
16:21:53 <bknudson> sweet
16:22:01 <zzzeek> i started a bit on trying to work in the transactional testing port for nova but this week I got caught up just getting better openstack run environments going
16:22:04 <bknudson> +28, -2959 is what I like to see
16:22:12 <dhellmann> :-)
16:22:29 <zzzeek> things move slowly with OS which is good b.c. this is taking awhile on my end :)
16:22:33 <i159> zzzeek: can we take this list as a plan?
16:22:48 <zzzeek> i159: when you say “this list"....
16:23:06 <i159> zzzeek: I mean Nova, Neutron
16:23:21 <zzzeek> i159: oh.   Well im looking at nova the most since it seems to be where the DB patterns originated
16:23:31 <rpodolyaka> true
16:23:46 <rpodolyaka> we are going to port Nova and Neutron to oslo.db soon
16:23:50 <zzzeek> also I get to talk to russell bryant all day and he’s on nova specifically
16:23:51 <rpodolyaka> probably next week :)
16:24:00 <zzzeek> he’s sort of my sherpa at redhat
16:24:01 <i159> so, Nova is the first candidate?
16:24:09 <viktors> no, Ironic
16:24:16 <rpodolyaka> i159: akurilin is already working on that
16:24:30 <i159> rpodolyaka: ok, I see
16:24:35 <rpodolyaka> i159: and I'm going to help with neutron
16:24:41 <dhellmann> viktors, rpodolyaka : would you help keep track of who is doing the work in each project by adding names to https://etherpad.openstack.org/p/juno-oslo-adoption-status please?
16:24:54 <viktors> dhellmann: ok, sure
16:25:01 <dhellmann> viktors: thanks
16:25:24 * dhellmann is gaining a better understanding of how ttx must feel tracking all of the openstack projects
16:25:38 <i159> viktors: Ironic already have a patch. Is it?
16:26:00 <viktors> i159: yes, see https://review.openstack.org/#/c/42159/
16:26:39 <dhellmann> is there anything else on oslo.db?
16:26:50 <bknudson> great job on this
16:26:53 <devananda> dhellmann: i've a few things, but they are at the end of the agenda, i think
16:27:09 <dhellmann> devananda: yeah, I have those on the list of review priorities
16:27:26 <dhellmann> ok, then
16:27:27 <dhellmann> #topic oslo.i18n graduation status
16:27:34 <dhellmann> It would be good to get 0.1.0 released next week, since we have so many other new libraries depending on this.
16:27:56 <dhellmann> there's one more patch I would like to land before we release, the one to fix the docs
16:28:01 <dhellmann> #link https://review.openstack.org/96961
16:28:04 <markmc> the docs look great, btw
16:28:17 <markmc> that should clear up a lot of confusion
16:28:37 <markmc> the one I came across was whether to use _() or _LE() with LOG.exception()
16:28:40 <dhellmann> yeah, we've started seeing push-back on making the logging changes, so I want to get those docs published asap
16:28:40 <markmc> I'm guessing the latter?
16:28:57 <dhellmann> it depends on whether the exception is logged and raised or just logged
16:29:04 <dhellmann> I need to make that case explicit, if I haven't already
16:29:23 <markmc> like LOG.exception(_(..)) or LOG.exception(_LE())
16:29:24 <dhellmann> basically, all _() messages will be translated, so exceptions should use those
16:29:26 <markmc> not sure that depends?
16:29:34 <dhellmann> but logging errors that aren't raised as exceptions should use _LE()
16:29:37 <dhellmann> so I guess that doesn't depend
16:29:40 <dhellmann> :-)
16:29:48 <markmc> right, the language just confused mikal I think
16:29:53 * markmc wasn't totally sure either
16:29:59 <bknudson> I think LOG.exception is just a small wrapper (helper function)
16:30:02 <dhellmann> #action dhellmann clarify language about when to use _() vs. _LE()
16:30:19 <bknudson> I assume it just LOG.error with exception info
16:30:32 <dhellmann> bknudson: it includes the traceback, IIRC
16:30:40 * markmc has to run
16:30:45 <bknudson> right, you can get the traceback with any LOG.xxx
16:30:47 <dhellmann> thanks, markmc
16:30:49 <markmc> dhellmann, figure I'll do a1 of oslo.messaging early next week
16:30:51 <morganfainberg> dhellmann, ++
16:30:59 <dhellmann> markmc: ok
16:31:13 <dhellmann> bknudson: true
16:31:52 <bknudson> since it logs at error I'd expect _LE()
16:32:23 <dhellmann> bknudson: we have some places where people build a message, log an exception, then raise. For that case, they need to use _(). Otherwise, use _LE().
16:32:51 <dhellmann> I'll add some more examples to the docs
16:33:09 <dhellmann> #topic release review
16:33:18 <dhellmann> We have 4 libraries ready for new releases. I’ve been holding off until the alpha release publishing stuff was working, but I think we’re ready to go now.
16:33:28 <dhellmann> make that 5, since markmc added oslo.messaging
16:33:36 <dhellmann> I set up etherpads to track the release notes for each library
16:33:45 <dhellmann> #info stevedore 1.0.0.0a1
16:33:45 <dhellmann> #link https://etherpad.openstack.org/p/stevedore-1.0.0
16:33:45 <dhellmann> #info oslotest 1.1.0.0a1
16:33:45 <dhellmann> #link https://etherpad.openstack.org/p/oslotest-1.1.0
16:33:46 <dhellmann> #info oslo.config 1.4.0.0a1
16:33:47 <dhellmann> #link https://etherpad.openstack.org/p/oslo.config-1.4.0
16:33:48 <dhellmann> #info oslosphinx 2.2.0.0a1
16:33:49 <dhellmann> #link https://etherpad.openstack.org/p/oslosphinx-2.2.0
16:34:13 <dhellmann> #info oslo.messaging 1.4.0a1
16:34:14 <dhellmann> #link https://etherpad.openstack.org/p/oslo.messaging-1.4.0
16:34:33 <dhellmann> we will have lots of opportunities to make more alphas, so I don't think there's any need to hold these up
16:34:41 <dhellmann> are there any other releases we should be planning for monday?
16:34:59 <dhellmann> for example, are we ready for another oslo.db? :-)
16:35:38 <viktors> not yet )
16:35:46 <dhellmann> ok, I would have been surprised if you said yes :-)
16:35:47 <rpodolyaka> we haven't merged anything new, I think
16:36:15 <dhellmann> I have mentioned the impending releases during the release meeting this week, but liaisons keep an eye out for any issues that might come up with the new versions in your projects
16:36:34 <dhellmann> we haven't fixed up the cross-project unit test gating, so that's where I would expect issues to surface
16:37:05 <dhellmann> any questions from liaisons on that?
16:38:02 <dhellmann> ok, then, let's talk about review priorities
16:38:04 <dhellmann> #topic review priorities for this week
16:38:10 <dhellmann> #info db migration test issues (devananda)
16:38:14 <dhellmann> #link https://bugs.launchpad.net/ironic/+bug/1327397
16:38:15 <uvirtbot> Launchpad bug 1327397 in nova "No notice given when db migrations are not run due to missing engine" [Low,Fix committed]
16:38:25 <flashgordon> if there are any issues that arise in the gate from the alphas don't forget to file elastic-recheck patches
16:38:39 <dhellmann> flashgordon: good point, thanks for the reminder
16:38:42 <devananda> dhellmann: that one ^ is still present in oslo.db, afaict
16:39:05 <dhellmann> devananda: ok
16:39:11 <devananda> dhellmann: because tests iterate over self.engines, without concern to whether that's an empty list
16:39:16 <viktors> this shuld be fixed by patch https://review.openstack.org/#/c/93424/ , but at the moment Ironic use it's own implementation, instead of oslo code
16:39:17 <dhellmann> is there a patch in progress for it?
16:39:32 <dhellmann> #link https://review.openstack.org/#/c/93424/
16:39:56 * devananda adds taht to his review queue
16:39:58 <dhellmann> viktors: are the implementations very different?
16:40:40 <viktors> at the moment - almost equal, but we suppose to use "opportunistic" approach in the future
16:40:52 <viktors> so this path refactors migration tests
16:40:55 <devananda> ironic and nova migration test code is very similar to oslo-incubator code
16:41:01 <dhellmann> viktors: ok, as long as we don't hold up fixing it for a feature addition
16:41:17 <viktors> yes, because ironic ann oslo took this code from nova
16:41:35 <viktors> devananda: ^
16:41:39 <dhellmann> makes sense
16:41:59 <devananda> second bug there is also coming from the same inherited code - https://bugs.launchpad.net/nova/+bug/1328997
16:42:01 <uvirtbot> Launchpad bug 1328997 in nova "Unit test failure: openstack_citest" is being accessed by other users\nDETAIL:  There are 1 other session(s) using the database." [Critical,In progress]
16:42:14 * dhellmann didn't notice those were different numbers
16:42:20 <viktors> this bug  was caused, by different approaches in the database testing in Nova
16:42:30 <devananda> i believe that that is *not* fixed in oslo.db - only a partial fix was landed
16:42:35 <devananda> but I can not change the bug status
16:42:57 <rpodolyaka> this will be fixed by https://review.openstack.org/#/c/93424/ too
16:43:02 <viktors> we need to use opportunistic migration test for Nova db migrations to get this bug totally closed
16:43:07 <i159> It should be fixed with opportunistic approach
16:43:13 <devananda> see my discussion with viktors on https://review.openstack.org/#/c/99614/
16:43:15 <dhellmann> I changed the bug status to triaged
16:43:58 <dhellmann> viktors: so patch 93424 will fix both of those bugs?
16:44:01 <devananda> so while these two bugs affect(ed) nova and ironic, I'm not sure what other projects inherited their db migration test code from oslo-incubator - -I suspect any project which did that will be affected
16:44:30 <devananda> and wanted to raise that question to ya'll who might know better than I what other projects use the common test code
16:44:41 <viktors> dhellmann: we have fix in Ironic and nova code and workaround in oslo.db code
16:44:44 <dhellmann> devananda: I'm sure that's right. The shortest path to the fix might be to put this in oslo.db, and then update the projectss to use oslo.db instead of the broken incubator version
16:45:11 <devananda> dhellmann: that's fair, if projects are willing to make that switch soon
16:45:15 <i159> dhellmann: with a high probability
16:45:35 <devananda> dhellmann: fwiw, as soon as ya'll tell me that oslo.db is stable, and I have a couple hours to play with it, i think ironic can switch to it
16:45:40 <dhellmann> devananda: I'm trying to minimize the number of syncs we have to do, too, since those tend to drag on.
16:45:49 <devananda> dhellmann: indeed
16:45:53 <dhellmann> devananda: it should be stable enough to start that work now
16:46:10 <rpodolyaka> yeah, it's no really different from the incubator code
16:46:16 <dhellmann> viktors, we don't anticipate any API changes, right? just improvements and fixes underneath?
16:46:39 <dhellmann> right, it's not a new implementation, just new packaging, fixes, etc.
16:46:41 <viktors> dhellmann: yes, just  improvements and fixes
16:46:52 <devananda> great. but i dont want to derail this meeting into "when should ironic switch" -- we were talking about bugs :)
16:46:58 <dhellmann> hep
16:47:01 <dhellmann> yep
16:47:15 <dhellmann> I have a few more items to raise before we close out
16:47:16 <dhellmann> #info notifier middleware security fix
16:47:21 <dhellmann> #link https://review.openstack.org/#/c/100414/
16:47:39 <dhellmann> oh, hey, that merged when I wasn't looking :-)
16:48:01 <dhellmann> liaisons, if your project uses the notifier middleware and not oslo.messaging, you should look at ^^
16:48:17 <dhellmann> actually, that's a backport, so you probably want it for havana anyway
16:48:24 <dhellmann> there's also an icehouse version of the patch
16:48:34 <dhellmann> #info log handler for oslo.messaging notifier (blocking heat)
16:48:38 <dhellmann> #link https://review.openstack.org/#/c/100457/
16:48:46 <dhellmann> markmc mentioned that one earlier, but repeating here for the meeting logs
16:48:51 <dhellmann> #info oslo.i18n docs
16:48:55 <dhellmann> #link https://review.openstack.org/96961
16:49:00 <dhellmann> that's another repeat
16:49:12 <dhellmann> does anyone else have anything they would like to add to the review priority list?
16:50:12 <dhellmann> silence means "no" :-)
16:50:13 <dhellmann> #topic open discussion
16:50:22 <dhellmann> Since we’re spread out across many different time zones, I want to mention a tool I’ve found useful.
16:50:31 <dhellmann> ZNC is an “IRC bouncer” that you can run on a cloud server, and then connect to as though it was a regular IRC server.
16:50:47 <dhellmann> It can monitor channels even when you are disconnected, so when you reconnect you see messages people left when you were not online — especially if they mention your nickname.
16:50:48 <dhellmann> #link http://wiki.znc.in/ZNC
16:50:58 <dhellmann> If you combine ZNC with the practice of asking for something specific instead of just pinging people, it makes IRC much more useful.
16:51:21 <zzzeek> id mention it is often run from docker or some other container as it can kind of be a security point of failure
16:51:36 <dhellmann> that's good to know
16:52:57 <dhellmann> I think we're done for today, then.
16:53:29 <dhellmann> thanks, everyone!
16:53:40 <zzzeek> lates
16:54:04 <dhellmann> #endmeeting