#openstack-meeting-alt: oslo

Meeting started by dims_ at 16:01:08 UTC (full logs).

Meeting summary

  1. Review action items from previous meeting (dims_, 16:02:56)
  2. Report from Sprints/ParisJuno2014 (dims_, 16:05:30)
  3. Red flags for/from liaisons (dims_, 16:08:50)
    1. https://review.openstack.org/104400 (dhellmann, 16:14:11)

  4. Exception filtering proposal (dims_, 16:19:08)
  5. Adoption status (dhellmann, 16:27:31)
    1. https://etherpad.openstack.org/p/juno-oslo-adoption-status (dhellmann, 16:27:31)
    2. marconi has adopted oslo.i18n (dhellmann, 16:28:28)
    3. glance use of oslo.i18n up for review https://review.openstack.org/#/c/105453/ (dhellmann, 16:28:41)
    4. the fix to allow alpha releases to be added to the requirements list is up for review (dhellmann, 16:29:30)
    5. https://review.openstack.org/#/c/106125/ (dhellmann, 16:29:30)
    6. that fix is actually merged (dhellmann, 16:29:47)
    7. ACTION: dhellmann poke the reviews for adding alpha versions of oslo libs to global requirements (dhellmann, 16:30:13)

  6. Approved specs (dhellmann, 16:30:54)
    1. oslo.utils - https://review.openstack.org/#/c/98431/ (dhellmann, 16:30:54)
    2. rootwrap daemon mode - https://review.openstack.org/#/c/94613/ (dhellmann, 16:30:54)
    3. taskflow conditional execution - https://review.openstack.org/#/c/98946/ (dhellmann, 16:30:54)

  7. Nearly approved specs (dhellmann, 16:31:36)
    1. greenio executor for oslo.messaging - https://review.openstack.org/#/c/104792/ (dhellmann, 16:31:36)
    2. redis backend for taskflow - https://review.openstack.org/#/c/105298/ (dhellmann, 16:31:36)
    3. AMQP 1.0 driver for oslo.messaging - https://review.openstack.org/#/c/96729/ (dhellmann, 16:31:37)
    4. scoping for atoms and flows - https://review.openstack.org/#/c/100048/ (dhellmann, 16:31:38)

  8. Specs needing review (dhellmann, 16:32:53)
    1. cross-service profiling changes in oslo.messaging - https://review.openstack.org/#/c/103825/ (dhellmann, 16:33:17)
    2. https://review.openstack.org/#/c/105796/2/specs/juno/oslo-messaging-server-main-loop/main_loop_current.uml (Alexei_987, 16:39:06)

  9. oslo.utils graduation status (dhellmann, 16:40:34)
    1. https://blueprints.launchpad.net/oslo/+spec/graduate-oslo-utils (dhellmann, 16:40:44)
    2. http://git.openstack.org/cgit/openstack/oslo.utils (dhellmann, 16:40:44)

  10. oslo.serialization graduation status (dhellmann, 16:42:03)
    1. https://blueprints.launchpad.net/oslo/+spec/graduate-oslo-serialization (dhellmann, 16:42:03)

  11. oslo.concurrency graduation status (dhellmann, 16:43:25)
    1. https://blueprints.launchpad.net/oslo/+spec/graduate-oslo-concurrency (dhellmann, 16:43:25)

  12. Release review (dhellmann, 16:45:19)
    1. oslo.i18n 0.1.0 (dhellmann, 16:45:36)
    2. https://etherpad.openstack.org/p/oslo-i18n-1.0.0 (dhellmann, 16:45:36)
    3. oslo.vmware 0.4.0 (dhellmann, 16:45:37)
    4. http://lists.openstack.org/pipermail/openstack-dev/2014-July/039230.html (dhellmann, 16:45:37)
    5. oslosphinx 2.2.0.0a2 (dhellmann, 16:45:37)
    6. https://etherpad.openstack.org/p/oslosphinx-2.2.0 (dhellmann, 16:45:38)
    7. pbr 0.9.0 (dhellmann, 16:45:39)
    8. http://lists.openstack.org/pipermail/openstack-dev/2014-July/039481.html (dhellmann, 16:45:40)
    9. oslo.config 1.4.0.0a2 (dhellmann, 16:45:41)
    10. http://lists.openstack.org/pipermail/openstack-dev/2014-July/040013.html (dhellmann, 16:45:42)
    11. oslo.messaging 1.4.0.0a3 (dhellmann, 16:45:43)
    12. http://lists.openstack.org/pipermail/openstack-dev/2014-July/039669.html (dhellmann, 16:45:44)
    13. oslo.db 0.3.0 (dhellmann, 16:45:45)
    14. http://lists.openstack.org/pipermail/openstack-dev/2014-July/039738.html (dhellmann, 16:45:46)

  13. review priorities for this week (dhellmann, 16:48:40)
    1. db migration test issues (devananda) (dhellmann, 16:48:51)
    2. https://review.openstack.org/#/c/93424/ (dhellmann, 16:48:51)
    3. oslo.utils changes needed to allow a release (dhellmann, 16:57:13)


Meeting ended at 17:01:18 UTC (full logs).

Action items

  1. dhellmann poke the reviews for adding alpha versions of oslo libs to global requirements


Action items, by person

  1. dhellmann
    1. dhellmann poke the reviews for adding alpha versions of oslo libs to global requirements


People present (lines said)

  1. dhellmann (131)
  2. dims_ (42)
  3. flaper87 (41)
  4. zzzeek (31)
  5. devananda (13)
  6. Alexei_987 (12)
  7. beekneemech (10)
  8. rpodolyaka (6)
  9. openstack (4)
  10. jogo (3)
  11. uvirtbot (2)
  12. i159 (2)
  13. markmc (1)
  14. viktors (1)


Generated by MeetBot 0.1.4.