#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:11 UTC (full logs).

Meeting summary

  1. Review action items from previous meeting (dhellmann, 16:01:33)
  2. Red flags for/from liaisons (dhellmann, 16:03:17)
    1. ACTION: viktors, rpodolyaka, zzzeek to prepare report about db driver-specific exceptions caught in integrated and incubated projects and what changes will be needed to handle the new wrapped exceptions from oslo.db (dhellmann, 16:12:30)

  3. Adoption status (dhellmann, 16:13:54)
    1. https://etherpad.openstack.org/p/juno-oslo-adoption-status (dhellmann, 16:14:00)
    2. ACTION: dhellmann approach the other integrated projects who have not started work on oslo.i18n (dhellmann, 16:16:34)

  4. Spec status (dhellmann, 16:18:39)
    1. pylockfile adoption - https://review.openstack.org/#/c/102202/ (jd__) - team needs to vote on adopting the lib (dhellmann, 16:18:48)
    2. ACTION: jd__ post about pylockfile adoption to the mailing list (dhellmann, 16:20:23)
    3. policy configuration directories - https://review.openstack.org/#/c/104157/ - needs review (dhellmann, 16:20:34)

  5. Moving openstack/pycadf to the (proposed) TripleA program (dolphm) (dhellmann, 16:25:41)
    1. https://review.openstack.org/#/c/108739/ (dolphm, 16:27:10)
    2. ACTION: dolphm start discussion on the mailing list to get feedback from the oslo team about taking over pycadf library (dhellmann, 16:36:02)

  6. oslo.utils graduation status (dhellmann, 16:38:15)
    1. https://review.openstack.org/#/q/status:open+project:openstack/oslo.utils,n,z (dhellmann, 16:38:21)

  7. oslo.serialization graduation status (dhellmann, 16:40:38)
    1. https://review.openstack.org/108861 (dhellmann, 16:40:46)

  8. oslo.concurrency graduation status (dhellmann, 16:41:48)
  9. Release review (dhellmann, 16:53:53)
    1. oslo.rootwrap 1.3.0.0a1 - https://etherpad.openstack.org/p/oslo-rootwrap-1.3.0 (dhellmann, 16:53:54)
    2. oslo.messaging 1.3.1 - bug fix release for ceilometer team (dhellmann, 16:53:54)
    3. oslo.messaging 1.4.0.0a4 - https://etherpad.openstack.org/p/oslo.messaging-1.4.0 (dhellmann, 16:53:54)

  10. review priorities for this week (dhellmann, 16:55:07)
    1. oslo.utils release blockers (dhellmann, 16:55:07)
    2. https://review.openstack.org/#/q/status:open+project:openstack/oslo.utils,n,z (dhellmann, 16:55:07)
    3. oslo.i18n doc updates (dhellmann, 16:55:07)
    4. https://review.openstack.org/#/q/project:openstack/oslo.i18n+is:open,n,z (dhellmann, 16:55:07)

  11. meeting next week (dhellmann, 16:56:22)
    1. meeting next week cancelled (dhellmann, 16:58:56)

  12. open discussion (dhellmann, 16:59:18)
    1. dhellmann's email address is changing from doug.hellmann@Dreamhost.com to doug@doughellmann.com (dhellmann, 16:59:18)


Meeting ended at 17:01:53 UTC (full logs).

Action items

  1. viktors, rpodolyaka, zzzeek to prepare report about db driver-specific exceptions caught in integrated and incubated projects and what changes will be needed to handle the new wrapped exceptions from oslo.db
  2. dhellmann approach the other integrated projects who have not started work on oslo.i18n
  3. jd__ post about pylockfile adoption to the mailing list
  4. dolphm start discussion on the mailing list to get feedback from the oslo team about taking over pycadf library


Action items, by person

  1. dhellmann
    1. dhellmann approach the other integrated projects who have not started work on oslo.i18n
  2. dolphm
    1. dolphm start discussion on the mailing list to get feedback from the oslo team about taking over pycadf library
  3. rpodolyaka
    1. viktors, rpodolyaka, zzzeek to prepare report about db driver-specific exceptions caught in integrated and incubated projects and what changes will be needed to handle the new wrapped exceptions from oslo.db
  4. viktors
    1. viktors, rpodolyaka, zzzeek to prepare report about db driver-specific exceptions caught in integrated and incubated projects and what changes will be needed to handle the new wrapped exceptions from oslo.db
  5. zzzeek
    1. viktors, rpodolyaka, zzzeek to prepare report about db driver-specific exceptions caught in integrated and incubated projects and what changes will be needed to handle the new wrapped exceptions from oslo.db


People present (lines said)

  1. dhellmann (150)
  2. beekneemech (27)
  3. dolphm (24)
  4. zzzeek (21)
  5. bknudson (18)
  6. YorikSar (18)
  7. dims (11)
  8. viktors (10)
  9. amrith (7)
  10. rpodolyaka (4)
  11. i159 (4)
  12. openstack (3)
  13. morganfainberg (1)
  14. salv-mobile (1)
  15. jecarey (1)


Generated by MeetBot 0.1.4.