#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:12 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Oslo (dhellmann, 16:00:27)

  1. Review action items from previous meeting (dhellmann, 16:02:15)
    1. viktors, rpodolyaka, zzzeek to prepare report about db driver-specific exceptions caught in integrated and incubated projects and what changes will be needed to handle the new wrapped exceptions from oslo.db. (dhellmann, 16:02:50)
    2. https://etherpad.openstack.org/p/sqla_exceptions_caught (dhellmann, 16:02:50)
    3. https://review.openstack.org/#/c/108935/ is merged in keystone (bknudson, 16:04:08)
    4. ACTION: dhellmann approach the other integrated projects who have not started work on oslo.i18n (dhellmann, 16:04:46)
    5. jd__ post about pylockfile adoption to the mailing list (dhellmann, 16:05:01)
    6. http://lists.openstack.org/pipermail/openstack-dev/2014-June/038387.html (dhellmann, 16:05:01)
    7. https://review.openstack.org/#/c/102202/ (dhellmann, 16:05:01)
    8. ACTION: dolphm start discussion on the mailing list to get feedback from the oslo team about taking over pycadf library (DONE) (dhellmann, 16:06:07)
    9. http://lists.openstack.org/pipermail/openstack-dev/2014-July/041269.html (dhellmann, 16:06:07)
    10. https://review.openstack.org/#/c/109664/ (dhellmann, 16:06:59)

  2. Red flags for/from liaisons (dhellmann, 16:07:31)
    1. ACTION: bknudson file a bug about timeutils mocking issue (dhellmann, 16:14:50)
    2. https://review.openstack.org/#/c/112337/ (bknudson, 16:15:43)

  3. Adoption status (dhellmann, 16:21:00)
    1. https://etherpad.openstack.org/p/juno-oslo-adoption-status (dhellmann, 16:21:00)

  4. Spec status (dhellmann, 16:26:26)
    1. jd__’s pylockfile spec will be approved, as we just discussed. (dhellmann, 16:26:33)
    2. boris-42’s osprofiler spec approval will depend on the outcome of the QA/Rally team discussion about where the profiling code should live. (dhellmann, 16:26:39)
    3. https://review.openstack.org/#/c/104691/ (boris-42, 16:28:48)
    4. gordc's oslo.middleware spec is related to a repo that was already imported (dhellmann, 16:35:28)
    5. https://review.openstack.org/#/c/110353/3/specs/juno/graduate-oslo-middleware.rst (dhellmann, 16:35:28)
    6. http://git.openstack.org/cgit/openstack/oslo.middleware (dhellmann, 16:35:28)
    7. AGREED: we will have a temporary freeze on approving new specs to concentrate on the graduation work and reviews already in process (dhellmann, 16:41:15)

  5. Graduation status (dhellmann, 16:41:29)
    1. https://review.openstack.org/#/c/112666/ (dhellmann, 16:41:42)
    2. ACTION: everyone review the repo being imported as oslo.concurrency (dhellmann, 16:41:42)
    3. oslo.serialization has been imported (dhellmann, 16:43:54)
    4. http://git.openstack.org/cgit/openstack/oslo.serialization (dhellmann, 16:43:55)
    5. oslo.utils 0.1.1 was released since the last meeting (dhellmann, 16:45:17)

  6. oslo.db (dhellmann, 16:46:11)
  7. Adding functional tests for Oslo libs (dhellmann, 16:49:07)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-March/thread.html#31387 (dhellmann, 16:49:07)
    2. http://lists.openstack.org/pipermail/openstack-dev/2014-July/thread.html#41057 (dhellmann, 16:49:07)

  8. future spec process changes (dhellmann, 16:52:56)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-August/042157.html (dhellmann, 16:52:56)

  9. review priorities for this week (dhellmann, 16:55:27)
  10. open discussion (dhellmann, 16:58:47)


Meeting ended at 17:00:28 UTC (full logs).

Action items

  1. dhellmann approach the other integrated projects who have not started work on oslo.i18n
  2. dolphm start discussion on the mailing list to get feedback from the oslo team about taking over pycadf library (DONE)
  3. bknudson file a bug about timeutils mocking issue
  4. everyone review the repo being imported as oslo.concurrency


Action items, by person

  1. bknudson
    1. bknudson file a bug about timeutils mocking issue
  2. dhellmann
    1. dhellmann approach the other integrated projects who have not started work on oslo.i18n
  3. UNASSIGNED
    1. dolphm start discussion on the mailing list to get feedback from the oslo team about taking over pycadf library (DONE)
    2. everyone review the repo being imported as oslo.concurrency


People present (lines said)

  1. dhellmann (160)
  2. bknudson (26)
  3. beekneemech (24)
  4. YorikSar (19)
  5. rpodolyaka (14)
  6. boris-42 (10)
  7. zzzeek (10)
  8. i159 (4)
  9. openstack (3)
  10. sileht (1)
  11. jecarey (1)


Generated by MeetBot 0.1.4.