16:00:15 <dimsum_> #startmeeting oslo
16:00:16 <openstack> Meeting started Fri Aug 22 16:00:15 2014 UTC and is due to finish in 60 minutes.  The chair is dimsum_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:19 <openstack> The meeting name has been set to 'oslo'
16:00:22 <rpodolyaka> o/
16:00:28 <dimsum_> hi all
16:00:45 <YorikSar> Hi
16:00:47 <zzzeek> o/ and also what is the origin of o/.  i mean, :) is intuitive.  o/ ? is that like a handtruck ?  a musical note ?
16:00:55 <viktors> hi!
16:00:58 <bnemec> o/
16:01:11 <bknudson> hi
16:01:13 <YorikSar> zzzeek: It's like a raised hand :)
16:01:15 <bnemec> zzzeek: o/ is a little stick figure man waving :-)
16:01:20 <zzzeek> oh yes, very clear
16:01:21 <zzzeek> :)
16:01:52 <dimsum_> dhellmann is travelling today, fyi
16:01:58 <dimsum_> #topic Review action items from previous meeting
16:02:05 <bknudson> is still trying to figure out why everyone colon - close parenthesis?
16:02:23 <bnemec> bknudson: ;)
16:02:27 <dimsum_> Anyone have things to bring up from the action items from previous meeting?
16:02:58 <dimsum_> k let's switch topics
16:03:00 <dimsum_> #topic Red flags for/from liaisons
16:03:27 <dimsum_> any liaisons around today?
16:03:30 <bknudson> trying to switch keystoneclient to use oslo proved to be more complicated than just using it.
16:03:41 <zzzeek> what defines a “liaison” exactly ?
16:03:46 <zzzeek> im I a liaison ?
16:03:57 <bknudson> so I'm not sure that I'll be able to get that done for juno.
16:04:19 <dimsum_> zzzeek: point people from large projects like nova, glance etc
16:04:24 <zzzeek> dimsum_: OK
16:04:27 <bknudson> but I'll keep working on it from time to time. I think I know what I need to do for it.
16:04:32 <YorikSar> zzzeek: https://wiki.openstack.org/wiki/Oslo/ProjectLiaisons
16:04:53 <dimsum_> bknudson: how can we help? any pending bugs/reviews?
16:04:55 <zzzeek> hooray! im not a liasion
16:05:03 <dimsum_> zzzeek: :)
16:05:19 <bknudson> let me see... there might be a change in requirements.
16:05:39 <dimsum_> bknudson: oslo.utils and oslo.i18n have been rev'ved up in requirements
16:06:03 <bknudson> the issue is that if I try to use it in keystoneclient then it gets used in stable testing
16:06:17 <bknudson> so now oslo.utils needs to be in stable requirements
16:06:42 <dimsum_> bknudson: ah. has someone logged a review already?
16:06:56 * zzzeek would like to point out that a sofa delivery which was expected 2 hours from now has just arrived, and has to step away
16:06:59 <bknudson> I think mriedem has one
16:07:16 <dimsum_> bknudson: thanks. switching topics
16:07:22 <zzzeek> but if i may AFK with, please approve these patches!  https://review.openstack.org/#/q/status:open+project:openstack/oslo.db+branch:master+topic:use-dispatch-for-engine-init,n,z
16:07:33 <dimsum_> zzzeek: ack
16:07:56 <dimsum_> #action cores to look at zzzeek's patches   https://review.openstack.org/#/q/status:open+project:openstack/oslo.db+branch:master+topic:use-dispatch-for-engine-init,n,z
16:08:08 <dimsum_> #topic oslo.concurrency graduation status
16:08:15 <viktors> dimsum_, zzzeek ok, will do )
16:08:17 <dimsum_> bnemec around?
16:08:23 <bnemec> dimsum_: Yep
16:08:45 <dimsum_> bnemec: any updates? anyone helping you?
16:08:49 <bnemec> Need to finish up https://review.openstack.org/#/c/116126/
16:08:52 <viktors> sorry, I had a few time for review on this week (
16:09:01 <bnemec> YorikSar took care of switching to oslo.utils.
16:09:10 <YorikSar> We had some progress on oslo.concurrency. CRs switching it to oslo libs are almost done....
16:09:11 <dimsum_> viktors: ack, not an issue :)
16:09:21 <dimsum_> YorikSar, bnemec nice
16:09:37 <bnemec> I think there may be some other work that needs to be done before release (moving the config opts to a concurrency group, for example).
16:10:14 <dimsum_> bnemec ok, will watch out for reviews
16:10:18 <YorikSar> bnemec: Yes, there is a lot of work ahead - cleaning up processutils, fixing tests, etc.
16:10:50 <dimsum_> YorikSar: bnemec - have a etherpad or something?
16:11:13 <dimsum_> for tracking TODO's
16:11:17 <bnemec> Probably should track it in the bp whiteboard.
16:11:25 <YorikSar> dimsum_: There are TODOs in bp
16:11:37 <YorikSar> dimsum_: But they might not cover everything.
16:12:07 <dimsum_> ok thanks, i'll let you both figure it out :) if you do need help with items, please holler
16:12:23 <dimsum_> #topic oslo.serialization graduation status
16:12:42 <dimsum_> couple of reviews left i think
16:12:53 <dimsum_> 3 reviews merged yday
16:13:01 <bnemec> All of my infra changes merged, so that side of things should be ready.
16:13:07 <dimsum_> bnemec: nice
16:13:20 * bnemec should update the bp whiteboard
16:13:33 <dimsum_> let's shoot for a release next week bnemec?
16:14:01 <bnemec> Without looking at the todo list, that sounds reasonable. :-)
16:14:05 <dimsum_> #action bnemec and dims to try get oslo.serialization out next week
16:14:07 <dimsum_> lol
16:14:24 <dimsum_> #topic oslo.utils release review
16:14:34 <dimsum_> Anyone have issues with oslo.utils?
16:14:52 <bknudson> other than the issue with using it in keystoneclient.
16:14:56 <dimsum_> i have a review in oslo-incubator to switch it to oslo.utils (utcnow issues in keystone, nova)
16:15:01 <dimsum_> bknudson: ack
16:15:16 <bknudson> dimsum_: that review in oslo-incubator would make it so we can't use it in keystoneclient.
16:15:27 <dimsum_> i believe YorikSar was asking about keeping test cases for code that moved into libraties
16:15:51 <YorikSar> dimsum_: Yes, I think tests should stay with libraries.
16:15:56 <bknudson> i.e., we won't be able to update oslo-incubator in keystoneclient until the issue with stable branches gets resolved.
16:16:16 <bnemec> bknudson: So we should prioritize getting that resolved?
16:16:30 <bknudson> yes, I think that can get resolved.
16:16:34 <bnemec> Otherwise it sounds like oslo.utils adoption is blocked.
16:16:49 <bknudson> https://review.openstack.org/#/c/114844/ was the requirements review, which is +A
16:16:56 <dimsum_> #action dims to chase oslo.utils adoption in stables branches
16:17:10 <bknudson> so now I need to figure out how to get the update to keystone requirements.
16:17:44 <bknudson> which is this one: https://review.openstack.org/#/c/114846/
16:17:47 <YorikSar> bknudson: It should be done with incubator update
16:18:02 <bknudson> but I'm trying to figure out the review comments.
16:18:32 <bknudson> and was waiting on the requirements update anyways.
16:18:45 <dimsum_> bknudson: ack, will discuss with dhellmann about this
16:18:59 <dimsum_> switching topics
16:19:03 <dimsum_> #topic oslo.db release fallout
16:19:14 <dimsum_> is Manila back on its feet?
16:19:22 <viktors> dimsum_: yes
16:19:28 <dimsum_> viktors: nice
16:19:36 <dimsum_> Anyone else broken?
16:19:50 <viktors> dimsum_: seems, no
16:20:03 <dimsum_> viktors: glad to hear. any other issues with the release?
16:20:20 <dimsum_> (that we should be fixing in next rev of oslo.db)
16:20:59 <dimsum_> moving on
16:21:02 <dimsum_> #topic Adoption status
16:21:13 <viktors> dimsum_:  aliasons didn't informed me :)
16:21:34 <dimsum_> viktors: i hear you
16:22:03 <viktors> dimsum_: by the way
16:22:17 <dimsum_> yes
16:22:26 <viktors> dimsum_: should we set min and max release versions in projects reqiurements?
16:22:40 <bnemec> viktors: No max.
16:22:46 <bnemec> If we can help it anyway.
16:22:48 <viktors> bnemec: why?
16:22:52 <dimsum_> viktors: yes, no max, just min
16:23:12 <bnemec> People forget to update the max when there's a new release and then we end up way behind without realizing it.
16:23:28 <bknudson> are you planning a backwards incompatible change?
16:23:32 <bnemec> If a new version is broken then we have to version cap temporarily, but in general we don't want to.
16:23:37 <viktors> bnemec: imo, openstack proposel bot will bump the version
16:23:43 <dimsum_> viktors: getting new stuff in will get hard
16:23:48 <viktors> and then we will fix issues (if any)
16:23:48 <bnemec> viktors: But someone has to update it in global-requirements.
16:24:17 <bnemec> And if all we're going to do is "release -> update global-requirements" then we might as well not cap at all.
16:25:15 * viktors want this - https://review.openstack.org/#/c/85487/
16:25:15 <rpodolyaka> I guess viktors' point is more like - we need a way to test everyting works correctly before we *tag* a new release
16:25:16 <dimsum_> getting core reviews and +2's from other projects is very hard :(
16:25:54 <bnemec> Yeah, we have a cross-testing problem still.
16:25:57 <bknudson> the master branch should be testing against all the projects
16:26:14 <rpodolyaka> is someone working on this?
16:26:39 <bnemec> I suspect it's blocked on infra resource limits lately.
16:26:43 <rpodolyaka> :(
16:26:53 <dimsum_> we need dhellmann's view anyways
16:26:55 <viktors> :(
16:27:06 <bnemec> Adding the cross-test matrix is going to increase the number of nodes we use quite a bit.
16:27:16 <viktors> afaik, it's dhellmann's proposal
16:27:47 <dimsum_> #action raise this topic again next week - Better way to test oslo.libs releases don't break consuming projects
16:27:48 <viktors> bnemec: can we run these tests at least on demand ?
16:27:49 <bnemec> Yeah, so he'd be the one to talk to about it.
16:28:18 <bnemec> viktors: You should be able to use the run_cross_tests.sh script to do it manually.
16:28:40 <bnemec> I don't think there's any way to do it in the gate right now.
16:28:44 <viktors> bnemec: hm, looks like I missed something
16:29:13 <viktors> bnemec: can I fins this script somewhere?
16:29:17 <viktors> *find
16:29:57 <dimsum_> #link https://github.com/openstack/oslo-incubator/blob/master/tools/run_cross_tests.sh
16:30:06 <bnemec> Hmm, it's missing from oslo.db.
16:30:24 <viktors> dimsum_: thanks, will look at it
16:30:33 <bnemec> So yeah, you'll want to sync the script dimsum_ linked.
16:30:37 <dimsum_> switching topics?
16:30:50 <dimsum_> going once
16:30:53 <viktors> bnemec: seems, yes
16:31:07 <dimsum_> #topic Review priorities for this week
16:31:29 <dimsum_> zzzeek: already mentioned he needed reviews, anyone else?
16:31:32 <bnemec> viktors: Like this: https://github.com/openstack/oslo.concurrency/blob/master/openstack-common.conf#L7
16:31:50 * bnemec catches up
16:32:01 <dimsum_> #action viktors to look at merging run_cross_tests.sh in oslo.db
16:32:14 <viktors> dimsum_: ok
16:32:46 <dimsum_> switching topics...
16:32:51 <dimsum_> #topic open discussion
16:33:13 <YorikSar> That was fast
16:33:25 <dimsum_> Summer is ending here, kids are going to school in a week :)
16:33:52 <YorikSar> My rootwrap daemon mode patches landed.
16:34:04 <dimsum_> YorikSar: nice!
16:34:07 <YorikSar> So I guess we'll have new rootwrap release soon
16:34:19 <dimsum_> YorikSar: pinged ttx yet?
16:35:02 <dimsum_> bnemec: you still on for chairing next week?
16:35:07 <YorikSar> dimsum_: He pinged me about it. I'll have to verify that this code works with my Neutron patches and then I'll ask him to do release.
16:35:11 <bnemec> dimsum_: Yep
16:35:19 <dimsum_> YorikSar: cool
16:35:42 <dimsum_> #info benemec to chair the meeting in 1 week
16:36:13 <dimsum_> YorikSar: do ping dhellmann before you cut a release. he likes to know
16:36:27 <YorikSar> dimsum_: Sure.
16:36:39 <dimsum_> zzzeek: back yet?
16:37:12 <bknudson> must be a big couch
16:37:15 <dimsum_> :)
16:37:56 <dimsum_> if there isn't anything else...let's call it a wrap
16:38:15 <dimsum_> fyi, i'll be out the tail end of next week (quick trip to cape cod)
16:38:34 <dimsum_> bye for now
16:38:36 <dimsum_> #endmeeting