16:01:09 <bnemec> #startmeeting oslo
16:01:09 <openstack> Meeting started Fri Aug 29 16:01:09 2014 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:13 <openstack> The meeting name has been set to 'oslo'
16:01:31 <bnemec> Who have we got today?
16:01:42 <bknudson> me
16:01:45 <i159> o/
16:01:46 <rpodolyaka> o/
16:01:48 <kgiusti> o/
16:01:49 <viktors> hi!
16:01:56 <tedross> here
16:02:27 <bnemec> \o everyone
16:02:46 <YorikSar_> o/
16:02:57 <bnemec> dhellmann_ is unavailable again this week, so you're stuck with me. :-)
16:03:01 <bnemec> #topic Review action items from previous meeting
16:03:10 <bnemec> dhellmann approach the other integrated projects who have not started work on oslo.i18n
16:03:28 <bnemec> Postponed until rc timeframe.
16:03:40 <bnemec> This is probably not going to happen until K at this point.
16:03:52 <bnemec> dimsum_ propose patch adding mask_password to oslo.utils.strutils
16:04:00 <bknudson> some are using oslo.i18n and some are not?
16:04:07 <bnemec> I think dims is out today too.
16:04:24 <bnemec> bknudson: I think so.
16:04:28 <zzzeek> o/
16:05:01 <YorikSar> bnemec: I think that has already been merged
16:05:19 <bnemec> YorikSar: Oh, right.  I think I knew that. :-)
16:05:26 <bnemec> So we'll call that one done.
16:05:36 <bnemec> make sure oslo.concurrency is in the graduating libs query for the dashboard
16:05:59 <bnemec> dhellmann_ tells me this is done too.  All of the oslo.* libraries should be included now automatically.
16:06:17 <bnemec> cores to look at zzzeek's patches https://review.openstack.org/#/q/status:open+project:openstack/oslo.db+branch:master+topic:use-dispatch-for-engine-init,n,z
16:06:38 <zzzeek> jsut that one left
16:06:58 <bknudson> do I have to change keystone?
16:07:10 <bnemec> Okay, so good progress on that one.
16:07:21 <bnemec> bknudson: For which part?
16:07:32 <bknudson> use-dispatch-for-engine-init
16:07:42 <zzzeek> bknudson: how so
16:08:22 <bknudson> I haven't been following the changes so don't know if it's changing something in the initialization?
16:08:37 <zzzeek> bknudson: it is, within oslo.db, it uses a different system to organize how the engine is set up
16:08:52 <zzzeek> bknudson: shoudln’t have impacts on how that engine behaves
16:08:53 <bnemec> It's not intended to be visible to users though, right?
16:08:55 <bknudson> pl
16:08:57 <bknudson> ok
16:09:11 <zzzeek> bknudson: the most major change is that last one, where we change how the sqlite driver does begin/commit, so that savepoints work
16:10:06 <bnemec> So no changes should be needed.  If any issues come up contact zzzeek?
16:10:12 <zzzeek> bnemec: yup
16:10:18 <bnemec> Awesome
16:10:31 <bnemec> bnemec and dims to try get oslo.serialization out next week
16:10:43 <bnemec> Done: http://lists.openstack.org/pipermail/openstack-dev/2014-August/044172.html
16:10:55 <bnemec> dims to chase oslo.utils adoption in stables branches
16:11:08 <bknudson> I'm not sure that projects are going to want to be switching to the library this late in the release cycle.
16:11:40 <bnemec> Yeah, we might have to leave that one on the agenda for next week, and see if we still want to pursue that.
16:12:18 <bnemec> raise this topic again next week - Better way to test oslo.libs releases don't break consuming projects
16:12:28 <bnemec> I suspect we want to defer this discussion again.
16:12:50 <bnemec> dhellmann_ should probably be here for it, and I believe the cross-testing work has been pushed back to K now.
16:13:03 <bnemec> viktors to look at merging run_cross_tests.sh in oslo.db
16:13:12 <viktors> I tested run_cross_tests.sh script, it works fine for me, if I run test on a single project. But I'd like to have a some tool, which will run tests on all (or only integrated?) projects. Something like `tox -e cross-project-tests` Anyway, test for all integrated projects will take a few hours locally :(
16:13:42 <bnemec> Yeah, it takes a while.
16:13:56 <bnemec> viktors: So is run_cross_tests.sh in oslo.db now at least?
16:13:59 <bknudson> it's tempest or unit tests?
16:14:10 <rpodolyaka> viktors:  well, it's better than nothing ;)
16:14:16 <bnemec> bknudson: Unit tests
16:14:31 <viktors> bnemec: no, I'll add it today or in monday
16:14:58 <bnemec> I think tempest should already be running against master everything.
16:15:00 <viktors> its not a silver-bullet fo me (
16:15:15 <bnemec> viktors: Okay, I'll leave that one on for next week too.
16:15:20 <bnemec> #action viktors to look at merging run_cross_tests.sh in oslo.db
16:15:25 <YorikSar> We should have Zuul verifying every new release
16:15:54 <viktors> YorikSar: +1
16:15:57 <YorikSar> Like run devstack jobs with it, for example.
16:16:14 <YorikSar> And probably all python* jobs for all projects...
16:16:39 <bnemec> YorikSar: Yeah, I think that's the oslo.libs release item.
16:16:46 <bnemec> Will keep that one for next week too.
16:16:48 <YorikSar> And if we go this way we might want to run it for new libs from outside as well.
16:16:57 <bnemec> #action Better way to test oslo.libs releases don't break consuming projects
16:17:21 <bnemec> YorikSar: Yeah, that's getting into the "CI the world" discussion that actually goes beyond Oslo.
16:17:26 <viktors> consuming projects == integrated projects?
16:17:32 <viktors> or incubated also?
16:18:03 <bnemec> Probably just integrated to start.
16:18:15 <bnemec> If we can figure that out then we can look into adding more.
16:19:25 <bnemec> Okay, Mike's patches:
16:19:36 <zzzeek> OK the hot item here is the blueprint
16:19:39 <bnemec> per-test-run provisioning: https://review.openstack.org/#/c/110486/ - a late request to rework the whole approach to use testresources has come in, and it is probably a good idea
16:19:39 <bnemec> patches: engine setup, listener overhaul: https://review.openstack.org/#/q/status:open+project:openstack/oslo.db+branch:master+topic:use-dispatch-for-engine-init,n,z
16:19:42 <zzzeek> https://review.openstack.org/#/c/117335/
16:20:07 <bnemec> Phew 556 lines :-)
16:20:08 <zzzeek> everyone get on the blueprint, i need to add some things and we can all agree on what we’re building
16:20:17 <zzzeek> well i triued to just push the patches through
16:20:33 <zzzeek> but!  complaints :)
16:20:45 <zzzeek> definitely big enough to be a blueprint item.  but the code is simpler than the descriptoin
16:20:53 <rpodolyaka> :)
16:21:02 <bnemec> #action Everyone review https://review.openstack.org/#/c/117335/
16:21:23 <bnemec> zzzeek: Anything else?
16:21:27 <zzzeek> theres this library testresources, it’s robert collins’ thing, it is definitely clever but i think a little crazy.  but he’s on board w/ helping, im totally fine using it if everyone else is
16:21:52 <zzzeek> that’s my big push right now, otehr than that im really doing sqla upstream performance things and want to start presenting those soon
16:22:04 <zzzeek> as oslo.db recipes/etc but thats defintiely not juno stuff
16:22:22 <bnemec> Cool, sounds good.
16:22:36 * bnemec needs to read up on testresources
16:22:42 <zzzeek> yeah read the source :)
16:22:49 <zzzeek> its all in __init__.py of course :)
16:22:54 <bnemec> Heh
16:22:57 <bknudson> we use it in python-keystoneclient tests
16:23:14 <zzzeek> bknudson: yup. he wants to patch it in a special way though so it runs across the whole set of tests
16:23:16 <bknudson> although the keystoneclient tests don't need it as much as a db would
16:23:33 <zzzeek> bknudson: which we need.  so that we can optimize tests across modules.  needs the latest testtools version (e.g. a requirements bump)
16:23:35 <zzzeek> so it’s a big deal
16:24:03 <zzzeek> i had the whole thing working of course….but sure, testresources is much more luxury
16:24:04 <zzzeek> :)
16:25:12 <bnemec> Okay, sounds like we know what direction we're headed there at least.
16:25:39 <bnemec> #topic Red flags for/from liaisons
16:25:51 <bnemec> Anything this week?
16:25:53 <bknudson> none from keystone.
16:26:06 <bnemec> I would imagine this section will be getting quieter as the adoptions slow down late in the cycle.
16:26:14 <bknudson> other than, as I said earlier, not sure if we'll be able to do anymore
16:26:53 <bknudson> apparently we did a poor job of oslo.i18n and didn't switch to _LI, etc
16:27:02 <bknudson> so I don't know when the translation cutoff is.
16:27:11 <bnemec> Yeah, I think that's fine.  We weren't expecting to get all of the libs adopted this cycle.  Getting them graduated so they can be adopted early in K was more the plan.
16:27:22 <zzzeek> does kilo start officially after the france summit that i have to miss?
16:27:46 <bnemec> I believe Kilo actually kicks off a bit before Summit.
16:27:50 <zzzeek> ok
16:28:24 <bknudson> probably a question for ttx as to when we'll have stable branches
16:28:50 <bnemec> Yeah, so Juno is scheduled to release Oct. 16: https://wiki.openstack.org/wiki/Releases
16:29:27 <bknudson> 9/4 is string freeze.
16:29:43 <bnemec> Coming right up then.
16:30:03 <bnemec> bknudson: So your concern was that you adopted oslo.i18n but didn't switch to the new translation markers?
16:30:23 <bknudson> bnemec: right, so we've got a bunch of translations that are unnecessary.
16:30:29 <bknudson> e.g., the debug logs
16:31:30 <bnemec> Ah, okay.  I don't think that's the end of the world, it just means the Keystone translators won't be able to prioritize as well.
16:32:38 <bnemec> So that'll be a good change early in Kilo.
16:32:45 <bnemec> Anything else on this topic?
16:33:18 <bnemec> Moving on then.
16:33:22 <bnemec> #topic Please review proposed changes to our incubator deprecation policy and respond on the ML
16:33:31 <bnemec> #link http://lists.openstack.org/pipermail/openstack-dev/2014-August/044360.html
16:34:04 <bnemec> This is the proposal that we cut a stable branch early in the cycle and then delete the graduating libs from master.
16:34:08 <bnemec> (IIRC)
16:34:25 * bnemec still needs to give that thread a serious read
16:34:45 <bnemec> So everyone please take a look and respond with any comments.
16:34:57 <bnemec> #topic Adoption status
16:35:37 <bnemec> Probably not going to be a lot of activity on this for a while too.
16:36:27 <bnemec> #topic Graduation status
16:36:39 <bnemec> oslo.serialization is done!
16:36:40 <bnemec> \o/
16:36:53 <bnemec> oslo.concurrency is underway still.
16:37:04 <bnemec> And I think we just approved the oslo.middleware graduation spec.
16:37:24 <bnemec> Did I miss anything?
16:39:22 <bnemec> #topic Release review
16:39:30 <bnemec> I think the only one this week was oslo.serialization
16:39:43 <bnemec> At least that's the only one I can find an announcement for since last week
16:40:50 <bnemec> #topic review priorities for this week
16:41:06 <bnemec> blueprints and bugs targeted for juno
16:41:06 <bnemec> taskflow, oslo.db, and pbr all need extra love!
16:41:06 <bnemec> updating the graduation status of our libs: https://review.openstack.org/#/q/status:open+project:openstack/oslo-incubator+branch:master+topic:update-graduation-status,n,z
16:41:16 <kgiusti> o/
16:41:25 <bnemec> Let me see if I can find a link for the blueprints and bugs for juno.
16:41:44 <bnemec> Ah, also the AMQP 1.0 driver in oslo.messaging
16:41:50 <kgiusti> :D
16:42:46 <kgiusti> my last pushed review updates busted jenkins, fixing now.
16:42:56 <bnemec> #link https://review.openstack.org/#/c/75815/
16:43:17 <kgiusti> hoping this can be released as EXPERIMENTAL for juno-3
16:43:46 <kgiusti> CI test is blocked on bare-f20 node support: https://review.openstack.org/#/c/117397/
16:44:19 <kgiusti> but Ian's been pretty positive of the test itself: https://review.openstack.org/#/c/115752/
16:44:43 <bnemec> Yeah, on that front there's been some discussion in the mailing list thread about how to handle the different driver states.
16:44:45 <bnemec> #link http://lists.openstack.org/pipermail/openstack-dev/2014-August/044175.html
16:46:15 <bnemec> Approved blueprints for juno:
16:46:18 <bnemec> #link https://blueprints.launchpad.net/oslo-incubator/juno
16:46:31 * bnemec should have collected these links before the meeting
16:47:39 <bnemec> I think this is the bugs targeted for juno
16:47:41 <bnemec> #link https://bugs.launchpad.net/oslo/?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.
16:47:42 <bnemec> structural_subscriber=&field.milestone%3Alist=65960&field.milestone%3Alist=67334&field.milestone%3Alist=66209&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.
16:47:42 <bnemec> has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
16:47:47 <bnemec> Yikes
16:48:42 <bnemec> Okay, that's all of the review priorities I'm aware of.  Anyone have anything to add?
16:49:00 <i159> maybe my spec
16:49:16 <bnemec> i159: Link?
16:49:32 <bnemec> i159: Also, I think we had agreed on a soft spec freeze for Juno.
16:49:44 <i159> https://review.openstack.org/#/c/112842/
16:50:18 <i159> bnemec: I wasn't at the last meeting...
16:50:33 <i159> bnemec: so I could lost it
16:52:09 <bnemec> Okay, yeah.  See point g under Spec status: http://eavesdrop.openstack.org/meetings/oslo/2014/oslo.2014-08-08-16.00.html
16:52:31 <bnemec> i159: So unless that is critical to get in for Juno it probably isn't going to make it this cycle.
16:53:21 <i159> bnemec: yep...
16:54:14 <bnemec> Okay, anything else?
16:54:59 <bnemec> #topic open discussion
16:55:19 <bnemec> We have about five minutes if there's anything anyone wants to bring up.
16:56:31 <kgiusti> o/ - any thoughts on where the best place to document oslo.messaging driver stuff?
16:56:58 <kgiusti> in regards to that driver discussion on the -dev list.
16:58:03 <kgiusti> is this something normally published in the oslo.messaging wiki?
16:58:07 <bnemec> kgiusti: Probably something that would end up in http://docs.openstack.org/developer/oslo.messaging/
16:58:33 <bnemec> Which is generated from http://git.openstack.org/cgit/openstack/oslo.messaging/tree/doc/source
16:58:52 <kgiusti> +1 thanks!
16:59:20 <bnemec> I guess the only thing would be that that's developer-oriented docs.
17:00:25 <bnemec> I'll have to see if I can find anything in the user docs about messaging.  I have to think we mention the different drivers somewhere.
17:00:44 <bnemec> #action bnemec to find user docs for messaging
17:01:00 <bnemec> Okay, that's all the time we have for today.
17:01:03 <bnemec> Thanks everyone!
17:01:06 <bnemec> #endmeeting