16:00:12 <dhellmann> #startmeeting oslo
16:00:12 <dhellmann> our agenda is in the wiki, as usual:
16:00:12 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
16:00:12 <dhellmann> who’s here for the oslo meeting?
16:00:13 <openstack> Meeting started Fri Sep  5 16:00:12 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:16 <openstack> The meeting name has been set to 'oslo'
16:00:19 <beekneemech> o/
16:00:22 <zzzeek> o/
16:00:25 <jecarey> o/
16:00:27 <tedross> o/
16:00:49 <dhellmann> dimsum_, flaper87 : ping?
16:00:53 <flaper87> o/
16:00:58 <dimsum_> o/
16:00:59 <kgiusti> o/
16:01:02 <beekneemech> brb
16:01:30 <i159> o/
16:01:30 <dhellmann> first, thanks to dimsum_ and beekneemech for leading the meetings the past couple of weeks while I was traveling
16:01:47 <bknudson> hi
16:01:49 <dimsum_> very welcome :)
16:02:00 <dhellmann> I think we have quorum, so let's get started
16:02:02 <dhellmann> #topic Review action items from previous meeting
16:02:16 <dhellmann> I think most of these were covered, but I want to be sure
16:02:24 <dhellmann> #info bnemec and dims to try get oslo.serialization out next week
16:02:33 <dhellmann> we're blocked on that still, I think (more later)
16:02:39 <dhellmann> #info dims to chase oslo.utils adoption in stables branches
16:02:56 <dhellmann> dimsum_, is this the thing about updating the incubator?
16:03:18 <dimsum_> dhellmann: yep
16:03:29 <dhellmann> ok, more on that later, too, I think
16:03:36 <bknudson> here's my attempt on icehouse for keystone -- https://review.openstack.org/#/c/114845/
16:03:40 <dhellmann> #info viktors to look at merging run_cross_tests.sh in oslo.db
16:03:46 <bknudson> blocked... they requested something about a change to devstack.
16:03:54 <dhellmann> bknudson: yeah, we're going to have a long talk about that in a bit
16:04:06 <dhellmann> viktors: any update?
16:04:07 <viktors> dhellmann: I'm still supoose, that this script will not fix the testing issue
16:04:24 <dhellmann> ok, I pushed the larger testing discussion to next week so we have time for some release stuff today
16:04:34 <morganfainberg> dhellmann, bknudson, if that isn't really blocked i'm happy to see that go in. but i was holding off until we decided how to handle Ihar's comment.
16:04:38 <viktors> dhellmann: IMO, it should be extended in incubator, at least
16:04:40 <viktors> dhellmann: ok
16:05:09 <dhellmann> ok, I think that covers the actions from last week that aren't postponed to next week
16:05:13 <dhellmann> did I miss anything?
16:05:47 <dhellmann> ok, moving on then
16:05:48 <dhellmann> #topic Feature Freeze Exceptions
16:05:53 <dhellmann> #info AMQP 1.0 driver for oslo.messaging was given an FFE
16:06:06 <kgiusti> yay!
16:06:07 <dhellmann> that was our only FFE request, and wasn't too controversial
16:06:32 <dhellmann> kgiusti: good work so far!
16:06:46 <kgiusti> thanks all for the help.
16:06:56 <flaper87> indeed, thanks for working on the driver and especiallyy for taking care of all the gate/test things
16:06:57 <kgiusti> docs in progress.
16:06:59 <dhellmann> is the blueprint up to date with the remaining work needed? I'm not sure what we want to do to track the stuff that has to happen in the distros
16:07:19 <kgiusti> I can add status about that.
16:07:33 <kgiusti> I'm in touch with the qpid packaging guy.
16:07:42 <dhellmann> kgiusti: ok, please do (ttx tends to ask me about that sort of thing in our Tuesday morning 1:1 so if you can do it by then I'd appreciate it)
16:07:54 <kgiusti> np
16:07:59 <dhellmann> cool, thanks
16:08:09 <dhellmann> ok, let's talk about the release
16:08:09 <dhellmann> #topic Other RC-1 Work
16:08:28 <dhellmann> I started an etherpad to try to track the *critical* changes we want to make sure we get in for our releases
16:08:28 <dhellmann> #link https://etherpad.openstack.org/p/juno-oslo-feature-freeze
16:08:43 <dhellmann> please don't just add every little thing there, just the things we would consider blockers
16:08:51 <dhellmann> that said, please do add things :-)
16:09:40 <flaper87> I think probably oslotests is one of the most importants in that least
16:09:46 <flaper87> I don't mean to say the rest is not important
16:09:50 <dhellmann> I haven't started including any bugs. We can handle those by updating their targets in launchpad
16:10:04 <flaper87> but I'd probably put more focus on the issues related to that one
16:10:06 <dhellmann> flaper87: yep, we have most (all?) of those changes merged and I'm going to break my rule and do a release this afternoon
16:10:09 <beekneemech> oslotest should be just about done.
16:10:21 <flaper87> right
16:10:25 <dhellmann> I think we're waiting for one last merge, unless it happened when I wasn't watching
16:10:32 <flaper87> dhellmann: the never release on fridays rule?
16:10:36 <flaper87> :D
16:10:39 <dhellmann> yes, that one :-)
16:10:56 <bknudson> you're setting yourself up for a busy weekend.
16:11:35 <dhellmann> yeah, but I'd rather have to fix a bug or two than lose 2 days of time for other merges to happen :-/
16:11:45 <dhellmann> I can always revert a change if I have to
16:12:28 <dhellmann> speaking of losing 2 days...
16:12:29 <dhellmann> #topic finishing the juno libraries
16:12:55 <dhellmann> I audited the libs we have against the steps in CreatingANewLibrary and found some steps we had missed
16:12:58 <dhellmann> #link https://docs.google.com/spreadsheets/d/1MvXsg0XxPonJ8yAFSraIwHM940eAfoXhfBVRa6hN7MY/edit#gid=0
16:13:14 <dhellmann> most of the missing work is in other repositories, but we do have some documentation to update, too
16:13:22 <dhellmann> dimsum_ has already started a bunch of that work
16:13:43 * dims_ apologies for flaky network
16:14:31 <dhellmann> we need to be careful that we don't have a lot of projects adopting libs that aren't set up for gate testing, so liaisons keep an eye on that before you submit changes to your projects
16:14:41 <dhellmann> (line 18)
16:15:07 <dhellmann> oh and line 7
16:15:49 <beekneemech> ack
16:16:00 <dhellmann> if you don't have edit rights on that spreadsheet and would like to help track, send me your google id privately and I'll invite you after the meeting
16:16:30 <dhellmann> overall we're in pretty good shape, and the WIP items are not surprises, but let's not rush adoption
16:16:35 <dhellmann> questions about the data?
16:16:52 <flaper87> none from me
16:16:53 <beekneemech> Are we still pushing adoption?
16:17:04 <dhellmann> oh, the doc stuff on lines 27-30 is incomplete
16:17:15 <beekneemech> I thought at this poitn in the cycle we'd be holding off on that anyway.
16:17:15 <dhellmann> beekneemech: at this point, I think not. Only oslo.db in nova, AFAIK
16:17:20 <beekneemech> ok
16:17:32 <dhellmann> they got a FFE for that work because it fixes some of the bugs nova had
16:17:52 <beekneemech> Yeah, I think mriedem mentioned that.
16:18:24 <bknudson> let's start the rush for k-1
16:18:40 <YorikSar> dhellmann: Can I edit that table? oslo.concurrency had Python 3 job and it's voting.
16:18:47 <dhellmann> yes, I would like to finish the libs we have started in juno so that projects can adopt them for k-1
16:19:06 <dhellmann> YorikSar: fixed, and send me your google id so I can add you to the editors list
16:19:18 <YorikSar> dhellmann: yorik.sar@gmail.com
16:19:32 <dhellmann> sent
16:19:58 <dhellmann> has anyone spotted anything else we should fix right away?
16:20:42 <dhellmann> YorikSar: if those python 3 tests pass, does that mean you're not using oslotest?
16:20:59 <viktors> :)
16:21:04 <YorikSar> dhellmann: last requirements update didn't land
16:21:08 <dhellmann> ok
16:21:17 <YorikSar> dhellmann: So waiting for new oslotest release
16:21:29 <dhellmann> that should be later today
16:21:33 <dhellmann> ok, let's move on then
16:21:37 <dhellmann> #topic Summit Planning
16:21:51 <dhellmann> this came up on the mailing list, but it bears repeating:
16:21:56 <dhellmann> We won't have the proposal system this time around, so we need to brainstorm topics and discuss on the mailing list.
16:21:56 <dhellmann> #link https://etherpad.openstack.org/p/kilo-oslo-summit-topics
16:22:24 <bknudson> I think we'll all just be wandering around the summit chatting.
16:23:01 <dhellmann> we're probably not going to have time to do "status" sessions as we have in the past, so we need to be focused on sessions that will help us make decisions or sort out who is going to do some of the work next cycle
16:23:18 <dhellmann> bknudson: heh, we actually asked ttx to give us more time between sessions for that :-)
16:23:37 <flaper87> I wouldn't dedicate a session to the ZMQ thing
16:23:45 <flaper87> lets just say it in the mailing list
16:23:53 <flaper87> that it'll be deprecated and move on
16:24:15 <bknudson> morganfainberg: were you interested in the "Obfuscation / encryption of config option" ?
16:24:26 <morganfainberg> bknudson, yeah.
16:24:27 <bknudson> I wound up not having time to work on this in J.
16:24:39 <dhellmann> we have some time to think of topics (several weeks) but I wanted to give everyone lots of time
16:24:57 <morganfainberg> bknudson, definitely interested. but it was a "it'd be cool to have" not "omg must have" for J.
16:25:03 <dhellmann> flaper87: right, that might be what we do, but this lets us record the decision to do that
16:25:11 <flaper87> dhellmann: +1
16:25:27 <dhellmann> my (our?) motto for kilo is "write it down"
16:26:07 <dhellmann> ok, let's run through our libs...
16:26:07 <dhellmann> #topic oslo.serialization
16:26:23 <dhellmann> beekneemech, dims, how are we looking?
16:26:36 <dhellmann> #link https://review.openstack.org/#/q/project:openstack%2Foslo.serialization+is:open,n,z
16:27:12 <dhellmann> we're blocked on the oslotest thing, but is there anything else on that list that we must land?
16:27:48 <beekneemech> We should probably fix the namedtuple thing.
16:27:49 * dhellmann keeps mixing up oslo.serialization status with oslo.concurrency status and is appreciating the irony of that
16:28:01 <beekneemech> lol
16:28:03 <dhellmann> yeah, that one should be able to merge after we fix oslotest
16:28:34 <dhellmann> #topic oslo.log
16:28:41 <dhellmann> #link https://review.openstack.org/#/q/project:openstack/oslo.log+is:open,n,z
16:29:08 <dhellmann> oh, I should mention, if you have +2 on a library and see a translation patch, that does not require 2 +2 to merge -- just go ahead and approve it
16:29:17 <dhellmann> ditto for global requirements patches
16:29:39 <dhellmann> assuming the tests pass, of course :-)
16:29:57 <beekneemech> Will do
16:30:10 <YorikSar> Me too :)
16:30:17 <dhellmann> this one is a little farther away, but I think we agreed oslo.log was a k1 target anyway so no worries
16:30:34 <dhellmann> #topic oslo.utils
16:30:42 <dhellmann> #link https://review.openstack.org/#/q/project:openstack/oslo.utils+is:open,n,z
16:31:51 <dhellmann> I think we want to remove that dependency on oslo.config
16:32:08 <dhellmann> the doc stuff would be nice to have, too
16:32:40 <dhellmann> #topic oslo.db
16:32:49 <dhellmann> viktors, how are things going?>
16:32:56 <dhellmann> #link https://review.openstack.org/#/q/project:openstack/oslo.db+is:open,n,z
16:33:38 <dhellmann> now that we're past feature freeze, we should be careful about what we merge
16:34:02 <dhellmann> be thinking about settling development down to bug fixes to prepare for a 1.0 release
16:34:09 <dhellmann> I assume we're still planning for a 1.0 this cycle?
16:34:25 <zzzeek> https://review.openstack.org/#/c/116324/ looks like the hot one
16:34:26 <viktors> dhellmann: sure, also there is was a small API fix
16:34:30 <zzzeek> because its a real bug
16:35:30 * viktors co-authored this
16:35:41 <dhellmann> zzzeek: ok, let's put that on the etherpad
16:35:57 <dhellmann> https://etherpad.openstack.org/p/juno-oslo-feature-freeze
16:36:26 <zzzeek> im trusting that viktors/ etc. are definitely sure this is the format of the execption on mariadb, mysql , :)
16:37:04 <viktors> zzzeek: now we run test on real db-s, so we can be sure (a bit)
16:37:17 <viktors> also recently folks from Nova got an issue this exceptions from oslo.db - not all SQLA exception were wrapped
16:37:32 <dhellmann> are they actually using oslo.db, or are they using the incubated version?
16:37:47 <dhellmann> we need to make sure when we talk about our code that we're clear which copy we mean :-)
16:37:53 <dhellmann> I'm guilty of that, too
16:38:00 <viktors> these was an issue with patch, thich move nova to oslo.db
16:38:18 <dhellmann> ah
16:38:34 <zzzeek> viktors: OperationalErrors are not wrapped in all cases
16:38:35 <dhellmann> will you have time to help them resolve that? does it involve any changes in oslo.db?
16:38:58 <viktors> dhellmann: yes, I did, Also IMO, we should wrap all SQLA exceptions, but I'm not sure when we should do it
16:39:11 <dhellmann> make sure there is a bug for that filed against oslo.db and targeted to next-juno, please
16:39:21 <zzzeek> viktors: is there a stack trace for this unwrapped exception somewhere ?
16:39:21 <viktors> dhellmann: ok
16:39:35 <dhellmann> viktors: wrapping all exceptions could happen in kilo, maybe?
16:40:06 <viktors> dhellmann: it's would be safer, IMO
16:40:15 <dhellmann> is there anything else on the open change list for oslo.db that we should be prioritizing for juno?
16:40:35 <viktors> zzzeek: I show you test yesterday. See also discussion in Nova - https://review.openstack.org/#/c/101901/44/nova/db/sqlalchemy/utils.py
16:40:41 <zzzeek> viktors: ok
16:41:04 <dhellmann> ok, let's keep going, we have several other libs to discuss
16:41:09 <dhellmann> #topic oslo.messaging
16:41:22 <dhellmann> we know we need a release for the amqp driver
16:41:31 <dhellmann> #link https://review.openstack.org/#/q/project:openstack/oslo.messaging+is:open,n,z
16:41:40 <dhellmann> we have a lot of other changes pending, are any of those blockers for the release?
16:42:15 <dhellmann> flaper87: do you know?
16:42:24 <flaper87> IIRC, there weren't blockers
16:42:28 <dhellmann> ok
16:42:30 <flaper87> but I'll double check
16:42:41 <dhellmann> thanks, and if you find any please add them to that etherpad
16:42:50 <flaper87> absolutely
16:42:51 <dims> flaper87: a tiny fix for ipv6 - https://review.openstack.org/#/c/119389/
16:43:10 <dims> don't know if you consider that blocking
16:43:24 <flaper87> that's cheating, that was submitted today :P
16:43:35 <flaper87> I should've said: As of yday, there weren't blockers
16:43:38 <flaper87> lemme take a look
16:43:39 <dims> heh :)
16:43:56 <dhellmann> now the topic you've all been waiting for...
16:43:57 <dhellmann> #topic oslotest
16:44:09 <dhellmann> #link https://review.openstack.org/#/q/project:openstack/oslotest+is:open,n,z
16:44:23 <dhellmann> it looks like the fix for python 3 packaging has merged
16:44:32 <dhellmann> so I will create the release right after the meeting
16:44:44 <beekneemech> \o/
16:44:51 <dhellmann> that should unblock oslo.serialization and keystone, I hope
16:45:00 * dhellmann crosses his fingers that nothing else will break
16:45:20 <dhellmann> are there any *other* issues with oslotest that we know about now?
16:45:46 <bknudson> \o\
16:46:22 <bknudson> the other fix was for the mock patch stopall
16:46:37 <dhellmann> yep, that will be in this release
16:46:38 <beekneemech> Also merged.
16:47:05 <dhellmann> ok, a few more to hit...
16:47:06 <dhellmann> ok, good, moving on then
16:47:08 <dhellmann> oops
16:47:11 <dhellmann> #topic cliff
16:47:16 <dhellmann> #info release planned for monday, long overdue
16:47:34 <dhellmann> nothing major, but we've had some bug fixes and features unreleased for a while now
16:47:42 <dhellmann> #topic pbr
16:47:42 <dhellmann> #info release planned for monday, also overdue
16:47:42 <dhellmann> same
16:47:49 <dhellmann> #topic oslo.i18n
16:47:53 <dhellmann> this is one of our new libs
16:48:06 <dhellmann> I think we're ready for a 1.0 release this cycle. Does anyone have any reason not to proceed with that?
16:48:41 * beekneemech does not
16:49:05 <dhellmann> lots of adoptions already
16:49:15 <dhellmann> cinder designate glance glance_store glance.store heat ironic keystone nova oslo.concurrency oslo.db oslo.log oslo.middleware oslo.serialization oslo.utils python-openstackclient python-saharaclient requirements sahara zaqar
16:49:41 <dhellmann> #topic stevedore
16:49:43 <dhellmann> same question
16:49:55 <dhellmann> that library has been pretty stable for almost a year now, so I don't see any issues
16:50:07 <beekneemech> +1
16:50:18 <dims> dhellmann: there were some bugs logged around tar.gz etc for stevedore
16:50:40 * dhellmann looks
16:51:24 <dhellmann> dims: ah, I think that's an artifact of our wheel publishing
16:51:31 <dims> dhellmann: ok
16:52:36 <dhellmann> #action dhellmann ensure stevedore builds universal wheels
16:53:02 <YorikSar> MemcacheClient = type('MemcacheClient', (object,), dict(memcache.Client.__dict__))
16:53:09 <YorikSar> Ooops, sorry.
16:53:31 <dhellmann> heh
16:53:33 <dhellmann> #topic oslo.rootwrap
16:53:38 <dhellmann> this is also fairly stable
16:53:41 <zzzeek> heh
16:53:54 <dhellmann> we have the new server mode this release, but I think we can safely call it 1.0
16:53:59 <dhellmann> ttx: any thoughts? ^^
16:54:42 <dhellmann> #action dhellmann verify with ttx that oslo.rootwrap is still ok for a 1.0 release
16:54:45 <dhellmann> #topic oslo.utils version
16:54:57 <dhellmann> we didn't cover versioning for oslo.utils earlier
16:55:08 <dhellmann> are we ready for 1.0, or should we wait for k1?
16:55:20 <YorikSar> dhellmann: I tried my best to not touch any existing rootwrap codepaths with my work, so it should be safe to assume nothig changed there, just added a new feature.
16:55:28 <dhellmann> YorikSar: excellent
16:55:57 <dhellmann> dims, beekneemech : thoughts on oslo.utils?
16:55:57 <dims> dhellmann: ready for 1.0 (oslo.utils)
16:56:01 <dhellmann> ok
16:56:12 <dhellmann> #info oslo.utils will be released as 1.0 this cycle
16:56:21 <dhellmann> I hate to rush this last one
16:56:21 <dhellmann> #topic when to branch stable/juno (or proposed)
16:56:44 <dhellmann> we talked about doing this early, and we have a couple of changes we need to land in the incubator before we can
16:57:08 <dhellmann> see "blocking branching oslo-incubator for rc-1" near the top of https://etherpad.openstack.org/p/juno-oslo-feature-freeze
16:57:25 <dhellmann> when that jsonutils fix backport lands in the incubator, I will talk to ttx about branching
16:57:42 <dims> dhellmann: sounds good to me
16:57:44 <dhellmann> it will probably be juno/proposed rather than stable/juno, because the stable branches use different acls
16:58:09 <dhellmann> at that point, we can start submitting changes to remove anything we graduated in this cycle, so go ahead and start preparing those patches for your libs now :-)
16:58:26 <beekneemech> git rm ftw :-)
16:58:33 <dhellmann> my favorite command
16:58:50 <dhellmann> #topic review priorities for this week
16:58:56 <dhellmann> see the etherpad linked several times above
16:59:04 <dhellmann> and bug fixes on our normal dashboard view
16:59:15 <dhellmann> remember, don't merge any new features not approved for a FFE
16:59:32 <dhellmann> #topic open discussion
16:59:35 <dhellmann> < 1 min left
16:59:51 <dhellmann> if you have anything you need to bring up, we can continue talking in #openstack-oslo
17:00:14 <dhellmann> otherwise, nice job on the feature freeze this week, everyone!
17:00:24 <dims> w00t!
17:00:31 <beekneemech> Yay us!
17:01:05 <dhellmann> #endmeeting