16:00:20 <beekneemech> #startmeeting oslo
16:00:22 <openstack> Meeting started Fri Oct 17 16:00:20 2014 UTC and is due to finish in 60 minutes.  The chair is beekneemech. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:26 <openstack> The meeting name has been set to 'oslo'
16:00:41 <beekneemech> dhellmann is travelling today, so you're all stuck with me. :-)
16:00:59 <beekneemech> Who's here for the meeting?
16:01:09 <jecarey_> o/
16:01:18 <kgiusti> o/
16:01:26 <viktors> o/
16:01:27 <sileht> o/
16:01:39 <GheRivero> o/
16:01:58 <beekneemech> dimsum_: jd__ ping
16:02:05 <harlowja_at_home> \o
16:02:20 <dimsum_> oy
16:02:22 <sileht> jd__ is travelling too
16:02:32 <beekneemech> sileht: Thanks
16:02:47 <beekneemech> Okay, we'll get started then.
16:02:57 <beekneemech> #topic Review action items from previous meeting
16:03:04 <beekneemech> dhellmann ask bknudson and morganfainberg to provide more detail for config encryption plans
16:03:33 <morganfainberg> o/
16:03:37 <beekneemech> bknudson: morganfainberg: Did ^ happen?
16:03:43 <morganfainberg> did what happen?
16:03:47 <morganfainberg> config encryption?
16:03:53 <morganfainberg> don't think it has yet
16:03:57 <zzzeek_> o/
16:04:10 <bknudson> hi... showing up late
16:04:10 <morganfainberg> afaik there is legiitmate interest in it though
16:04:29 <bknudson> I haven't had time to look at config encryption
16:04:38 <beekneemech> Hmm, okay.
16:05:06 <beekneemech> We'll come back to that in the summit topics then.
16:05:09 <bknudson> ok
16:05:14 * dimsum_ notes vmware nova driver needs password encrypted in nova.conf as well
16:05:31 <beekneemech> That's all we had for action items from last week, so we'll move on to the summit topic discussion since that went long last week.
16:05:32 <bknudson> why?
16:06:05 <bknudson> (why would vmware need it but other passwords are ok?)
16:06:47 <dimsum_> bknudson: one more use case. everyone needs it :)
16:07:14 <beekneemech> #topic summit planning
16:07:21 <beekneemech> Okay, we'll start with that one then.
16:07:28 <beekneemech> #link https://etherpad.openstack.org/p/kilo-oslo-summit-topics
16:08:20 <beekneemech> bknudson: morganfainberg: Okay, so I think the main question from last time was whether we need a summit topic for config encryption or if that can be handled with a spec.
16:08:44 <bknudson> it would be nice to gather up requirements to make sure we're designing the right thing
16:09:02 <morganfainberg> bknudson, ++
16:09:10 <bknudson> I kind of know what I think we should do but maybe that's not others vision
16:09:36 <beekneemech> Well, that's also the purpose of spec reviews. :-)
16:10:04 <bknudson> if we can get that in a spec review then no session is needed.
16:10:20 <zzzeek> so im not going to be at the summit but all feel free to admire and +2 my wonderful oslo.db specs
16:10:33 <zzzeek> i am hoping to get one more up in the next few days
16:10:52 * beekneemech did
16:10:58 <rpodolyaka1> ^ +1 those :)
16:11:02 <rpodolyaka1> 'ed
16:11:05 <zzzeek> OK
16:11:08 <harlowja_at_home> i admired them, ha
16:11:51 <beekneemech> Alright, moving away from namespace packages
16:11:59 <beekneemech> Spec is up.
16:12:13 <beekneemech> Does anyone feel like we need f2f discussion on that?
16:12:27 <beekneemech> lifeless: had proposed an alternative, I know
16:12:29 <zzzeek> i wish we could use ns packages but not if it breaks everything :(
16:12:42 <beekneemech> Although I also realize it's super early Saturday morning there. :-/
16:13:08 <morganfainberg> i want namespace packages to not suck . but I'd say the right answer is move away from them :(
16:13:37 <beekneemech> I think the problem with this is that every time we think we're in the clear we find another land mine to step on.
16:14:18 <beekneemech> Maybe this could just be something for the pod discussions?
16:14:21 <beekneemech> Or hallway track.
16:14:54 <harlowja_at_home> +1 i'd like to learn more about what went wrong with them
16:14:55 <zzzeek> i think the decision is made we just have to do it
16:15:09 <beekneemech> In any case, everyone please go read the spec and if there's a lot of contention over it we could discuss it more.
16:15:30 <morganfainberg> beekneemech, link for the spec? [for the summary of the meeting]
16:15:42 <beekneemech> morganfainberg: Ah, right.
16:15:52 <beekneemech> #link https://review.openstack.org/#/c/128759/
16:15:59 <morganfainberg> beekneemech, ++
16:16:07 <beekneemech> morganfainberg: Thanks for the reminder
16:16:13 <morganfainberg> of course
16:16:43 <beekneemech> Nova objects spec is up, so we're not planning a session on that.
16:17:07 * beekneemech looks for the link
16:17:34 <beekneemech> #link https://review.openstack.org/#/c/127532/
16:17:46 <beekneemech> taskflow then
16:17:56 <beekneemech> harlowja_at_home: An update?
16:18:20 <beekneemech> *Any
16:18:34 <harlowja_at_home> nothing from me, a small session could be useful i guess
16:18:59 <harlowja_at_home> but i'm not sure if doug wanted one or not for that :-/
16:19:32 <harlowja_at_home> i see 'SESSION NEEDED' ha
16:19:34 <beekneemech> harlowja_at_home: I think he wanted a more specific topic than "all about taskflow" :-)
16:20:03 <harlowja_at_home> *oh session needed is under oslo.messaging (nm)
16:20:09 <beekneemech> harlowja_at_home: So is there discussion needed about the db and messaging topic I see linked there?
16:20:14 <beekneemech> #link https://etherpad.openstack.org/p/taskflow-oslo-db-messaging
16:20:56 <beekneemech> If there are issues blocking that adoption then I could see that being a good topic.
16:21:02 <beekneemech> Lots of oslo there. :-)
16:21:06 <harlowja_at_home> well the whole issue of 'oslo.messaging' :-P
16:21:29 <harlowja_at_home> oslo.db not really an issue (just need py3.x compat)
16:21:51 <beekneemech> harlowja_at_home: Will the oslo.messaging part be covered in the messaging session?
16:22:16 <harlowja_at_home> well i think the outcome can influence taskflows usage of it (but that outcome seems unknown currently)
16:22:38 <harlowja_at_home> so hard to cover outcomes which are unknown at this current time :)
16:23:11 <beekneemech> harlowja_at_home: Right, but you have a specific outcome you need for taskflow to adopt it, right?
16:23:24 <beekneemech> So that's input we need in the oslo.messaging session.
16:23:47 <beekneemech> If we knew the outcome of these things we wouldn't need a session. :-)
16:23:51 <harlowja_at_home> :-p
16:24:22 <harlowja_at_home> ok, i can add some inputs that might help
16:24:32 <beekneemech> I wonder if oslo.messaging needs to be a multi-session discussion...
16:24:49 <beekneemech> Seems like there's a lot to discuss there.
16:25:02 <kgiusti> +1 - I'd like to discuss testing across different rpc backends, too
16:25:18 <kgiusti> that's mentioned below, in functional testing
16:25:22 <beekneemech> harlowja_at_home: So are you okay with covering taskflow's use of oslo.messaging in that session then?
16:25:28 <harlowja_at_home> sureee
16:25:35 <beekneemech> harlowja_at_home: Cool
16:25:54 <beekneemech> kgiusti: Yep, so that's the functional testing topic, right?
16:26:12 <kgiusti> yeah, so that's already broken out, yay!
16:26:54 <beekneemech> kgiusti: I had a question in the etherpad: "Do we need a session for this or just people to sign up to work on it?"
16:27:18 <beekneemech> I don't know exactly what is needed to make progress on this.
16:27:37 <kgiusti> Actually, neither do I  - Doug added the topic, I just wanted to help out
16:27:46 <harlowja_at_home> imho i always come back to the question of what is olso.messaging providing over kombu nowadays
16:27:47 * kgiusti thinks it was doug
16:28:10 <beekneemech> Yeah, looks like it.
16:28:26 * beekneemech thinks we're going to end up with multiple oslo.messaging sessions
16:28:34 <kgiusti> and it's technically not just messaging.
16:28:42 <kgiusti> functional testing, that is.
16:28:46 <beekneemech> Right
16:29:46 <beekneemech> Okay, I'm going to mark that one as needs more detail.  We'll have to follow up with Doug on Monday.
16:30:44 <beekneemech> We had talked about maybe meeting on Monday again at the new meeting time to finalize these plans since he's not here today.
16:31:02 <beekneemech> Will that work for everyone?
16:31:18 <bknudson> what's the new meeting time?
16:31:29 <beekneemech> Let me find it...
16:32:07 <beekneemech> #link http://doodle.com/zv8izg7ymxcank34
16:32:28 <beekneemech> Based on ^ we were going to move it to Monday at 10:00 my time.
16:32:32 * beekneemech converts to UTC...
16:33:00 <beekneemech> Looks like 1600 UTC.
16:33:31 <kgiusti> works for me
16:34:02 <morganfainberg> what does that change?
16:34:06 <morganfainberg> erm when*
16:34:18 <beekneemech> morganfainberg: Not til after Summit.
16:34:22 <morganfainberg> ok
16:34:25 <morganfainberg> sounds good
16:34:38 <beekneemech> And we were planning to skip the Monday immediately after since presumably there won't be anything more to discuss.
16:35:05 <beekneemech> I'm sure we'll send out a reminder on the list.
16:36:07 <beekneemech> #action Everyone plan to meet again on Monday at 1600 UTC to finalize these plans with dhellmann
16:36:18 <beekneemech> Next topic then...
16:36:22 <bknudson> it'll be a different time for you on monday
16:36:40 <beekneemech> bknudson: Oh crud, is it DST this weekend?
16:36:51 <bknudson> I think it's time to fall back.
16:37:19 <jecarey_> I thought it was Nov 2 this year.
16:37:30 <beekneemech> Yeah, that's what Google is telling me
16:37:48 <bknudson> ok, so it's right before the meeting
16:37:50 <bknudson> summit
16:38:11 <beekneemech> So while we're all at summit.  That actually might be good. :-)
16:38:42 <beekneemech> So, What to do with the local module
16:39:11 <beekneemech> Unfortunately both of the people currently listed on this topic are travelling.
16:39:50 <beekneemech> My thought is to cover this in the graduation session, but I'm only vaguely familiar with the topic.
16:40:03 <beekneemech> dimsum_: Were you more involved in the local module discussion?
16:40:22 <dimsum_> beekneemech: off and on
16:40:55 <beekneemech> dimsum_: Do you think we need a separate session or will it fit in with the graduation discussion?
16:41:04 <beekneemech> I expect it will at least come up there.
16:41:09 <dimsum_> don't need a separate session
16:41:31 <beekneemech> dimsum_: Great, thanks
16:42:17 <beekneemech> Moving ahead to Python 3 then.
16:42:37 <beekneemech> Seems to have a lot of interest.
16:43:04 <harlowja_at_home> def +2
16:43:05 <beekneemech> I know harlowja_at_home mentioned py3 support is a blocker for taskflow adopting oslo.db.
16:43:09 <beekneemech> Heh
16:43:32 <harlowja_at_home> the crappy part is that libraries which are py3.x compat can't depend on ones that aren't :-/
16:43:45 <harlowja_at_home> especially if they plan to replace a major component
16:43:52 <beekneemech> Right, it's tricky.
16:44:36 <harlowja_at_home> so thats my interest, i'd like to use more oslo stuff, but in a rock-and-hard-place if its not py3.x
16:44:39 <beekneemech> So let's plan on having a session to hash out what needs to be done and in what order.
16:44:54 <harlowja_at_home> cool
16:44:57 <beekneemech> So far we've been kind of scattershot porting to Python 3, but it would be good to have a specific plan.
16:45:11 <harlowja_at_home> agreed
16:45:42 <beekneemech> Quota library
16:45:53 * beekneemech probably should have topic'd all of these for easier reference
16:46:14 <harlowja_at_home> i'm interested in that one
16:46:30 <beekneemech> Yeah, I see salv-orlando is too.
16:46:44 <harlowja_at_home> a quota library can be a way to start fixing all the quota in the projects
16:47:03 <beekneemech> To me the main question is where the development should live, not so much whether we should do it.
16:47:08 <harlowja_at_home> if we can unify projects interfaces to this library, that library could then talk to a central service (or other) in the future...
16:47:12 <harlowja_at_home> ah
16:47:12 <harlowja_at_home> ok
16:47:20 <salv-orlando> beekneemech: right. I just think not in a new project.
16:47:50 <beekneemech> salv-orlando: Yeah, I think it either needs to live in a project like Neutron or the incubator for easy consumption.
16:47:51 <salv-orlando> Could be directly oslo-incubator, the only caveat would be that validating into projects would be a two-step process
16:48:17 <salv-orlando> beekneemech: I was thinking of doing it for neutron in kilo, validating it there, and then contributing it back to oslo-incubator
16:48:30 <salv-orlando> but if other projects want to consume it in kilo we might do it directly in the incubator
16:48:50 <harlowja_at_home> why not immediatly create a new project, oslo_quota or something?
16:48:57 <harlowja_at_home> *new subosloproject
16:49:19 <salv-orlando> harlowja_at_home: there is actually already a quota module in oslo-incubator. Seems however nobody is using it.
16:49:37 <beekneemech> Which is funny, I could have sworn Nova was using that at one point.
16:50:04 <salv-orlando> beekneemech: maybe. I did not dig the history of that module.
16:50:13 <salv-orlando> but we can start from there maybe...
16:50:21 <harlowja_at_home> salv-orlando, sure, i'm just wondering if a fast-moving library can/could be more suitable than oslo-incubator (which then later will have to be made into a library anyway)
16:50:34 <beekneemech> Okay, so this is probably a discussion we need to have at Summit, hopefully with more stakeholders from other projects present.
16:50:55 <harlowja_at_home> agreed
16:51:13 <salv-orlando> harlowja_at_home, beekneemech: summit or even the mailing list. No reason to use precious session time maybe.
16:51:49 <beekneemech> salv-orlando: We'll keep it on the list of possibilities for now.
16:51:55 <harlowja_at_home> salv-orlando, i'd really like to have summit, there have been a trail of dead projects that have tried to fix this quota stuff, and i don't want this to turn into another dead one...
16:52:25 <harlowja_at_home> thats my 2 cents at least
16:52:30 <beekneemech> Although a mailing list thread before Summit to get the discussion going wouldn't hurt either way.
16:52:36 <salv-orlando> harlowja_at_home: I know. However usually when salv-orlando files a spec, then it gets done ;)
16:53:03 <salv-orlando> not necessarily by salv-orlando, but it gets done
16:53:07 <harlowja_at_home> salv-orlando, haha, ya, this spec just crosses many projects, those specs are 'really' hard
16:53:35 <harlowja_at_home> not hard from code point of view (imho), hard from coordiantion/political point of view
16:54:03 <salv-orlando> harlowja_at_home: ah there’s also the other thing that blazar devs will be keen to suggest you’ve got to use that
16:54:30 <harlowja_at_home> that expected to
16:54:36 <harlowja_at_home> ^ thats why this is hard ;)
16:54:37 <beekneemech> Okay, 5 minute warning.
16:54:48 <beekneemech> salv-orlando: Can you start a ML thread about this?
16:56:52 <salv-orlando> beekneemech: there is already a thread active… I’d post a link but I can’t find the browser window on my screen ;)
16:57:20 <beekneemech> salv-orlando: Heh, okay. :-)
16:57:49 <beekneemech> salv-orlando: When you find it, can you drop a link in the etherpad?
16:58:53 <salv-orlando> beekneemech: https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg36883.html
16:59:16 <beekneemech> slagle: Awesome, thanks
16:59:24 <beekneemech> salv-orlando: ^
16:59:31 <beekneemech> Sorry slagle.  Habit. :-)
16:59:43 <beekneemech> #link https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg36883.html
17:00:10 <beekneemech> #action Anyone interested in the quote topic please look at the mailing list thread linked above.
17:00:16 <beekneemech> #undo
17:00:17 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x318e550>
17:00:26 <beekneemech> #action Anyone interested in the quota topic please look at the mailing list thread linked above.
17:00:29 <beekneemech> Better
17:00:38 <harlowja_at_home> someone needs to add a __str__ to that action object, lol
17:00:53 <beekneemech> Okay, time's up, but I think Doug wanted an alpha versioning session.  Does anyone have a strong objection to that?
17:01:03 <harlowja_at_home> nope
17:01:25 <beekneemech> Okay, we'll plan on that then.
17:01:55 <beekneemech> And also to meet again on Monday at 1600 UTC to finalize these plans.  I'm not sure we've ended up with the right number of sessions yet. :-)
17:02:11 <beekneemech> Thanks everyone!
17:02:16 <zzzeek> woop
17:02:30 <beekneemech> #endmeeting