16:00:42 <dhellmann> #startmeeting oslo
16:00:43 <openstack> Meeting started Mon Nov 17 16:00:42 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:47 <openstack> The meeting name has been set to 'oslo'
16:00:49 <rpodolyaka2> o/
16:00:52 <dhellmann> Who's here for the Oslo team meeting?
16:00:58 <bknudson> hi
16:01:01 <harlowja_at_home> yo
16:01:02 <ozamiatin> o/
16:01:06 <jecarey__> hi
16:01:36 <dhellmann> bnemec, dims, flaper87, jd__, sileht: ping
16:01:38 <viktors> hi
16:01:49 <dims> pong
16:01:52 <dims> o/
16:02:00 <bnemec> Sorry, other meeting running long.
16:02:01 <dhellmann> Our agenda is in the wiki:
16:02:01 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:02:16 <GheRivero> o/
16:02:24 <jungleboyj> o/
16:02:24 <dhellmann> we have a lot to cover today, so I'm going to go ahead and get started
16:02:43 <dhellmann> please keep raising your hand if you join the meeting a couple of minutes late
16:02:46 <dhellmann> #topic Review action items from previous meeting
16:03:00 <dhellmann> this is old info, but just for the record:
16:03:02 <dhellmann> #info dhellmann send an email reminder of the time change before our next meeting - DONE
16:03:02 <dhellmann> #info beekneemech add lib name prefixes to titles for existing specs - DONE
16:03:27 <dhellmann> #topic Reviews for messaging heartbeat issue
16:03:27 <dhellmann> #link https://bugs.launchpad.net/oslo.messaging/+bug/856764
16:03:30 <uvirtbot> Launchpad bug 856764 in oslo.messaging "RabbitMQ connections lack heartbeat or TCP keepalives" [Critical,In progress]
16:03:46 <dhellmann> this bug was reported as a pretty bad issue for real production environments with HA rabbit
16:03:50 <dhellmann> sileht: it looks like there are several changes for this marked WIP, can you point out which one we should be looking at?
16:03:52 <jd__> o/
16:04:20 <dhellmann> (or maybe anyone else?)
16:04:34 <dhellmann> the bug itself appears pretty old
16:05:15 <dhellmann> #action dhellmann talk to sileht about bug 856764
16:05:17 <uvirtbot> Launchpad bug 856764 in oslo.messaging "RabbitMQ connections lack heartbeat or TCP keepalives" [Critical,In progress] https://launchpad.net/bugs/856764
16:05:32 <dhellmann> #topic Review new release instructions in Oslo/ReleaseProcess
16:05:33 <dhellmann> #link https://wiki.openstack.org/wiki/Oslo/ReleaseProcess
16:05:33 <dhellmann> I sent this request to the ML, too.
16:05:33 <dhellmann> Please take a look at the wiki page and follow up with questions on the ML so we can be sure everyone understands.
16:05:33 <dhellmann> I would like each library team to manage their own releases this cycle.
16:05:51 <sileht> o/
16:06:00 <dhellmann> ah, hi, sileht
16:06:08 <dhellmann> #undo
16:06:09 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x184a8d0>
16:06:12 <dhellmann> #undo
16:06:13 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x184afd0>
16:06:53 <dhellmann> sileht: for bug 856764, the rabbit heartbeat issue, I wasn't able to tell which patch to review from looking at the open oslo.messaging patches. Can you point out the right one?
16:06:55 <uvirtbot> Launchpad bug 856764 in oslo.messaging "RabbitMQ connections lack heartbeat or TCP keepalives" [Critical,In progress] https://launchpad.net/bugs/856764
16:07:26 <sileht> dhellmann, the only implementation that works for now (but not ready to land) : https://review.openstack.org/#/c/126330/
16:07:36 <dhellmann> ok, so that's still a WIP?
16:07:59 <dhellmann> #link https://review.openstack.org/#/c/126330/
16:08:01 <sileht> dhellmann, yes but this implementation use python thread
16:08:27 <sileht> dhellmann, if we move the heartbeat logic to the executor
16:08:38 <sileht> dhellmann, that will fix only the server side issue
16:08:58 <sileht> dhellmann, because executor is only used by a server
16:09:04 <dhellmann> good point
16:09:37 <dhellmann> ok, we're not going to have time to solve it during the meeting this week, do we need a mailing list thread or are you and Ilya working on it?
16:09:48 <i159> Hi all!
16:09:54 <i159> sorry...
16:10:14 <dhellmann> hi, i159, we're talking about bug 856746
16:10:15 <uvirtbot> Launchpad bug 856746 in phpdevshell "PHP_VERSION check bug in class.phpmailer.php" [Medium,Fix released] https://launchpad.net/bugs/856746
16:10:34 <dhellmann> her, no, bug 856764
16:10:35 <uvirtbot> Launchpad bug 856764 in oslo.messaging "RabbitMQ connections lack heartbeat or TCP keepalives" [Critical,In progress] https://launchpad.net/bugs/856764
16:10:39 <dhellmann> that's the one
16:11:01 <dhellmann> we have a lot to cover today, so maybe i159 or sileht can post a status update to the ML?
16:11:35 <sileht> dhellmann, I will do a resume on ML, on both approch and thoses issues
16:11:38 * flaper87 is back
16:11:42 <dhellmann> sileht: thanks
16:11:50 <i159> dhellmann: Ok, so it is all about https://review.openstack.org/#/c/126330/
16:12:06 <dhellmann> #action sileht post summary of the rabbit heartbeat issue to the mailing list so we can pick a solution
16:12:10 <i159> dhellmann: what is ML?
16:12:16 <dhellmann> i159: sorry, "mailing list"
16:12:24 * flaper87 has reviewed some of the heartbeat patches, there are a couple
16:12:29 <flaper87> (AFAIR)
16:12:35 * dhellmann gets out his not-lazy fingers for typing during the meeting
16:13:02 <i159> dhellmann: Yes, I write a status of the implementation today, in a few hours
16:13:20 <dhellmann> i159: ok, thanks, please coordinate with sileht so we don't start 2 threads
16:13:25 <dhellmann> lots to cover, so we need to move on
16:13:28 <dhellmann> #topic Review new release instructions in Oslo/ReleaseProcess
16:13:28 <dhellmann> #link https://wiki.openstack.org/wiki/Oslo/ReleaseProcess
16:13:28 <dhellmann> I sent this request to the ML, too.
16:13:29 <dhellmann> Please take a look at the wiki page and follow up with questions on the ML so we can be sure everyone understands.
16:13:29 <dhellmann> I would like each library team to manage their own releases this cycle.
16:13:30 <i159> *i'm going to write the status
16:14:05 * bnemec is here for real now
16:14:13 <dhellmann> by next week we need everyone to read that wiki page so we can start with releases
16:14:20 <sileht> i159, I have already take the action...
16:14:35 <dhellmann> it's not quite as simple as just tagging a release, since we need to keep launchpad up to date as well, but it's not difficult either
16:14:48 <i159> sileht: np, sure
16:15:01 <dhellmann> next week we will put together the list of who is responsible for releases for each library
16:15:21 <dhellmann> #action dhellmann add "identify release managers" to agenda for next week
16:15:31 <dhellmann> did anyone read the document and have questions about it?
16:16:16 <dims> dhellmann: just glanced through it
16:16:18 * bnemec is way behind on all things mailing list
16:16:46 * viktors missed this email, so made a new release manually
16:17:20 <dhellmann> viktors: ok, let's talk about that later and make sure launchpad is cleaned up. I think we can run the script with the same tag you used and it will do the right thing
16:17:28 <dhellmann> #action viktors talk to dhellmann about fixing up oslo.db launchpad
16:17:36 <viktors> dhellmann: ok
16:17:45 <dhellmann> this segues into our next topic nicely...
16:17:50 <dhellmann> #topic managing priorities for kilo
16:17:51 <dhellmann> For Juno we had a couple of etherpads we used for tracking review priorities.
16:17:52 <dhellmann> Now that we have launchpad set up, I thought we would use that instead.
16:17:53 <dhellmann> As described in the ReleaseProcess wiki page, we have a "next-kilo" milestone for each library for active work that needs attention.
16:17:54 <dhellmann> That also gives us a unified view across all of the projects:
16:17:55 <dhellmann> #link https://launchpad.net/oslo/+milestone/next-kilo
16:17:56 <dhellmann> and that list makes it relatively easy to ensure we're reviewing the patches associated with bugs and blueprints we have agreed are important.
16:18:41 <beagles> markmcclain, did you get a chance to revisit: https://review.openstack.org/#/c/127633/ ?
16:18:47 <dhellmann> launchpad isn't great, but it's better than some free-form etherpads I think, and with the new tool that ttx has provided it will also help with release notes and tracking down when fixes went into releases
16:18:49 <beagles> oh sorry folks
16:18:52 <dhellmann> beagles: you probably want another room
16:18:52 <beagles> too many windows
16:19:01 <dhellmann> np
16:19:31 <dhellmann> harlowja_at_home: it looks like taskflow's lp page needs to be cleaned up, too
16:19:44 <harlowja_at_home> dhellmann,  quite possibly, will try to do that today
16:19:50 <dhellmann> #action harlowja_at_home talk to dhellmann about updating taskflow's bug tracker and milestones
16:20:01 <dhellmann> harlowja_at_home: I see some "fix released" items in the "kilo-next" milestone there
16:20:22 <dhellmann> #action dhellmann clean up oslo-incubator kilo-next page
16:20:42 <dhellmann> here comes another good segue
16:20:43 <dhellmann> #topic Need help with bug triage work
16:20:43 <dhellmann> In order to keep launchpad up to date, we need to make sure we are triaging bugs regularly.
16:20:43 <dhellmann> Some of the other teams have a small group who volunteer to triage, and others have "triage" days where they go through in batches in a meeting.
16:20:43 <dhellmann> I'd like to try having someone from each library team handle the triage work for that library, but I'm open to other suggestions, too.
16:21:09 <dhellmann> How do you all think we should handle bugs triage?
16:21:36 <dhellmann> we have a bit of a backlog to go through, and we also need to keep up with new incoming bugs
16:22:01 <rpodolyaka2> viktors and I have set up a event for triaging bugs in oslo.db
16:22:23 <dhellmann> rpodolyaka2, viktors: so you go through the list regularly? that's a good system.
16:22:35 <rpodolyaka2> we will
16:22:39 <viktors> dhellmann: we are suppose to do it
16:22:44 <flaper87> I've been thinking we should have a job that each week sends 10 bugs for triage to people that volunteered for triaging bugs
16:22:50 <dhellmann> ok, that sounds good
16:23:02 <flaper87> I've seen this done in other communities (Rust's for example) and it's useful
16:23:07 <rpodolyaka2> in tripleo we used to have a bot posting a list of incoming bugs to the channel
16:23:09 <flaper87> you'd get a list of 10 bugs each week
16:23:09 <dhellmann> flaper87: that's an interesting approach
16:23:13 <bnemec> Being subscribed to oslo-coresec was a spammy way to keep up with bug triage.
16:23:20 <flaper87> I'll send an email to the mailing list
16:23:33 <bnemec> +1 to using rpodolyaka2's bug triage bot.
16:23:49 <flaper87> I think we could use a job like this, each project opts in and same for volunteers
16:23:55 <bnemec> That has been super helpful in tripleo.
16:24:00 <dhellmann> heh, pretty soon #openstack-oslo is going to be a collection of bots talking to each other :-) "here's a bug" "here's  a patch"
16:24:04 <rpodolyaka2> :)
16:24:08 <bnemec> lol
16:24:13 <flaper87> dhellmann: LOL
16:24:20 <dims> lol
16:24:22 <rpodolyaka2> well, it's not that bad :)
16:24:26 <dhellmann> seriously, though, if that helps we can probably get that set up
16:24:27 <bnemec> #openstack-skynet
16:24:30 <dhellmann> haha
16:24:37 <rpodolyaka2> people will try hard to make it silent :)
16:24:46 <dhellmann> rpodolyaka2: can you talk to the infra team about setting that up?
16:24:56 <rpodolyaka2> ok
16:25:02 <dhellmann> cool, thanks
16:25:02 <rpodolyaka2> I'm not sure who I need to ping
16:25:04 <bnemec> RAaaS: Robot Apocalypse as a Service
16:25:15 <rpodolyaka2> will ask on -infra
16:25:16 <dhellmann> #action rpodolyaka2 talk to #openstack-infra about setting up a bot to announce new oslo bugs
16:25:37 <dhellmann> #action flaper87 start a mailing list thread on a job/bot to email bugs for triage to volunteers
16:25:53 * flaper87 does that
16:26:13 <dhellmann> if anyone has other ideas about managing the bug triage work, please start a mailing list thread so we can talk about them there
16:26:37 <dhellmann> #topic specs that are ready to be approved
16:26:37 <dhellmann> There are quite a few specs carried over from Juno or that were submitted early enough that I think they're ready to be approved.
16:26:37 <dhellmann> Let's go through them, and unless there are objections here or on the review by the end of the day today I will approve them tomorrow morning.
16:26:38 <bnemec> I think this should be a good start.
16:26:53 <dhellmann> bnemec: yeah, having some more visibility will help
16:27:09 <dhellmann> let's go through a few of the specs quickly
16:27:15 <dhellmann> #info db: Make EngineFacade a Facade
16:27:16 <dhellmann> #link https://review.openstack.org/#/c/125181
16:27:24 <bnemec> +2
16:27:28 <flaper87> +@
16:27:30 <flaper87> +2
16:27:39 <flaper87> my shift finger is too slow
16:27:39 <bnemec> flaper87: +:)
16:27:44 <flaper87> :P
16:27:49 <dhellmann> heh
16:27:54 <shardy> o/
16:28:03 <shardy> sorry, forgot new meeting time..
16:28:15 <dhellmann> ok, I'll approve that one in the morning to give folks time to comment
16:28:19 <dhellmann> #info db: Add long-lived-transactionalized-db-fixtures
16:28:20 <dhellmann> #link https://review.openstack.org/#/c/117335
16:28:42 * dims stepping out for a bit
16:28:43 <dhellmann> rpodolyaka2 and viktors have +1 this one, but I'd like some of the cores to look, too
16:29:24 <viktors> we are already +1'ed this
16:29:28 * bnemec hasn't looked at that one yet
16:29:56 <dhellmann> viktors: yeah, if no one objects by tomorrow I will approve it but it would be good to have more input if the team has time today
16:30:04 * dhellmann liks the new start-of-the-week meeting time
16:30:10 <dhellmann> #info cache: Convert oslo.cache to use dogpile.cache
16:30:10 <dhellmann> #link https://review.openstack.org/#/c/124776
16:30:21 <dhellmann> this one we approved late in juno, so I don't think it's controversial
16:30:47 <bnemec> Oh hey, I voted on that one already. \o/
16:30:51 <harlowja_at_home> only question i had on that was the memorycache implemnations aren't the same :-/
16:31:08 <harlowja_at_home> *or aren't currently the same
16:31:25 <dhellmann> harlowja_at_home: I think the idea is for this new thing to cause the old one to be deprecated. Do you mean the new one doesn't have a feature that the old one does have?
16:31:34 <harlowja_at_home> right
16:31:40 <harlowja_at_home> aka, no expiry in the dogpile one
16:31:54 <harlowja_at_home> the existing memorycache one does have some expiry (not great, but it has one)
16:32:14 <harlowja_at_home> http://dogpilecache.readthedocs.org/en/latest/api.html#dogpile.cache.backends.memory.MemoryBackend
16:32:17 <harlowja_at_home> 'There is no size management, and values which are placed into the dictionary will remain until explicitly removed. Note that Dogpile�s expiration of items is based on timestamps and does not remove them from the cache.'
16:32:31 <harlowja_at_home> ^ which is a change in how this works from the existing memorycache
16:32:36 <dhellmann> ok, I thought the in-memory thing was really meant for tests and not production
16:32:40 <bnemec> I don't think the current memorycache is actually production ready anyway.  It kind of terrifies me that projects are using it as such.
16:33:00 <harlowja_at_home> well no matter, if they are using it and its different, thats a problem right?
16:33:28 <dhellmann> it is, except that switching to the new one will require active dev work so we have a trigger point to say "here's a change you need to consider as you migrate"
16:33:50 <dhellmann> I don't think morganfainberg is planning to just delete the old cache module
16:33:56 <harlowja_at_home> k, fair enough
16:34:12 <dhellmann> but that's a good point, and something we should make sure is highlighted in the migration documentation
16:34:12 <morganfainberg> dhellmann, i am not. i plan on having it get deprecated
16:34:42 <dhellmann> morganfainberg: right, so there will be time for projects using that to adjust to the new implementation
16:34:45 * harlowja_at_home i just don't know what people are doing with the memorycache stuff, so thats all, just wanted to make sure its known
16:34:55 <dhellmann> harlowja_at_home: yep, good point
16:35:07 <dhellmann> next:
16:35:09 <dhellmann> #info middleware: oslo.middleware healthcheck
16:35:09 <dhellmann> #link https://review.openstack.org/#/c/130453
16:35:38 <dhellmann> the config option for the endpoint seemed a bit odd to me, but otherwise this one looked fine
16:35:54 <harlowja_at_home> +1 to me, will avoid a patch yahoo has to do the same (used by load balancers to see if things are ok)
16:36:31 <dhellmann> harlowja_at_home: is there any chance you can share the implementation of that with sileht and jd__ as they look at implementing this?
16:36:43 <harlowja_at_home> dhellmann,  sure, i think its pretty standard
16:36:49 <harlowja_at_home> will check what it is when i get into office
16:36:49 <dhellmann> harlowja_at_home: cool, thanks
16:36:58 <jd__> thanks harlowja_at_home
16:37:05 <harlowja_at_home> np
16:37:14 <dhellmann> also, as a reminder, everyone is able to +1/-1 specs so please do look at them even if you're not on the core team (yet :-)
16:37:41 <dhellmann> #info Propose tooz adoption
16:37:41 <dhellmann> #link https://review.openstack.org/#/c/122439
16:37:57 <dhellmann> there was a lot of interest in tooz's features at the summit this time
16:38:16 <dhellmann> #info Graduate oslo.context
16:38:16 <dhellmann> #link https://review.openstack.org/#/c/131544/
16:38:40 <dhellmann> dims has started working on oslo.context already (the repository is imported) and we need a release of that done before we can release oslo.log
16:38:58 <jd__> dhellmann: about tooz, what's blocking the +A ?
16:39:09 <harlowja_at_home> tooz +1 from me (i'm biased, ha)
16:39:19 <bnemec> :-)
16:39:24 <dhellmann> jd__: nothing, now, so it will be approved tomorrow unless someone objects
16:39:35 <jd__> cool, I'll cook patches then!
16:39:37 <dims> dhellmann: harlowja_at_home wanted oslo.utils rev
16:39:42 <dhellmann> jd__: before I think it was just timing and the fact that we were focused on other things
16:40:04 <dhellmann> dims: if we're ready to go, that's fine. Do you want to handle it?
16:40:58 <dhellmann> #topic specs needing more review
16:41:03 <dims> dhellmann: i'll run through reviews and do it tomorrow
16:41:18 <dhellmann> dims: ok, let me know if you run into issues with that new tool
16:41:33 <dhellmann> #action dims to prepare oslo.utils release
16:41:56 <dhellmann> dims: oh, and it looks like we don't need to use alpha versions since we can pin upper bounds in the stable branches
16:42:20 <dhellmann> dims: if you bump the minor version we can retroactive pin the stable branches if we need to
16:42:29 <dhellmann> #undo
16:42:29 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x1fa8e50>
16:42:34 <dhellmann> #topic specs needing more review
16:42:38 <dhellmann> #info Add adopt-oslo-versionedobjects spec
16:42:38 <dhellmann> #link https://review.openstack.org/#/c/127532/
16:42:38 <dhellmann> I think this is close to ready, but it doesn't have many votes on it, yet.
16:43:04 <harlowja_at_home> dhellmann,  there was a question on the version spacing i think for oslo libraries, did u see that?
16:43:05 <bnemec> That's the top of my spec review priority list for this week.
16:43:12 <dhellmann> harlowja_at_home: no, not yet
16:43:21 <harlowja_at_home> let me see if i can find it
16:43:37 <dhellmann> bnemec: ok, I think I'll hold off on approving that one for another week to give everyone time to come up to speed on it
16:43:59 <dhellmann> #topic cross-project liaisons
16:43:59 <dhellmann> Some of the other cross-project teams have adopted our liaison approach to coordinating work between teams.
16:43:59 <dhellmann> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
16:44:11 <bnemec> dhellmann: Yeah, I've just been swamped since summit covering for people off gallivanting through Europe. :-)
16:44:23 <dhellmann> based on how well things went for us in juno, most/all of the other cross-project teams are going to follow the same pattern
16:44:32 <bnemec> Nice
16:44:32 <dhellmann> we should help them out, by making sure we have our representatives lined up
16:44:44 <dhellmann> The stable maintenance team has asked for a liaison, for example, to help with tracking backports and reviews.
16:44:44 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/050390.html
16:44:44 <dhellmann> For us, this means oslo-incubator backports as well as deciding when to create bug-fix releases for libraries.
16:44:45 <dhellmann> Does anyone want to volunteer for that work?
16:45:21 <dhellmann> bnemec: it was awfully quiet last week, I wondered what was going on :-)
16:46:00 <dhellmann> #action dhellmann ask for stable maint volunteer again next week
16:46:07 <dhellmann> We also need someone to work with the documentation team.
16:46:07 <dhellmann> They use some of the libraries we've created for their tools, and they also need guidance from time to time on things like how to document configuration options that come from libraries instead of applications.
16:46:07 <harlowja_at_home> dhellmann,  ah, ya, the review was https://review.openstack.org/#/c/134727/ (but seems resolved, might be useful to look at)
16:47:01 <dhellmann> harlowja_at_home: ah, ok, I didn't see that one. We are using pbr's version of semver, so as long as we start each cycle by bumping the minor version for new releases we should be ok
16:47:09 <harlowja_at_home> kk
16:47:28 * dhellmann looks around for hands to be raised to volunteer to work with the documentation team
16:48:05 <dhellmann> it shouldn't be a lot of work, just making sure we help if they run into issues
16:48:15 <dhellmann> I think the only area we overlap right now is documenting configuration options, really
16:48:39 <dhellmann> although we may have some info for configuring messaging and database connections that should go into the manuals, too
16:48:50 <dhellmann> #action dhellmann ask for a doc liaison volunteer next week
16:49:01 <dhellmann> #topic Review backlog
16:49:02 <dhellmann> We have quite a review backlog, so in addition to the blueprints you've signed up for please take a look at existing patches and let's see what we can clear out this week.
16:49:02 <dhellmann> #link https://wiki.openstack.org/wiki/Oslo#Review_Links
16:49:23 <bnemec> Ooh, on that topic I think I figured out the Firefox review link thing.
16:49:35 <bnemec> It dislikes the Welcome, new contributor! one.
16:49:45 <bnemec> Probably due to the ! or ,
16:49:52 <dhellmann> oh, interesting
16:49:57 <dhellmann> we can change that
16:50:22 <bnemec> Yeah, I've been meaning to follow-up with you on that.
16:50:25 <dhellmann> bnemec: do you want to submit the patch to the repo with the dashboards and update the wiki page?
16:50:55 <bnemec> dhellmann: I just removed it from my local bookmark, how do you want to handle the official link?
16:51:09 <dhellmann> bnemec: let's talk after the meeting
16:51:16 <bnemec> ok
16:51:22 <dhellmann> #action bnemec talk to dhellmann about updating review dashboard links
16:51:42 <dhellmann> #topic Ongoing work
16:51:42 <dhellmann> #link https://launchpad.net/oslo/+milestone/next-kilo
16:51:42 <dhellmann> Is any of this work blocked?
16:52:03 * dhellmann looks for why the namespace packages blueprint isn't on that list
16:52:09 <zzzeek> hmm I believe I have a time conversion issue
16:52:36 <dhellmann> ah, it's marked for kilo-2
16:52:37 <dhellmann> https://blueprints.launchpad.net/oslo-incubator/+spec/drop-namespace-packages
16:53:00 <zzzeek> oh how unfortuante, the “1600 UTC” link on https://wiki.openstack.org/wiki/Meetings/Oslo refers to 1600 UTC on october 25th so that it showed me EDT and I thought the meeting was @ 12
16:53:03 <dhellmann> I have patches up for a few of the libraries to move them out of namespace packages listed there
16:53:09 <dhellmann> zzzeek: :-(
16:53:19 <zzzeek> what i miss?
16:53:22 <dhellmann> #action dhellmann fix meeting time link
16:53:53 <dhellmann> zzzeek: http://eavesdrop.openstack.org/meetings/oslo/2014/oslo.2014-11-17-16.00.log.txt
16:54:13 <dhellmann> is anyone blocked on any of their blueprints or bug fixes?
16:54:24 <dhellmann> we already mentioned the oslo.log work being blocked on oslo.context
16:55:20 <dhellmann> ok, I'll take silence as "no"
16:55:23 <dhellmann> #topic Red flags from liaisons
16:55:39 <bknudson> None for keystone
16:55:40 <dhellmann> usually we will cover this first, but this week we had a lot of new-cycle topics to cover
16:55:55 <dhellmann> thanks, bknudson
16:56:12 <shardy> Heat going OK now bug #1390505 is fixed
16:56:14 <uvirtbot> Launchpad bug 1390505 in oslo-incubator "cliutils.print_list mangles output with python3" [Undecided,Fix committed] https://launchpad.net/bugs/1390505
16:56:23 <dhellmann> liaisons, if you're present during this part of the meeting please response as bknudson did if you have no issues, or obviously mention any issues you do have
16:56:46 <bnemec> I think tripleo is up to date on lib adoptions, and no other issues.
16:56:53 <jungleboyj> None for Cinder.
16:56:59 <GheRivero> ironic no issues
16:57:15 <dhellmann> having you actively respond here helps us keep track of which liaisons are in the meeting, so we can follow up in case someone misses
16:57:26 <dhellmann> bnemec: good point
16:57:39 <jungleboyj> I still have a work item to get Cinder moved to using libraries for the components that aren't doing that yet.
16:58:23 <dhellmann> liaisons, one of the priorities for all projects early in the cycle should be updating the incubator and adopting existing libraries.
16:58:34 <dhellmann> it would be good to have that work done by k-1 (18 december)
16:58:57 <dhellmann> sooner is better, because this cycle as we graduate more libraries we're going to be deleting code from the incubator so it's going to be a moving target for you
16:59:27 <dhellmann> we're about out of time, so please drop by #openstack-oslo if you run into any issues or have questions
16:59:42 <jungleboyj> Will do.
16:59:55 <dhellmann> and thank you all for being here for the meeting this week!
16:59:56 <bknudson> I haven't checked since was on vacation, but when I left keystone was waiting on some issues oslo.config file generator.
17:00:14 <bknudson> so hopefully that will get resolved early enough
17:00:21 <dhellmann> bknudson: I think that was the patch to add the option discovery functions to the incubator, and I think that landed
17:00:32 <bknudson> ok, thanks.
17:00:39 <bknudson> should be able to use it now... I'll see how it's going.
17:00:55 <dhellmann> ah, no, it hasn't merged: https://review.openstack.org/#/c/113940/
17:01:16 <dhellmann> jd__, bnemec, dims : could one of you +2a ^^
17:01:28 <dhellmann> and we're a bit over time, so we need to cut it off here
17:01:32 <dhellmann> thanks again, everyone
17:01:35 <dhellmann> #endmeeting