16:00:01 <dhellmann> #startmeeting oslo
16:00:02 <openstack> Meeting started Mon Nov 24 16:00:01 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'oslo'
16:00:13 <dhellmann> who's around for the oslo meeting this week?
16:00:24 * kragniz lurks
16:00:36 <dstanek> o/
16:00:38 <bnemec> o/
16:00:43 <dims> o/
16:00:45 <bknudson> hi
16:00:46 <shardy> o/
16:00:48 * bnemec is triple booked this morning though :-/
16:00:55 <viktors|wfh> hi
16:00:57 <dims> busy man :)
16:01:16 <i159> o/
16:01:18 <bnemec> Seriously, who schedules stuff for Monday morning? :-)
16:01:28 * dhellmann looks around sheepishly
16:01:31 <rpodolyaka1> o/
16:01:38 <viktors|wfh> it's better than friday night :)
16:01:44 <dhellmann> viktors|wfh: true
16:01:48 <zzzeek> o/
16:01:52 <dhellmann> ok, good turn out, let's get started
16:01:54 <dhellmann> #topic Review action items from previous meeting
16:01:59 <dhellmann> We had a lot of items from last week.
16:02:07 <dhellmann> #info dhellmann talk to sileht about bug 856764
16:02:13 <GheRivero> o/
16:02:14 <uvirtbot> Launchpad bug 856764 in oslo.messaging "RabbitMQ connections lack heartbeat or TCP keepalives" [Critical,In progress] https://launchpad.net/bugs/856764
16:02:33 <dhellmann> we've discussed this, but I don't think we have a resolution, yet
16:02:40 <dhellmann> #info sileht post summary of the rabbit heartbeat issue to the mailing list so we can pick a solution - DONE
16:02:40 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/050782.html
16:02:40 <dhellmann> I don't think we really resolved the question though, did we silhet?
16:02:43 <dhellmann> (same topic)
16:02:52 <ozamiatin> o/
16:03:00 <dhellmann> oops, I meant sileht there
16:03:01 <dhellmann> typo
16:03:05 <bnemec> We have someone from tripleo looking at this issue, has he contacted either of you ?
16:03:20 <bnemec> jprovazn is his nick
16:03:45 <sileht> o/
16:03:57 <i159> dhellmann: The patch for Rabbit is in progress
16:03:58 <dhellmann> I don't recognize the nick
16:04:23 <jd__> o/
16:04:24 <dhellmann> i159: well, I thought we were still discussing whether the approach was what we wanted? maybe I'm just not caught up?
16:04:30 <kgiusti> o/
16:05:03 <dhellmann> sileht: did we decide which heartbeat approach to take, or are we still evaluating options?
16:05:17 <bnemec> I'll maybe send an email to connect everyone up.  I know he's been testing the various proposed fixes.
16:05:23 <sileht> dhellmann, the option 3 is too big refactoring for me
16:05:24 <dhellmann> bnemec: sounds good
16:05:33 <sileht> dhellmann, so land the i159 patch
16:05:40 <sileht> first
16:05:40 <dhellmann> sileht: was option 3 my suggestion to use a thread inside the connector?
16:05:46 <i159> dhellmann: I have pushed a lot of fixes appropriate to a comments in it and sileht pushed something too.
16:05:46 <dhellmann> or was that option 4?
16:06:02 <jungleboyj> o/
16:06:32 <sileht> dhellmann, connector ? you means transport ?
16:06:32 <dhellmann> i159: is that https://review.openstack.org/126330 ?
16:06:38 <dhellmann> sileht: yes, sorry
16:07:34 <sileht> dhellmann, this one is a too bug refactoring
16:07:38 <sileht> bug/big
16:07:39 <dhellmann> ok
16:07:49 <i159> dhellmann: I thought that we are ok with driver and other options is just an options
16:08:28 <dhellmann> ok, so we'll proceed with i159's patch and refine it if we need to later
16:08:36 <dhellmann> #info we'll proceed with i159's patch and refine it if we need to later
16:08:53 <dhellmann> #link https://review.openstack.org/126330
16:09:01 <dhellmann> #info rpodolyaka2 talk to #openstack-infra about setting up a bot to announce new oslo bugs
16:09:12 <dhellmann> rpodolyaka1: did you have a chance to talk to them?
16:09:38 <rpodolyaka1> dhellmann: I want to update my script first before talking to them to make it more general
16:09:48 <rpodolyaka1> dhellmann: but I can run it right now on my machine
16:09:54 <i159> hellmann: good, I'll be in it immediately after I push KS patch which I owe for a long time.
16:10:03 <rpodolyaka1> dhellmann: I tried that today and we have 116 untriaged bugs in oslo projects
16:10:11 <bnemec> Ouch
16:10:14 <dhellmann> rpodolyaka1: yes, that's not a surprise
16:10:24 <dhellmann> we'll talk more about triaging later in the agenda :-)
16:10:26 <rpodolyaka1> dhellmann: I can add it to cron right away and then move it to infra when it's ready
16:10:39 <rpodolyaka1> as right now the projects list is hard coded :(
16:11:02 <dhellmann> rpodolyaka1: ok, I'll leave that up to you and the infra team to work out
16:11:07 <rpodolyaka1> ok
16:11:09 <bnemec> We should write something that scrapes the governance repo for the list of official projects.
16:11:17 <bnemec> I know that came up for reviewstats too.
16:11:17 <dhellmann> we can afford to wait, I think
16:11:29 <dhellmann> bnemec: there's a script like that in oslo-incubator already
16:11:41 <bnemec> Oh.  Good. :-)
16:11:45 <dhellmann> #link http://git.openstack.org/cgit/openstack/oslo-incubator/tree/tools/list_oslo_projects.py
16:11:45 <rpodolyaka1> ok, so you don't mind the bot posting about 100 entries every 6 hours? :)
16:12:04 <dhellmann> rpodolyaka1: no, no, no, it should only post things it has not posted before! :-)
16:12:06 <rpodolyaka1> as long as we don't triage those ;)
16:12:18 * dhellmann wants to keep #openstack-oslo useful
16:12:50 <rpodolyaka1> ok, let's take to #openstack-oslo after meeting then
16:12:53 <dhellmann> rpodolyaka1: keep in mind that we'll be shifting to storyboard next cycle (I think that's the schecule)
16:12:58 <dhellmann> schedule
16:13:01 <dhellmann> rpodolyaka1: ok
16:13:11 <dhellmann> #info dims to prepare oslo.utils release
16:13:11 <dhellmann> We have a bunch of other releases to do this week, so maybe dims was waiting?
16:13:11 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/051271.html
16:13:41 <dims> dhellmann: was waiting to see if we heard back on that email thread you started
16:13:48 <dhellmann> that's what I figured
16:13:58 <dhellmann> more on releases later in the meeting, too
16:14:04 <dims> k
16:14:06 <dhellmann> #info bnemec talk to dhellmann about updating review dashboard links
16:14:06 <dhellmann> We talked, but I'm not sure the dashboards were updated?
16:14:28 <bnemec> I pushed a patch, let me grab the link.
16:14:41 <bnemec> #link https://review.openstack.org/#/c/135032/
16:14:49 <dhellmann> bnemec: ok, cool, will you update the wiki page, too?
16:14:56 <bnemec> dhellmann: Sure
16:15:09 <dhellmann> bnemec: great, thanks
16:15:13 <dhellmann> And we have a bunch of others that are done, stand by for paste-bomb:
16:15:21 <dhellmann> #info viktors talk to dhellmann about fixing up oslo.db launchpad - DONE
16:15:22 <dhellmann> #info harlowja_at_home talk to dhellmann about updating taskflow's bug tracker and milestones - DONE
16:15:22 <dhellmann> #info dhellmann clean up oslo-incubator kilo-next page - DONE
16:15:22 <dhellmann> #info flaper87 start a mailing list thread on a job/bot to email bugs for triage to volunteers - DONE
16:15:22 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/050767.html
16:15:23 <dhellmann> #info dhellmann fix meeting time link - DONE
16:15:36 <dhellmann> I think that's everything from last week
16:15:42 <dhellmann> #topic Red flags for/from liaisons
16:15:59 <bknudson> none for keystone... haven't been looking at oslo stuff much lately.
16:16:21 <GheRivero> none for ironic
16:16:24 <dhellmann> reminder for our new liaisons, this is the section of the meeting where we ask for critical issues you're seeing. Please say "none for $project" if you have nothing, as bknudson just did, so we know who is reporting in.
16:16:51 <shardy> None for heat, other than bug #1394530 blocking merge of the remaining patches for python-heaclient
16:16:53 <uvirtbot> Launchpad bug 1394530 in neutron "Icehouse client test failing when deleting external network" [Undecided,New] https://launchpad.net/bugs/1394530
16:17:00 <bnemec> One minor thing that bit tripleo last week: https://bugs.launchpad.net/tripleo/+bug/1394963
16:17:01 <shardy> maybe I just need to do more rechecks ;)
16:17:03 <uvirtbot> Launchpad bug 1394963 in tripleo "RequiredOptError: value required for option: lock_path" [Critical,Fix committed]
16:17:19 <bknudson> shardy: I've tried recheck, doesn't help
16:17:27 <jungleboyj> None for Cinder.  We made progress moving to the new libraries last week.  Just working on wrapping that up.
16:17:44 <bnemec> Cinder had a very old copy of lockutils and when they switched to oslo.concurrency it broke us because we weren't setting lock_path.
16:17:53 <shardy> bknudson: Yeah, it seems fairly persistent :(
16:18:00 <dhellmann> shardy: do you think that bug is related to oslo? or is it just a general issue?
16:18:04 <bknudson> shardy: I think that was already reported, or reported independently...
16:18:14 <bknudson> shardy: https://bugs.launchpad.net/tempest/+bug/1395368
16:18:17 <uvirtbot> Launchpad bug 1395368 in tempest "ExternalNetworksTestJSON.test_delete_external_networks_with_floating_ip (icehouse) failures" [Undecided,Confirmed]
16:18:25 <jungleboyj> bnemec: Sorry about that.  Thanks for helping get it fixed.
16:18:26 <shardy> dhellmann: AFAICT it's a neutron or tempest bug so probably not oslo related
16:18:40 <dhellmann> shardy: ok, thanks
16:18:53 <shardy> bknudson: ah, thanks
16:19:21 <dhellmann> speaking of test failures, we turned on stable requirements checks for oslo libs last week. Have we seen any issues landing patches as a result?
16:19:39 <bknudson> shardy: also, elastic-recheck for the newer bug: https://review.openstack.org/#/c/136657/
16:20:03 <bknudson> dhellmann: does it have an icehouse-neutron job?
16:20:13 <shardy> bknudson: thanks, I'll mark my bug as a dupe
16:20:22 <dhellmann> bknudson: no, this is just to ensure that we don't add requirements to libs in use in the stable branches without updating the stable requirements list first
16:21:15 <bknudson> I wonder if clients & keystonemiddleware get the same test?
16:21:31 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/051206.html
16:21:55 <dhellmann> bknudson: yes, some of the oslo libs had holes there and we were causing issues when we cut new releases
16:22:13 <dhellmann> #action dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs
16:22:33 <dhellmann> let's keep going
16:22:35 <dhellmann> #topic Invite liaisons to the cross-project meeting
16:22:36 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/051153.html
16:22:36 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings#OpenStack_Project_.26_Release_Status_meeting
16:22:56 <bknudson> it's on my calendar
16:23:00 <dhellmann> Thierry sent mail to the list last week inviting all of the cross-project liaisons to attend the project management meetings on Tuesday
16:23:15 <dhellmann> This requirements job thing is the sort of topic that might come up there
16:23:30 <dhellmann> and we also talk about things like deadlines, summit planning, etc.
16:23:59 <dhellmann> I encourage all of the Oslo liaisons to consider attending -- it's voluntary, but it can be useful to stay informed about what is going on, so lurking is good even if you don't contribute directly
16:24:38 <dhellmann> As Thierry said on the list, we are also looking for people interested in helping in other meta-ways with the project, and as you've expressed at least some interest in cross-project concerns you're all on our short list. :-)
16:24:52 <dhellmann> does anyone have questions about the meetings?
16:25:06 <dhellmann> bknudson: excellent, thanks!
16:25:09 <dims> dhellmann: sounds good
16:25:45 <jungleboyj> dhellmann: I will add it to my calendar.
16:26:01 <dhellmann> jungleboyj: good, thanks!
16:26:18 <dhellmann> #topic Reviews for config option discovery functions in incubator
16:26:18 <dhellmann> #link https://review.openstack.org/#/c/113940/
16:26:28 <dhellmann> #info it looks like that merged since I put it on the agenda
16:26:39 <dhellmann> #topic Identify release manager for each library
16:26:46 <dhellmann> so, releases
16:26:58 <dhellmann> we have a long long list of patches landed and not released that I would like to clear out
16:27:09 <dhellmann> as we did last cycle, I'd like to evaluate each library every week to see if it needs a release
16:27:39 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/051277.html
16:27:45 <dhellmann> that's the list of changes we have pending
16:28:09 <dhellmann> rather than me spend all day today or tomorrow cutting releases, I would like to start having the lead (or some other designated person) manage releases for each library
16:28:41 <dhellmann> we have a nice tool from ttx for making that simple, and I have instructions in the wiki:
16:28:43 <dhellmann> #link https://wiki.openstack.org/wiki/Oslo/ReleaseProcess
16:29:25 <dhellmann> shall we talk about the releases we have pending, and get volunteers to handle them?
16:29:47 <dhellmann> #action dhellmann to release cliff
16:30:02 <dhellmann> next up is oslo.concurrency
16:30:15 <bnemec> I can take that one.
16:30:22 <dims> i can do oslo.utils
16:30:24 <dhellmann> #action bnemec to release oslo.concurrency
16:30:29 <dhellmann> #action dims to release oslo.utils
16:30:42 <dhellmann> next up is oslo.config
16:31:05 <dhellmann> I'll take that one if no one else wants it
16:31:15 <dhellmann> #action dhellmann to release oslo.config
16:31:19 <sileht> I can try todo oslo.messaging (first I do a release,so :p)
16:31:31 <dhellmann> #action sileht to release oslo.messaging
16:31:52 <dhellmann> sileht: we can set up a time where I can walk you through it, if you like
16:32:07 <sileht> dhellmann, yep
16:32:14 <dhellmann> rpodolyaka1, viktors|wfh : you've done oslo.db releases, right? it looks like we're ready for another
16:32:33 <viktors|wfh> ok, we will do the next one
16:32:36 <dhellmann> sileht: ok, after this meeting we can pick a time for tomorrow morning
16:32:42 <dhellmann> #action viktors to release oslo.db
16:32:53 <dhellmann> next up is oslo.i18n
16:33:31 * dhellmann waits for a volunteer
16:33:42 <dims> i can do that dhellmann
16:33:47 <dhellmann> thanks, dims
16:33:52 <dhellmann> #action dims to release oslo.1i8n
16:34:21 <dhellmann> oslo.middleware is next
16:34:49 <dhellmann> I don't see gordc online
16:34:59 <bnemec> dhellmann: Please let me know when you talk to sileht.  I haven't done releases before either.
16:35:03 <dhellmann> jd__, can you take that one?
16:35:21 <jd__> dhellmann: sure
16:35:28 <dhellmann> #action jd__ to release oslo.middleware
16:35:50 <dhellmann> bnemec: we can do a quick run-through right after the meeting, if people have time to stick around for 5-10 minutes
16:36:05 <bnemec> dhellmann: Sounds good.
16:36:06 <dhellmann> #action dhellmann to release oslo.rootwrap (or talk to ttx about doing it)
16:36:21 <dhellmann> next up: oslo.serialization
16:37:10 <bnemec> I guess that was mine too.
16:37:19 <dhellmann> #action bnemec to release oslo.serialization
16:37:38 <ttx> dhellmann: there isn't much in it, but yes, we can do a release
16:37:40 <dhellmann> I hope we don't have so many after this week, so it shouldn't be such a big deal
16:37:52 <dhellmann> ttx: yeah, I'm trying to clear out our backlog
16:38:10 <dhellmann> dims already said he would handle oslo.utils
16:38:19 <dhellmann> next is oslo.vmware
16:38:42 * dims as well
16:38:49 <dhellmann> #action dims to release oslo.vmware
16:39:00 <dhellmann> next oslosphinx
16:39:08 <dhellmann> I can do that one, I guess
16:39:13 <dhellmann> #action dhellmann to release oslosphinx
16:39:22 <dhellmann> and oslotest, too, I suppose
16:39:29 <dhellmann> #action dhellmann to release oslotest
16:39:44 <dhellmann> harlowja_away: taskflow is next, can you do a release today or tomorrow?
16:40:44 <dhellmann> #action talk to harlowja_away about releasing taskflow
16:41:07 <dhellmann> ok, great, that's all that I had on the list this time around
16:41:36 <dhellmann> #topic Spec reviews
16:42:02 <dhellmann> I haven't had a chance to look through the list for anything I think we've reached consensus on. Does anyone want to propose merging any specs?
16:42:13 <sileht> https://review.openstack.org/#/c/131666/
16:42:28 <sileht> it's about oslo.messaging: notification-listener-pools
16:42:50 <dhellmann> sileht: that one looks good to me, but is there anyone else we need to make sure has looked at it?
16:43:18 <dhellmann> https://review.openstack.org/#/c/124847/ also has one +2 but could use some more votes
16:44:38 <dhellmann> ok, we'll look again next week
16:44:45 <dhellmann> #topic Stable maintenance liaison
16:44:45 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/050390.html
16:45:14 <dhellmann> last week we asked for a volunteer to be the liaison between the oslo team and the stable maintenance team
16:45:18 <dhellmann> we still need someone :-)
16:46:06 <dhellmann> we also need someone for the documentation liaison, but I think I can manage that myself
16:46:23 <dhellmann> I'd like someone else to take on the stable branch work
16:46:47 <dhellmann> #action dhellmann sign up as documentation liaison
16:47:08 <dhellmann> does anyone have questions about the responsibilities?
16:48:03 <dhellmann> well, let's try again next week
16:48:10 <dhellmann> #topic Need help with bug triage work - one person for each lib?
16:48:10 <dhellmann> The bot and teams flaper87 is working on setting up are a long-term plan for this, but we need a short-term plan, too.
16:48:10 <dhellmann> Suggestions?
16:48:29 <dhellmann> as rpodolyaka1 pointed out, we have >100 untriaged tickets now
16:48:37 <dhellmann> I'm certain some of the triaged tickets are obsolete, as well
16:48:44 <dhellmann> so we should really review everything that's open
16:49:27 <dhellmann> I asked on the mailing list about having a review sprint day, but I wonder if we'd be better off spending that time on bug cleanup?
16:49:42 <dhellmann> it's less fun, but will still be useful :-)
16:49:50 <bnemec> Maybe some of each?
16:49:59 <dhellmann> bnemec, dims : I didn't see whether either of you were going to be able to make it on the proposed day
16:50:17 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/051281.html
16:50:29 <dhellmann> #info proposed sprint day 4 December
16:50:30 <bnemec> dhellmann: I should be able to, but things here are kind of nuts right now (see triple-booked this morning).
16:50:33 <dims> dhellmann: yep, i'll be there
16:50:38 <dhellmann> bnemec: good idea
16:50:43 <dhellmann> dims: cool, thanks
16:50:59 <dhellmann> bnemec: understood; I hope you can join in
16:51:13 <dhellmann> how about our liaisons, and library cores?
16:51:40 <rpodolyaka1> will try to join to help with other oslo projects
16:51:45 <dhellmann> I know flaper87 had a conflict with that proposed day
16:51:49 <shardy> I should be around to help out
16:51:49 <dhellmann> rpodolyaka1: thanks!
16:51:54 * shardy adds to calendar
16:51:55 <rpodolyaka1> oslo.db should be fine :) thanks, viktors|wfh!
16:51:59 <dhellmann> shardy: cool
16:52:22 <dhellmann> the way I envision this working is people sort of doing it during their normal hours, unless you want to work a longer day that day :-)
16:52:35 <dhellmann> I'll try to be online very early my time to overlap with the folks in europe
16:53:31 <dhellmann> #topic Ongoing work & Review priorities
16:53:32 <dhellmann> #link https://launchpad.net/oslo/+milestone/next-kilo
16:53:32 <dhellmann> #link https://launchpad.net/oslo/+milestone/kilo-1
16:53:58 <dhellmann> is anyone blocked on any work they are doing because they need reviews, or something to land before they can proceed?
16:54:02 <dhellmann> what are our priorities this week?
16:54:13 <dhellmann> we talked about the rabbit heartbeat issue
16:54:15 <dhellmann> #info rabbit heartbeat review
16:54:15 <dhellmann> #link https://review.openstack.org/126330
16:54:19 <dhellmann> what else?
16:54:27 <sileht> I have not got the status of https://review.openstack.org/#/c/134727/
16:54:40 <sileht> someone works on a fix ?
16:55:11 <dhellmann> sileht: I'm not sure, I need to ask the devstack team about what they're doing there
16:55:29 <dhellmann> unless you want to talk to them?
16:55:45 <sileht> gate is a bit blocked since the new jobs are in place
16:55:51 <sileht> dhellmann, sure
16:55:58 <dhellmann> sileht: great, thanks
16:56:15 <dhellmann> #action sileht talk to devstack team about updating to not install oslo from source in stable branches
16:56:28 <kgiusti> I'm stuck on a threading issue in the 1.0 driver :(
16:56:29 <dhellmann> how about anyone else?
16:56:38 <kgiusti> no bug yet
16:56:59 <dhellmann> kgiusti: ok, maybe start a ML thread if you need to pull in some help?
16:57:08 <kgiusti> +1 will do
16:57:32 <dhellmann> dims: how is oslo.context looking? I didn't put that on our release list, should it be there?
16:57:55 <dims> dhellmann: checking, i think all we had is in already
16:58:15 <dims> yep. it's ready
16:58:22 <dhellmann> dims: I don't see any open reviews, but maybe we were waiting for some of the specs related to the context class API?
16:58:45 <dims> dhellmann: yes, those all got merged
16:58:49 <dims> so we are good
16:58:55 <dhellmann> #link https://review.openstack.org/132551
16:59:08 <dhellmann> #link https://review.openstack.org/124847
16:59:14 <dhellmann> those 2 specs are related to context
16:59:22 <dhellmann> do we want to do that work before we release?
16:59:54 <dims> dhellmann: could we unblock oslo.log first?
17:00:12 <dhellmann> dims: well, that first one with the app-agnostic-logging-parameters affects logging, too :-/
17:00:54 <dims> k
17:01:06 <bnemec> Yeah, that one was kind of the whole reason we want oslo.context to exist.
17:01:07 <dhellmann> let's see if we can land the spec this week :-)
17:01:19 <dims> sounds good
17:01:32 <dhellmann> ok, we're a bit over time so we should stop
17:01:51 <dhellmann> we'll move to #openstack-oslo for a quick review of the release process and I can schedule 1:1 meetings with anyone who wants them
17:01:54 <dhellmann> thanks, everyone!
17:02:04 <dhellmann> #endmeeting