16:00:10 <dhellmann> #startmeeting oslo
16:00:11 <openstack> Meeting started Mon Dec  1 16:00:10 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:14 <openstack> The meeting name has been set to 'oslo'
16:00:33 <dhellmann> who's around for the meeting today?
16:01:01 <harlowja_at_home> \o
16:01:02 <bknudson> hi
16:01:22 <i159> o/
16:01:54 <kgiusti> o/
16:02:07 <harlowja_at_home> maybe people still having turkey hangovers, lol
16:02:17 <dhellmann> bnemec, dims, sileht, jd__: ping
16:02:25 <jd__> pong
16:02:31 <dims> o/
16:02:57 <dhellmann> ok, let's start
16:02:58 <dhellmann> #topic Review action items from previous meeting
16:03:03 <viktors> hi!
16:03:07 <dhellmann> #info dhellmann sign up as documentation liaison DONE
16:03:16 <bnemec> o/
16:03:20 <dhellmann> #info dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs
16:03:20 <dhellmann> We have started capping requirements in the stable branches, so I have a patch up to remove the stable requirements jobs from the Oslo libs now.
16:03:21 <dhellmann> #link https://review.openstack.org/137451
16:04:13 <harlowja_at_home> cool lets see how that goes
16:04:15 <dhellmann> we've made the judgement call that we will have few enough stable branch releases that the unit tests are good enough to catch issues, but if that proves incorrect we can add these jobs back later
16:04:36 <dhellmann> for now, removing the jobs should free up test resources
16:04:48 <dhellmann> #info sileht talk to devstack team about updating to not install oslo from source in stable branches
16:05:03 <dhellmann> sileht: do you have an update for us?
16:05:28 <zzzeek> \o
16:06:27 <dhellmann> that may be less important now, but I'll put it back on the list for us to review next week
16:06:33 <dhellmann> #action sileht talk to devstack team about updating to not install oslo from source in stable branches
16:06:39 <dhellmann> #topic tagging releases
16:06:39 <dhellmann> We postponed the release actions from last week, until we could finish the stable branch version cap work.
16:06:39 <dhellmann> Enough of that is done to let us proceed, so I'll restore the assignments from last week (stand by for paste bomb):
16:06:55 <dhellmann> #action dhellmann to release cliff
16:06:55 <dhellmann> #action bnemec to release oslo.concurrency
16:06:55 <dhellmann> #action dims to release oslo.utils
16:06:55 <dhellmann> #action dhellmann to release oslo.config
16:06:56 <dhellmann> #action sileht to release oslo.messaging
16:06:57 <dhellmann> #action viktors to release oslo.db
16:06:58 <dhellmann> #action dims to release oslo.1i8n
16:06:59 <dhellmann> #action jd__ to release oslo.middleware
16:07:00 <dhellmann> #action dhellmann to release oslo.rootwrap (or talk to ttx about doing it)
16:07:01 <dhellmann> #action bnemec to release oslo.serialization
16:07:02 <dhellmann> #action dims to release oslo.vmware
16:07:03 <dhellmann> #action dhellmann to release oslosphinx
16:07:04 <dhellmann> #action dhellmann to release oslotest
16:07:05 <dhellmann> #action harlowja to release taskflow
16:07:20 <dims> yes, sir!
16:07:26 <dhellmann> we should try to prepare these releases today or tomorrow
16:07:34 <bnemec> ack
16:07:44 * bnemec needs to finish reading through the release docs
16:08:08 * dims too
16:08:10 <harlowja_at_home> sure
16:08:11 <viktors> tomorrow looks ok
16:08:25 <dhellmann> good point -- if you have any questions at all about the new tool or the process, let me know
16:08:45 <dhellmann> it's fairly robust, so you're not likely to break anything by just running it, but don't hesitate to ask either
16:09:29 <bnemec> Will do
16:09:54 <dhellmann> there's a script to produce the release notes in https://review.openstack.org/#/c/136401/
16:10:07 <dhellmann> I don't think that's mentioned in the instructions, yet, since it hasn't merged (hint, hint)
16:10:22 <dhellmann> #action dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged
16:10:48 <dhellmann> I think that's all of the old business, unless anyone has questions about the release tools now?
16:11:33 <dhellmann> we can come back to that during open discussion, then
16:11:34 <dhellmann> #topic Red flags for/from liaisons
16:11:57 <dhellmann> are there any blockers or other issues from the liaison corps?
16:12:06 <bnemec> Nothing that I'm aware of for tripleo.
16:12:09 <jungleboyj> o/  Sorry I am late.
16:12:23 <bknudson> none for keystone
16:12:24 <bnemec> Although since I just got back from Thanksgiving I haven't caught up on everything yet.
16:12:28 <i159> https://review.openstack.org/#/c/93558/ here is one important
16:12:35 <jungleboyj> Not that I am aware of from Cinder,  behind after vacation though.
16:12:45 <jungleboyj> bnemec: +1
16:12:48 <i159> keystone related
16:13:32 <i159> https://review.openstack.org/#/c/93558/ has strange gate problems but it has uncovered a bunch of db dugs
16:13:33 <dhellmann> i159: are those job failures real, or was there some sort of issue with that keystone patch?
16:13:37 <i159> *bugs
16:14:12 <dhellmann> #info keeping an eye on https://review.openstack.org/#/c/93558/ for the keystone team
16:14:19 <i159> dhellmann: it works well lokally, but has problems with gates, I'm not sure is it really bug free now
16:15:17 <dhellmann> i159: ok, let the oslo.db team know if you need a hand with debugging the failures. Maybe we can reproduce them on a clean test VM
16:15:19 <i159> It has became big bug fix chain again
16:15:57 <viktors> i159: please ping me after the meeting, I have some ideas about that
16:16:07 <dhellmann> viktors: thanks
16:16:13 <i159> hellmann: I'll be very grateful. Thanks!
16:16:14 <dhellmann> are there any other issues to be addressed?
16:17:10 <dhellmann> ok, we'll see what happens after we cut all of the releases this week :-)_
16:17:20 <dhellmann> #topic Sprint planning
16:17:31 <dhellmann> #link https://etherpad.openstack.org/p/oslo-kilo-sprint
16:17:42 <dhellmann> Remember we're sprinting on the 4th. I think we're spread out enough that it's likely we will not all be online at the same time, so if it's the 4th wherever you are, start or finish without the rest of us as needed!
16:18:28 <dhellmann> I noticed the infra team is using #openstack-sprint for coordinating, but I thought we'd just use #openstack-oslo since we're all usually there anyway
16:18:40 <bnemec> +1
16:19:24 <dhellmann> between today and the 4th, it would be good to have all of the library leads look through the open reviews and identify any that need special priority attention. You can list those in the etherpad
16:19:34 <dhellmann> Otherwise, I think we can just work our way through the backlog
16:20:02 <dhellmann> #action dhellmann announce sprint on the dev mailing list
16:20:41 <dhellmann> questions or comments about the sprint?
16:22:04 <dhellmann> cool, moving on then
16:22:05 <dhellmann> #topic Spec reviews
16:22:12 <dhellmann> #link https://review.openstack.org/#/q/project:openstack%2Foslo-specs+is:open,n,z
16:22:40 <i159> https://review.openstack.org/#/c/112842/ significant one
16:22:45 <dhellmann> https://review.openstack.org/#/c/131666/ has 2 +2
16:23:14 <dhellmann> i159: yep, that's a big feature we've been trying to work on for a while
16:23:17 <rpodolyaka1> i159: on my list. will try to review yommorow
16:23:22 <dhellmann> ditto
16:23:36 <viktors> ditto
16:23:48 <i159> https://review.openstack.org/#/c/133668/ and about messaging
16:24:03 <dhellmann> does anyone have any issues with merging 131666?
16:24:47 <i159> Tipically I need more help than questions with #133668....
16:25:29 <dhellmann> i159: I need to make sure I understand how that one would interact with the async work going on. I'd also want sileht to sign off on it, since it's a rather large design change.
16:25:40 <dhellmann> I definitely need to re-read it
16:25:58 <i159> dhellmann: OK
16:26:03 <dhellmann> the versioned objects spec looks ready to land: https://review.openstack.org/#/c/127532/
16:26:15 <dhellmann> #action dhellmann approve spec https://review.openstack.org/#/c/127532/
16:26:25 <bnemec> The code change for https://review.openstack.org/#/c/131666 has already landed, so I think we might as well go ahead and merge the spec. :-)
16:26:36 <dhellmann> #action dhellmann approve spec https://review.openstack.org/#/c/131666/
16:26:37 <dhellmann> heh
16:27:02 <dhellmann> bnemec: that's actually an issue -- we need to stop approving code related to specs if the specs themselves haven't been approved
16:27:28 <bnemec> Yeah
16:27:53 <dhellmann> https://review.openstack.org/#/c/132551/ is the app-agnostic-logging spec from last cycle. It has 1 +2, and it looks like I owe bnemec a response there
16:28:36 <dhellmann> https://review.openstack.org/#/c/124847/ is the spec for removing the context adapter from oslo.log
16:28:41 <dhellmann> that's another one we restored from juno
16:28:55 <dhellmann> #action dhellmann approve spec https://review.openstack.org/#/c/124847/
16:29:07 <dhellmann> #info I'll approve all of those tomorrow unless someone objects today.
16:29:15 <bnemec> Yeah, looks like jd__ had previously +2'd that one too.
16:29:55 <dhellmann> yeah, I think I lost that when I rebased
16:31:03 <dhellmann> one thing to note related to blueprints: ttx turned on the "autokicker" to remove blueprints from the kilo release or any kilo milestone if they are not marked as approved with a valid priority
16:31:28 <dhellmann> that will help us keep our progress reports clean, but it means we can't toss things into the milestones that we think we might want to work on before they are approved
16:32:03 <dhellmann> when we talked last week, there were no blueprints at risk of being kicked out, but there were a few with the "kilo" series goal that were updated when the script ran
16:33:07 <dhellmann> #topic Stable maintenance liaison
16:33:13 <dhellmann> We still need a volunteer for this duty.
16:33:16 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2014-November/050390.html
16:33:41 <dhellmann> The volunteer does not have to be an oslo-core member, since the responsibilities are really limited to the stable branches.
16:33:59 <dhellmann> Would anyone like to get involved in the stable release management?
16:35:32 <dhellmann> stable maint for oslo libs is going to be more important now that we're graduating the code from the incubator, so we need to find someone to do this. :-/
16:35:58 <dhellmann> maybe we can find some help from one of the distros
16:36:10 <dhellmann> #topic Ongoing work & Review priorities
16:36:15 <dhellmann> #link https://launchpad.net/oslo/+milestone/next-kilo
16:36:18 <dhellmann> #link https://launchpad.net/oslo/+milestone/kilo-1
16:36:22 <dhellmann> Is anyone blocked on work we prioritized for this release?
16:37:58 <bnemec> Oh, I need to revisit the concurrency deletion from incubator. :-/
16:38:26 <dhellmann> we can use https://launchpad.net/oslo/+milestone/next-kilo to get priorities for some of the reviews for this week, but I do want us to focus on clearing out the backlog of really old stuff, too
16:40:12 <dhellmann> we're just a few weeks out from kilo-1 at this point (december 18) so if you have a blueprint that you think won't land please re-target it for a later milestone
16:40:48 <dhellmann> #topic open discussion
16:40:59 <dhellmann> that's all I had for the formal agenda this week, does anyone have anything else to bring up?
16:42:27 <dhellmann> I'm working on moving a lot of our "creating a new library" document into the infra manual so it is in a place where it's more likely they will help maintain it as infra processes change: https://review.openstack.org/138094
16:43:55 <dhellmann> well, it seems we don't have anything else to discuss, so we can cut the meeting short
16:43:58 <dhellmann> thanks for coming everyone
16:44:07 <dhellmann> #endmeeting