#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:07 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Oslo (dhellmann, 16:00:23)

  1. Review action items from previous meeting (dhellmann, 16:02:23)
    1. dhellmann to release cliff DONE (dhellmann, 16:02:41)
    2. bnemec to release oslo.concurrency DONE (dhellmann, 16:02:41)
    3. dims to release oslo.utils DONE (dhellmann, 16:02:41)
    4. dhellmann to release oslo.config DONE (dhellmann, 16:02:41)
    5. sileht to release oslo.messaging DONE (dhellmann, 16:02:42)
    6. viktors to release oslo.db DONE (dhellmann, 16:02:43)
    7. dims to release oslo.1i8n DONE (dhellmann, 16:02:44)
    8. jd__ to release oslo.middleware DONE (dhellmann, 16:02:45)
    9. dhellmann to release oslo.rootwrap (or talk to ttx about doing it) DONE (dhellmann, 16:02:47)
    10. bnemec to release oslo.serialization DONE (dhellmann, 16:02:48)
    11. dims to release oslo.vmware DONE (dhellmann, 16:02:49)
    12. dhellmann to release oslosphinx DONE (dhellmann, 16:02:50)
    13. dhellmann to release oslotest DONE (dhellmann, 16:02:51)
    14. dhellmann approve spec https://review.openstack.org/#/c/127532/ DONE (dhellmann, 16:02:59)
    15. dhellmann approve spec https://review.openstack.org/#/c/131666/ DONE (dhellmann, 16:03:00)
    16. dhellmann approve spec https://review.openstack.org/#/c/124847/ DONE (dhellmann, 16:03:01)
    17. sileht talk to devstack team about updating to not install oslo from source in stable branches (dhellmann, 16:03:14)
    18. harlowja to release taskflow (dhellmann, 16:04:11)
    19. ACTION: dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged (dhellmann, 16:06:09)
    20. ACTION: dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs (dhellmann, 16:06:09)

  2. backwards compatibility concerns (dhellmann, 16:07:49)
  3. Red flags for/from liaisons (dhellmann, 16:14:42)
    1. https://etherpad.openstack.org/p/oslo-mocks-in-project-unit-tests (dhellmann, 16:15:37)
    2. https://review.openstack.org/#/c/138463/ (dhellmann, 16:16:02)
    3. https://review.openstack.org/#/c/138462/ (dhellmann, 16:21:40)
    4. ACTION: dhellmann send email asking liaisons to prepare list of potential fixtures to be added to libraries and config options used by tests (dhellmann, 16:22:23)
    5. http://paste.openstack.org/show/147086/ (dims, 16:27:28)

  4. Moving the hacking project to QA program (dhellmann, 16:30:34)
    1. https://review.openstack.org/#/c/138499/ (dhellmann, 16:30:34)
    2. http://lists.openstack.org/pipermail/openstack-dev/2014-December/052025.html (dhellmann, 16:30:34)

  5. tooz adoption under way (dhellmann, 16:34:07)
    1. ACTION: jd__ to update gerrit dashboard config for oslo and review links in the oslo wiki to add tooz and remove hacking (dhellmann, 16:35:05)
    2. https://bitbucket.org/zzzeek/dogpile.cache/src/345d07d5b740c4aca3f16ce34e6d9316fcf39b55/dogpile/cache/backends/memcached.py?at=master#cl-243 :( (harlowja_at_home, 16:39:58)
    3. ACTION: jd__ prepare a list of projects using memcache libraries directly that will need to be migrated if we recommend a new memcache lib (dhellmann, 16:40:04)

  6. Sprint retrospective (dhellmann, 16:42:23)
    1. https://etherpad.openstack.org/p/oslo-kilo-sprint (dhellmann, 16:42:23)
    2. http://lists.openstack.org/pipermail/openstack-dev/2014-December/052316.html (dhellmann, 16:42:24)
    3. ACTION: harlowja_at_home to plan a date for a taskflow review sprint (dhellmann, 16:47:52)

  7. Ongoing work & Review priorities (dhellmann, 16:48:12)
    1. https://launchpad.net/oslo/+milestone/next-kilo (dhellmann, 16:48:12)
    2. https://launchpad.net/oslo/+milestone/kilo-1 (dhellmann, 16:48:12)
    3. dhellmann needs reviews on the namespace packaging changes (dhellmann, 16:48:38)
    4. https://review.openstack.org/#/q/status:open+branch:master+topic:bp/drop-namespace-packages,n,z (dhellmann, 16:48:38)
    5. oslo-incubator cleanup for oslo.concurrency is blocking neutron adoption (dhellmann, 16:48:56)
    6. https://review.openstack.org/122796 (dhellmann, 16:48:56)

  8. open discussion (dhellmann, 16:51:20)


Meeting ended at 17:01:13 UTC (full logs).

Action items

  1. dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged
  2. dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs
  3. dhellmann send email asking liaisons to prepare list of potential fixtures to be added to libraries and config options used by tests
  4. jd__ to update gerrit dashboard config for oslo and review links in the oslo wiki to add tooz and remove hacking
  5. jd__ prepare a list of projects using memcache libraries directly that will need to be migrated if we recommend a new memcache lib
  6. harlowja_at_home to plan a date for a taskflow review sprint


Action items, by person

  1. dhellmann
    1. dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged
    2. dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs
    3. dhellmann send email asking liaisons to prepare list of potential fixtures to be added to libraries and config options used by tests
  2. harlowja_at_home
    1. harlowja_at_home to plan a date for a taskflow review sprint
  3. jd__
    1. jd__ to update gerrit dashboard config for oslo and review links in the oslo wiki to add tooz and remove hacking
    2. jd__ prepare a list of projects using memcache libraries directly that will need to be migrated if we recommend a new memcache lib
  4. openstack
    1. dhellmann update release instructions after https://review.openstack.org/#/c/136401/ is merged


People present (lines said)

  1. dhellmann (195)
  2. harlowja_at_home (25)
  3. ihrachyshka (23)
  4. dims (17)
  5. zzzeek (15)
  6. jd__ (14)
  7. bknudson (10)
  8. therve (5)
  9. openstack (3)
  10. sileht (2)
  11. rpodolyaka1 (1)
  12. uvirtbot (1)
  13. ozamiatin (1)
  14. kgiusti (1)
  15. viktors (1)
  16. ihrachyshka_ (1)
  17. jecarey (1)


Generated by MeetBot 0.1.4.