16:00:13 <dhellmann> #startmeeting oslo
16:00:13 <openstack> Meeting started Mon Dec 22 16:00:13 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:14 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:17 <openstack> The meeting name has been set to 'oslo'
16:00:22 <dhellmann> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka1, zzzeek, sileht
16:00:22 <dhellmann> courtesy ping for redrobot, jungleboyj, zhiyan, shardy, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:30 <dims> pong
16:00:33 <bnemec> o/
16:00:36 <dims> o/
16:00:38 <viktors> o/
16:00:43 <kgiusti> o/
16:00:43 <rpodolyaka1> o/
16:00:47 <ozamiatin> o/
16:01:34 <flaper87> o/
16:01:49 <jd__> o/
16:01:59 <dhellmann> #topic Review action items from previous meeting
16:02:13 <dhellmann> just one item for me to carry over again
16:02:16 <dhellmann> #action dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs
16:02:29 <dhellmann> #topic meeting next week
16:02:34 <jungleboyj> o/
16:02:51 <jungleboyj> dhellmann: Thanks for the ping.
16:03:03 <dhellmann> I was planning to cancel the meeting next week, on the assumption that most people would be taking holiday breaks around the new year. Any objections?
16:03:13 <dhellmann> jungleboyj: np, picked that up from ttx :-)
16:03:26 <bnemec> Nope, I won't be around next week anyway.
16:03:33 <jungleboyj> Same here.
16:03:59 <dhellmann> if you're working next week, review patches during the meeting time ;-)
16:04:03 <rpodolyaka1> :)
16:04:10 <dhellmann> #info no meeting on Dec 29
16:04:16 <dhellmann> #info next meeting on Jan 5
16:04:23 <zhiyan> o/
16:04:31 <dhellmann> #topic Red flags for/from liaisons
16:04:46 <dhellmann> how are things looking?
16:05:02 * jungleboyj has been busy updating oslo-incubator in Cinder.
16:05:06 * flaper87 is waiting for oslo.log to be out to clean up quite few things in Zaqar
16:05:27 <jungleboyj> Just merged the patch for oslo.concurrency -> oslo_concurrency
16:05:35 <dhellmann> flaper87: jd__ pointed out one more thing we need to do before we can release oslo.log, and I think dims is already working on it
16:05:41 <bnemec> All quiet on the TripleO front
16:05:44 <dhellmann> jungleboyj: oh, good, you're ahead of the game :-)
16:05:50 <dims> dhellmann: just logged a review
16:05:54 <dims> 143477
16:05:54 <dhellmann> dims: cool
16:05:57 <flaper87> dhellmann: dims awesome
16:06:09 <jungleboyj> dhellmann: No one is around here and I am able to get stuff done.
16:06:30 <dhellmann> jungleboyj: yeah, it's funny how that works, isn't it?
16:06:33 <dims> jungleboyj: gate is relatively empty as well :)
16:06:43 <jungleboyj> :-)
16:07:09 <bnemec> It makes me kind of sad that we have mandatory PTO between XMas and New Years.  That was always my favorite time to work. :-)
16:07:38 <jungleboyj> bnemec: Now that is going too far.  :-)
16:07:40 <dhellmann> as far as the other package renames like oslo_concurrency, I thought we'd wait until after the holidays to cut releases, and then announce the change and make a concerted effort to shift the projects over before kilo-2
16:07:47 <dhellmann> does that seem like a reasonable time-frame?
16:08:07 <dhellmann> bnemec: so the whole company closes down?
16:08:08 <bnemec> dhellmann: We already released oslo.concurrency with the rename.
16:08:10 <jungleboyj> dhellmann: That sounds good.  Hoping early January will be pretty quiet so I can tackles those.
16:08:27 <bnemec> dhellmann: Yep, pretty much.  Except if you have to be there for some reason.
16:08:39 <dhellmann> bnemec: yeah, that's ok, I just meant the announcement of the need to update could wait until we make the other releases, and I don't want to do those before we all disappear for break
16:08:56 <bnemec> dhellmann: Ah, +1 to that.
16:09:13 <dhellmann> ok, let's talk about some other specs
16:09:18 <dhellmann> #topic spec review
16:09:23 <dhellmann> we have a few specs that I think are ready to be approved, but that could use one more +2
16:09:28 <dhellmann> #link https://review.openstack.org/#/q/project:openstack%2Foslo-specs+is:open,n,z
16:09:35 <dhellmann> #info debtcollector adoption
16:09:36 <dhellmann> #link https://review.openstack.org/#/c/141220/
16:09:56 <dhellmann> this is another lib from harlowja, with some deprecation tools
16:10:23 <dhellmann> it currently has 4 +2, so I'll approve it today
16:10:37 <dhellmann> #info notification dispatcher for oslo.messaging
16:10:37 <dhellmann> #link https://review.openstack.org/#/c/135379/
16:11:18 <dhellmann> that's a pretty straightforward new feature from gordc, with sileht's +1
16:11:30 <dhellmann> I'll approve that tomorrow unless there are objections filed by then
16:11:47 <dhellmann> #info graduating reports
16:11:47 <dhellmann> #link https://review.openstack.org/#/c/135657/
16:12:15 <bnemec> I'll try to look at that today too.
16:12:17 <dhellmann> that one has 3 +2, so I'll approve it later today unless anyone wants me to wait
16:13:52 <dhellmann> there are a bunch of other specs up for review, but none of them seem to be in shape to merge right now
16:14:46 <dhellmann> #topic Ongoing work & Review priorities
16:15:00 <dhellmann> #link https://launchpad.net/oslo/+milestone/next-kilo
16:15:01 <dhellmann> #link https://launchpad.net/oslo/+milestone/kilo-2
16:15:18 <dhellmann> #info need reviews on the namespace packaging changes
16:15:18 <dhellmann> #link https://review.openstack.org/#/q/status:open+branch:master+topic:bp/drop-namespace-packages,n,z
16:15:18 <dhellmann> I've updated the oslo.db patch to work with sahara, and tested against nova and cinder's unit tests as well.
16:15:47 <bnemec> It's basically just db left, right?
16:15:51 <dhellmann> I have a few more to submit as well
16:15:55 <dhellmann> I don't think messaging is done
16:15:59 <dhellmann> I have a branch, but it's not working yet
16:16:02 <bnemec> ok
16:16:14 * dhellmann searches for bp link
16:16:30 <dhellmann> #link https://blueprints.launchpad.net/oslo-incubator/+spec/drop-namespace-packages
16:16:36 <rpodolyaka1> dhellmann: a couple of tests are missing. Did you remove those on purpose? or they are just broken and you need someone to fix those?
16:16:39 <dhellmann> the work items there should be accurate
16:16:50 <rpodolyaka1> dhellmann: (oslo.db namespaces patch)
16:17:03 * dhellmann looks
16:17:09 <rpodolyaka1> dhellmann: https://review.openstack.org/#/c/138787/10/tests/sqlalchemy/test_sqlalchemy.py
16:17:30 <viktors> dhellmann: as for Sahara - imports already fixed there
16:17:37 <rpodolyaka1> dhellmann: if you need a hand, viktors and/or I could take a look
16:17:58 <dhellmann> viktors: ok, cool. I ran the sahara unit tests with the current oslo.db patch and they worked
16:18:26 <dhellmann> rpodolyaka1: I think I had trouble making those tests pass, and then noticed they were testing a private function, so I just removed them and kept the copy that moved into oslo_db/tests
16:18:58 <rpodolyaka1> dhellmann: ok. cool. I think thats not a problem and we can add them back later
16:19:04 <dhellmann> the tests in ./tests just need to verify the public API
16:19:13 <rpodolyaka1> (if we need them)
16:19:28 <dhellmann> yeah, if we decide we need them -- there should be copies in ./oslo_db/tests/sqlalchemy/test_sqlalchemy.py
16:19:44 <rpodolyaka1> dhellmann: ack, thanks
16:19:53 <dhellmann> the way I prepared these patches was to "cp -a tests oslo_foo/" and then adjust the imports in the copy
16:20:27 <dhellmann> ugh, looks like my latest db patch is failing tests that it passed for me
16:20:29 <dhellmann> more debugging
16:20:47 <dhellmann> is anyone else blocked on work that needs to be reviewed?
16:21:55 <dhellmann> ok, we had a short agenda today
16:21:58 <dhellmann> #topic open discussion
16:22:08 <dhellmann> is there anything else you'd like to bring up before we adjourn?
16:22:20 <jecarey> dhellmann, I was concerned about the namespace stuff and the po file name.
16:23:11 <jecarey> We changed from oslo.i18n to oslo_i18n do we have to change the yaml file that generates the po files as well?
16:23:14 <dhellmann> jecarey: right - I talked to Andreas about it, and he assured me that the .po name should match the *dist* and not the importable package.
16:23:40 <dhellmann> jecarey: no, the job that builds those uses "python setup.py --name" to get the name
16:23:49 <ozamiatin> please take a look at my spec https://review.openstack.org/#/c/140318/
16:24:24 <jecarey> sry having screen problems
16:24:33 <dhellmann> jecarey: np
16:24:59 <jecarey> I think that's for installation.  For lookup we look for a po with the name passed to the Translation factory.
16:25:07 <dhellmann> ozamiatin: do the examples take the place of the functional tests spec, or do they supplement it?
16:25:59 <dhellmann> jecarey: I tried to leave the domain set to the dist name; did I mess one up?
16:26:07 <dhellmann> in the _i18n.py files, that is
16:26:39 <jecarey> it is calling the TranslatorFacotry with 'oslo_i18n'
16:26:50 <dhellmann> jecarey: ugh, ok, and I see oslo_concurrency, too
16:26:53 <dhellmann> ok, so I need to fix those
16:27:16 <bnemec> So we didn't want to change the translation domain?
16:27:38 <ozamiatin> dhellman: I think we need more discussion on functional tests, but for now examples would replace the previous spec
16:27:45 <dhellmann> bnemec: no, I don't think so
16:28:10 <bnemec> Okay, will keep my eyes open for that in the future.
16:28:46 <dhellmann> jecarey, bnemec : patches to fix those submitted
16:30:21 <bnemec> dhellmann: I think we may need to fix setup.cfg too.
16:30:44 <bnemec> I actually requested that on one of the reviews because I thought it was supposed to change.
16:31:06 <dhellmann> ozamiatin: ok, I'll take another look. That's a long list of libraries, so you're probably going to want to break the work up. Have you thought about what the examples will actually look like?
16:31:33 <bnemec> dhellmann: Oh, maybe not.  i18n looks fine anyway.
16:32:23 <dhellmann> bnemec: yeah, I think we'd have failures from the jobs that build the translation files if that was wrong and Andreas would have come by to fix them, like he did with one of the early libraries we changed
16:33:14 <dhellmann> is there anything else we should discuss today?
16:33:32 <bnemec> dhellmann: Ah, it was oslo.log: https://github.com/openstack/oslo.log/blob/master/setup.cfg#L43
16:33:53 <bnemec> I knew I had -1'd something for the mismatch, but I requested the wrong fix apparently.
16:34:46 <ozamiatin> dhellmann: I think there would be a tiny apps easy to understand, running on the gates and building into a documentation
16:34:50 <dhellmann> bnemec: patch submitted
16:35:32 <bnemec> dhellmann: Thanks.  +2 to all.
16:35:54 <dhellmann> ozamiatin: I don't think anyone would argue with that. But the spec doesn't give any details about what the examples are, so there's not really much to review here. I'm afraid asking you to provide descriptions of all of the examples is going to be a lot of work, so rather than approve a vague spec I'm suggesting splitting it up into something more manageable for reviews.
16:36:31 <dhellmann> ozamiatin: that way you can propose the examples you've thought about, and we can leave the others for future release cycles
16:36:44 <ozamiatin> dhellmann: Ok, I'll work more on the spec, thanks
16:37:05 <dhellmann> ozamiatin: good, thanks, and thank you for working on the docs -- I think it will be extremely helpful to have good example apps
16:37:29 <dhellmann> if there's nothing else, I propose that we end a little early this week
16:38:32 <dhellmann> ok, I think that's it then
16:38:34 <jungleboyj> Everyone have a Merry Christmas and Happy New Year.
16:38:46 <dhellmann> have a good holiday, however and whenever you choose to celebrate
16:39:00 <jungleboyj> dhellmann: +1
16:39:02 <dhellmann> remember we'll skip the meeting next week, so see you all again here on 5 Jan
16:39:14 <dhellmann> thanks everyone!
16:39:19 <dhellmann> #endmeeting