16:00:57 <dhellmann> #startmeeting oslo
16:00:57 <openstack> Meeting started Mon Jan  5 16:00:57 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:00 <openstack> The meeting name has been set to 'oslo'
16:01:15 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:01:20 <dhellmann> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka1, zzzeek, sileht, kgiusti
16:01:25 <dhellmann> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:01:25 <jungleboyj> o/
16:01:25 <zzzeek> o/
16:01:29 <sileht> o/
16:01:30 <viktors> o/
16:01:32 <rpodolyaka1> o/
16:01:32 <jd__> happy new year! \o/
16:01:33 <redrobot> o/
16:01:34 <dims> o/ (partially here)
16:01:35 <dhellmann> happy new year, everyone
16:01:35 <beekneemech> o/
16:01:37 <bknudson> hi
16:01:44 <jungleboyj> Happy New Year!
16:01:52 <redrobot> woot 2015!
16:01:54 <ozamiatin> o/
16:02:03 <sigmavirus24> happy new year all
16:02:04 <sileht> happy new yeah
16:02:09 <bnemec> I have another conflict today so I may be semi-absent.
16:02:33 <inc0> hello, any chances to drop something to agenda yet?
16:02:34 <dhellmann> it should be a relatively quick meeting today
16:02:42 <bnemec> I really thought Monday morning would be a safe time to schedule this. :-/
16:02:49 <dhellmann> inc0: we usually have an "open discussion" section at the end of the meeting
16:03:04 <inc0> allright
16:03:04 <dhellmann> #topic Review action items from previous meeting
16:03:06 <dhellmann> #info dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs - DONE
16:03:14 <dhellmann> we didn't meet last week, so that's a pretty old one :-)
16:03:25 <dhellmann> #topic dropping namespace packages
16:03:36 <dhellmann> #link https://blueprints.launchpad.net/oslo-incubator/+spec/drop-namespace-packages
16:03:37 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/053737.html
16:03:49 <dhellmann> As I mentioned on the mailing list there, we have a few libraries ready for releases with the namespace package changes.
16:03:56 <dhellmann> To avoid breaking too many things at once, we should release them one at a time, with some delay in between.
16:04:07 <dhellmann> I thought I would cut a release of oslo.config later today, and follow that up with one of the others after a few hours.
16:04:10 <bknudson> where's your sense of adventure?
16:04:15 <dhellmann> Then tomorrow two more, etc.
16:04:23 <dims> bknudson: hehe
16:04:44 <dhellmann> bknudson: it was burned off ages ago :-)
16:04:46 <dims> dhellmann: sounds good
16:05:36 <dhellmann> liaisons, there's no real rush to update the imports in your project, but we don't want you to delay it either
16:05:43 <dhellmann> I know with the k-2 deadline coming up in a few weeks there's going to be a rush of other changes
16:06:06 <dhellmann> are there any questions or other comments about the plan for this?
16:06:13 <jungleboyj> dhellmann: At this point, which libraries should we be making changes for?
16:06:40 <dhellmann> jungleboyj: right now, only oslo.concurrency has been released with this change, I think. Watch the mailing list for other release announcements.
16:07:06 <jungleboyj> dhellmann: Ok, we have concurrency done.  I will start tackling the others as they come.
16:07:16 <dhellmann> jungleboyj: good, thanks
16:07:27 <dhellmann> ok, speaking of kilo-2
16:07:35 <dhellmann> #topic status check for kilo-2
16:07:38 <dhellmann> We have quite a few blueprints and bug fixes in progress.
16:07:41 <dhellmann> We need to look at each of them and see whether we're actually on schedule to finish them by their current projected deadline.
16:07:47 <dims> dhellmann: should we do oslo.log before kilo-2?
16:08:05 <dhellmann> I don't expect to do that today, but please be prepared to discuss them next week.
16:08:12 <bknudson> here's the keystone change for oslo_concurrency: https://review.openstack.org/#/c/139777/
16:08:16 <dhellmann> #action dhellmann email dev list reminding oslo contributors to be ready to discuss schedule at the next meeting
16:08:19 <bknudson> (merged)
16:08:49 <dhellmann> dims: let's figure out today what else is left to add before we're ready for a first release
16:08:58 <dims> dhellmann: ack
16:09:00 <dhellmann> bknudson: good reference, thanks
16:09:39 <dhellmann> so that's for next week
16:09:47 <dhellmann> #topic Red flags for/from liaisons
16:10:06 <dhellmann> liaisons, are you encountering any issues?
16:10:15 <bnemec> None for tripleo
16:10:20 <bknudson> keystone could use a new release of oslo.middleware with https://review.openstack.org/#/c/144700/
16:10:37 <bknudson> also, the config generator ordering issue fix
16:10:41 <jungleboyj> No major issues.  I have updated most of the incubator code in Cinder but am having an issue with policy that I need to further investigate.
16:10:48 <dhellmann> bknudson: ok, I think it's safe to release middleware since we haven't done the namespace work there
16:11:14 <jungleboyj> I will open an issue on that after I look at it a bit more.
16:11:18 <bknudson> looks like the change to use the new config generator is going to merge without the fix and we'll just pick it up when it's there.
16:11:34 <dhellmann> #action dhellmann talk to gordc about releasing oslo.middleware
16:11:38 <bnemec> The ordering fix merged to oslo.config, didn't it?
16:11:48 <bnemec> In which case it should be in the release tomorrow.
16:12:10 <bknudson> great, we'll pick it up then
16:12:11 <dhellmann> bnemec: yes, I don't see it as an open patch so I think it merged
16:12:38 <dhellmann> #link https://review.openstack.org/136482
16:12:44 <dhellmann> I think that's the one
16:13:20 <bknudson> yep, that'll do it
16:14:05 <dhellmann> jungleboyj: the spec to graduate the policy module was approved over the break: https://blueprints.launchpad.net/oslo-incubator/+spec/graduate-policy
16:14:33 <dhellmann> jungleboyj: if you find any bugs, we'll need to make sure we coordinate with adam about where/when to fix
16:15:33 <jungleboyj> dhellmann: Well do.
16:15:35 <dhellmann> let's move on
16:15:37 <dhellmann> #topic Ongoing work & Review priorities
16:15:38 <dhellmann> #link https://launchpad.net/oslo/+milestone/next-kilo
16:15:39 <dhellmann> #link https://launchpad.net/oslo/+milestone/kilo-2
16:15:41 <dhellmann> Is anyone blocked on work we prioritized for this release?
16:16:36 <dhellmann> I'm seeing a lot of failures in neutron tests for my oslo.messaging patch. I've had other issues to fix with it, so I haven't debugged those, yet. Does anyone know if there's currently a race condition with neutron?
16:17:56 * dhellmann prepares to debug the failures himself
16:18:33 <dhellmann> #topic open discussion
16:18:35 <bknudson> dhellmann: thanks.
16:18:38 <dhellmann> inc0: you had something?
16:18:52 <sileht> dhellmann, I have already seen some issue with this jobs on other review, I will check this is the same I issue I have started to investigate
16:18:56 <inc0> yup, oslo.versionedobjects
16:19:06 <dhellmann> sileht: ah, good, thanks
16:19:23 <inc0> anyone has started any work on that? what is status of this bp? anything I could help with?
16:19:53 <dhellmann> the work hasn't been started. I think we're blocked on my promise to prepare a repository based on the code currently in nova.
16:20:09 <dhellmann> I've spent a lot more time on this namespace package thing than I expected to
16:20:51 <viktors> dhellmann, zzzeek - I'd like to ask, what DB driver should we use for MySQL in py3 env?
16:21:05 <viktors> I confused by Doug's comment in https://review.openstack.org/#/c/133962/
16:21:05 <zzzeek> viktors: well I think mysql-connector is most appropriate
16:21:22 <viktors> I remember, that jd__ was against mysqlconnector on summit
16:21:30 <zzzeek> viktors: we have two contacts at oracle who are interested in keeping it working
16:21:38 <dhellmann> I can never remember, which one is the one from oracle?
16:21:40 <viktors> and it still not hosted on pypi
16:21:44 <inc0> I'd like to help, even code the thing if needed, but I'd like few pointers, repo you mention, and well, any help I can get:)
16:21:51 <zzzeek> viktors: that’s an issue they seek to solve
16:22:28 <viktors> zzzeek: yes, but why can't we use PyMySQL for now?
16:22:29 * jd__ is against MySQL whatever it is :p
16:22:36 <viktors> :-D
16:22:41 <zzzeek> viktors: our contacts are Andrew Rist and Geert Vanderkelen
16:22:52 <dhellmann> inc0: extracting the code from the nova repository using a modified version of our graduate.sh script is going to be fairly complicated, which is why I offered to do it for dan. If you feel comfortable with git, maybe that's something you want to look at?
16:22:56 <zzzeek> viktors: because it is not maintained to the levels of quality that openstack should have
16:23:10 <zzzeek> jd__: sure, but good luck with that :)
16:23:53 <viktors> zzzeek: ok, but is there any top quality, pypi hosted and py3 compatible db driver? )
16:24:04 <zzzeek> viktors: not particularly :)
16:24:09 <viktors> :)
16:24:24 <viktors> bad luck
16:24:25 <inc0> dhellmann, I can do it, although I would need few pointers from you
16:24:34 <dhellmann> zzzeek: is oracle planning to publish the package to pypi?
16:24:36 <inc0> like this graduate.sh thing;)
16:24:38 <dhellmann> inc0: ok, let's talk more after this meeting
16:24:43 <inc0> sure
16:24:48 <zzzeek> dhellmann: I’ll send andrew somehting of an ultimatum
16:24:50 <dhellmann> inc0: graduate.sh is in the incubator repository under "tools"
16:25:01 <dhellmann> zzzeek: yeah, that's a big blocker for us adopting it
16:25:07 <zzzeek> dhellmann: OK
16:25:16 <viktors> zzzeek: they "supposed to publish" for a few month already, afaik
16:26:34 <dhellmann> we need someone to take the lead on this driver issue, to summarize all of the information we have and keep track of progress or issues
16:26:37 <dhellmann> volunteers?
16:27:53 <viktors> I can try to summarize the information we have, but I can miss something
16:27:55 <dhellmann> a wiki page would be a good start
16:28:13 <dhellmann> sure, I just need someone who knows more about it than I do to get it started :-)
16:28:49 <dhellmann> does anyone else have a topic to raise this week?
16:29:15 <bknudson> can't think of anything.
16:29:49 <dhellmann> ok, well, let's stop a little early -- spend your extra 30 minutes reviewing oslo patches, please! :-)
16:30:11 * ihrachyshka is sorry for being late
16:30:22 <dhellmann> hi, ihrachyshka - we were just wrapping up
16:30:32 <ihrachyshka> dhellmann, aha! :) I have one thing
16:30:38 <ihrachyshka> oslo.concurrency release please ;)
16:30:51 <ihrachyshka> so that we can proceed with neutron
16:30:53 <dhellmann> ihrachyshka: what changes do you need?
16:31:00 <ihrachyshka> ConfigFilter removal
16:31:19 <dhellmann> ah, right
16:31:24 <ihrachyshka> that was already committed
16:31:34 <dhellmann> ok, that is merged
16:31:37 <dhellmann> #action dhellmann release oslo.concurrency
16:31:56 <dhellmann> I'll wait to create the release until after the oslo.config release with the namespace package change
16:32:08 <zzzeek> dhellmann: OK I’ve sent out an email and I think the answer is going to be more stalling, so if we want to get into pymysql i think we should maybe move in a bit on their github repo :)
16:32:10 <dhellmann> I don't want 2 releases possibly introducing competing breaking changes
16:32:16 <ihrachyshka> ack
16:33:10 <dhellmann> zzzeek: if they are interested in help, that may unblock us on this. Can you help viktors prepare that summary of what issues need to be addressed in the lib?
16:34:54 <dhellmann> zzzeek, viktors : we should also make sure that there's a note on the python 3 page haypo maintains mentioning that we need a good db driver
16:35:35 <dhellmann> ok, if there's nothing else we can all go review code
16:35:45 <zzzeek> dhellmann: it’s just a casually run project, that’s all.  e.g. the crummy changelog, etc.
16:36:22 <zzzeek> there’s the big issue with eventlet monkeypatching as well, but all the drivers have that issue
16:36:41 <dhellmann> zzzeek: I think we'd all rather use the driver from oracle. Maybe now that they're OpenStack Foundation members, we can convince them to put the code up on pypi.
16:36:52 <zzzeek> dhellmann: OK will see what response I get
16:37:12 <dhellmann> zzzeek: If we need to get the TC & Board involved, we can.
16:37:29 <zzzeek> dhellmann: I think the issue is that Oracle wants to track downloads of their products
16:37:33 <zzzeek> dhellmann: and pypi makes this impossible
16:37:42 <dhellmann> sigh
16:37:55 <zzzeek> dhellmann: I can’t say I don’t sympathize :)
16:38:09 <ihrachyshka> dhellmann, zzzeek, if you need email of mysql connector guy, tell me (it was not trivial to find it)
16:38:19 <zzzeek> ihrachyshka: i have the emails
16:38:25 <ihrachyshka> (which says enough about their dev model)
16:38:36 <ihrachyshka> ack
16:38:50 <dhellmann> zzzeek: ok, let's see what they say and then talk to the infra team about our options
16:40:36 <dhellmann> I think we're done for today. Thank you, everyone!
16:40:37 <dhellmann> #endmeeting