16:00:18 <dhellmann> #startmeeting oslo
16:00:20 <openstack> Meeting started Mon Jan 12 16:00:18 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:24 <openstack> The meeting name has been set to 'oslo'
16:00:26 <jungleboyj> o/
16:00:27 <bnemec> o/
16:00:28 <sileht> o/
16:00:29 <dhellmann> our agenda, as usual:
16:00:30 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:00:32 <bknudson> hi
16:00:42 <dhellmann> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka1, zzzeek, sileht, kgiusti
16:00:46 <dhellmann> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:53 <jd__> o/
16:01:02 <jungleboyj> o/ again.  :-)
16:01:17 <dhellmann> heh, I have those lined up to paste so you don't have to answer twice :-)
16:01:18 <zzzeek> o/
16:01:24 <jungleboyj> dhellmann: Nice.
16:01:30 <rpodolyaka1> o/
16:02:02 <dhellmann> we have a lot to cover today, so I'm going to dive right in
16:02:03 <dhellmann> #topic Review action items from previous meeting
16:02:13 <dhellmann> #info dhellmann email dev list reminding oslo contributors to be ready to discuss schedule at the next meeting DONE
16:02:17 <dhellmann> *foreshadowing*
16:02:26 <dhellmann> #info dhellmann talk to gordc about releasing oslo.middleware DONE
16:02:29 <dhellmann> #info dhellmann release oslo.concurrency DONE
16:02:55 <dhellmann> #topic Red flags for/from liaisons
16:03:14 <dhellmann> does anyone have any blocking issues?
16:03:30 <dhellmann> I think we've at least identified all of the fixes for things broken by the namespace package changes, right?
16:03:34 <bknudson> things are looking good in keystone-land
16:03:50 <flaper87> o/
16:03:58 * flaper87 loves dhellmann's courtesy pings
16:04:03 <jungleboyj> dhellmann: I have this issue:  https://review.openstack.org/#/c/145642/
16:04:06 <bknudson> I have some complaints about config generator that I haven't brought up yet.
16:04:08 <dhellmann> cinder, heat, and ceilometer had some breakages
16:04:25 <jungleboyj> I am about to submit a patch to set olso.i18n to be <=1.1.0 for Juno.
16:04:37 <jungleboyj> dhellmann: That makes sense?
16:04:59 <bknudson> I don't think you can cap versions in juno since then can't upgrade
16:05:11 <dhellmann> jungleboyj: yeah, that may be the best way to address stable branch issues. We'll see if it works. :-)
16:05:25 <jungleboyj> bknudson: ???
16:05:27 <dhellmann> bknudson: that used to be true, but I don't think it is any more.
16:05:46 <bknudson> must have changed the grenade test then
16:06:13 <dhellmann> we keep trying to make it work, but I honestly don't know the current state
16:06:28 <jungleboyj> I will push it out there and see if anyone has concerns and if it blows up in grenade.
16:06:31 <dhellmann> grenade does apparently update dependencies
16:07:08 <dhellmann> jungleboyj: yeah, let's see what happens
16:07:21 * jungleboyj makes it so
16:07:22 <dhellmann> how blocked is cinder development based on this? are all patches failing now?
16:07:42 <jungleboyj> All the stable/juno ones.  We got master fixed up already.
16:07:55 <dhellmann> ok, as long as the blockage is limited
16:08:25 <dhellmann> how about any of the other projects? heat and ceilometer also had some issues, are those resolved?
16:08:39 <dhellmann> therve, and jd__ ?
16:08:59 <bknudson> these are all related to using internal interfaces that change?
16:09:06 <jd__> that does not ring a bell
16:09:10 <dhellmann> yeah
16:09:19 <dhellmann> jd__: ok, I thought I saw something about unit tests being broken
16:09:41 <dhellmann> maybe it was already resolved, but as long as you're not blocked
16:10:04 <dhellmann> if there's nothing else, we can move on to our kilo-2 status check
16:10:14 <bknudson> in keystone we had an issue with using timeutils but fixed that quickly.
16:10:41 <dhellmann> bknudson: did you just change the mock?
16:11:21 <bknudson> dhellmann: yes, a mock was made: https://review.openstack.org/#/c/145989/
16:11:32 <dhellmann> bknudson: ok, cool
16:11:33 <bknudson> would be nice to see this mock in oslo_utils
16:12:00 <bknudson> class TimeFixture(fixtures.Fixture):
16:12:08 <bknudson> oh, wrong, we were using the mock before.
16:12:18 <bknudson> we switched to set_time_override() instead of the mock.
16:12:21 <dhellmann> oh, yeah, we should put that in the lib
16:13:03 <dhellmann> bknudson: do you want to work on a patch for that?
16:13:11 <bknudson> dhellmann: I'll put it on my list!
16:13:33 <dhellmann> #action bknudson to work on patch to add fixture for timeutils in oslo.utils
16:13:37 <dhellmann> thanks!
16:13:57 <dhellmann> anything else from liaisons before we start our status review?
16:14:21 <bnemec> Not from me
16:14:29 <jungleboyj> No, I am good.
16:14:49 <dhellmann> ok, moving on then
16:14:55 <dhellmann> #topic kilo-2 status review
16:14:58 <dhellmann> https://launchpad.net/oslo/+milestone/kilo-2
16:15:18 <dhellmann> #topic Drop our use of namespace packages
16:15:18 <dhellmann> #link https://blueprints.launchpad.net/oslo-incubator/+spec/drop-namespace-packages
16:15:29 <dhellmann> we made good progress last week, in spite of breaking a few things
16:15:36 <dhellmann> we have two more patches to land to update oslo.messaging and oslo.vmware
16:15:42 <dhellmann> #link https://review.openstack.org/#/c/144794/2
16:15:42 <dhellmann> #link https://review.openstack.org/145924
16:15:51 <dhellmann> then we can continue releasing libraries as we go, and I think we'll be able to finish those by k-2
16:15:53 <bknudson> there's some reviews out there: https://review.openstack.org/#/q/status:open+topic:bp/drop-namespace-packages,n,z
16:16:18 <dhellmann> that oslo.messaging patch is still not working with some of the imports in the other projects, so it needs more work, but I think the vmware changes are OK
16:16:48 <dhellmann> bknudson: it's good to see the migration happening already
16:17:36 <dhellmann> I was planning to release oslo.db after the meeting, but I have to run an errand so I won't be around if things break. Is someone else going to be around to keep an eye on things for an hour or two, or should I wait until tomorrow?
16:17:43 <dhellmann> rpodolyaka1, zzzeek: ?
16:18:08 <dhellmann> waiting isn't a problem, but releasing when we're all going offline is :-)
16:18:24 <zzzeek> dhellmann: im around
16:18:31 <rpodolyaka1> dhellmann: I'll be around too
16:18:31 <dhellmann> bnemec: oslo.serialization also looks ready to go
16:18:38 <zzzeek> dhellmann: it might be nice to merge https://review.openstack.org/#/c/139738/
16:18:49 <zzzeek> dhellmann: have been trying to get viktors to drop his -1
16:18:55 <dhellmann> zzzeek: ok, great, I'll do the release when we're done here
16:19:01 <rpodolyaka1> zzzeek: I'll take a look
16:19:06 * dhellmann is typing slowly today
16:19:27 <dhellmann> we can wait, but we can also do another release later in the week with that change in it
16:19:40 <dhellmann> I want to get the package stuff out there so we can find what it breaks before k-2
16:19:58 <dhellmann> make sense?
16:20:10 <bnemec> dhellmann: You already released oslo.serialization: http://lists.openstack.org/pipermail/openstack-dev/2015-January/054049.html
16:20:21 <dhellmann> bnemec: hmm, I forgot to update my notes
16:20:23 <zzzeek> dhellmann: OK that’s fine, its a bug fix so should be out soon
16:21:08 <dhellmann> zzzeek: yep, there's no reason to delay once we have the ns pkg version of the lib out there
16:21:32 <dhellmann> I'm only spacing out the other releases because we anticipate things breaking, and I want to know we can fix issues by limiting them to one lib at a time
16:21:46 <zzzeek> dhellmann: that’s good.  so just release as it is
16:22:02 <dhellmann> sounds good
16:22:06 <dhellmann> let's move on then
16:22:08 <bknudson> there was some discussion of a hacking rule to prevent use of the deprecated package names, which I agree with ... there's a reviews in flight and merge conflict resolution to consider.
16:22:48 <jungleboyj> bknudson: Is did someone already write that?
16:22:51 <dhellmann> bknudson: yeah, it's ok if projects want to maintain something like that I suppose. I don't want to have to wait on oslo releases until it's updated, though, so I'm not super excited about having it
16:23:18 <dhellmann> I don't want to be in a situation where we can't release an oslo lib because a hacking rule would break a bunch of apps all at once
16:23:19 <jungleboyj> bknudson: That was on my list for today.  :-)
16:23:25 <bknudson> jungleboyj: apparently dims__ has one in nova.
16:23:39 <jungleboyj> bknudson: Cool, I will look at what he did.
16:23:44 <dims__> bknudson: yep just a regexp
16:23:49 <bknudson> not sure if it should be shared or copied.
16:23:57 <jungleboyj> dhellmann: So you would prefer this be a per project thing?
16:24:34 <dhellmann> jungleboyj: it depends on how it's implemented. How does it know which libs need the rule applied, and which don't?
16:24:39 <bknudson> if it's like other hacking rules, we have to explicitly update.
16:25:10 <jungleboyj> dhellmann: Not sure, will look at what dims__ did.  I was going to add it and then update it with each namespace I got moved over.
16:25:22 <jungleboyj> dims__: Do you have a review link?
16:25:36 <dhellmann> that would work. I'm not sure how we could do that in the central hacking project, but i haven't given it any real thought
16:25:49 <bknudson> I have no problem with project-specific... we seem to have a lot of projects in keystone so it's annoying.
16:26:13 <jungleboyj> dhellmann: Good point, seems it would need to be project specific.
16:26:45 <bknudson> https://github.com/openstack/nova/blob/master/nova/hacking/checks.py#L452
16:26:55 <dhellmann> jungleboyj: yeah
16:27:21 <jungleboyj> bknudson: Thanks!
16:27:54 <bknudson> how about oslo-incubator?
16:28:03 <bknudson> want a hacking check in there? (does if have them already?)
16:28:31 <dhellmann> bknudson: I haven't started updating any of the code there, yet. I was counting on being able to delete more of it. :-)
16:29:14 <dhellmann> we have several other blueprints to look at, so let's move on and come back to this one if we need at the end of the meeting
16:29:15 <dhellmann> #topic graduate oslo.context
16:29:21 <dhellmann> #link https://blueprints.launchpad.net/oslo-incubator/+spec/graduate-oslo-context
16:29:27 <dhellmann> I think for this we just need to remove the old code from the incubator.
16:29:34 <dhellmann> Is that blocked on the oslo.log release?
16:29:41 <dhellmann> #link https://review.openstack.org/#/c/140149/
16:29:43 <dhellmann> dims: ?
16:31:05 <dhellmann> ok, I'll check with dims__ later today
16:31:12 <dhellmann> #topic adopt debtcollector library
16:31:16 <dhellmann> #link https://blueprints.launchpad.net/oslo-incubator/+spec/adopt-debtcollector
16:31:26 <dhellmann> harlowja_away: ?
16:32:37 <dhellmann> ok, I'll bump that one to kilo-3
16:32:59 <dhellmann> #topic graduate oslo.policy
16:33:05 <dhellmann> #link https://blueprints.launchpad.net/oslo-incubator/+spec/graduate-policy
16:33:12 <dhellmann> ayoung is working on this one
16:33:19 <dhellmann> and I don't see him online at the moment
16:34:34 <dhellmann> I think we're waiting on the actual import to happen, which is probably blocked on that governance change. That should happen today.
16:34:38 <bknudson> dhellmann: I caught him in openstack-keystone
16:34:51 <dhellmann> There's a link in the bp to the repo set up to be imported, so we could start reviewing that
16:34:52 <dhellmann> bknudson: thanks
16:34:58 <dhellmann> #link https://github.com/rodrigods/oslo.policy
16:35:49 <dhellmann> ayoung: we were just checking up on https://blueprints.launchpad.net/oslo-incubator/+spec/graduate-policy
16:36:07 <ayoung> dhellmann, knocking off items on the ticklist
16:36:47 <dhellmann> ayoung: it seems like it will be tight to get the release in by k-2, but some of that depends on how much cleanup is needed before a release
16:37:34 <ayoung> dhellmann, why?  It's pretty minimal
16:37:45 <dhellmann> ayoung: review time?
16:38:00 <ayoung> dhellmann, K+2 is when?
16:38:04 <dhellmann> how much do you anticipate changing once that repo is imported?
16:38:16 <dhellmann> k-2 is 5 Feb, about 4 weeks from now
16:38:42 <ayoung> dhellmann, we can't get the library released by then?  If not, we are broken
16:39:02 <dhellmann> ayoung: come on, you know this isn't the only thing we're doing right now
16:39:04 <ayoung> To start?  Nothing
16:39:18 <ayoung> I havea achange I want in, but if it misses, its not worth holding up the release
16:39:35 <ayoung> dhellmann, I realize, but this is just procedural
16:39:54 <ayoung> The code is not going to change, just the distro mechanism
16:40:14 <ayoung> I'm not even assuming that the other projects will switch over to using it
16:40:18 <ayoung> but let's get it out
16:40:36 <ayoung> RIght now we have the launchpad stuff basicall set:
16:40:54 <ayoung> need to probably put together a policy specific group , as it is all owned by me right now
16:40:57 <ayoung> who should that be?
16:41:43 <ayoung> #link https://launchpad.net/oslo/oslo.policy
16:42:16 <ayoung> dhellmann, the repo is in git under rodrigods
16:42:22 <ayoung> HA!
16:42:34 <bknudson> ayoung: you must have made him really mad.
16:43:01 <ayoung> dhellmann, don't you like me any more?
16:43:33 <bnemec> ayoung: I think for the lp project you just need to set it to be part of Oslo: http://docs.openstack.org/infra/manual/creators.html#put-your-new-project-in-the-correct-project-group
16:43:42 <ayoung> bnemec, done
16:43:59 <ayoung> bnemec, see the link? Part of oslo
16:44:14 <ayoung> bnemec, question is who should be the maintainers.
16:44:30 <ayoung> I'm not Oslo core, nor are any of the other Keystone core
16:44:34 <ayoung> I'm guessing we need a minimum of 3
16:44:48 <ayoung> as that is what we need to always have 2 to be able to code review
16:44:55 <bknudson> seems like the maintainers would start with whoever's on there now, + whoever else you want.
16:45:16 <bknudson> then can trim from there
16:45:22 <ayoung> so:  bknudson "whoever's on there now"  meaning what?
16:45:29 <ayoung> Rightnow it is just me
16:45:37 <ayoung> O
16:45:42 <ayoung> I'd say:
16:45:51 <bknudson> ayoung: whoever has core reviewer authority on policy in oslo-incubator.
16:45:51 <bnemec> Oslo cores are always added (part of the oslo-core group), and we can add anyone from Keystone that you want
16:46:12 <dhellmann> I lost internet, reading scrollback
16:46:19 <dhellmann> bnemec: thanks
16:46:26 <dhellmann> #undo
16:46:27 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x3bb1190>
16:46:30 <ayoung> bnemec, Ok, I'll make an oslo.policy.core  group and start with the oslo core team plus....
16:46:33 <dhellmann> ayoung: http://docs.openstack.org/infra/manual/creators.html#set-up-supervisors-for-your-project
16:46:38 <ayoung> me, morganfainberg bknudson
16:46:41 <dhellmann> ayoung: oslo-core should be added to the review group in gerrit
16:46:48 <dhellmann> ayoung: and yourself, and then we can talk about who else needs to be added
16:46:55 <dhellmann> I do want to make sure we're adding people interested in reviewing, and not just people we *want* to be interested in reviewing
16:47:06 <bnemec> Is there a difference? ;-)
16:47:12 <morganfainberg> ++ oslo core needs to be there.
16:47:35 <ayoung> dhellmann, it was origianlly going to be a Keystone project.  I'd like a healthy dose of Keystone core in there, as we want people that understand the wide scope of policy
16:47:50 <ayoung> and people that have touched the policy mechanism in the past
16:47:58 <dhellmann> ayoung: yep, that's fine, I just want to make sure we get some sort of confirmation from them as we add them
16:48:10 <morganfainberg> You can add me to that list.
16:48:12 <ayoung> OK...so new group?  oslo-policy-core   is the right name?
16:48:24 <morganfainberg> (Quick confirmation)
16:48:38 <ayoung> or oslo.policy.core?
16:48:48 <dhellmann> ayoung: I spent many many hours working on http://docs.openstack.org/infra/manual/creators.html Please go read it.
16:49:12 <ayoung> dhellmann, so hyphens?
16:49:21 <dhellmann> that is consistent with the other names, yes
16:49:21 <morganfainberg> dhellmann: ooh nice documentation!!
16:49:34 <zzzeek> “This is a long document. It’s long because it has to be, not because we want it to be. If you follow it, everything will be fine."
16:50:22 <ayoung> dhellmann, I had been reading it, just the oslo.policy value got prepoulated.  My real question is "Is there a group for any other oslo library that is different from oslo-core?"  And, if so, is there a naming convention
16:50:25 <dhellmann> I'd really like to have a script to do this stuff, but a lot of the pieces are tricky to automate
16:50:44 <dhellmann> ayoung: yes, we have been creating oslo-foo-core and oslo-foo-release groups
16:50:50 <ayoung> Got it
16:50:56 <bnemec> ayoung: See https://review.openstack.org/#/admin/groups/?filter=oslo
16:50:57 <dhellmann> especially for libs that have reviewers who are not oslo-core
16:51:11 <ayoung> maintainer is now oslo-policy-core.  I'll seed it
16:51:30 <dhellmann> wait, we're talking about gerrit right?
16:52:19 <dhellmann> ayoung: launchpad and gerrit work differently
16:52:28 <ayoung> starting with launchpad first
16:52:45 <ayoung> https://launchpad.net/~oslo-policy-core
16:53:04 <ayoung> hadn't gotten as far as Gerrit yet.
16:53:30 <dhellmann> ok, apparently some of the oslo-specific details got lost when I extracted that documentation from the wiki to move to the infra manual
16:53:46 <dhellmann> the maintainer on lp should be https://launchpad.net/~oslo-drivers
16:53:59 <dhellmann> and the driver should also be the same
16:54:27 <ayoung> dhellmann, Um.  Not quite, as that rules me out
16:54:38 <ayoung> Oh, wait, drivers?
16:54:41 <dhellmann> yeah
16:54:46 <ayoung> Isn't that like the galactic list?
16:54:52 <dhellmann> we're going to have to talk about this later, ayoung, we're running out of time
16:55:10 <ayoung> dhellmann, that is fine.  I was just working through the list
16:55:25 <dhellmann> #topic notification dispatcher filter
16:55:28 <dhellmann> #link https://blueprints.launchpad.net/oslo.messaging/+spec/notification-dispatcher-filter
16:55:32 <ayoung> dhellmann, if you update the doc and ping me, I'll take it from there
16:55:34 <dhellmann> it looks like I blocked the patch for this until the namespace package changes merge into oslo.messaging
16:55:39 <dhellmann> sileht?
16:55:55 <sileht> dhellmann, I have just propose a patch
16:56:07 <sileht> dhellmann, https://review.openstack.org/#/c/146547/
16:56:08 <dhellmann> sileht: ok, do you think this work will complete for k-2?
16:56:29 <sileht> I hope to release a new version of oslo.messaging for k-2
16:57:05 <dhellmann> ayoung: the vmware lib sets a precedent for having a separate set of drivers so go ahead with that plan
16:57:14 <sileht> dhellmann, if my change works work you can squash it into your change and they we can release a new version
16:57:23 <ayoung> dhellmann, will do
16:57:35 <dhellmann> sileht: ok, rebasing those namespace changes is pretty painful but I'll give it a try
16:57:48 <dhellmann> oh, squash, I see
16:58:29 <dhellmann> yeah, I see what you're doing
16:58:47 <dhellmann> ok, sileht, if this works it should let us unblock the notification dispatcher
16:59:06 <dhellmann> #topic application-agnostic logging parameters in format strings
16:59:06 <dhellmann> #link https://blueprints.launchpad.net/oslo.log/+spec/app-agnostic-logging-parameters
16:59:06 <dhellmann> I think we can do this work after oslo.log has graduated, but not for k-2
16:59:33 <dhellmann> it's in the lib, with next-kilo, so either way I think it's fine
16:59:49 <dhellmann> #topic semantic version support for pbr
16:59:49 <dhellmann> #link https://blueprints.launchpad.net/pbr/+spec/pbr-semver
16:59:49 <dhellmann> lifeless?
16:59:58 <dhellmann> I'll check with him on this one later, we're about out of time
17:00:02 <dhellmann> #topic open discussion
17:00:05 <dhellmann> one minute or so
17:00:16 <dhellmann> oops, not even
17:00:34 <dhellmann> I think we're in pretty good shape for k-2. We have time to finish quite a bit of what we have scheduled for then.
17:00:36 <dhellmann> thanks everyone!
17:00:41 <bknudson> thanks
17:01:08 <dhellmann> #endmeeting