16:00:04 <dhellmann> #startmeeting oslo
16:00:04 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:00:05 <openstack> Meeting started Mon Feb  2 16:00:04 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:09 <openstack> The meeting name has been set to 'oslo'
16:00:21 <jecarey> hi
16:00:22 <dhellmann> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka1, zzzeek, sileht, kgiusti
16:00:27 <dhellmann> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:28 <bnemec> o/
16:00:32 <rpodolyaka> o/
16:00:49 <bknudson> lol
16:01:25 <jd__> o/
16:01:26 <dhellmann> low turnout today :-)
16:01:35 <bknudson> groundhog day
16:01:43 <bknudson> I think that's a holidy
16:01:44 <dhellmann> haha
16:02:00 <dhellmann> #topic Review action items from previous meeting
16:02:12 <dhellmann> #info rpodolyaka & viktors to start a mailing list thread discussing mysql driver change - DONE
16:02:16 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/thread.html#55469
16:02:23 <dhellmann> #info dhellmann write down spec approval policy in the specs repository - DONE
16:02:29 <dhellmann> #link https://review.openstack.org/150119
16:02:39 <dhellmann> #action dhellmann document policy assumptions for library adoption among applications, including milestones and support for incubator code after graduation
16:03:10 <GheRivero> o/
16:03:22 <dhellmann> #action bnemec write policy spec on feature freezes
16:03:25 <zzzeek> \o
16:03:29 <dims> o/
16:03:30 <dhellmann> I think that's it from alst week
16:03:36 <bnemec> dhellmann: Not done yet. :-/
16:03:43 <dims> dhellmann: we're getting more snow today
16:03:59 <dhellmann> dims: better you than me :-)
16:04:06 <dims> haha
16:04:11 <bknudson> dims: groundhog saw his shadow.
16:04:16 <dhellmann> bnemec: yeah, I didn't do mine either, so we'll carry those over
16:04:19 <bnemec> Yeah, we know what happens when Atlanta gets snow. ;-)
16:04:28 <dhellmann> bknudson: his shadow would have blown away here in GA
16:04:36 <dhellmann> bnemec: seriously, those people are nuts
16:05:06 <dhellmann> SNOW = So Not Outside Weather
16:05:09 <dims> bknudson: :(
16:05:14 <bnemec> lol
16:05:35 <dhellmann> #topic Red flags for/from liaisons
16:05:55 <bknudson> nothing from keystone... looks like oslo.policy is at least getting cleaned up.
16:06:02 <dhellmann> now that the Great Breaking of 2014 is done and all of the libs with namespace packages are released, how are things looking?
16:06:02 <bknudson> not sure what the outlook is for a release.
16:06:20 <dhellmann> bknudson: probably not this week
16:06:27 <bknudson> we need a requirements update for oslo.messaging I think.
16:06:58 <dhellmann> #link https://review.openstack.org/150556
16:07:08 <dhellmann> it should be in the merge queue already
16:07:24 <bknudson> ok, that should be coming along soon.
16:07:47 <dhellmann> I approved some of the policy changes that were up for review this morning, but there are still a few open tickets I think
16:07:51 <bknudson> for some reason some of the changes in keystone are failing... I need to check those out.
16:08:20 <dhellmann> #link https://launchpad.net/oslo.policy/+milestone/next-kilo
16:08:47 <dhellmann> how about some of the other projects, are things going smoothly?
16:08:49 <bknudson> http://logs.openstack.org/81/151881/1/check/check-grenade-dsvm/d87723f/logs/grenade.sh.txt.gz#_2015-01-31_15_32_40_193 -- looks like oslo_messaging.
16:08:59 <bknudson> maybe just needs the requirements update.
16:09:16 <bnemec> No issues from tripleo.
16:09:20 <dhellmann> bknudson: check the logs to see if it downgraded for some reason
16:10:34 <dhellmann> bknudson: and let me know if you continue to have trouble and I'll see if I can help figuring out what's going on there
16:11:01 <dhellmann> if there are no other issues to raise, we'll move on to the k-2 checkup
16:11:28 <dhellmann> #topic Ongoing work & Review priorities
16:11:28 <dhellmann> #link https://launchpad.net/oslo/+milestone/next-kilo
16:11:28 <dhellmann> #link https://launchpad.net/oslo/+milestone/kilo-2
16:11:36 <dhellmann> The k-2 deadline is this week, so we should be focusing on wrapping up any remaining work for blueprints and bugs associated with this milestone.
16:12:03 <dhellmann> I don't see any incubator reviews that look critical for k-2
16:12:05 <dhellmann> #link https://review.openstack.org/#/q/project:openstack%2Foslo-incubator+is:open,n,z
16:12:16 <zzzeek> OK I’d like to put a plug out for enginefacade: https://review.openstack.org/#/c/138215/
16:12:31 <dhellmann> I would like to have some reviews for https://review.openstack.org/#/c/151027/ because that will make it easier to work on the versionedobjects lib
16:12:56 <dhellmann> zzzeek: ok, is that blueprint targeted for k-3?
16:13:09 <zzzeek> dhellmann: I don’t know
16:13:15 <dhellmann> #link https://blueprints.launchpad.net/oslo.db/+spec/make-enginefacade-a-facade
16:13:21 <dhellmann> 1.2.0? what is that?
16:13:24 <zzzeek> how do you find that so fast....
16:13:36 <dhellmann> zzzeek: practice
16:13:38 <zzzeek> shrugs
16:13:46 <dhellmann> ok, I changed it to "next-kilo"
16:13:52 <zzzeek> thanks
16:14:33 <dhellmann> just a reminder to everyone, make sure the milestone target on your bps and bugs are set correctly to ensure review priority
16:15:06 <dhellmann> and reviewers, check https://launchpad.net/oslo/+milestone/next-kilo for items to review
16:15:44 <dhellmann> how about anyone else? is anyone blocked on something you thought you'd have done by the k-2 deadline?
16:17:38 <dhellmann> ok, moving on then
16:17:39 <dhellmann> #topic Releases for this week
16:18:00 <dhellmann> we should get back into a routine of releasing libs frequently, to keep the changes small
16:18:12 <dhellmann> We have a backlog of changes in taskflow that I'd like to release. I need to talk with harlowja about that
16:18:24 <dhellmann> The same for pbr, though I need to talk to some of the other pbr devs about those before a release.
16:18:34 <dhellmann> I don't think we want pbr this week, with the deadline.
16:19:11 <dhellmann> I see a new fixture in oslo.utils. dims, is that ready for a release?
16:19:25 <dims> dhellmann: looking
16:19:36 <dhellmann> #link https://etherpad.openstack.org/p/wVpLp8C4ES
16:20:15 <dims> dhellmann: i believe so
16:20:32 <dhellmann> dims: do you want to do the honors, or shall I?
16:20:56 <dims> dhellmann: please go ahead, still catching up from travels
16:21:04 <dhellmann> dims: ok, sure thing
16:21:50 <dhellmann> oslotest looks like it's ready, too, so I'll do that one as well
16:22:31 <dhellmann> bnemec: oslo.serialization has a new "messagepack utils helper" -- is someone waiting for that?
16:23:29 <bnemec> dhellmann: I'm not sure.  That only sounds vaguely familiar to me.  I think maybe harlowja was involved in that somehow?
16:23:40 <dhellmann> if we can get https://review.openstack.org/149090 approved we can do another oslo.log change and test it with the nova patch again
16:23:44 <bnemec> I could be wrong though.  That's my vague memory of seeing an email about it.
16:23:46 <dhellmann> bnemec: ok
16:24:23 <dhellmann> rpodolyaka, zzzeek : oslo.db has some fixes and new features, is anyone waiting for those? are we at a good point for a release?
16:24:32 <zzzeek> dhellmann: hmmm
16:25:05 <zzzeek> dhellmann: yes the retry decorator I’d like people to get onto
16:25:22 <dhellmann> zzzeek: ok, I'll go ahead and cut a release
16:25:50 <dhellmann> well, now that I think about it, I wonder if we shouldn't wait until next week because of the milestone this week
16:25:58 <dhellmann> maybe I'll just do all of these on monday
16:26:28 <jungleboyj> o/  Sorry, had another meeting run long.
16:26:35 <zzzeek> dhellmann: theres just that one change, an improvement in revalidation of failed connections, and that’s it
16:27:30 <dhellmann> zzzeek: ok, let's let this be a quiet week and release things next week
16:27:36 <zzzeek> dhellmann: OK
16:27:41 <jecarey> dhellmann oslo.i18n ... I've got new Nova tests and Cinder test cleanup waiting on the new fixture that is under review (https://review.openstack.org/#/c/147262/)
16:27:53 <bnemec> It's unlikely anyone is going to be adopting anything new at a deadline anyway.
16:28:16 <dhellmann> bnemec: right
16:28:33 <dhellmann> jecarey: ok, I'll put that on my review list
16:28:53 <dhellmann> #topic open discussion
16:29:03 <dhellmann> that's all I had on the agenda, does anyone have anything else to bring up?
16:30:15 * dhellmann puts on some music to drown out the crickets
16:30:24 <bnemec> :-)
16:30:37 <dhellmann> ok, I think we can call it early then
16:30:47 <dhellmann> spend your extra 29 minutes reviewing patches! :-)
16:31:03 <bknudson> thanks
16:31:08 <dhellmann> thanks everyone
16:31:40 <dhellmann> #endmeeting