16:00:14 <dhellmann> #startmeeting oslo
16:00:15 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:00:16 <openstack> Meeting started Mon Feb 16 16:00:14 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:19 <openstack> The meeting name has been set to 'oslo'
16:00:26 <dhellmann> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka, zzzeek, sileht, kgiusti
16:00:26 <dhellmann> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:27 <jungleboyj> o/
16:00:34 <xek> o/
16:00:36 <viktors> o/
16:00:40 <ihrachyshka> o/
16:00:42 <flaper87> o/
16:00:47 <ozamiatin> o/
16:00:48 <jecarey_> o/
16:01:19 * flaper87 remembers the first oslo IRC meeting.... There were so few of us
16:01:30 <jd__> o/
16:01:31 <dhellmann> flaper87: so true :-)
16:01:58 <bnemec> Sort of o/
16:02:12 <dhellmann> bnemec: o~
16:02:23 <dhellmann> let's get started
16:02:24 <bnemec> dhellmann: I like it :-)
16:02:24 <dhellmann> #topic Review action items from previous meeting
16:02:38 <dhellmann> #info dhellmann start a mailing list thread for summit room planning
16:02:39 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2015-February/056617.html
16:02:40 <dhellmann> we'll talk more about this in a few minutes
16:02:52 <dhellmann> not much old business this week
16:02:56 <dhellmann> #topic Red flags for/from liaisons
16:03:03 <dhellmann> I've released several libraries today already, and we have a few more to go.
16:03:16 <zzzeek> o/
16:03:22 <dhellmann> All of the requirements will be capped in juno and icehouse by the time they are released.
16:03:29 <dhellmann> Let us know if the releases start causing trouble in master.
16:03:45 <dhellmann> Other than that, how are things going, liaisons?
16:04:16 <ihrachyshka> pretty calm. waiting for official oslo.policy release.
16:04:20 <jungleboyj> Other than the Juno mess.  Fine.
16:04:50 <dhellmann> ihrachyshka: we'll be looking at policy for a release tomorrow probably -- I want to look at the state of things before we cut 0.1.0
16:05:01 <dhellmann> jungleboyj: is that still an issue for you?
16:05:03 * bnemec just approved https://review.openstack.org/#/c/154742/
16:05:26 <ihrachyshka> ack, thank
16:05:28 <dhellmann> bnemec: excellent, thanks
16:05:28 <ihrachyshka> *s
16:05:40 <jungleboyj> I need to check today.  It was last week.
16:06:05 <dhellmann> jungleboyj: ok. We believe that now with the caps in place everything should be working ok.
16:06:31 <dhellmann> we do have caps for all runtime libs, but oslotest and oslosphinx are still in the merge queue from the patch I posted today
16:06:43 <dhellmann> #link https://review.openstack.org/#/c/156239/1
16:07:10 <jungleboyj> dhellmann: Ok, will let you know if that isn't the case.
16:07:38 <dhellmann> how about any of the other liasons? if you have nothing to report, please say that explicitly so we know we've heard from you
16:07:44 <dhellmann> jungleboyj: ok, good
16:08:26 <dougwig> Good here. It's Presidents' Day, so folks might be absent
16:08:51 <dhellmann> that's a good day for releases, then :-)
16:08:59 <ihrachyshka> :D
16:09:03 <dougwig> Haha
16:09:38 <dhellmann> let's move on to the main topic for today
16:09:40 <dhellmann> #topic summit planning
16:09:45 <dhellmann> #link https://etherpad.openstack.org/p/liberty-oslo-summit-planning
16:10:14 <dhellmann> as we discussed last week, and as I said in the ML thread mentioned above, we need to give ttx an estimate for the number of each type of room we will need at the summit
16:10:28 <dhellmann> we have a few good sessions proposed already
16:11:01 <dhellmann> I can probably use that to extrapolate for the next cycle, but I'd like hard numbers if possible
16:11:14 <dhellmann> does anyone have ideas for topics that we'll need to discuss?
16:14:50 <dhellmann> and especially do any of the library leads feel like it would be useful to have the smaller working sessions?
16:15:21 <ihrachyshka> ok, if everyone is shy... versionedobjects, I need to understand how it applies to neutron.
16:17:34 <dhellmann> ihrachyshka: are you asking for a "tutorial" style session with dansmith? or more of a discussion?
16:18:06 <ihrachyshka> dhellmann, I guess I will be ok with someone giving walk through
16:18:22 <ihrachyshka> I tried to get the idea from docs, but failed
16:18:30 <ihrachyshka> maybe it's just me
16:18:44 <dhellmann> ihrachyshka: maybe that's different from item #6 on the etherpad then
16:19:41 <ihrachyshka> yeah, that's for advanced users, which I am not
16:20:23 <dhellmann> yeah, I would have to ask dansmith if he's up for doing an introductory walk-through session
16:20:32 <dansmith> sure
16:20:46 <ihrachyshka> thanks
16:22:00 <dhellmann> dansmith: great, I added a fishbowl session for that
16:23:14 <bnemec> +1 to that.  I got a lot of similar questions last summit about objects.
16:24:54 <dhellmann> rpodolyaka, viktors : I added a placeholder for an oslo.db session, but it could use more info about what would actually be a useful format for you
16:25:33 <rpodolyaka> dhellmann: ok. got it. thanks
16:25:40 <viktors> dhellmann: ok, thanks.
16:26:03 <dhellmann> sileht: I added a session on zmq, but if you want a more general one for oslo.messaging we should add that, too
16:26:43 <flaper87> I'd probably vote for a more general one
16:26:49 <dhellmann> sileht:I went ahead and added a placeholder, too
16:26:57 <flaper87> I think there are a couple of things we might want to discuss w.r.t o.m
16:27:18 <dhellmann> keep in mind that sessions based on specific proposals will need to have specs filed
16:27:30 <dhellmann> #action dhellmann set up specs repo to accept liberty specs
16:28:47 <dhellmann> flaper87: can you add topics to item #9 in the etherpad?
16:29:08 <flaper87> dhellmann: absolutely
16:29:13 <dhellmann> flaper87: great, thanks
16:30:51 <dhellmann> ok, I'll keep pinging people individually for more topics today and try to have an estimate tomorrow
16:31:11 <dhellmann> #topic Ongoing work & Review priorities
16:31:17 <dhellmann> #link https://launchpad.net/oslo/+milestone/next-kilo
16:31:20 <dhellmann> #link https://launchpad.net/oslo/+milestone/kilo-3
16:31:23 <dhellmann> Is anyone blocked on work we prioritized for this release?
16:32:14 <dhellmann> dansmith: do you need any help with versionedobjects reviews?
16:32:37 <dansmith> dhellmann: not currently, dims has been staying on top of them pretty well
16:33:06 <dhellmann> dansmith: excellent; thanks, dims__!
16:33:13 <dansmith> indeed, thanks dims__  :)
16:33:40 <dhellmann> we have some clean up work for the policy release and some of our tooling in the incubator: https://review.openstack.org/#/q/project:openstack%2Foslo-incubator+is:open,n,z
16:34:47 <dhellmann> it doesn't sound like we're blocked anywhere, though
16:35:01 <dhellmann> #topic Releases for this week
16:35:29 <dhellmann> #info oslo.utils, oslo.config, and oslo.i18n have been released
16:35:47 <dhellmann> #info expect releases of oslo.db, oslo.messaging, oslo.serialization, oslo.concurrency, and oslotest today or tomorrow
16:36:08 <dhellmann> we have a few other libs with minor changes, but I think that's a big enough dump for one week
16:36:13 <dhellmann> unless there is something critical that I missed?
16:36:25 <viktors> we are having issues with unittest with a new oslo.db in Ironic
16:36:39 <dhellmann> viktors: what's the nature of the issue?
16:37:33 <viktors> Ironic patches timeutils from oslo.utils, and it uses oslo.utils, but oslo.db uses oslo_utils
16:37:48 <dhellmann> ah
16:37:51 <viktors> so in some cases timeutils leaves unpatched
16:38:02 <dhellmann> right
16:38:18 <dhellmann> that should be easy enough to fix with a patch to ironic's tests
16:38:27 <dhellmann> where are they on adopting the new import style?
16:38:42 <dhellmann> GheRivero: ^^
16:38:49 <viktors> yes, but we can't just replace olso.utils to oslo_utils in Ironic because of the same issue
16:39:01 <viktors> there is a patch on review
16:39:27 <viktors> I'm going to investigate this tomorrow
16:39:54 <dhellmann> viktors: this one? https://review.openstack.org/#/c/149450/
16:40:09 <viktors> dhellmann: yes, this one
16:40:35 <ihrachyshka> viktors, patch both?
16:40:41 <dhellmann> viktors: perhaps we should provide a fixture for the tests, instead of expecting them to mock out the function
16:40:56 * dims__ peeks
16:41:03 <dhellmann> I'd have to look at what the test is doing
16:41:27 <viktors> ihrachyshka: sounds reasonable, we made this in ironic some time ago
16:42:14 <dhellmann> ok, we can hold off on the oslo.db release until we sort this out
16:42:33 <dhellmann> although if releasing oslo.db makes this simpler for ironic, we can go ahead
16:43:38 <dims__> dhellmann: on the same note, we need one more review to cleanup oslo-incubator's imports (https://review.openstack.org/#/c/155869/) we still have oslo.config there
16:43:43 <dhellmann> that's it for the formal agenda today
16:43:44 <dhellmann> #topic open discussion
16:43:45 <dhellmann> does anyone have anything else to bring up?
16:43:59 <dhellmann> dims__: thanks, I'll look at that today if no one beats me to it
16:44:19 <dims__> dhellmann: the oslo.policy LOG.info, are we all on board the latest review?
16:44:53 <dhellmann> dims__: the one about the missing diretories?
16:44:55 <dims__> https://review.openstack.org/#/c/154742/
16:44:56 <dims__> y
16:45:13 <dhellmann> dims__: yeah, bnemec approved that one just a little while ago
16:45:34 <dims__> cool, follow up, do we fix oslo-incubator copy now?
16:45:48 <bnemec> I think we need to.
16:45:58 <dhellmann> dims__: yeah, if we're seeing lots of issues in test jobs we should
16:45:59 <dims__> or we wait to get rid of policy.py entirely
16:46:12 <dims__> +1 bnemec
16:46:33 <dhellmann> I suspect that backporting to the incubator is going to be pointless given the amount of time it takes to sync the code into projects, but we can make the gesture
16:46:39 <dims__> right dhellmann
16:47:14 <bnemec> There were over 100 million hits on this log message in CI recently.  I think they'll be motivated to sync. :-)
16:47:17 <dhellmann> speaking of oslo.policy, we should give it a hard look in the next day or two so we can prepare the first release
16:47:31 <dhellmann> bnemec: sounds like it
16:48:32 <dims__> one more, do we continue to add default log levels to oslo.log? https://bugs.launchpad.net/oslo.log/+bug/1422075 or push back to add project specific ones
16:48:34 <openstack> Launchpad bug 1422075 in oslo.log "urllib3.util.retry prints not so useful debug messages" [Undecided,In progress] - Assigned to ZhiQiang Fan (aji-zqfan)
16:49:42 <dhellmann> dims__: we talked about that at the summit
16:49:48 * dhellmann thinks back that far
16:50:06 <dims__> y if i remember right, we are going for project specific ones
16:50:39 <dhellmann> I think we said we would have an app-specific logger with useful level and then the root logger would only emit error or something, so that libraries would by default be quiet
16:51:13 <dhellmann> right, I think we're saying the same thing
16:51:19 <dims__> dhellmann: this one is a log level for urllib3
16:51:35 <dhellmann> but for now we could add an exception for urllib3, because the other change is bigger
16:51:47 <dims__> ok
16:51:51 <dhellmann> and we don't have a spec for the logging stuff
16:52:01 * dhellmann adds a logging working session to the summit planning
16:53:29 <dims__> dhellmann: url?
16:53:32 <dhellmann> sdague: I added a summit session for us to work out changes to oslo.log: https://etherpad.openstack.org/p/liberty-oslo-summit-planning
16:53:39 <dhellmann> dims__: ^^
16:53:54 <dhellmann> sdague: we should see about some specs before then
16:54:48 <dhellmann> we're about out of time, does anyone have anything else we need to discuss?
16:55:46 <dims__> all set
16:56:05 <dhellmann> ok, that's it then
16:56:10 <dhellmann> thanks, everyone!
16:56:17 <dhellmann> #endmeeting