16:02:30 <dims> #startmeeting oslo
16:02:31 <openstack> Meeting started Mon Mar  9 16:02:30 2015 UTC and is due to finish in 60 minutes.  The chair is dims. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:35 <openstack> The meeting name has been set to 'oslo'
16:02:59 <GheRivero> o/
16:03:02 <harlowja_at_home> yo
16:03:10 <amotoki> o/
16:03:12 <ihrachyshka> \o
16:03:22 <dhellmann> o/
16:03:29 <kgiusti> o/
16:03:45 <sileht> o/
16:03:50 <zzzeek> \o
16:03:50 <dims> bnemec: jd__: flaper87 and others?
16:04:04 <harlowja_at_home> who all is @ the operators meetup?
16:04:05 <jd__> o/
16:04:23 <dims> k let's begin
16:04:24 <bnemec> Sort of here.  Previous meeting running long.
16:04:25 <dims> #topic Review action items from previous meeting
16:04:54 <dims> dhellmann: any action items that needed our attention?
16:05:10 * dhellmann checks the meeting logs
16:05:16 <dims> i see oslo.concurrency oslo.middleware mentioned
16:05:40 <dhellmann> http://eavesdrop.openstack.org/meetings/oslo/2015/oslo.2015-03-02-16.00.html has no action items listed
16:05:43 <dims> dhellmann: and the schedule
16:06:01 <bknudson> release oslo.policy (done)
16:06:08 <dims> we had a bunch of releases, so everyone please watch out for regressions
16:06:22 <dhellmann> yeah, I think I released all but ~4 of our libraries today
16:06:31 * harlowja_at_home likely should also release taskflow, but will wait for the current releases issues to calm down :)
16:06:38 <bknudson> dhellmann must have a script.
16:06:47 <dims> nice! lots of positive vibes in our announce emails
16:06:51 <bknudson> for project in "": do release $project; done
16:06:53 <harlowja_at_home> lol
16:07:17 <dims> ok moving on
16:07:25 <jd__> when are we replacing dhellmann by a bot?
16:07:29 <jd__> :-)
16:07:29 <dims> #topic Red flags for/from liaisons
16:07:43 <bknudson> none for keystone...
16:07:55 <GheRivero> none for ironic
16:07:58 <ihrachyshka> none for neutron
16:08:24 <jungleboyj> None for Cinder ... though we are at the point that some of the incubator updates are being asked to be held for Libery.
16:08:28 <dhellmann> jd__: I'm thinking about how to automate the release emails further :-)
16:08:29 <jungleboyj> Don't want big changes right now.
16:08:45 <bknudson> is there anything still to be moved from oslo-incubator?
16:08:54 <dims> jungleboyj: thanks you mean oslo-incubator?
16:09:10 <dims> or oslo libs
16:09:22 <jungleboyj> Yes, oslo-incubator.
16:09:26 <dims> bknudson: i don't think so
16:09:33 <dims> jungleboyj: thanks
16:09:34 <jungleboyj> Had a couple of syncs I wanted to do, but too late now.
16:09:39 <dims> ok
16:09:50 <jungleboyj> Still hoping to get the new config-generator code in though.
16:09:51 <dims> is everyone using oslo-config-generator?
16:09:59 <dims> Nova isn't
16:10:06 <amrith> don't believe trove is.
16:10:08 <dhellmann> dims: I don't think so. We should add that to our priority list for next cycle.
16:10:09 <bknudson> keystone is.
16:10:11 <jungleboyj> dims: Working on the patch for that now.  Takes a bit of work.
16:10:39 <dims> #dims - add oslo-config-generator to priority work for Liberty
16:10:47 <amrith> being the luddite, would you please post a #link for oslo-config-generator
16:10:51 <dims> #action - add oslo-config-generator to priority work for Liberty
16:11:17 <dims> #link http://docs.openstack.org/developer/oslo.config/generator.html
16:11:22 <amrith> thanks dims
16:11:40 <dims> related note, i polled oslo.log adoption
16:11:43 <dims> Heat - Done
16:11:44 <dims> Nova - Done
16:11:44 <dims> Keystone - Done
16:11:45 <dims> Glance - https://review.openstack.org/#/c/149344/ (from Louis Taylor)
16:11:47 <dims> Neutron - https://review.openstack.org/#/c/159638/ (from Ihar Hrachyshka)
16:11:49 <dims> Cinder - https://review.openstack.org/#/c/157441/ (from Ivan Kolodyazhny)
16:11:56 <dims> Anyone else doing oslo.log?
16:12:01 <dhellmann> nice!
16:12:01 <dims> for Kilo?
16:12:41 <dims> moving on
16:12:43 <kragniz> dims: working on this right now!
16:12:48 <jungleboyj> dims: We plan to merge Cinder's patch middle of this week.  Want those who are trying to get new features in done first.
16:12:49 <dims> kragniz: nice thanks
16:13:03 <jungleboyj> dims: Hope to have good news for the next meeting.
16:13:15 <dims> nice
16:13:17 <dims> #topic Feature freeze
16:13:29 <dims> dhellmann: do you have some time to drive this?
16:13:37 <dhellmann> sure
16:13:47 <dhellmann> this thursday is our feature-freeze cut off
16:13:57 <dhellmann> I've released all but 2 of the libraries that had pending changes
16:14:16 <dhellmann> I pinged harlowja_at_home about debtcollector and taskflow but need to ask again
16:14:28 <harlowja_at_home> probably on my work computer; will check when i get in
16:14:30 <dhellmann> the change list is https://etherpad.openstack.org/p/oslo-kilo-feature-freeze-releases
16:14:47 <dhellmann> I've proposed caps for oslo libs in https://review.openstack.org/#/c/162656
16:15:20 <dhellmann> those assume that we don't have any major features in flight, and I think the only big things being worked on now are not likely to land in a safe state by thursday
16:15:43 <bknudson> what's ~= do?
16:15:59 <dhellmann> so I'm sort of assuming that these releases are what we're using for kilo, and we'll create stable branches from those tags after thursday
16:16:08 <dhellmann> but we'll wait to do that until we're sure we don't need bug fixes
16:16:11 <dims> dhellmann: +1
16:16:32 <dhellmann> bknudson: ~= means >=x.y.z,==x.y.* which means only patch releases against an x.y release
16:16:41 <dims> dhellmann: what will the tags be named?
16:16:47 <dhellmann> so ~=1.5.1 is compatible with 1.5.2 but not 1.5.0, for example
16:16:55 <bknudson> ok, thanks.
16:17:02 <bknudson> then we'll have stable branches.
16:17:03 <dhellmann> dims: I expect we'll call them stable/kilo to ensure all of our stable tooling works as expected
16:17:14 <dims> dhellmann: cool
16:17:16 <amrith> dims ... question on the previous topic. Oslo.log
16:17:29 <dims> yes amrith
16:17:36 <dhellmann> bknudson: more background on the version numbers is in https://review.openstack.org/#/c/155072/
16:17:36 <amrith> dims, is oslo.log a requirement for kilo
16:17:38 <amrith> or liberty?
16:17:47 <amrith> I don't believe trove has done it yet.
16:17:50 <amrith> hence the q?
16:18:12 <dims> amrith: not pushing hard on Kilo, but would be great to have in Kilo
16:18:37 <dhellmann> We would like everyone to be using it by the end of liberty. The incubated version of that code is deprecated, and won't be updated. Bug fixes will come to the library, and you'll get them by adopting it.
16:19:02 <dhellmann> That's consistent with our general policy of "please adopt new libraries by the cycle after they are graduated"
16:19:03 <bknudson> for security maintenance reasons it would be great if everyone was using oslo.log rather than incubator.
16:19:05 <amrith> dhellmann, dims ... I'll take the action for trove to get to oslo.log.
16:19:16 <amrith> currently still using o.incubator
16:19:17 <amrith> thx
16:19:20 <amrith> sorry for the interrupt
16:19:24 <dims> #action amrith to drive trove to use oslo.log
16:19:30 <dims> :)
16:19:34 <dhellmann> bknudson: jd__ also found an issue combining the incubated version and oslo.log through gnocchi's test suite
16:19:51 <dims> brings us to
16:19:52 <dims> #topic Releases for this week
16:20:03 <dhellmann> #link https://etherpad.openstack.org/p/oslo-kilo-feature-freeze-releases
16:20:48 <harlowja_at_home> hmmm, etherpad really slow, lol
16:20:51 <dims> k we've talked about it already
16:20:54 <dims> #topic Other policy reviews
16:21:07 <dims> #link requirements management: https://review.openstack.org/157135
16:21:07 <dims> #link test tooling: https://review.openstack.org/158787
16:21:18 <dims> anyone have some cycles please review ^^^
16:21:40 <dims> any other requests from policy team?
16:21:52 <dhellmann> also this cross-project spec related to library stable branches: https://review.openstack.org/#/c/155072/
16:22:16 <harlowja_at_home> the whole concept of examples; would be a nice policy (like in https://review.openstack.org/#/c/140318/ )
16:22:31 <harlowja_at_home> i believe tooz, taskflow, debtcollector have nice examples and such
16:22:41 <dhellmann> yeah, let's prioritize the ones we need to finish this release, though
16:22:56 <dhellmann> I'm not sure we need a spec to say that we need documentation :-)
16:23:06 <harlowja_at_home> fair nuff ;)
16:23:22 <dims> i want to highlight zigo's request from mailing list
16:23:35 <dims> for better library descriptions
16:23:42 <dhellmann> dims: ++
16:23:43 <bknudson> is it in the checklist?
16:23:53 <bknudson> for releasing a library
16:23:57 <dims> #link http://markmail.org/message/7ql2usgb7nyo2unb
16:24:22 <dhellmann> bknudson: https://wiki.openstack.org/wiki/Oslo/CreatingANewLibrary#Provide_Basic_Documentation
16:24:39 <dims> bknudson: need to dig it up
16:24:39 <dhellmann> we should go back and audit our existing libraries, though, because I know we were more focused on code than docs this cycle
16:24:53 <dims> dhellmann: yea, the audit spreadsheet
16:25:09 <dhellmann> dims: ++
16:25:31 <dims> dhellmann: got a url to the old one?
16:26:09 <dhellmann> dims: I'm sure I do, but I'm not finding it
16:26:09 <dims> #link https://docs.google.com/spreadsheets/d/1MvXsg0XxPonJ8yAFSraIwHM940eAfoXhfBVRa6hN7MY/edit#gid=0
16:26:13 <dims> that one?
16:26:22 <dhellmann> that's it
16:26:47 <dims> ok next one
16:26:48 <dims> #topic Priority bug fixes for after freeze
16:27:05 <dims> i have these from the wiki
16:27:09 <dims> #link https://launchpad.net/oslo/+milestone/next-kilo
16:27:09 <dims> #link DB handle stays open after fork: https://bugs.launchpad.net/cinder/+bug/1417018
16:27:10 <openstack> Launchpad bug 1417018 in oslo.db "Cinder encounters dbapi error: NoSuchColumnError: "Could not locate column in row for column '%(140070887032400 anon)s.volumes_id'"" [Medium,In progress] - Assigned to Mike Bayer (zzzeek)
16:27:39 <zzzeek> who is handling what we will actualyl do with that one
16:27:40 <dims> anyone else have things we should review quickly after the freeze?
16:27:48 <dhellmann> we also have the oslo.messaging rabbit heartbeat thing that sileht is working on
16:27:53 <zzzeek> b.c. it shouldnt even be assigned to me IMO
16:28:04 <dhellmann> zzzeek: you can unassign yourself
16:28:08 <zzzeek> dhellmann: Ok
16:28:16 <harlowja_at_home> also rabbit-mq @ ops meetup - https://etherpad.openstack.org/p/PHL-ops-rabbit-queue
16:28:26 <zzzeek> dhellmann: basically I have all the info and proposed fixes up and ppl can decide to do waht they want :)
16:28:42 <dims> dhellmann: +1 to oslo.messaging rabbit heartbeat - wish we had a functional test for it
16:28:43 <zzzeek> or have we decided what we’re doing on that
16:28:51 <dhellmann> dims: I have to leave now, but if we could get a list of these into an etherpad somewhere that would give us all a focus for reviews this week.
16:29:06 <dims> dhellmann: ack will do
16:29:23 <dims> #action dims to collect items to review after feature freeze
16:29:26 <dhellmann> harlowja_at_home: did you run your changes to the service code against nova and some of the other projects?
16:29:50 <dhellmann> harlowja_at_home: it would be good to propose a patch to at least cinder to sync those changes in, mark it as Depends-On your incubator change, and then we can see what the gate does with it
16:29:56 <harlowja_at_home> dhellmann,  guess i should do that
16:30:00 <dims> #link https://review.openstack.org/#/c/146047/ heartbeat for rabbitmq
16:30:08 <dims> harlowja_at_home: thanks!
16:30:11 <harlowja_at_home> np
16:30:17 <dims> dhellmann: ttyl
16:30:20 <dhellmann> sorry, time to for me to run, I'll be back later on this afternoon
16:30:31 <dims> #topic open discussion
16:30:38 <dims> floor is open
16:30:58 <dims> is the DST time change ok with everyone?
16:31:12 <bknudson> survived it.
16:31:20 <dims> yay bknudson
16:31:23 <harlowja_at_home> worked out for me, lol
16:31:38 <bknudson> keystone unit tests started failing, though.
16:31:39 <harlowja_at_home> people might be intersted in http://lists.openstack.org/pipermail/openstack-operators/2015-March/006458.html
16:31:45 <harlowja_at_home> some useful stuff might come out of that...
16:31:56 <harlowja_at_home> * Ops meetup *
16:31:58 <dims> harlowja_at_home: ah the ops summit
16:32:05 <bknudson> next concern is leap second.
16:32:06 <harlowja_at_home> ya
16:32:12 <harlowja_at_home> oh, leap second, lol
16:32:53 <dims> bknudson: when is it getting added?
16:33:01 <ihrachyshka> June 31?
16:33:20 <ihrachyshka> well, there is no 31st, but... :)
16:33:33 <bknudson> http://www.livescience.com/49370-leap-second-added-2015.html
16:33:40 <ihrachyshka> or maybe it will, with a leap day
16:33:43 <bknudson> "June 30 will be a second longer than any other day this year."
16:33:47 <dims> haha ihrachyshka
16:34:07 <harlowja_at_home> so my general question, is what is the python community doing about this?
16:34:29 <bknudson> I'm going to take that second off on June 30.
16:34:31 <harlowja_at_home> instead of re-writing all the date-time handling, wouldn't it be better to look at what everyone else is doing?
16:34:38 <bknudson> tell me when it's over.
16:34:41 <dims> i found this old etherpad which may get us some things to do (graceful config reload, graceful termination) https://etherpad.openstack.org/p/kilo-crossproject-ha-integration
16:35:01 <dims> bknudson: same strategy as y2k? :)
16:35:01 <harlowja_at_home> https://etherpad.openstack.org/p/PHL-ops-burning-issues (also i guess)
16:35:30 <dims> thanks harlowja_at_home
16:35:34 <bknudson> I'll come out of my bunker.
16:36:03 <dims> bnemec: jd__: flaper87: anything from you all?
16:36:16 <harlowja_at_home> also related to the leap-second stuff is https://github.com/openstack/oslo.utils/commit/91dc7 (it'd be nice to think of who really needs absolute times and who doesn't)
16:36:27 <harlowja_at_home> and if people don't need it, start using that stop watch thing
16:36:38 <dims> harlowja_at_home: that made it to release today!
16:36:40 <harlowja_at_home> woot
16:36:55 <dims> y chuffed, pumped :)
16:36:59 <harlowja_at_home> :)
16:37:05 <bknudson> a tempest run where the clock is set to cover leap second would be interesting.
16:37:09 <dims> so if there is nothing else...
16:37:28 <harlowja_at_home> my guess is the people who need absolute times (that are affected by leap seconds) is less than those who care about the duration between 2 time points (and can use that stop watch thing)
16:37:46 <dims> harlowja_at_home: ack
16:38:23 <dims> so...wrapping up
16:38:29 <dims> thanks everyone
16:38:38 <dims> #endmeeting