16:00:30 <dhellmann> #startmeeting oslo
16:00:30 <dhellmann> our agenda:
16:00:30 <openstack> Meeting started Mon Mar 23 16:00:30 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:32 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:00:34 <openstack> The meeting name has been set to 'oslo'
16:00:36 <bknudson> lol
16:00:37 <dhellmann> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka, zzzeek, sileht, kgiusti, dansmith
16:00:38 <dhellmann> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:45 <kgiusti> o/
16:00:45 <redrobot> o/
16:00:49 <amrith> o/
16:00:50 <dims> o/
16:00:52 <ihrachyshka> o/
16:00:59 <e0ne> hi
16:01:03 <harlowja_at_home> yo yo
16:01:10 <viktors> o/
16:01:13 <rpodolyaka> o/
16:01:14 <dansmith> \oj
16:01:29 <dhellmann> #topic Review action items from previous meeting
16:01:36 <dhellmann> just one item from last week
16:01:40 <dhellmann> #info dims set up backport of oslo.db fix for after-fork handling of connections DONE oslo.db 1.7.1
16:01:40 <dhellmann> more on backports later...
16:01:47 <dhellmann> #topic Red flags for/from liaisons
16:02:00 <dhellmann> how are things looking going into the release candidate period?
16:02:00 <bknudson> none from keystone
16:02:20 <e0ne> jungleboyj: are you around?
16:02:29 <jecarey> o/
16:02:38 <bnemec> \o
16:03:07 <e0ne> i'm with jungleboyj would like to ask about adding hacking checks to projects for logging guidelines
16:03:08 <harlowja_at_home> did all the requirements tweaks get merged into the various projects?
16:03:21 <ihrachyshka> oslo.messaging kilo release? neutron would like to have one with multitarget patch
16:03:29 <ihrachyshka> patch: https://review.openstack.org/166349
16:03:30 <jungleboyj> o/
16:03:34 <jungleboyj> I am here now.
16:03:42 <dhellmann> ihrachyshka: we'll be discussing that in a bit
16:03:46 <bknudson> some of these hacking checks could just as well be unit tests.
16:03:52 <ihrachyshka> in that way we'll be able to deprecate old namespaces earlier
16:03:54 * stevemar sneaks in and continues to lurk
16:03:54 <ihrachyshka> ack
16:03:54 <jungleboyj> e0ne: Yeah, we should chat about that.
16:03:57 <dims> harlowja_at_home: i tried to +A over the weekend, there may be some stragglers
16:04:04 <harlowja_at_home> dims, cools
16:04:15 <harlowja_at_home> ^ also i guess for integrating projects; seems like thats underway
16:04:30 <harlowja_at_home> seems like glance had a brokeness @ https://review.openstack.org/#/c/166796/
16:04:41 <e0ne> imo, it would be graet to have such checks in oslo.log or openstack/hacking to run it for all projects
16:04:41 <dhellmann> e0ne: I know some projects have written checks like that. It's worth discussing adding them to hacking or oslo.log or something to make them easy to share
16:04:54 <e0ne> dhellmann: +1
16:05:04 <dhellmann> e0ne: but they need to be optional, in case not all projects want to use them
16:05:16 <jungleboyj> e0ne: We just pulled a number in from Nova.
16:05:35 <e0ne> dhellmann: sure. but makint it only for cinder or nova is not a best way.
16:05:42 <dhellmann> e0ne: so maybe a mailing list thread is the next step? jogo and mtreinish manage the hacking project under QA now
16:05:53 <ihrachyshka> hacking project seems to be quite slow to receive changes though
16:06:01 <dhellmann> ihrachyshka: that is by design
16:06:04 <ihrachyshka> :)
16:06:17 <e0ne> dhellmann: ok. lets start disccussion aboit logging hacking checks in openstack-dev ML
16:06:25 <e0ne> :)
16:06:30 <dhellmann> e0ne: sounds good, I'll watch for the thread
16:06:36 <jungleboyj> e0ne: +2
16:06:37 <bknudson> what logging check do you want to do?
16:06:41 <dhellmann> are there any other issues we need to discuss?
16:06:56 * dhellmann notices harlowja_at_home's comment about glance
16:06:57 <e0ne> bknudson: to make logging correspond guidelines
16:07:14 <harlowja_at_home> dhellmann,  glance comment @ https://review.openstack.org/#/c/166796/  :-P
16:07:14 <jungleboyj> dhellmann: General issues?
16:07:15 <dims> dhellmann: Andreas spotted it, should be under control
16:07:30 <e0ne> dhellmann, jungleboyj:  are you ok if i'ls start thread?
16:07:56 <jungleboyj> e0ne: Go for it.
16:08:07 <e0ne> ok. i'll do
16:08:09 <dhellmann> jungleboyj: anything that might be blocking your progress
16:08:21 <dhellmann> jungleboyj: but I guess really anything :-)
16:08:36 <jungleboyj> dhellmann: Ok, I just wanted to bring up here:  https://review.openstack.org/165431
16:08:39 <dstanek> e0ne: i'd love to know more about the logging checks. i've implemented a bunch of stuff about logging for Keystone
16:08:50 <jungleboyj> That is the review for trying to move to using the new oslo-config-generator.
16:09:16 <jungleboyj> Cinder cores were not super excited by that approach so I have proposed an alternate approach to the mailing list.
16:09:35 <jungleboyj> Appreciate feedback, especially from Nova and Neutron on that note.
16:09:40 <e0ne> dstanek: i want to get it aotomatic for all patches.
16:09:41 <bknudson> mock the log call and make it fail if you don't like the args.
16:10:22 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2015-March/thread.html#59557
16:10:30 <dhellmann> jungleboyj's ML thread on the config generator ^^
16:11:04 <ihrachyshka> jungleboyj, ack, I'll check and respond
16:11:07 <bknudson> would be nice if you didn't have to import the world to generate the config file.
16:11:10 <jungleboyj> dhellmann: Thank you.  At this point I am guessing this is going to go out into Liberty.  We shall see though.  I am out the next week but will try to code up whatever is agreed upon as soon as I get back.
16:11:25 <bknudson> but I guess it's easy enough with tox venv.
16:11:27 <jungleboyj> bknudson: Yeah, the new proposal would reduce that a lot.
16:11:38 <dhellmann> yeah, it may be late to make the change for kilo, but that's up to the cinder team
16:12:05 <bknudson> doesn't have to be perfect to begin with, as long as it works.
16:12:47 <jungleboyj> bknudson: Agreed.  Want to move in the direction of something that everyone is ok with though.
16:13:25 <dhellmann> it would be good to put together some advice for projects going through a similar discussion
16:13:50 <jungleboyj> dhellmann: +2
16:14:13 <dhellmann> there hasn't been much input on that thread, yet, but maybe this week
16:15:02 <dhellmann> harlowja_at_home: it looks like that glance patch is failing so it won't merge?
16:15:14 <dhellmann> harlowja_at_home: something to do with a database migration test
16:15:28 <jungleboyj> dhellmann: Yeah, hoping maybe while I am out this week people will give more input.
16:15:33 <harlowja_at_home> dhellmann,  maybe some other glance issue then
16:15:47 <jungleboyj> If I don't hear much more I will just try to go forward with what we discussed next week.
16:15:59 <dhellmann> jungleboyj: ++
16:16:04 <dhellmann> harlowja_at_home: yeah :-/
16:16:13 <dhellmann> ok, is there anything else we need to raise as an issue?
16:16:23 <jungleboyj> I am done.  :-)
16:16:39 <dims> dhellmann: heartbeat patch, whether or not to ship with kilo
16:16:55 <dhellmann> dims: I have that listed under ongoing work
16:16:57 <dims> code is in oslo.messaging/trunk
16:17:01 * dhellmann failed to update the agenda in the wiki
16:17:07 <dims> cool thx
16:17:21 <dhellmann> #topic Feature freeze
16:17:22 <dhellmann> #info we should be focusing on bug fixes leading up to the release candidate period
16:17:23 <dhellmann> #info remember the incubator is still frozen because we haven't created a stable branch there, yet
16:17:24 <dhellmann> we will do that around the time of the other release candidates
16:17:46 <dhellmann> the fix to the service module for reloading the config is a good example of something we want to let in
16:18:08 <dims> +1 dhellmann
16:18:13 <dhellmann> while harlowja_at_home's patch to add a deprecation warning to a method of the same class is an example of something that needs to wait
16:18:33 <harlowja_at_home> fine with me :)
16:18:47 <dhellmann> harlowja_at_home's patch has 2 +2 so it can land right after the branch is created
16:18:59 <bnemec> ack
16:19:32 <dhellmann> #topic Ongoing work & Review priorities
16:19:32 <dhellmann> #info we released a fix for the db connection after fork issue as oslo.db 1.7.1
16:19:37 <dhellmann> do we have any other fixes we need to backport to the stable/kilo branches of any libraries?
16:19:37 <dhellmann> maybe the rabbit heartbeat fix for oslo.messaging?
16:20:20 <dhellmann> ihrachyshka proposed https://review.openstack.org/#/c/166349/ but I don't know if that's a good candidate -- it looks like a feature?
16:21:02 <dims> dhellmann: oslo.db probably has a couple (there's a LOG for retry)
16:21:32 <ihrachyshka> dhellmann, yeah, for incremental upgrade. otherwise we're left with RPC namespaces in bad shape for another cycle.
16:21:50 <dhellmann> dims: good point; rpodolyaka & viktors : can you put together a list of patches that need to be backported for a new release of oslo.db from the stable/kilo branch?
16:22:09 <dhellmann> ihrachyshka: ok, I probably need to read more about the background of that
16:22:23 <ihrachyshka> dhellmann, the bug should give you insight
16:22:26 <rpodolyaka> dhellmann: ok. viktors will put a list of patches
16:22:35 <rpodolyaka> *and I
16:22:50 <dhellmann> rpodolyaka, viktors : if you go ahead and submit them for review, we won't need to track a separate list somewhere :-)
16:23:04 <rpodolyaka> dhellmann: true :)
16:23:31 <dhellmann> ihrachyshka: ok, I'll take a look
16:23:45 <dims> ++ to reviews
16:24:13 <dhellmann> #action rpodolyaka and viktors to identify oslo.db patches that need to be backported to stable/kilo
16:24:16 <dhellmann> sileht: can you do the same for oslo.messaging?
16:24:34 <sileht> dhellmann, sure
16:24:39 <dhellmann> sileht: thanks
16:24:53 <dhellmann> #action sileht to identify oslo.messaging patches that need to be backported to stable/kilo
16:25:16 <dhellmann> do we need to look at any of the other libs?
16:25:58 <dhellmann> We also have a bunch of specs up for review, and we should start the discussion on those before the summit
16:25:59 <dhellmann> #link https://review.openstack.org/#/q/project:openstack%2Foslo-specs+is:open,n,z
16:26:55 <dims> don't see anything else dhellmann
16:27:11 <dhellmann> yeah, I think we've already found all of the big items
16:27:13 <viktors> rpodolyaka, dhellmann: sorry, was afk. Agree with Roman
16:27:21 <dhellmann> viktors: np, thanks
16:27:34 <dhellmann> ok, that's it for the formal agenda this week
16:27:39 <dhellmann> #topic open discussion
16:27:58 <bknudson> stevedore: https://review.openstack.org/#/c/166543/
16:28:17 <dhellmann> I am going to be on vacation 26-31 March. I don't expect to be checking email during that time.
16:28:30 <dhellmann> dims volunteered to chair the meeting next week
16:28:49 <dhellmann> bknudson: nice, I'll put that on my review list
16:28:50 <dims> have a good vacation dhellmann!
16:29:01 <dhellmann> dims: thanks!
16:29:30 <jungleboyj> I am also out 3/24 to 3/31 if anyone is looking for me.  I will occasionally check e-mail.
16:29:41 <dhellmann> jungleboyj: thanks for the heads-up
16:29:54 <bknudson> spring breakers.
16:29:55 <jungleboyj> Welcome.
16:30:04 * jungleboyj needs vacation!  Warm beach, here I come!
16:30:19 <jungleboyj> bknudson: Indeed.
16:30:29 * dhellmann is headed to dublin, so doesn't expect "warm" to be part of the agenda
16:30:30 <dims> jungleboyj: have fun!
16:30:56 <jungleboyj> dims: Thanks!
16:31:02 <harlowja_at_home> dublin, nice, sounds like fubn
16:31:11 <harlowja_at_home> ought to be slightly different weather than georgia ;)
16:31:31 <dhellmann> harlowja_at_home: actually, it's cool and wet here right now, too :-)
16:31:40 <bknudson> http://en.wikipedia.org/wiki/Craic
16:31:44 <harlowja_at_home> nm, then i guess its the same weather, ha
16:31:55 <bnemec> It's cool and white here today.
16:31:58 <harlowja_at_home> please do not use crack
16:32:18 <harlowja_at_home> * refering to http://en.wikipedia.org/wiki/Craic
16:32:26 <jungleboyj> dhellmann: Nice!  I would like to visit there some time.
16:32:34 <bknudson> don't tell the border agents you're going for the craic
16:32:45 <dhellmann> jungleboyj: we've been looking forward to it
16:32:47 <harlowja_at_home> bknudson, +2 i second that, lol
16:32:54 <amrith> I've been working with neutron, I need a vacation.
16:32:59 <dhellmann> heh
16:33:47 <dhellmann> I think that probably covers it for this week, so let's call the meeting done and spend a few minutes on spec reviews
16:33:50 <dhellmann> thanks, everyone!
16:34:19 <jungleboyj> dhellmann: Thanks.  Have a great vacation!
16:34:42 <dhellmann> jungleboyj: you, too!
16:34:46 <dhellmann> #endmeeting