16:03:29 <dims> #startmeeting oslo
16:03:31 <openstack> Meeting started Mon Mar 30 16:03:29 2015 UTC and is due to finish in 60 minutes.  The chair is dims. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:35 <openstack> The meeting name has been set to 'oslo'
16:03:40 <stevemar> o/
16:03:42 <jecarey> o/
16:03:46 <harlowja_at_home> yo yo
16:03:47 <rpodolyaka1> o/
16:03:50 <dims> sorry for the delay
16:03:51 <kgiusti> o/
16:03:54 <harlowja_at_home> np
16:03:54 <bknudson> 'zup
16:04:01 <harlowja_at_home> sup dawgs
16:04:01 <amotoki> hi
16:04:26 <dims> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:04:34 <dims> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka, zzzeek, sileht, kgiusti, dansmith
16:04:37 <zzzeek> o/
16:04:41 <dims> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:04:43 <ihrachyshka> 0/
16:04:45 <bnemec> o/
16:04:50 <redrobot> o/
16:04:52 <therve> o/
16:05:06 <dims> #topic Review action items from previous meeting
16:05:37 <dims> there was one item, oslo.db fix backporting...that's done
16:05:49 <dims> #topic Red flags for/from liaisons
16:06:02 <bknudson> none for keystone
16:06:07 <harlowja_at_home> taskflow got a release in also; i haven't heard anything so i'm assuming its all going ok
16:06:19 <dims> bknudson: harlowja_at_home: thanks
16:06:33 <harlowja_at_home> np
16:06:59 <sputnik13> alo
16:06:59 <dims> #topic Feature freeze
16:07:09 <dims> any one needs exceptions?
16:07:34 <harlowja_at_home> not me
16:07:45 <dims> i think i saw something about backing out a change in oslo-inc
16:07:51 <sileht> o/
16:08:00 <harlowja_at_home> dims,  hmmm, whichone?
16:08:13 <harlowja_at_home> ah https://review.openstack.org/#/c/168924/ i guess?
16:08:16 <dims> #link https://review.openstack.org/#/c/168924/
16:08:44 <dims> anyone wants to chime in on that please take a look Revert "Optimization of waiting subprocesses in ProcessLauncher"
16:08:50 <harlowja_at_home> damn launcher and eventlet, :(
16:08:56 <rpodolyaka1> indeed :(
16:09:09 <sileht> still the same story...
16:09:29 <dims> k moving on
16:09:34 <dims> #topic Ongoing work & Review priorities
16:10:07 <bknudson> "eventlet goes crazy" he he
16:10:09 <dims> any more backports to stable/kilo from anyone?
16:10:25 <harlowja_at_home> the big one was the heartbeat stuff right?
16:10:32 <harlowja_at_home> *the big backport that is
16:10:33 <dims> harlowja_at_home: y, we released that
16:10:33 <sileht> harlowja_at_home, that done
16:10:39 <harlowja_at_home> cools
16:10:47 <bnemec> \o/
16:10:53 <harlowja_at_home> :)
16:11:09 <dims> sileht: any update on https://bugs.launchpad.net/oslo.messaging/+bug/1436788 ?
16:11:11 <openstack> Launchpad bug 1436788 in oslo.messaging "rabbitmq heartbeat failures don't reset connections" [Undecided,New]
16:11:11 <jd__> there are patches waiting for stable in tooz that will need a release once merged
16:11:21 <dims> jd__: ack
16:11:28 <sileht> dims, no news
16:11:30 <jd__> and I've patches i'd like to see merged and release in oslo.serialization :)
16:11:32 <harlowja_at_home> sileht,  it'd be interesting to hear about how u feel the heartbeat stuff went, maybe upstream kombu can be made better; giving some feedback to upstream projects might be useful?
16:11:47 <dims> jd__: the timestamp ones?
16:11:55 <jd__> dims: that and 2 more IIRC
16:11:58 <flaper87> o/
16:12:00 <sileht> harlowja_at_home, I have opened that recently: https://github.com/celery/kombu/issues/463
16:12:06 <dims> jd__: paste them here please with #link
16:12:06 <harlowja_at_home> sileht, cool
16:12:18 <jd__> https://review.openstack.org/#/q/status:open+project:openstack/oslo.serialization+branch:master+topic:jd/remove-strtime,n,z
16:12:27 <harlowja_at_home> sileht, it'd be a neat blog post once it 'calms down' a little
16:12:27 <dims> zzzeek: any oslo.db things needed?
16:12:45 <zzzeek> dims: not really
16:12:54 <dims> zzzeek: that's good news :)
16:12:56 <zzzeek> dims: my stuff is on hold until evertyhing isnt frozen
16:13:18 <dims> zzzeek: we have stable/kilo cut already, so we can move things on
16:13:32 <zzzeek> dims: do we want to talk about enginefacde?  because that’s the big one
16:13:55 <dims> zzzeek: hang on, till we open discussion
16:13:57 <harlowja_at_home> zzzeek, that needs to mergeee; been to long :-P
16:14:02 <zzzeek> harlowja_at_home: sure
16:14:04 <harlowja_at_home> :)
16:14:10 * zzzeek hasn’t done anything oslo in like a month
16:14:20 <dims> got specs anyone?
16:14:21 <dims> #link https://review.openstack.org/#/q/project:openstack%2Foslo-specs+is:open,n,z
16:14:35 <harlowja_at_home> hmmm, i'll write some i think; got some idears
16:14:43 <dims> harlowja_at_home: ++++
16:14:44 <harlowja_at_home> maybe do that this week
16:15:11 <harlowja_at_home> although i guess my idea is connected to https://review.openstack.org/#/c/151300/
16:15:22 <dims> #link https://etherpad.openstack.org/p/kilo-oslo-summit-planning
16:15:26 <harlowja_at_home> i'd like to have msgpack be used more; it at least isn't as lossless...
16:15:29 <dims> please flesh out etherpad everyone
16:15:48 <dims> hmm, got link wrong
16:16:16 <harlowja_at_home> ya, seems blank
16:16:29 <bnemec> Try https://etherpad.openstack.org/p/liberty-oslo-summit-planning
16:16:30 <dims> #link https://etherpad.openstack.org/p/liberty-oslo-summit-planning
16:16:35 <dims> thanks bnemec
16:16:39 <harlowja_at_home> ya, much better
16:17:02 <dims> giving everyone a minute to peek
16:17:05 <harlowja_at_home> when does that session schedule planning start?
16:17:12 <harlowja_at_home> probably soon i guess
16:17:25 <harlowja_at_home> *aka the actual schedule
16:17:34 <dims> harlowja_at_home: don't know yet
16:17:36 <harlowja_at_home> k
16:17:48 <dims> #action : dims to find schedule for session planning
16:17:59 <dims> anyone see things we can add?
16:18:23 <dims> one thing for liaisions, we need to add a bunch at the very bottom of the page
16:18:32 <dims> "Adopt oslo-config-generator and get rid of existing generator.py"
16:18:40 <dims> things to do for next cycle
16:19:13 <harlowja_at_home> dims, no big hurry on the schedule finding; more of just curious since it always seems sorta arbitrary, lol
16:19:23 * bknudson is hoping things will generally settle down with oslo work in keystone.
16:19:32 <bknudson> not that there's been a lot this release.
16:19:39 <dims> harlowja_at_home: y mostly needed for bargaining upwards on how may slots we need i think
16:19:48 <dims> bknudson: haha :)
16:19:55 <dims> k. moving
16:19:56 <dims> #topic open discussion
16:20:01 <dims> zzzeek: you are on :)
16:20:07 <zzzeek> dims: oh hey :)
16:20:22 <zzzeek> so enginefacade is this big refactoring of how everyone will connect to sesssions and engines
16:20:34 <zzzeek> and me and mbooth have tried to get it into nova and hit a lot of complications
16:20:53 <zzzeek> so I’ve refacotred it like four times and now it really can do like, anything.    so we can merge it, its backwards-compatible, but nobody is using it yet
16:20:57 <harlowja_at_home> #link https://review.openstack.org/#/c/138215/
16:21:00 <zzzeek> yeah
16:21:17 <zzzeek> so the issue is, we stil ldont know if any projects can use the API as is, b.c. when we hit nova, we hit all kinds of edge cases
16:21:45 <harlowja_at_home> can u use the new 'depends-on' feature to push it into other projects as a WIP somehow?
16:21:48 <zzzeek> turns out, the best way to migrate is that we *dont* change transaction boundaries to start with, nova has cases where they may be relying on a transacvtion nested in another transaction
16:21:48 <bknudson> what issues did nova have?
16:22:05 <zzzeek> bknudson: a lot with “this method needs to be able to retry itself”, inside of the context of a bigger transaction
16:22:11 <zzzeek> bknudson: which you can do by using a savepoint
16:22:14 <bknudson> keystone barely uses isolation.
16:22:26 <bknudson> mostly ignored and hope for the best.
16:22:51 <zzzeek> bknudson: but, nova isn’t doing that now :)  so, its dramatic changes in how transactions work.   so enginefacade right now, can be rolled out onto nova in such a way that its all the new code, but the way transactions demarcarte is completely maintained
16:23:19 <zzzeek> bknudson: mbooth really dug into it and kept finding more and more weird edges where maybe things would no longer work, if we used one big transaction
16:23:49 <bknudson> might need to clean up the nova code first... wouldn't be the first time.
16:24:01 <dims> right bknudson
16:24:05 <bknudson> although it seems to be difficult to get code reorgs into nova.
16:24:09 <harlowja_at_home> it would seem uesful to have a vancouver session about how to make this get into projects (with the various folks/cores from the projects there to provide some insight)
16:24:11 <zzzeek> bknudson: also, if we were using “master” for read/write and “slave” for reads, w galera, what if an API call bounced from a “read/write” into a “read”, woudl the “read” have the data available immediately
16:24:22 <dims> zzzeek: do we need a nova session, we can ask for one
16:24:25 <zzzeek> dims: yes
16:24:33 <harlowja_at_home> *just what i am thinking; making sure that they are there and involved...
16:24:57 <dims> zzzeek: please add here https://etherpad.openstack.org/p/liberty-nova-summit-ideas
16:24:59 <zzzeek> but i would note - that right now, the legacy EngineFacade can be replaced with the new system in nova, all throughout, with no change in semantics, and I think we should go for that, then when on the new API, begin improving the nesting of transactions
16:25:14 <harlowja_at_home> ya, that does seem like a good plan
16:25:23 <harlowja_at_home> break nothing, then start breaking/adjusting as we go
16:25:32 <dims> #action zzzeek to add oslo.db enginefacade to nova agenda - https://etherpad.openstack.org/p/liberty-nova-summit-ideas
16:25:35 <harlowja_at_home> *where breaking == making better
16:25:38 <zzzeek> harlowja_at_home: but!  when i first asked about this, nova devs were very nervous about a single patch that changes all “get_session()” globally.
16:25:46 <harlowja_at_home> arg
16:25:55 <harlowja_at_home> that to me seems like we just need the nova folks more actively involved
16:26:03 <dims> rpodolyaka1: could use some help on this?
16:26:04 <harlowja_at_home> someone needs to hug them, and stuff so that they don't feel nervous...
16:26:13 <harlowja_at_home> ^ maybe not for real, lol
16:26:19 <bknudson> hug session at the summit.
16:26:21 <harlowja_at_home> lol
16:26:22 <dims> harlowja_at_home: jaypipes and rpodolyaka1 can help i think
16:26:25 <dims> harlowja_at_home: ++
16:26:32 <zzzeek> harlowja_at_home: also, nobody in nova seems to have too much enthusiasm for the whole thing :)
16:26:43 <sputnik13> everyone needs a hug now and again
16:26:47 <harlowja_at_home> :)
16:26:57 <harlowja_at_home> zzzeek, ya, i'm not sure whats up with that
16:27:00 <zzzeek> there’s the possibility that we go for enginefacade in a project with simpler database logic, as nova is probably one of the worst
16:27:17 <dims> zzzeek: harlowja_at_home: that's beer worthy discussion :)
16:27:20 * harlowja_at_home thinks it must be related to the hug problem
16:27:23 <harlowja_at_home> dims,  ;)
16:27:44 <dims> zzzeek: so which others can start earlier then?
16:27:50 <rpodolyaka1> dims: sure!
16:28:03 <zzzeek> dims: ummm there was another project someone mentioned…
16:28:34 <zzzeek> dims: maybe zaqar ?
16:28:41 <harlowja_at_home> cinder might be possible also?
16:28:50 <zzzeek> harlowja_at_home: yes
16:29:02 <harlowja_at_home> although the objects stuff is probably one of the other factors thats diverting peoples attention
16:29:08 <dims> we can ping liaisons again
16:29:10 <harlowja_at_home> ^ which makes them more nervous...
16:29:43 <zzzeek> dims harlowja_at_home : i think zaqar was mentioned b.c. im a redhatter and other redhatters are working on it
16:29:53 <harlowja_at_home> ya, might be a good way to go
16:30:03 <harlowja_at_home> makes the hugging easier to do when they are all nearby
16:30:09 <harlowja_at_home> lol
16:30:15 <zzzeek> harlowja_at_home: um right this IRC server vs. the other IRC server :)
16:30:25 <dims> zzzeek: +1 if you can get someone from there to help
16:30:26 <harlowja_at_home> :-p
16:30:57 <zzzeek> dims: im waiting for a big track of time where I can just do a POC for nova.  mbooth did a lot of good work but I want to just get the old code ripped out first, and replaced with a 100% compatible but new API
16:31:06 <dims> zzzeek: do we have anything written down other than this? http://specs.openstack.org/openstack/oslo-specs/specs/kilo/make-enginefacade-a-facade.html
16:31:17 <zzzeek> dims: there’s a nova spec also hold on
16:31:42 <zzzeek> https://review.openstack.org/#/c/150434/
16:32:17 <dims> zzzeek: we can get things into oslo.db trunk and then use this trick (Depends-On and LIBS_FROM_GIT) to stabilize a nova patch
16:32:24 <dims> https://review.openstack.org/#/c/160149/
16:32:32 <zzzeek> dims: OK im not yet familiar with that
16:32:34 <harlowja_at_home> dims,  nice; good idea
16:32:38 <zzzeek> dims: but sure
16:32:41 <dims> zzzeek: i'll work with you on that
16:32:45 <zzzeek> dims: ok
16:32:59 <dims> k. let's switch...
16:32:59 <harlowja_at_home> sounds like a common pattern we might want to shove on a twiki somewhere zzzeek dims
16:33:02 <zzzeek> dims: can you start by reviewing enginefacade and getting your head around it a bit ?
16:33:09 <dims> zzzeek: ack will do
16:33:23 <zzzeek> dims: it’s changed a bunch since the blueprint
16:33:28 <dims> right
16:33:46 <dims> anyone else have something to talk about?
16:34:23 <dims> anyone *not* making it to vancouver?
16:34:39 * harlowja_at_home will be there
16:34:45 <zzzeek> do you fokls all go to the asia summits too, that’s a longer trip
16:34:47 <harlowja_at_home> summit #7 or something for me, lol
16:34:55 <harlowja_at_home> zzzeek, i'm not sure i want to go to the tokyo one
16:34:56 <harlowja_at_home> we'll see
16:35:07 <dims> zzzeek: y i attended a couple
16:35:09 <bknudson> tokyo is one of the safest cities.
16:35:22 <harlowja_at_home> ya, just so far, pita....
16:35:28 <zzzeek> harlowja_at_home: same….im super curious to see tokyo but got a 1-year olds 1st birthday at the same time here…. also not a huge airplane/jetlag fan…
16:35:53 <harlowja_at_home> zzzeek, ya; i know what u mean, i did hong kong, paris, think i might let someone else go to the international one or something
16:35:55 <harlowja_at_home> we'll see
16:35:59 <dims> zzzeek: yay! grow up too fast :)
16:36:19 <sputnik13> 2nd birthday comes quick after the 1st
16:36:22 <bknudson> I don't remember my 1st birthday
16:36:25 <harlowja_at_home> lol
16:36:26 <dims> haha
16:36:35 <harlowja_at_home> i'm only 2 so i remeber it
16:36:43 <sputnik13> and before you know it they're in day care
16:36:50 <dims> harlowja_at_home: one of my friends was born on Feb 29
16:37:21 <dims> so, let's wrap up
16:37:22 <harlowja_at_home> dims, guess he's/shes pretty young then :-P
16:37:30 <dims> haha y
16:37:47 <dims> more on our regular channel. ttyl folks
16:37:48 <dims> #endmeeting