16:00:06 <dhellmann> #startmeeting oslo
16:00:06 <dhellmann> our agenda:
16:00:06 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:00:07 <openstack> Meeting started Mon Apr 13 16:00:06 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <openstack> The meeting name has been set to 'oslo'
16:00:13 <ihrachyshka> o/
16:00:16 <dhellmann> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka, zzzeek, sileht, kgiusti, dansmith
16:00:16 <dhellmann> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:19 <harlowja_at_home> yo
16:00:21 <dims> o/
16:00:22 <jungleboyj> o/
16:00:22 <redrobot> o/
16:00:26 <jd__> o/
16:00:33 <dougwig> o/
16:00:41 <bnemec> o/
16:00:46 <dims> fyi amrith is travelling and won't make it today
16:00:56 <dhellmann> thanks for the heads-up
16:01:13 <dhellmann> #topic Review action items from previous meeting
16:01:15 <dhellmann> #link http://eavesdrop.openstack.org/meetings/oslo/2015/oslo.2015-04-06-16.02.html
16:01:20 <dhellmann> #action dhellmann replace stable teams with review teams on oslo libs
16:01:22 <GheRivero> o/
16:01:23 <dhellmann> I need to carry that one over. I'll try to do it this week.
16:01:39 <flaper87> o/
16:01:44 <dhellmann> the first item listed in the action list last week was made redundant by the second, so I think that's it
16:01:55 <harlowja_at_home> quickest meeting ever
16:01:56 <harlowja_at_home> lol
16:02:08 * dhellmann is hungry and it's lunchtime
16:02:14 <jungleboyj> :-)
16:02:14 <dhellmann> #topic need someone to chair the meeting next week
16:02:15 * dims too
16:02:18 <jecarey> o/
16:02:24 <dhellmann> both dims and I will be out next week, so we need a volunteer to chair the meeting
16:02:39 <harlowja_at_home> i can do it if needed and nobody else volunteers :)
16:02:46 <dhellmann> thanks, harlowja_at_home
16:02:58 * harlowja_at_home will put my meeting hat on, lol
16:02:59 <dims> thanks harlowja_at_home
16:03:13 <harlowja_at_home> np
16:03:28 <dhellmann> you've done it before, so I think you know how to use the bot and stuff, but let me know if you have any questions
16:03:40 <harlowja_at_home> dhellmann,  ya, just might be a little rusty :-P
16:04:14 <harlowja_at_home> are u 2 going on vacation together?
16:04:18 <harlowja_at_home> :-/
16:04:28 <dhellmann> harlowja_at_home: my "secret" is to set up a text file with all the commands in advance :-)
16:04:32 <harlowja_at_home> :)
16:04:33 <dims> harlowja_at_home: haha.
16:04:50 <dhellmann> harlowja_at_home: heh, not this time
16:04:57 <harlowja_at_home> oh, cool, maybe next time then
16:05:30 <dhellmann> harlowja_at_home: we're meeting up in vancouver in a couple of weeks, you should join us!
16:05:40 <harlowja_at_home> dhellmann,  think i just might :-P
16:05:51 <harlowja_at_home> one big family vacation, ha
16:05:58 <harlowja_at_home> ^ with sometimes to much family :-P
16:06:02 <dhellmann> heh
16:06:14 <dhellmann> moving on...
16:06:15 <dhellmann> #topic Red flags for/from liaisons
16:06:47 <dhellmann> how are the RCs looking? I saw a few, but I don't think I saw an announcement that they were all done
16:07:06 <bknudson> I sent a note to the mailing list about the issues I saw in the keystoneclient stable branch: http://lists.openstack.org/pipermail/openstack-dev/2015-April/061288.html
16:07:22 <bknudson> which might be interesting to others trying to figure out why their stable branches don't work.
16:08:08 <dhellmann> bknudson: ok, thanks, I'll give that a look
16:09:04 <dhellmann> do any other liaisons have anything to report?
16:09:15 <bknudson> nothing from keystone
16:09:20 <bnemec> Nope
16:09:31 <ihrachyshka> nothing from neutron
16:09:37 <dims> nothing from nova
16:09:44 <stevemar> o/
16:09:46 <jungleboyj> nothing from Cinder
16:09:47 <bknudson> maybe developers are focusing on summit work.
16:09:49 <harlowja_at_home> ihrachyshka, i see there is alot of unknowns about tooz in neutron, hopefully can clear that up
16:10:00 <harlowja_at_home> https://review.openstack.org/#/c/168921/ had me a little worried there (hopefully can correct that)
16:10:08 <harlowja_at_home> ^ seeing as that review wanted to create something like tooz :-P
16:10:52 <dhellmann> ok, it sounds like things are going pretty well
16:11:00 <dhellmann> harlowja_at_home: thanks for highlighting that review
16:11:04 <harlowja_at_home> np
16:11:16 <dhellmann> #topic Releases for this week
16:11:21 <dhellmann> I released tooz earlier today
16:11:22 <dhellmann> #info tooz 0.13.2 is a kilo bug-fix release
16:11:22 <dhellmann> #info tooz 0.14.0 is a liberty feature release
16:11:28 <dhellmann> oslo.policy needs a kilo bug-fix release
16:11:29 <dhellmann> #action dhellmann release oslo.policy stable/kilo
16:11:36 <dhellmann> jd__ asked for an oslo.db release from master
16:11:36 <dhellmann> #action dhellmann release oslo.db master
16:11:44 <dhellmann> are there any other releases needed/wanted?
16:12:04 <dims> dhellmann: did the zmq go out? oslo.messaing
16:12:16 <dhellmann> dims: I'll have to check, I don't think I did that one
16:12:18 <ihrachyshka> dhellmann, we may want to have oslo.utils with leap second issue fixed before June... :)
16:12:25 <dhellmann> dims: sileht may have, though?
16:12:38 <harlowja_at_home> leap second, arg, lol
16:12:38 <dhellmann> ihrachyshka: is that patch landed in the stable branch?
16:13:04 <ihrachyshka> not yet, I just cherry-picked it there
16:13:16 <dhellmann> ihrachyshka: link?
16:13:27 <ihrachyshka> https://review.openstack.org/172964
16:13:39 <dhellmann> ihrachyshka: ok, thanks
16:14:18 <dhellmann> that's a good segue into...
16:14:19 <dhellmann> #topic Ongoing work & Review priorities
16:14:51 <dhellmann> #link leap second fix https://review.openstack.org/172964
16:14:58 <dhellmann> We have a bunch of specs up for review, and we should start the discussion on those before the summit
16:15:04 <dhellmann> #link https://review.openstack.org/#/q/project:openstack%2Foslo-specs+is:open,n,z
16:15:26 <dhellmann> in fact, unless we have critical bugs, I think that's our biggest priority right now
16:15:44 <dhellmann> is there anything else we should be considering as the same or higher priority?
16:16:12 <dims> sounds right dhellmann
16:16:17 <bnemec> +1
16:16:17 <harlowja_at_home> seems fair to me
16:16:38 <dhellmann> ok, so let's try to identify any specs we think we can approve before the summit and review them
16:16:41 <dims> dhellmann: some on that list like https://review.openstack.org/#/c/167737/ seems ready to merge
16:16:49 <harlowja_at_home> https://review.openstack.org/#/c/169944/ was one that i'm still trying to think about what should be done there, comments welcome, it appears windows support is somewhat needed for whatever the replacement is :-/
16:17:07 <harlowja_at_home> ^ windows, eck
16:17:08 <dhellmann> dims: ok, I'll go ahead and do that now
16:18:06 <dhellmann> this oslotest proposal seems like it shouldn't be controversial: https://review.openstack.org/#/c/158788/
16:18:36 <dims> +2 dhellmann
16:18:44 <dhellmann> we need to decide what to do with fileutils for https://review.openstack.org/170685, and I'd like to have more input on that
16:18:48 * bnemec apparently failed to re-review that one
16:19:15 <dhellmann> the proposal to write examples for oslo.messaging strikes me as something we shouldn't require a spec for: https://review.openstack.org/140318
16:19:27 <harlowja_at_home> +2
16:19:38 <harlowja_at_home> as ye olde nike said 'just do it'
16:19:38 <dims> dhellmann: agree, no need for spec on that one
16:19:44 <dhellmann> it would be good to have more input on the logging changes: https://review.openstack.org/#/c/164851/
16:20:09 <dhellmann> ditto for this general testing policy: https://review.openstack.org/#/c/158787/
16:20:47 * krotscheck is lurking, running a different meeting
16:20:47 <dhellmann> I think the work on msgpack is done, isn't it jd__ ? https://review.openstack.org/151300
16:21:14 <dhellmann> we have the general feature freeze policy spec, and I think we followed that already: https://review.openstack.org/153642
16:21:30 <jd__> dhellmann: I don't think it's implemented yet
16:21:41 <jd__> dhellmann: this is about oslo.messaging not oslo.serialization
16:21:47 <dhellmann> jd__: oh, I thought I saw a patch somewhere with the new serializer
16:21:53 <dhellmann> ah, maybe that's why I was confused
16:21:58 <jd__> yeah I think so :)
16:22:14 <bnemec> dhellmann: The only thing the feature freeze spec might need is a mention that once stable branches are cut then master is open again.
16:22:17 <dhellmann> there's a zmq spec at https://review.openstack.org/#/c/171131/ that could use some attention
16:22:22 <bnemec> That isn't really called out right now.
16:22:49 <dhellmann> bnemec: I'd be OK with making an edit patch to it separately, and fast-approving that
16:23:04 <bnemec> dhellmann: Yeah, that would be fine with me.
16:23:36 <dhellmann> ok, that seems like a good list of things we might be able to either approve or ask detailed questions on by next week
16:23:53 <dhellmann> shall we make it a goal to review those over the course of the week, and try to merge them early next week?
16:24:14 <dhellmann> say, if there are no objections to those by next tuesday, I'll approve them?
16:24:22 <bnemec> +1 from me
16:25:00 <dims> +1 dhellmann
16:26:59 <dhellmann> oh, dims, you'll be ptl next week, but since you'll be out shall I push the workflow+1 button?
16:27:11 <dims> dhellmann: thanks, yes, please
16:27:18 * dhellmann notes dims chose his first week as ptl for a vacation
16:27:23 <harlowja_at_home> dear leader
16:27:24 <bnemec> dims: Excellent delegation skills! :-D
16:27:27 <dims> haha
16:27:45 <harlowja_at_home> u guys should pass a baton or something
16:27:45 <dhellmann> :-)
16:27:50 <dims> we are all in this together :)
16:27:59 <dhellmann> dims: indeed
16:28:21 <dhellmann> harlowja_at_home: I like that!
16:28:45 <bnemec> Cross-project summit session: PTL relay
16:28:50 <harlowja_at_home> ha
16:28:53 <dhellmann> bnemec: haha
16:29:02 <harlowja_at_home> i can bring a baton i bought but never used for work (for sprinting...)
16:29:11 <harlowja_at_home> *code sprinting (not real sprinting)
16:29:25 * bnemec is actually coaching track this spring
16:29:27 <dhellmann> harlowja_at_home: as long as we don't have to jog around the room...
16:29:30 <harlowja_at_home> lol
16:29:45 <bnemec> 25 pushups for anyone who drops a baton
16:29:48 <dims> y getting old for that :)
16:30:08 <dims> bnemec: i won't last that long
16:30:11 <harlowja_at_home> maybe should bring it so dims can beat (and/or tap) people with it when they get rambunctious at the summit, lol
16:30:26 <dims> :)
16:30:27 <dhellmann> bnemec: what are these "push ups" of which you speak?
16:30:36 <bnemec> Heh
16:30:39 <dhellmann> harlowja_at_home: the Oslo Clue Bat
16:30:45 <dims> it's like pull requests dhellmann
16:30:48 <harlowja_at_home> #action harlowja_at_home bring baton to canada
16:31:01 <dhellmann> ++
16:31:32 <dhellmann> ok, we're at the 30 min mark or so, and that's the end of the formal agenda for this week
16:31:35 <dhellmann> #topic open discussion
16:31:51 <dhellmann> #undo
16:31:53 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x98d5490>
16:32:14 <dhellmann> #action dhellmann merge approved specs mentioned above next tuesday
16:32:17 <dhellmann> #topic open discussion
16:32:30 <bknudson> congrats to dims
16:32:38 <harlowja_at_home> #action harlowja_at_home figure out what code needs to change to fix '<ircmeeting.items.Topic object at 0x98d5490>' using repr()
16:32:52 <dhellmann> yes, congratulations and *thank you* to dims for stepping up to be our ptl for liberty
16:32:58 <bnemec> +1
16:33:13 <dims> thanks everyone!
16:33:20 <harlowja_at_home> there should also be an oslo ptl ring that u guys transfer
16:33:27 <harlowja_at_home> not as evil as the one ring, but a ring
16:33:29 <harlowja_at_home> lol
16:33:36 <jungleboyj> congrats dims !
16:33:50 <dhellmann> harlowja_at_home: or a whiskey bottle, but by now it would be empty
16:33:53 <harlowja_at_home> lol
16:33:55 <ihrachyshka> apparently the ring is not very powerful since Doug passed it himself
16:34:23 <dhellmann> ihrachyshka: hmm, markmc never gave me any ring. maybe I should ask about that.
16:34:43 <harlowja_at_home> maybe he still has it :-/
16:34:46 <bknudson> scepter and crown.
16:34:48 <bnemec> dhellmann: Nor the crate of whiskey either, apparently ;-)
16:34:52 <ihrachyshka> 3 ptl cycles - for NOTHING??
16:34:57 <dhellmann> bnemec: hey, right! :-)
16:36:12 <harlowja_at_home> is https://etherpad.openstack.org/p/kilo-oslo-highlights going to filled in anymore?
16:36:20 <harlowja_at_home> ^ fill it in folks :-P
16:36:30 <dhellmann> harlowja_at_home: oh, good point, thanks
16:36:32 <harlowja_at_home> np
16:36:34 <dims> thanks for the reminder harlowja_at_home
16:37:29 <harlowja_at_home> were we going to get an oslo blog to?
16:37:34 <harlowja_at_home> whatever happened to that idea
16:37:37 <harlowja_at_home> or maybe that was in a dream, idk
16:37:38 <harlowja_at_home> lol
16:37:51 <dhellmann> harlowja_at_home: yeah, I didn't have time to do it while at pycon last week but I'm going to look at it between now and the summit
16:38:01 <harlowja_at_home> cool, i wasn't dreaming then
16:38:23 <dhellmann> nope, I just overestimated the length of my flight :-)
16:38:33 <dhellmann> and the need to sleep on the way home
16:38:37 <bknudson> how was pycon?
16:38:56 <harlowja_at_home> dhellmann, cool, one of the questions on the lowlights that i put is 'pylockfile'
16:39:00 <harlowja_at_home> what to do about that...
16:39:30 <dhellmann> it seems we've gone back and forth on that - from wanting to move oslo.concurrency code into it, to wanting to abandon it entirely
16:39:35 <harlowja_at_home> ya
16:39:56 <bnemec> Why are we abandoning it again?
16:40:00 <harlowja_at_home> http://docs.openstack.org/developer/tooz/developers.html#file exists to sooo (and IPC version as well..)
16:40:01 <dhellmann> I'm open to either, but it seems a shame to have gone through the trouble of adopting it to abandon it right away
16:40:16 <harlowja_at_home> agreed
16:40:22 <harlowja_at_home> something to think about..
16:40:28 <dhellmann> jd__, thoughts?
16:40:30 <bnemec> Can tooz be used standalone as a library?
16:40:40 <harlowja_at_home> bnemec, yes
16:40:47 <harlowja_at_home> if u are willing to accept the limitations
16:40:58 <harlowja_at_home> see matrix @ http://docs.openstack.org/developer/tooz/compatibility.html
16:41:04 <harlowja_at_home> matrix/tables
16:41:33 <harlowja_at_home> ^ might be a good design session or something, idk
16:41:38 <harlowja_at_home> jd__, how about that ;)
16:42:10 <dhellmann> harlowja_at_home: I think we're going to run out of space, but maybe a hallway or lunch discussion - we should definitely figure it out, one way or another
16:42:15 <harlowja_at_home> k
16:42:32 <bnemec> I have to admit I probably haven't been in a huge hurry to look at refactoring o.c to use a separate library because every time we make changes like that something breaks horribly.
16:42:59 <dhellmann> bnemec: right. I think the idea proposed was to move one or two functions wholesale, but that might cause it to be brittle
16:43:19 <harlowja_at_home> bnemec, understood, it'd be nice to have a long-term-plan though (even if it doesn't happen in the short-term)
16:43:34 <bnemec> We're way past brittle at this point. ;-)
16:43:44 <dhellmann> heh
16:43:48 <harlowja_at_home> refactoring these things is painful (by the shear nature of how many people touch it)
16:43:51 <bnemec> But agreed it would be nice to get rid of the duplication between all of these things.
16:43:57 <harlowja_at_home> ^ but it will always be painful...
16:44:04 <harlowja_at_home> *accept da pain, ha
16:44:15 <dhellmann> maybe someone can take on the task of looking for feature duplication within our code next cycle?
16:44:25 <harlowja_at_home> seems like a good idea
16:44:38 <dhellmann> we should also be thinking about finding more common code to put through incubation/librarification
16:44:54 <harlowja_at_home> ^ also doing it with the least pain possible...
16:44:56 <dhellmann> that might need to wait for M, though, since we have some graduations to finish
16:45:14 <dhellmann> harlowja_at_home: ++
16:45:55 <dhellmann> ok, I feel like we're winding up so let's call the meeting done for today and spend the remaining 15 minutes looking at some of those specs mentioned earlier
16:45:58 <dhellmann> thanks, everyone!
16:46:02 <harlowja_at_home> np, lata
16:46:32 <dhellmann> #endmeeting