16:06:09 <dhellmann> #startmeeting oslo
16:06:10 <amrith> ./
16:06:10 <openstack> Meeting started Mon Apr 27 16:06:09 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:13 <openstack> The meeting name has been set to 'oslo'
16:06:18 <dims> o/
16:06:22 <harlowja_at_home> yo
16:06:24 <jungleboyj> o/
16:06:25 <dhellmann> sorry, everyone
16:06:25 <rpodolyaka1> o/
16:06:26 <dhellmann> our agenda:
16:06:26 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:06:26 <dhellmann> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka, zzzeek, sileht, kgiusti, dansmith, sdague
16:06:26 <dhellmann> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:06:34 <amrith> fancy meeting y'all again ... been a while.
16:06:38 * jungleboyj is so confused
16:06:48 * dhellmann is glad dims is taking over next week
16:06:49 <bnemec> Ah, so that wasn't intentional. :-)
16:06:50 <jecarey> o/
16:06:54 <dims> :)
16:06:55 <bknudson> hi
16:07:02 <dhellmann> jungleboyj: sorry, I didn't notice I was in the wrong window
16:07:13 * redrobot is also somewhat confused
16:07:45 <dhellmann> FTR, I'll hand over the chair to dims next week, but I figured I'd help out since he was away last week
16:07:57 <dhellmann> #topic Review action items from previous meeting
16:08:01 <dims> dhellmann: thanks!
16:08:04 <dhellmann> 'thanks again to harlowja_away for running the meeting last week
16:08:07 <harlowja_at_home> np
16:08:11 <dhellmann> #link http://eavesdrop.openstack.org/meetings/oslo/2015/oslo.2015-04-20-16.00.log.html
16:08:11 <harlowja_at_home> it was jee golly fun
16:08:18 <dhellmann> #info harlowja_at_home poke dhellmann with stick about https://review.openstack.org/#/c/163163/
16:08:23 <dhellmann> he did, and I added a comment
16:08:38 <dhellmann> a couple of weeks back we had said we would approve some of the specs
16:08:39 <harlowja_at_home> lol
16:08:47 <dims> deja vu
16:08:57 <dhellmann> I did that with some, but someone edited my notes and now I don't have the links
16:09:00 * dhellmann glares at dims
16:09:18 <dims> sorry dhellmann!
16:09:24 <dhellmann> I think it was just http://specs.openstack.org/openstack/oslo-specs/specs/policy/test-tools.html actually
16:09:57 <dhellmann> the one on oslo.log (https://review.openstack.org/#/c/164851/) is ready, I think -- sdague has told me he was thinking of another approach, but that he believes this one might work
16:10:03 <dhellmann> or something to that effect
16:10:32 <dhellmann> there are quite a lot of other specs up for review
16:10:35 <dhellmann> #link https://review.openstack.org/#/q/project:openstack/oslo-specs+is:open,n,z
16:11:08 <dhellmann> we can talk more about that when we get to liberty planning
16:11:09 <dims> dhellmann: so i can Workflow+1 the https://review.openstack.org/#/c/164851/ today
16:11:18 <dhellmann> dims: sounds good
16:11:32 <zzzeek> o/
16:11:43 <dhellmann> #topic Red flags for/from liaisons
16:12:01 <bknudson> none for keystone
16:12:39 <jungleboyj> none for Cinder
16:12:48 <dims> dhellmann: do we have a list of people (and their projects) who volunteered to be liaisons?
16:13:08 <dhellmann> dims: good question, we need to send out a new request for volunteers
16:13:13 <bknudson> https://wiki.openstack.org/wiki/CrossProjectLiaisons
16:13:19 <dims> dhellmann: ack, i'll do that
16:13:22 <dhellmann> the list is in the wiki at ^^ (thanks bknudson )
16:13:35 <dims> thanks bknudson
16:13:40 <bnemec> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
16:14:02 <dhellmann> we also need to sort out volunteers from our team to be liaisons for other teams (like release and qa)
16:14:22 <dhellmann> dims: I'm happy to stay on as the doc team liaison
16:14:37 <dims> dhellmann: thanks
16:14:37 <dhellmann> dims: and for the logging working group
16:15:00 <dhellmann> we should get someone else involved in the stable branch work, so we have more training there
16:15:05 <dims> anyone interested in the other groups, please let me know
16:15:08 <dims> right dhellmann
16:15:31 <dhellmann> #action dims send email to -dev list requesting volunteers for liaisons
16:15:46 <dhellmann> #info dhellmann to be oslo liaison to documentation team for liberty
16:15:57 <dhellmann> #info dhellmann to be oslo liaison to logging working group for liberty
16:16:34 <dhellmann> #topic Releases for this week
16:16:46 <dhellmann> #info oslo.messaging 1.8.2 for kilo (this release includes fixes related to the heartbeat feature)
16:17:08 <dhellmann> I'll tag that as soon as we get https://review.openstack.org/#/c/177772 to merge
16:17:22 <dhellmann> are there any other releases needed?
16:17:47 <harlowja_at_home> not that i know
16:17:52 <dims> i did not see any other requests
16:18:22 <dhellmann> ok, we can look at the unreleased changes between now and next week and make plans for next week if we have others
16:18:35 <dhellmann> #topic Ongoing work & Review priorities
16:18:48 <dhellmann> we have quite a few specs open, as mentioned earlier
16:18:52 <dhellmann> #link https://review.openstack.org/#/q/project:openstack%2Foslo-specs+is:open,n,z
16:19:09 <dhellmann> we need to settle on which we're going to try to finish for sure in liberty
16:19:27 <dhellmann> though we tend to approve new ones at any point in the cycle, so that won't be the full list, just the start
16:19:35 <dims> right
16:19:36 <harlowja_at_home> for some of those older than 4 months, should we just abandon them?
16:19:56 <harlowja_at_home> or put nice comment, saying something, then abandon?
16:20:06 <dims> +1 to nice comment first
16:20:20 <jungleboyj> :-)  That usually works best
16:20:20 * harlowja_at_home wonders what our policy should be for that (its not that important, just wondering)
16:20:22 <dhellmann> harlowja_at_home: based on that email thread from a while back, I think abandoning sends the wrong message. A nice message and a -1 seems better, and we'll just leave them out of our reviews.
16:20:28 <harlowja_at_home> k
16:20:44 <dims> dhellmann: i'd even wait a week before -1
16:20:53 <dhellmann> dims: sure
16:21:09 <harlowja_at_home> we could put a nice cat picture and then -1 (who doesn't like nice cat pictures, lol)
16:21:22 <dhellmann> heh
16:21:26 <jungleboyj> :-)
16:21:28 <dhellmann> are there any other critical issues to be looking at?
16:22:06 <dims> dhellmann: the oslo.messaging is the only one
16:22:17 <dhellmann> ok, good
16:22:26 <dhellmann> #topic liberty planning
16:22:39 <dhellmann> as with the kilo summit, we need to be working together on the schedule
16:22:58 <zzzeek> dhellmann: is there a calendar of some kind ?
16:23:02 <dhellmann> we can leave it up to dims to decide when to schedule something, but we should help him out with deciding *what* to discuss
16:23:16 <dhellmann> #link https://etherpad.openstack.org/p/liberty-oslo-summit-planning
16:23:20 <dims> zzzeek: we have slots
16:23:37 <dims> #link https://libertydesignsummit.sched.org/overview/type/design+summit/Oslo
16:23:38 <dhellmann> zzzeek: the slot schedule is at https://docs.google.com/spreadsheets/d/1VsFdRYGbX5eCde81XDV7TrPBfEC7cgtOFikruYmqbPY/edit#gid=569963128
16:23:52 <zzzeek> dhellmann: ah!  yes this is what i was looking for
16:23:52 <dhellmann> oh, or that easier to read form :-)
16:23:55 <dims> y either one
16:24:12 <zzzeek> ah great
16:24:24 <zzzeek> so this is everyone!  great
16:24:24 <dhellmann> we will have even more overlap than usual with other projects because we asked for and received more slots
16:24:49 <dims> please see the "Doug's proposed allocation" at the end of the etherpad
16:24:55 <bnemec> Yeah, when I was checking boxes for my personal schedule there was a lot of Oslo. :-)
16:25:21 <dhellmann> as dims said, my first take at a schedule is at the bottom of the etherpad
16:25:23 <harlowja_at_home> cool, looks like yet another super-fun summit :-P
16:25:37 <dhellmann> I came up with 8 fishbowl out of 9, and 8 working out of 8
16:25:52 <dhellmann> I have a couple of proposals for what to do with the extra fishbowl session
16:26:10 <dhellmann> given the recent conversations about deprecation, I proposed a new topic on line 208
16:26:13 * harlowja_at_home keeps on thinking of https://tinyurl.com/pk8amfa  (or similar) when fishbowl is mentioned, lol
16:26:42 <bknudson> bring SCUBA gear.
16:26:46 <dhellmann> several proposed sessions need "drivers" for the meeting
16:26:55 <dims> ++
16:26:58 <dhellmann> in the past we've said we wouldn't hold sessions without a driver, so we need folks to step up for those
16:27:59 <dims> dhellmann: earlier we start filling up the sched.org the better it is for everyone to plan their schedule i think
16:28:03 <dhellmann> if you're interested in the deprecation topic, please add your name to the list so we know if that's a useful idea or if we should discuss something else instead
16:28:28 <harlowja_at_home> +1
16:29:19 <bknudson> the fewer oslo topics there are the more other groups we can barge in on.
16:29:42 <harlowja_at_home> :)
16:29:51 <bknudson> there's already a lot of overlap with keystone sessions :(
16:30:08 <dims> bknudson: reminds me, is there a policy session in your track?
16:30:21 <morganfainberg> dims: we haven't defined the sessions yet
16:30:27 <morganfainberg> dims: that is planned for tomorrow.
16:30:27 <dhellmann> bknudson: yeah, I'm going to be running back and forth between sessions in other tracks all week
16:30:29 <bknudson> I think there will be a lot of discussions around policy.
16:30:31 <dims> morganfainberg: ok
16:30:52 <morganfainberg> and i do expect a ton of discussion around policy
16:31:10 <morganfainberg> dims: i was holding off on sessions until we had liberty priorities lined up
16:31:15 <morganfainberg> dims: which is also tomorrow
16:31:19 <dims> :)
16:32:32 <dims> is there anything people really wanted to talk about but not in the list?
16:33:04 <dhellmann> I left out 2 sessions from the original proposal list, "something something new libraries" and "improving developer docs". Were those particularly important to anyone?
16:33:43 <bknudson> they're important... not sure that a session is reqd for either.
16:33:51 <dims> right bknudson
16:33:54 <dhellmann> right, I meant the sessions
16:34:59 <bknudson> there's nothing graduating?
16:35:08 <dims> harlowja_at_home: help me come up with catchy titles for sessions? :)
16:35:08 <harlowja_at_home> https://review.openstack.org/#/c/141961/
16:35:18 <dhellmann> bknudson: working session #1 is to figure that out
16:35:28 <harlowja_at_home> ^ maybe new library that i'd like to make (ironic has copied it into itself)
16:35:58 <harlowja_at_home> dims, sureee, will help with title,s ha
16:36:07 <dhellmann> harlowja_at_home: maybe we can include that in working session #1? make it about new libs not just graduations?
16:36:13 <bknudson> I'm looking forward to a bunch of meetings with "something something"
16:36:22 <dhellmann> I want to get morganfainberg's strictabc stuff into a library asap
16:36:22 <zzzeek> can someone constrast “fishbowl” with “working” room styles for me quick
16:36:41 <dhellmann> bknudson: the more vague we make it, the less likely we'll have people who won't have useful contributions? :-)
16:36:45 <morganfainberg> dhellmann: I'll roll that up into a github repo as my next priority
16:37:07 <dhellmann> zzzeek: a fishbowl session is like what you experienced at the last summit, with contributors up front and observers spread out in the back of the room
16:37:12 <dims> fishbowl - traditional one or two rows of active participants and everyone else listening in.
16:37:16 <dhellmann> a working session is a smaller room, and just contributors
16:37:20 <harlowja_at_home> dhellmann, sure, sounds good
16:37:21 <zzzeek> dhellmann: k
16:37:30 <dhellmann> morganfainberg: ++
16:37:33 <morganfainberg> zzzeek: working rooms are much smaller.
16:37:43 <dims> working - square or round everyone actually doing something together
16:37:51 <dims> not much fun to look at
16:37:52 <dhellmann> zzzeek: we wanted a way to get just the actual contributors together in a room to do some actual design work
16:38:30 <bknudson> the workroom sessions should be more like a meetup.
16:38:31 <dhellmann> harlowja_at_home: cool, I'll update the notes
16:38:49 <bknudson> like the midcycle meeupts
16:38:51 <bknudson> meetups
16:38:58 <dims> bknudson: you mean mid-cycle stule
16:39:02 <dims> y
16:39:09 <dhellmann> bknudson: not having been to one, I'm not sure what those look like either
16:39:37 <bknudson> you are invited to the keystone one.
16:39:44 <dims> :)
16:39:46 <dhellmann> aw, thanks! :-)
16:40:07 <morganfainberg> dhellmann: yes come to keystone midcycle ;)
16:40:12 <dims> should we have a oslo mid-cycle too? :)
16:40:26 <bknudson> do you want to get stuff done? might want to have one.
16:40:33 <bnemec> In Hawaii please. ;-)
16:40:35 <dhellmann> dims: we did, during juno -- jd__ & the other enovance folks hosted it
16:40:49 <dims> bknudson: +++++
16:40:56 <dhellmann> bnemec: somewhere cool during the summer, please
16:40:57 <dims> bnemec: ++
16:41:16 <bknudson> I think the nova midcycle is here in rochester ( bnemec )
16:41:31 <bnemec> bknudson: No kidding?
16:41:35 <dims> i'll try to figure out something
16:41:40 <bknudson> bnemec: yes, bldg 025
16:42:19 <bnemec> bknudson: Cool, I may have to drop by.  Maybe I can get my pxe booting spec written before then.
16:42:40 <dhellmann> bknudson: rochester, mn or rochester, ny?
16:42:44 <bknudson> mn
16:43:05 <bknudson> it's a hotbed for openstack activity
16:43:13 <bnemec> +1! :-)
16:43:35 <dims> bknudson: and i know both the indian restaurants :)
16:43:35 <dhellmann> isn't there a list of these somewhere in the wiki?
16:43:55 <bnemec> Yeah, there used to be anyway.
16:44:20 <zzzeek> dhellmann: are we having an oslo dinner in vancouver ? :)
16:44:31 <harlowja_at_home> the most senior person pays right?
16:44:33 <dhellmann> zzzeek: we could -- I haven't planned anything
16:44:33 <harlowja_at_home> lol
16:44:33 * bnemec can't find it though
16:44:44 <harlowja_at_home> my guess is dhellmann has to then pay?
16:45:07 <dims> haha
16:45:24 <harlowja_at_home> *maybe not, not sure who has been around this industry the longest :-P
16:45:47 <bnemec> I think by definition dims is most senior now. :-)
16:45:52 * dhellmann thinks harlowja_at_home is calling him old
16:45:53 <dims> :)
16:45:55 <harlowja_at_home> lol
16:45:57 <harlowja_at_home> *senior(
16:46:00 <harlowja_at_home> *senior*
16:46:00 <bknudson> #link https://wiki.openstack.org/wiki/Sprints
16:46:07 <bknudson> they're called sprints I guess.
16:46:22 <dhellmann> bknudson: is that it? I don't see one for nova on that list so I wasn't sure if that was really it
16:46:35 <dims> y i haven't heard the nova one yet
16:46:56 <bnemec> That's the page I am aware of.
16:47:02 <dhellmann> yeah, apparently that's it: http://lists.openstack.org/pipermail/openstack-dev/2015-February/056310.html
16:47:04 <dims> so action for me, research oslo mid-cycle possibilities
16:47:04 <bknudson> there's no keystone mentioned either
16:47:16 <dhellmann> dims: you can #action yourself
16:47:20 <bnemec> Probably not populated yet since we haven't actually made it past summit.
16:47:22 <dims> ah k
16:47:38 <dims> #action dims to research oslo mid-cycle possibilities
16:48:06 <dhellmann> as much as I'd like to spend a few days in a conference room with all of you, we should probably have a theme or focus identified first :-)
16:48:16 <dims> agree dhellmann
16:48:39 <harlowja_at_home> like a party theme?
16:48:40 <harlowja_at_home> nice
16:48:49 <harlowja_at_home> Hawaiian?
16:49:04 <harlowja_at_home> ;)
16:49:28 <dhellmann> dims: has ttx given you a deadline for settling our summit schedule?
16:49:28 <dims> harlowja_at_home: i am still groggy from TZ
16:50:04 <dims> dhellmann: was just checking my emails, i did not see a specific date yet. will respond back on oslo channel when i see one
16:50:18 <dims> earlier the better i think
16:50:22 <dhellmann> dims: sounds good
16:50:23 <dhellmann> yeah
16:51:05 <dhellmann> we should also start making notes about things like "don't let this overlap with a keystone session so bknudson can attend" and that sort of thing
16:51:15 <dhellmann> that will make fitting them into the slots easier when the time comes
16:51:44 <dims> so bknudson et all, make sure you add your names in the etherpad so i can adjust
16:52:03 <harlowja_at_home> is there a constraint solver that runs on the sessions schedule, can we like borrow that for pip, lol
16:52:13 <dims> harlowja_at_home: haha
16:52:15 <dhellmann> we can't promise everyone a perfect schedule, but we can try to make sure key folks have a chance to be at sessions
16:52:40 <dhellmann> harlowja_at_home: I wish. This is probably one of the hardest parts of the PTL role. :-)
16:52:40 <dims> +1
16:52:51 <bknudson> is the list at the bottom (proposed allocation) the likely topics?
16:53:08 <dims> bknudson: yes "Doug's proposed allocation"
16:53:24 <dhellmann> bknudson: unless there is a really really strong new candidate in the next couple of days, which seems unlikely
16:53:51 <dhellmann> out of the list proposed so far, I think only 2 aren't in that set in any way (some were combined)
16:54:36 <bknudson> I don't see myself needing to attend any of those, so you don't have to work around my schedule. I'll just show up at whatever's open.
16:55:01 <dhellmann> bknudson: ok, I was just using you as an example
16:55:35 <dhellmann> a better example is that oslo.versionedobjects intro, for which we'll need dansmith
16:56:06 <dhellmann> alright, we're about out of time and I want to end my term under budget
16:56:12 <dhellmann> #topic open discussion
16:56:29 <bknudson> oslo.messaging stable/kilo release today?
16:56:37 <dhellmann> bknudson: yeah, we need one more patch to land first
16:56:52 <dhellmann> https://review.openstack.org/#/c/177772/4
16:57:05 <bknudson> recheck
16:57:18 <dhellmann> did we hit some sort of race?
16:57:43 <bknudson> "Too many connections" -- probably not unexpected in a large-ops test.
16:58:03 <dhellmann> hmm
16:58:22 <dhellmann> ok, I'll work with sileht on that
16:58:56 <bknudson> must be caused by that help string getting slightly longer.
16:59:21 * dhellmann hopes not
16:59:38 <dhellmann> alright, I think that's all for today
16:59:40 <dims> haha
17:00:11 <dhellmann> thank you all again for your help this release, it has been great working with you all as ptl and I look forward to being part of the team again for liberty
17:00:20 <zzzeek> :)
17:00:26 <harlowja_at_home> woot
17:00:29 <dims> many many thanks dhellmann
17:00:35 <bnemec> o/\o dhellmann
17:00:35 <harlowja_at_home> for he was a jolly good fellow and nobody shall deny
17:00:54 <bnemec> (that's a high five, not some weird bird face, ftr)
17:01:07 <dhellmann> bnemec: ok, I thought maybe it was a midwestern cricket or something
17:01:12 <dhellmann> :-)
17:01:16 <bnemec> Heh
17:01:17 <dhellmann> thanks, all!
17:01:19 <dhellmann> #endmeeting