16:00:28 <harlowja_at_home> #startmeeting oslo
16:00:29 <openstack> Meeting started Mon May 11 16:00:28 2015 UTC and is due to finish in 60 minutes. The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:32 <openstack> The meeting name has been set to 'oslo'
16:00:35 <ihrachyshka> o/
16:00:36 <jungleboyj> o/
16:00:37 <sileht> o/
16:00:37 <dhellmann> o/
16:00:37 <johnsom> o/
16:00:40 <bknudson> hi
16:00:42 <harlowja_at_home> courtesy ping for jd__, dims, bnemec, flaper87, dhellmann, viktors, rpodolyaka, zzzeek, sileht, kgiusti, dansmith
16:00:47 <harlowja_at_home> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:48 <kgiusti> lo
16:00:51 <harlowja_at_home> yo yo
16:00:53 <flaper87> o/
16:00:55 <harlowja_at_home> all aboard the oslo train!
16:00:57 <viktors|wfh> o/
16:00:59 <harlowja_at_home> all aboard!!!
16:01:05 <amotoki_> o/
16:01:11 <jungleboyj> whoooo whooo.
16:01:20 * harlowja_at_home couldn't find any good pictures of oslo trains
16:01:22 <harlowja_at_home> ha
16:01:33 <bknudson> I thought it was a moose.
16:01:37 <harlowja_at_home> i did find the metro line though https://upload.wikimedia.org/wikipedia/commons/3/38/Oslo_t-bane.jpg
16:02:01 <harlowja_at_home> bknudson, u saw a moose?
16:02:07 <harlowja_at_home> ok, let's get started :)
16:02:10 <bknudson> the mascot
16:02:14 <harlowja_at_home> ah
16:02:20 <ihrachyshka> apparently they use reindeers there
16:02:21 <harlowja_at_home> so first order of business before i forget
16:02:24 <harlowja_at_home> !!WELCOME NEW CORES!!!
16:02:25 <openstack> harlowja_at_home: Error: "!WELCOME" is not a valid command.
16:02:34 <dhellmann> ++
16:02:44 <bnemec> o/
16:02:48 <jungleboyj> ++
16:02:50 <harlowja_at_home> :)
16:02:56 <sileht> :)
16:03:00 <jecarey> o/
16:03:16 <harlowja_at_home> ok, with great power comes great responsiblity or something, so ya, remember that
16:03:17 <harlowja_at_home> haha
16:03:35 <harlowja_at_home> #topic Review action items from previous meeting
16:03:48 <harlowja_at_home> #link http://eavesdrop.openstack.org/meetings/oslo/2015/oslo.2015-05-04-16.01.html
16:03:53 <harlowja_at_home> soooo i did mine, ha
16:04:06 <harlowja_at_home> i'm not sure if dims did his though :)
16:04:30 <harlowja_at_home> #link https://review.openstack.org/#/c/179890/ (futurist/tardis/whatever) spec
16:04:50 <bknudson> oslo.middleware 1.2.0 was released 2015-05-04
16:04:54 <harlowja_at_home> ah, cool
16:04:56 <harlowja_at_home> #action check up with dims when he gets back to figure out if he did his
16:05:19 <harlowja_at_home> so i guess he doesn't get coal for xmas then
16:05:30 <amrith> ./
16:05:50 <bknudson> he might want coal
16:05:56 <harlowja_at_home> good point
16:06:07 * harlowja_at_home isn't sure how coal futures are doing
16:06:14 <amrith> #cleancoal
16:06:45 <harlowja_at_home> alright, any other action items that i missed?
16:06:47 * jungleboyj wonders if there is a cleancoal channel
16:06:51 <harlowja_at_home> ha
16:06:53 <amrith> definition of oxymoron?
16:07:05 <amrith> sorry, back to real work
16:07:16 * harlowja_at_home this isn't real work, whattt
16:07:19 <harlowja_at_home> i've been lied to
16:07:27 <harlowja_at_home> #topic Red flags for/from liaisons
16:07:43 <harlowja_at_home> any red flags that need to be addressed?
16:07:49 <bknudson> None from keystone.
16:07:54 <ihrachyshka> a tiny oslo.context change for neutron (and others): https://review.openstack.org/#/c/176333/
16:07:57 <jungleboyj> I have one thing to note from Cinder.
16:07:57 * harlowja_at_home fixed the cinder + taskflow one (so u can't use that, ha)
16:08:11 <ihrachyshka> and I need to go back to that oslo.policy patch to move neutron forward with its adoption...
16:08:21 <johnsom> Hello from Octavia. Too new to raise any flags.
16:08:58 <harlowja_at_home> ihrachyshka, cool, so guess that one should get some attention?
16:09:07 <ihrachyshka> johnsom, I hope your move under networking program does not mean nuetron oslo liaison should be involved from now on? :)
16:09:21 <jungleboyj> harlowja_at_home: We discovered this problem at the end of Kilo: https://bugs.launchpad.net/cinder/+bug/1447380
16:09:21 <openstack> Launchpad bug 1447380 in OpenStack Compute (nova) "wrong cinder.conf.sample generation: missing directives for keystone_authtoken (at least)" [Critical,In progress] - Assigned to John Griffith (john-griffith)
16:09:21 <ihrachyshka> harlowja_at_home, if spare cycles, yes please
16:10:30 <harlowja_at_home> jungleboyj, intersting, hopefully some oslo.config knowledgeable person can weigh in on that (if they haven't already)
16:10:40 <jungleboyj> To resolve it we had to set up a config generator script that partially uses the new config-generator along with the old code to pull options out of Cinder.
16:10:49 <harlowja_at_home> dhellmann, have u seen that one?
16:11:17 <jungleboyj> The Cinder folk were kind-of hoping we could stick with that solution long term but I indicated that we shouldn't.
16:11:37 <harlowja_at_home> ya, agreed
16:11:39 <jungleboyj> I need to get back to the code I was working on for pulling options out of the different files in Cinder.
16:11:48 <bnemec> jungleboyj: Can you add oslo.config to that bug with an explanation of exactly what's wrong on the Oslo side?
16:12:00 <jungleboyj> There were a number of comments and I am thinking through improvements.
16:12:51 <jungleboyj> bnemec: I could try to recreate it. It just silently fail processing the other libraries.
16:13:16 <jungleboyj> Since the incubator config generator is EOL I figured it was best to try and move forward.
16:13:45 <dhellmann> is this the issue where the wrong namespace was being used?
16:13:46 <bnemec> jungleboyj: Agreed, but I got the impression there was still a problem?
16:14:31 <jungleboyj> bnemec: No, I don't think there is one in the new config-generator. Just need to come up with a good solution for scraping the options out of Cinder.
16:14:44 <jungleboyj> Once we have that Nova and the other projects can emulate the solution.
16:14:54 * jungleboyj just hasn't had time to code it up.
16:16:01 <jungleboyj> So, just wanted to make everyone aware of the issue. I will continue to work on getting to the new config-generator.
16:16:03 <harlowja_at_home> cool, seems resolvable/under way i guess; and something that can be used by a larger audience once its all going well
16:16:17 <jungleboyj> harlowja_at_home: ++
16:16:24 <harlowja_at_home> thx jungleboyj ; i think i see the issue now and understand what u are trying to do/fix :)
16:16:50 <bknudson> what was causing the partial config files? that's weird
16:17:22 <harlowja_at_home> i think its a mix of the old-style and new-style (entrypoint) loading (but that may just be my misunderstanding of it all); ha
16:17:37 <jungleboyj> bknudson: ^^
16:17:46 <harlowja_at_home> so jungleboyj is working on a old-new-style-config-generator (or whatever u want to call that)
16:18:00 * harlowja_at_home correct me if i'm out in left-field somewhere, ha
16:18:18 * harlowja_at_home which i've been known to be out in :-P
16:18:51 <bnemec> Basically cinder doesn't have list_opts entry points registered, right?
16:19:24 <jungleboyj> bnemec: Right. I am working on finding an agreeable solution to that problem.
16:20:38 <harlowja_at_home> alright let's keep that work going forward i guess and see where it ends up :) choo choo train moving to next topic
16:20:51 <harlowja_at_home> #topic Releases for this week
16:20:55 <jungleboyj> Sounds good. Will do.
16:21:00 <harlowja_at_home> thx :)
16:21:10 <harlowja_at_home> any releases for this week/planned or other?
16:21:19 <harlowja_at_home> probably a short week for most, due to summit...
16:22:14 <jungleboyj> Summit? There is a summit coming?
16:22:17 <jungleboyj> :-)
16:22:17 <harlowja_at_home> ha
16:22:41 <harlowja_at_home> ya, a summit, we are all going to climb a mountain together
16:22:47 <harlowja_at_home> and liberate things
16:22:54 <harlowja_at_home> u can come, its cool
16:23:05 * jungleboyj start checking into it.
16:23:13 <harlowja_at_home> *just avoid everest for a while...
16:23:21 <jungleboyj> ++
16:23:38 <bknudson> #lnk https://www.grousemountain.com/grousegrind
16:24:00 <harlowja_at_home> is that in vancouver?
16:24:08 <bknudson> yes
16:24:19 <harlowja_at_home> nice
16:24:30 <harlowja_at_home> ya, so that will be the oslo-workout-program-of-the-day
16:24:31 <harlowja_at_home> lol
16:24:44 <harlowja_at_home> be there, or else!
16:24:59 * bnemec notes to pack his trail shoes
16:25:00 <jungleboyj> Holy cow. 2800 foot gain in 1.8 miles
16:25:12 * ihrachyshka has been there once already
16:25:18 <harlowja_at_home> �Mother Nature�s Stairmaster.�
16:25:22 <harlowja_at_home> ha
16:25:55 <harlowja_at_home> ok, choo choo departing
16:25:55 <ihrachyshka> not a pleasant experience if you have snow and water near the top: you don't want to return, neither you feel safe moving further :)
16:26:02 <harlowja_at_home> :-/
16:26:14 * harlowja_at_home might be still snow there, not sure
16:26:16 <harlowja_at_home> #topic Ongoing work & Review priorities
16:26:32 <ihrachyshka> harlowja_at_home, you should check signs at the bottom. I just sneaked in.
16:26:45 <harlowja_at_home> ah, cool
16:26:57 <harlowja_at_home> any ongoing reviews, specs reviews welcome...
16:27:04 <harlowja_at_home> anything to highlight for folks?
16:27:06 <sileht> -> https://review.openstack.org/#/c/181010/
16:27:45 <sileht> we are going to break backward compat from the amqp pov
16:27:48 <harlowja_at_home> (also https://tinyurl.com/njkre43 ---> oslo dashboard)
16:28:24 <sileht> an old oslo.messaging will not be able to talk an older one
16:28:54 <bnemec> sileht: Is that going to break live upgrades? Nova will most likely not be happy about that.
16:28:56 <harlowja_at_home> right, because of the removal of `ending' param
16:29:19 <sileht> bnemec, no we keep backcompat during two versions
16:29:42 <bnemec> sileht: Okay, thanks
16:29:46 * bnemec should probably read the spec
16:29:55 <sileht> bnemec, but currently you can still talk a very very old version of oslo-incubator rpc
16:30:13 <sileht> we going to break that and only support 2 backward versions
16:30:32 <harlowja_at_home> guess we should like make sure that version change (and what version does/doesn't work) to operators ML to
16:31:08 * harlowja_at_home reminds me of using that oslo-blog idea that we were going to have for this kind of stuff
16:31:09 <dhellmann> yes, we should publicize this widely
16:31:20 <harlowja_at_home> whatever happened to that idea :-P
16:31:26 <sileht> I thought we should support upgrade like DB schema upgrade does
16:31:28 <dhellmann> harlowja_at_home: I have started looking into that, and need to check in with anne about the hostname for publishing
16:31:32 <harlowja_at_home> cool
16:32:05 <dhellmann> sileht: we need to make sure that there is *some* way to run mixed versions of services, so that we can do rolling upgrades
16:32:34 <sileht> dhellmann, sure I'm just wonder how many version back we should support (I'm guessing 2)
16:33:16 <harlowja_at_home> might be an interesting question for operators ML, to see if people can do pip freeze | grep oslo.messaging and post the results
16:33:18 <dhellmann> sileht: that seems good enough, but we should make sure we understand the supported upgrade paths -- I don't think we support jumping versions in upgrades
16:34:10 <harlowja_at_home> +1 any use any info we can get from operators/other sources to help undestand how this will go down
16:34:22 <harlowja_at_home> operators/devs/other secret sources
16:35:40 <harlowja_at_home> also folks check out https://review.openstack.org/#/q/project:openstack/oslo-specs for other things to review
16:35:59 <harlowja_at_home> specs more important to look over so we can all have some clue of whats happening/being talked about at the summit (for relevant sessions)
16:36:12 <harlowja_at_home> and with that segway
16:36:14 <harlowja_at_home> #topic Liberty or death
16:36:19 * bnemec needs to push a spec for one of his sessions
16:36:43 <harlowja_at_home> https://libertydesignsummit.sched.org/overview/type/design+summit/Oslo
16:36:55 <harlowja_at_home> check out the schedule folks
16:37:08 <harlowja_at_home> seems like all wed/thurs, so be there!
16:37:15 <bknudson> looks like the only oslo session I can really get to is the oslo.log one.
16:37:32 <harlowja_at_home> :(
16:37:35 <harlowja_at_home> clone yourself?
16:37:35 <bknudson> "Life, Liberty, and the pursuit of oslo.log changes "
16:38:04 <harlowja_at_home> ya, idk who came up with all those crazy names, ha
16:38:08 <harlowja_at_home> #link https://wiki.openstack.org/wiki/Summit/Liberty/Etherpads#Oslo also
16:38:24 <harlowja_at_home> for making etherpads beforehand if u want (some kind of basic strucutre usually helps)
16:39:22 <harlowja_at_home> and also https://www.openstack.org/summit/vancouver-2015/download-the-summit-app/ (seems to be up)
16:39:51 <harlowja_at_home> so i'm pretty sure all/most of us will be there
16:40:08 <harlowja_at_home> and hoepfully with little moose stickers on us
16:40:16 <harlowja_at_home> dhellmann, how's the moose stickers coming along?
16:40:36 <dhellmann> harlowja_at_home: the order is placed and my fingers are still crossed that they arrive before I leave
16:40:46 <harlowja_at_home> woot
16:40:58 <harlowja_at_home> https://review.openstack.org/#/c/180627/ (the moose)
16:41:12 <harlowja_at_home> https://review.openstack.org/cat/180627%2C2%2Cdoc/source/_images/oslo-moose-color.svg%5E0 (also the moose)
16:42:11 <harlowja_at_home> so my guess is starting friday most of the IRC channels will start to be more quiet than usual
16:42:17 <harlowja_at_home> just a word of warning :-P
16:42:24 <harlowja_at_home> probably starting thursday actually
16:43:08 <harlowja_at_home> #topic Open discussion
16:43:18 <harlowja_at_home> alright, chat among yourselves!
16:43:19 <harlowja_at_home> lol
16:43:32 <harlowja_at_home> lifeless, has been working on https://github.com/pypa/pip/pull/2716 (if anyone is intersted)
16:43:42 * harlowja_at_home thinks that will be a great to have
16:43:43 <bnemec> "Congrats! OpenStack will be installed on your device soon!"
16:43:47 <bnemec> If only it were so easy. ;-)
16:44:22 * harlowja_at_home is sure lifeless would also like any feedback/issues on that
16:44:33 <harlowja_at_home> basically he's trying to get something working for https://github.com/pypa/pip/issues/988
16:44:40 <harlowja_at_home> not really oslo related, but it will help everyone :-P
16:45:33 <harlowja_at_home> i also thought zzzzeek asked about some oslo-lunch/dinner meetup or something
16:45:45 <harlowja_at_home> lunch all together seems doable, idk about dinner
16:45:57 <harlowja_at_home> happy big family, lol
16:46:08 <dhellmann> picking a day to eat lunch together sounds like a good idea
16:46:18 <dhellmann> do we have a session right before lunch?
16:46:18 <harlowja_at_home> agreed
16:46:40 <harlowja_at_home> hmmm
16:46:49 <bknudson> oslo.log is before lunch
16:46:58 <bknudson> thursday
16:47:06 <bknudson> so everybody will be thinking about lunch instead.
16:47:59 <bknudson> and functional testing is on wed
16:48:26 <harlowja_at_home> hmmm, ya, so maybe this will have to be more ad-hoc then
16:48:30 <harlowja_at_home> or something to ponder on
16:49:20 * harlowja_at_home we need an event-planner :-P
16:49:30 * harlowja_at_home not it
16:50:16 <harlowja_at_home> anything else anyone wants to bring up
16:50:24 <harlowja_at_home> otherwise u can get 10 minutes of your free-time back, ha
16:51:00 <harlowja_at_home> 'free-time' (in air-quotes)
16:51:50 <harlowja_at_home> ok then, everyone have safe travels to the summit (or other destination) and we'll see some/most of u there!
16:52:01 <harlowja_at_home> may the force be with u
16:52:19 <harlowja_at_home> #endmeeting