16:00:18 <dims_> #startmeeting oslo
16:00:18 <openstack> Meeting started Mon Jun  1 16:00:18 2015 UTC and is due to finish in 60 minutes.  The chair is dims_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:22 <openstack> The meeting name has been set to 'oslo'
16:00:25 <zzzeek> o/
16:00:26 <rpodolyaka1> o/
16:00:27 <dims_> courtesy ping for jd__, dims, bnemec, flaper87, harlowja, viktors, rpodolyaka, zzzeek, sileht, kgiusti, dansmith
16:00:28 <dims_> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:29 <johnsom> o/
16:00:33 <harlowja_at_home> sup
16:00:36 <jecarey> o/
16:00:39 <dhellmann> o/
16:00:43 <nkrinner> o/
16:00:46 <jungleboyj> o/
16:00:48 <bnemec> o/
16:00:54 <ihrachyshka> \o
16:00:57 <bknudson> aloha
16:01:21 <bnemec> dims_: You might want to replace yourself in the courtesy ping list with dhellmann. :-)
16:01:36 <dims_> welcome back everyone, it was nice seeing y'all at vancouver
16:01:47 <dims_> bnemec: still using his cheat sheet :)
16:01:58 <bnemec> Yeah, I figured
16:02:18 <dims_> #topic Review action items from previous meeting
16:02:19 <harlowja_at_home> :)
16:02:37 <dims_> 1. dims to research oslo mid-cycle possibilities (IN PROGRESS)
16:02:48 <harlowja_at_home> hawaii?
16:02:50 <dims_> so, anyone fancy a mid-cycle meetup?
16:02:52 <redrobot> o/
16:03:15 <dims_> harlowja_at_home: other than lounging on the beach what else would we do?
16:03:32 <harlowja_at_home> collaborate and all that
16:03:44 <harlowja_at_home> ha
16:03:46 <dims_> :)
16:03:51 <zzzeek_> the oslo.db build made my entire machine hang up.  fully rebooted.  machine restored its state, the whole test suite ran completely while the whole machine was frozen!
16:03:55 <dhellmann> it would be best if we were able to identify a couple of specific things to focus on for that time
16:04:12 <dims_> looking for something to bind us all together or we'd end up doing something by ourselves there
16:04:14 <dims_> y
16:04:36 <dims_> i'll ask this again next week if anyone has any ideas
16:04:39 <harlowja_at_home> hmmmm
16:04:53 <dims_> #topic Red flags for/from liaisons
16:05:13 <bknudson> No red flags for keystone.
16:05:21 <bknudson> anything graduating that I need to worry about?
16:05:21 <stevemar> o/
16:05:23 <jungleboyj> Nothing from Cinder right now.  Just trying to find time to work on the issues I have open.  :-)
16:05:25 <dhellmann> heads up, we'll be cutting a bunch of releases tomorrow
16:05:29 <ihrachyshka> neutron is here to wave some flags!
16:05:30 <bknudson> I think I need to switch versionutils
16:05:37 <ihrachyshka> first, we want oslo.policy release to be able to switch to it
16:05:56 <dhellmann> #link http://paste.openstack.org/show/245057/
16:05:57 <dims_> ihrachyshka: that's next item on agenda
16:06:25 <johnsom> Nothing from Octavia
16:06:41 <ihrachyshka> second, we had that discussion on the summit about neutron playing bad with ServiceLauncher and friends. we have some patches in review, but I'm not completely sure whether we consume everything correctly from our side, so if someone from oslo.service guys is able to check those, it would be great
16:06:44 <ihrachyshka> #link https://review.openstack.org/#/c/161732/
16:06:57 <ihrachyshka> and dependents
16:07:04 <harlowja_at_home> hmmm, oslo.service is one of those things graduating i think this time around (last time i checked)
16:07:21 <ihrachyshka> harlowja, yeah, but there is already service.py that we consume from incubator
16:07:24 <ihrachyshka> should be the same code
16:07:27 <zzzeek_> hi where’s the agenda?  link at http://eavesdrop.openstack.org/#Oslo_Team_Meeting goes to a blank page
16:07:29 <dims_> #action dims to ping eezhova about ihar's https://review.openstack.org/#/c/161732/ review
16:07:35 <harlowja_at_home> right, or better ihrachyshka
16:07:51 <ihrachyshka> the neutron issue was mostly that we spawned multiple Launchers in single process
16:08:20 <ihrachyshka> there is one thing I want to note in this context: there is nothing that documents that current neutron usage of the module is incorrect
16:08:22 <dims_> zzzeek_: it's here - https://wiki.openstack.org/wiki/Meetings/Oslo - but i have to bring it up to date
16:08:28 <ihrachyshka> so oslo.service needs better docs
16:08:30 * harlowja_at_home wonders if https://review.openstack.org/#/c/164836/ should/would help
16:08:35 <ihrachyshka> or better, it needs docs :)
16:08:36 <harlowja_at_home> +1 to better docs
16:08:47 <dims_> ihrachyshka: true. will make sure we do as part of oslo.service
16:08:49 <zzzeek_> dims_: OK so the agenda for today is not published
16:08:55 <ozamiatin> o/
16:09:13 <dims_> zzzeek_: yes, it's dated
16:09:22 <ihrachyshka> dims_, meh... if eezhova is behind oslo.service, then it's worthless for her to check the patch since it's her patch :)
16:09:36 <harlowja_at_home> :)
16:09:57 <dims_> ihrachyshka: there's a couple of more people i think, don't remember off the top of my head have to go find the old reviews
16:10:06 <dims_> especially the reverts
16:10:07 <harlowja_at_home> https://review.openstack.org/#/c/142659/ (sachi?)
16:10:36 <harlowja_at_home> but elena uploading stuff, so i'm guessing both
16:10:47 <dims_> harlowja_at_home: at least those 2
16:11:07 <harlowja_at_home> ya
16:11:56 <dims_> ihrachyshka: will make sure there is eyes on that review. anything else from anyone?
16:12:03 <dims_> if not...
16:12:05 <dims_> #topic Releases for this week
16:12:20 <dims_> dhellmann: what are we releasing today?
16:12:54 <bknudson> a shorter list would be what's not being released today
16:12:59 <dims_> haypo needs a oslo.db release for some python34/nova work according to my notes
16:13:31 <dhellmann> dims_: I wasn't planning to release anything other than the middleware library today, but I can do more if you'd like
16:13:39 <harlowja_at_home> oslo.utils yet (or are we still waiting on that one for nova fixes?)
16:13:59 <gordc> stevemar: side topic but we want to release pycadf 1.0.0?
16:14:00 <ihrachyshka> dhellmann, oslo.policy? :)
16:14:04 <dims_> harlowja_at_home: i spoke wrong, it was not oslo.utils that was going to break nova, it was oslo.serialization
16:14:09 <harlowja_at_home> ah
16:14:13 <dhellmann> dims_: I had a long list for tomorrow: http://paste.openstack.org/show/253257/
16:14:15 <harlowja_at_home> release all the things!!!! lol
16:14:58 <dhellmann> yeah, basically, all of it
16:15:07 <dims_> dhellmann: if we don't break gate today, we can try to get all of them out tomorrow
16:15:07 <dhellmann> gordc: I can do pycadf as well, if you want
16:15:10 <dims_> :)
16:15:12 <dhellmann> dims_: ++
16:15:41 <dims_> #action dims to poke nova folks for possible oslo.serialization impact on nova unit tests
16:15:49 <gordc> dhellmann: sure -- just checking to see if there's no last minute patches
16:16:31 <gordc> dhellmann: yeah, i think we can do a 1.0.0 release for pycadf
16:16:45 <dims_> dhellmann: expect pbr, right?
16:16:59 <dims_> gordc: ++ to 1.0.0
16:17:01 <dhellmann> gordc: http://paste.openstack.org/show/253258/ shows what it will include
16:17:07 <dims_> except pbr i mean
16:17:08 <dhellmann> dims_: right, not pbr, I leave that for lifeless
16:17:14 <dims_> sounds good dhellmann
16:17:52 <gordc> dhellmann: looks fine to me. the big thing was just removing all the middleware and dependencies
16:18:15 <dhellmann> k
16:18:20 <dims_> dhellmann: at some point we have to figure out if the library versions need to be bumped up to 1.x (of those that are 0.x) do we do that in milestone 3 like last time?
16:18:29 <bknudson> pycadf 1.0 !
16:18:43 <stevemar> gordc, i think we're good for pycadf 1.0.0... we dropped the middleware bits right?
16:18:45 <dhellmann> we can do that whenever we're ready. It would be good to have them all at 1.0 by the end of the cycle
16:19:16 <dims_> gordc: just give me and dhellmann a heads up when you push it, so we can watch for fallout
16:19:27 <gordc> stevemar: yeah.
16:19:48 <dims_> next topic...
16:19:55 <dims_> #topic Documentation
16:20:13 <dims_> Anyone have time to write user facing documentation for different oslo libraries?
16:20:25 <harlowja_at_home> i can write a little, but not all of it :-P
16:20:48 <dims_> ack. is this something that we can do in a mid-cycle meetup?
16:21:23 <harlowja_at_home> i'd be nice to have at least each library have something minimial like @ http://docs.openstack.org/developer/debtcollector/ (overview, + some examples + some api doc)
16:21:25 <dhellmann> I'll be working on the oslo.log docs this cycle
16:21:28 <harlowja_at_home> dims_, could be
16:21:33 <dims_> please ping me if you are interested in specific ones so we can divide up work
16:21:48 <dhellmann> dims_: nice idea to work on the docs at the midcycle
16:21:53 <dims_> ++ harlowja_at_home
16:22:51 <dims_> ok. switching topics
16:22:53 <dims_> #topic Feedback from Vancouver summit
16:22:56 <harlowja_at_home> maybe we should see what people think as the ones that need the most docs and go from there?
16:23:00 <dims_> what was good? bad? keep? change?
16:23:20 <harlowja_at_home> change, more airplane rides
16:23:37 <dims_> apart from some travel issues (visa/flight).. :)
16:23:37 <amrith> dims_, ./
16:23:42 <zzzeek_> it was very difficult to get flights to vancouver
16:24:05 <dims_> zzzeek_: ack. thanks for google hangout at least
16:24:06 <harlowja_at_home> *airplane rides (== the ones taking off from the bay); not the other ones, lol
16:24:11 <zzzeek_> dims_: sure
16:24:17 <amrith> dims_, ./
16:24:22 <dims_> hi amrith
16:24:31 <amrith> dims_, didn't want to interrupt
16:24:34 <amrith> because I tuned in late
16:24:37 <dims_> np
16:24:42 <amrith> but your q: re: feedback from vancouver
16:24:45 <amrith> I have two
16:24:47 <dims_> yes
16:24:49 <amrith> relate specifically to trove
16:24:51 <bnemec> I thought we had a few Oslo sessions where there wasn't a lot of discussion needed.
16:25:04 <bnemec> Maybe those should have been resolved as plain old specs instead.
16:25:13 <dims_> bnemec: the config ones?
16:25:20 <amrith> the first is whether there is any way in which a oslo.messaging client can manage users/authentication of the underlying AMQP (like Rabbit) through o.m.
16:25:32 <amrith> the second is about the feasibility of having an o.m driver for zaqar
16:25:47 <amrith> to projects like Trove, the benefit of o.m is that it is a layer of abstraction
16:25:50 <dims_> sileht: around? ^^^
16:25:53 <bnemec> dims_: Yeah, maybe one or two others too.
16:25:54 <amrith> and a user can choose what they want under the covers
16:26:02 <dims_> bnemec: ack i agree
16:26:02 * harlowja_at_home would also somehow like more PTL(s) from other projects knowing whats happening in oslo, maybe there should be a designated session/talk/other each summit just for that, so they can know whats 'happening/coming up'?
16:26:29 <bnemec> dims_: In the past we had pushed back on topics like that, but because we got basically all the sessions we wanted this time we didn't bother.
16:26:32 <dims_> harlowja_at_home: hard to get PTL(s) into one meeting as every has a track
16:26:37 <harlowja_at_home> as the big tent gets bigger, it'd be nice to have something like that (IMHO); a oslo-recap
16:26:38 <dims_> bnemec: right
16:26:43 <harlowja_at_home> dims_,  maybe recorded presentation then?
16:26:47 <dims_> "State of Oslo"
16:26:50 <harlowja_at_home> ya
16:26:56 <harlowja_at_home> something like that
16:26:57 <bknudson> https://libertydesignsummit.sched.org/?s=oslo#.VWyHu0RL1Ls -- oslo schedule
16:27:07 <bnemec> I think it would have reduced the conflicts with other relevant sessions if we limited ours a little more.
16:27:25 <bknudson> I'd like to see fewer keystone sessions, too.
16:27:38 <dhellmann> we're not likely to have as many sessions for tokyo, so we'll need to be more careful with topic selection
16:27:47 <dims_> amrith: we have never talked about managing users/auth of underlying infra so far.
16:27:50 <bknudson> Do they really need to schedule the work room sessions? seems like we should just have free time to get together
16:28:09 <dims_> amrith: if we get someone interested its a possibility i guess
16:28:35 <bnemec> Well, we had pods in the past for ad hoc work sessions, but without a scheduled time I never actually went to any. :-/
16:28:43 <harlowja_at_home> it'd be cool if there was a technical (not just a presentation) for state of [oslo, nova, glance, keystone, all of them...] for all the projects, some kind of talk that is recorded so that everyone can know whats been and will be happening for each project
16:28:46 <amrith> dims_, the issue is that in case of projects like trove, the o.m channel is used to talk with guests
16:28:52 * bnemec is a slave to the schedule
16:28:53 <dims_> amrith: zaqar - flaper87 indicated that zaqar may not be a good fit for where oslo.messaging is used right now
16:29:03 <amrith> and having per-tenant authentication would be a good thing.
16:29:11 <dims_> bnemec: ack, we can trim our sessions
16:29:15 <flaper87> o/
16:29:27 <flaper87> so, we're very hesitant to have that driver inside o.m
16:29:28 <sileht> amrith, oslo.messaging is not aware of what is a tenant/user/project/domain/...
16:29:30 <amrith> dims_, I don't understand the issue there; I believe his feeling was that people would think zaqar was a replacement for rabbit and that would be bad.
16:29:37 <amrith> but he's here
16:29:39 <stevemar> harlowja_at_home, they used to do that
16:29:42 <amrith> he can explain it better.
16:29:46 <flaper87> TBH, the suggestion was to give it a try and have it as an external driver
16:30:05 <dims_> amrith: may i request adding a few blueprints on the topics you mentioned in oslo.messaging and see if anyone is interested? (after this meeting)
16:30:16 <harlowja_at_home> stevemar, oh, hmmm, wonder why that stopped
16:30:17 <sileht> amrith, oslo.messaging is rcp abstraction layer zaqar is messaging as service
16:30:21 <dhellmann> harlowja_at_home: in the past we've done those as video presentations recorded by the foundation and published online, I just didn't do one for kilo
16:30:21 <sileht> rcp/rpc
16:30:30 <flaper87> but generally, yeah, I'd like to avoid people thinking Zaqar is a replacement for rabbitmq
16:30:32 <bnemec> Also, ++ to state of oslo fishbowl session
16:30:38 <amrith> My request comes from the place that there are people who see value in running trove over zaqar but having trove get tied to zaqar seems like a bad idea.
16:30:51 <bnemec> Although I think we need liaisons to attend more than ptls, necessarily.
16:30:58 <dims_> bnemec: agree
16:31:00 <harlowja_at_home> bnemec, sure, either or
16:31:05 <flaper87> TBH, to some extent we could say that as long as we document it, we should be fine. But that's kinda never the case
16:31:06 <dhellmann> amrith, dims_, sileht : could we maybe discuss that separately from the summit feedback?
16:31:13 * amrith tries to demultiplex conversations
16:31:22 <amrith> dhellmann, ++
16:31:25 * flaper87 should have read the topic
16:31:26 <dhellmann> amrith: thanks :-)
16:31:30 <flaper87> I'm sorry for that
16:31:43 <bnemec> flaper87: Well, we did ping you. :-)
16:31:53 <harlowja_at_home> what else, hmmm, the food was good :-P
16:31:59 <harlowja_at_home> so +1 to that
16:32:02 <dims_> :)
16:32:23 <bnemec> I request more sessions on terraces with gorgeous views.
16:32:31 <bnemec> And float planes. :-)
16:32:33 <amrith> re: feedback ... the parties didn't run out of beer and wine which is an improvement over Paris.
16:32:40 <harlowja_at_home> def, more sessions on sea/flow planes
16:32:43 <dhellmann> it's good to hear that we noticed the lack of focus/usefulness in some sessions, since this was the first time we've had so many time slots available to us. I think that means we'll be able to be constructive with less time, even if we have to cut some topics.
16:32:57 <harlowja_at_home> *float planes (not flow, ha)
16:33:17 * dhellmann thinks harlowja_at_home  has taskflow on his mind
16:33:23 <harlowja_at_home> haha
16:33:27 <dims_> dhellmann: right and gives us time to attend other project sessions to get to know what they need from us
16:33:28 <bnemec> :-)
16:33:32 <bknudson> I would have liked to attend more oslo sessions but there were other ones keeping me busy
16:33:34 <dhellmann> dims_: ++
16:33:53 <dhellmann> we learn more about how to have good summits every time we do them
16:33:54 <bnemec> Yeah, between oslo and tripleo I could hardly attend any other sessions.
16:34:02 <bnemec> dhellmann: +1
16:34:06 <dims_> duly noted :)
16:34:16 <dims_> k. switching
16:34:19 <dims_> #topic New libraries and drivers - how is it going?
16:34:33 <dims_> anyone here got started on any of the new ones?
16:34:37 <dims_> #link specs - http://specs.openstack.org/openstack/oslo-specs/
16:34:40 <dims_> ozamiatin: ?
16:34:40 <ozamiatin> hi, I'm in progress with a spec
16:35:00 <dims_> ozamiatin: link?
16:35:16 <ozamiatin> not yet uploaded
16:35:21 <dims_> ok
16:35:22 <ozamiatin> I will finish today
16:35:41 <dims_> sounds good, did you get enough feedback from folks at the summit ozamiatin?
16:36:31 <ozamiatin> yes
16:36:49 <ozamiatin> I think we will also discuss in comments to the spec
16:36:57 <dims_> dhellmann: so i have trouble reaching solly
16:37:08 <dims_> dhellmann: for oslo.reports - (https://review.openstack.org/#/c/185715/)
16:37:19 <dims_> anyone work with solly?
16:37:36 <dhellmann> dims_: we should see if some of our other red hat contacts can help us reach him
16:37:43 <dims_> bnemec: ?
16:37:49 <kgiusti> dims_: I do
16:38:05 <bnemec> Yeah, we should be able to get ahold of him.
16:38:14 <dims_> kgiusti: please ping him about oslo.reports. review url above
16:38:17 <dims_> thanks
16:38:19 <bnemec> I know he was keen to get it graduated for Kilo, but ran out of time.
16:38:23 <kgiusti> dims_: will do
16:38:37 <dims_> k switching
16:38:53 <dims_> #topic What do we ask other projects to adopt for liberty on a higher priority?
16:38:56 <harlowja_at_home> oh me me
16:38:57 <harlowja_at_home> https://review.openstack.org/#/c/182808/ (waiting) and https://review.openstack.org/#/c/185077/ (waiting)
16:38:57 <harlowja_at_home> so mainly just waiting, lol
16:38:57 * harlowja_at_home may poke infra to just get those going...
16:39:15 <dims_> so i can find ptls and liaisons and talk to them about it
16:39:18 <dhellmann> dims_: oslo.context and oslo.log standardization should be a priority; I'll be helping with that.
16:39:32 <dims_> oslo-config-generator? oslo.policy? oslo.versionedobjects?
16:39:38 <dims_> dhellmann: nice
16:40:04 <dhellmann> dims_: the config generator is another good one
16:40:23 <bnemec> Yes, especially after what happened in cinder this cycle.
16:40:23 <dhellmann> all of those are good, but policy and vo are newer so maybe we give more time for those
16:40:37 <bnemec> There be dragons in mixing the old config generator with the new libs.
16:40:43 <dims_> dhellmann: bnemec: ack
16:41:05 <jungleboyj> bnemec: Yeah, there are dragons there.
16:41:24 <dims_> k switching
16:41:28 <dims_> #topic Ongoing work & Review priorities
16:41:42 <dims_> any requests for reviews?
16:41:48 <jungleboyj> bnemec: I need to find time to actually code up things for the new config generator.  Don't like that we are mixing old and new.
16:41:49 <dhellmann> jungleboyj: did we resolve the plan, or do we need to make changes to the config generator first?
16:42:34 <jungleboyj> dhellmann: I think I need to come up with a way of using the new config generator that everyone can agree upon.
16:43:03 <dhellmann> jungleboyj: ok, if that means changes to make it more palatable we can discuss those when the time comes
16:43:27 <jungleboyj> Ok.  I hope to get time to poke at that again in the next couple of weeks.
16:43:32 * jungleboyj crosses fingers.
16:43:49 <dims_> kgiusti: we need to work towards proton running dsvm+tempest CI jobs?
16:44:33 <dims_> harlowja_at_home: all your reviews for governance etc made it through?
16:44:38 <harlowja_at_home> also do we need to get the rabbitmq folks in the #oslo channel? be nice to have them there
16:44:39 <kgiusti> dims_: yes - flaper87 and I are working on making the required proton libraries better available via pypi
16:44:40 <harlowja_at_home> dims_, seems so
16:45:09 <harlowja_at_home> *or whoever the rabbitmq (corp) said they would get involved,be nice to get that person ramping up
16:45:09 <kgiusti> dims_: trying to land those changes in proton upstream shortly
16:45:24 <dims_> harlowja_at_home: we have them on twitter at the moment, let's see if we get any actual reviews from them then we can request them to show up on irc
16:45:31 <harlowja_at_home> k
16:45:35 <harlowja_at_home> fair enough
16:46:23 <dims_> harlowja_at_home: we have them on twitter at the moment, so we need you on twitter now :)
16:46:58 <dims_> anyone have really old reviews that needs attention?
16:47:25 <dims_> #topic Open discussion
16:47:48 * harlowja_still_a arg, why do i keep on getting disconnected
16:47:51 <dhellmann> the review dashboard link produces a query with patches older than 5 days without reviews
16:48:15 <dhellmann> https://wiki.openstack.org/wiki/Oslo#Review_Links
16:48:30 <dims_> zzzeek_: how did that nova session with oslo.db go? (you had mentioned that you can try to switch migrations to alembic etc and there was some concerns about the online migration they were proposing)
16:49:07 <zzzeek_> dims_: OK so, i had the session, and got their rationales, and basically they’re just going to do it that way and I’d anticipate that other projects will start doing similar things
16:49:21 <harlowja_still_a> is that good/bad/meh?
16:49:24 <zzzeek_> dims_: that is, they’re abandoning the concept of fixed schema migration files
16:49:33 <dhellmann> only for data migrations, right?
16:49:39 <zzzeek_> dhellmann: no, full schema migrations
16:49:41 <zzzeek_> dhellmann: everything
16:49:51 <dhellmann> where will column additions happen?
16:50:09 <zzzeek_> dhellmann: that is, a tool runs which inspects the current DB, compares it to the model in Python, and applies “expansions” dynmically
16:50:12 <zzzeek_> dhellmann: in the “expand” phase
16:50:22 <dhellmann> ok, I guess I need to find that spec
16:50:31 <zzzeek_> dhellmann: yeah
16:50:36 * harlowja_still_a wonders why we are using things with schema(s) at all, lol
16:50:50 * harlowja_still_a runs away
16:50:54 <dims_> thanks zzzeek_
16:51:08 <dims_> so anyone have an opinion on this one?  https://review.openstack.org/#/c/185504/
16:51:13 <dims_> removing oslo.utils dependency from debtcollector
16:51:19 <harlowja_still_a> ah, yes, that one
16:51:56 <dhellmann> we shouldn't have a circular dependency there, how did we let that happen?
16:52:18 <harlowja_still_a> snuck in i think
16:52:20 <bknudson> oslo.utils needs to have fewer dependencies.
16:52:40 * harlowja_still_a is fine with a new-tiny-library, but i'll let others decide
16:53:16 <bnemec> debtcollector probably needs to be one of those things that doesn't depend on much though.
16:53:25 <bnemec> Since it could be pulled in to any lib at any time
16:53:26 <harlowja_still_a> https://pypi.python.org/pypi/silvering (for example, the process of making mirrors, aka reflection...)
16:53:36 <harlowja_still_a> could just take that and make it the refelction stuff
16:53:40 <dhellmann> yeah, debtcollector should be at the bottom -- why does it need these functions?
16:54:08 <harlowja_still_a> making nice messages about what is deprecated
16:54:13 <harlowja_still_a> thats all
16:54:23 <dhellmann> can we not just ask the developer to provide the details?
16:54:43 <zzzeek_> dhellmann: original online schema cahnges spec at https://review.openstack.org/#/c/102545/
16:55:01 <dhellmann> for example, if we deprecate a public class in an oslo lib that's in a private module but exposed through a public module, we would want to specify the public name for the class rather than have this code give the actual name
16:55:05 <dhellmann> zzzeek_: thanks
16:55:48 <zzzeek_> dhellmann / dims_ : also a wrapup of my thoughts of the discussion are at http://lists.openstack.org/pipermail/openstack-dev/2015-May/064602.html
16:56:08 <harlowja_still_a> dhellmann,  possible to do that, although the current api tries to be nice and helpful and figure out the names
16:56:23 <dims_> zzzeek_: thanks
16:56:50 <dhellmann> harlowja_still_a: yeah, but it seems like the case I describe, which we have in our code, is going to break that anyway, right?
16:57:09 <bknudson> it's just reflection that it uses, so maybe have an oslo_reflection rather than oslo_utils.reflection.
16:57:10 <harlowja_still_a> sounds like a new feature to make it possible to turn off the auto-figuring stuff out
16:57:25 <harlowja_still_a> bknudson,  or i can go claim https://pypi.python.org/pypi/silvering and make that the reflection stuff
16:57:35 <dims_> 3 mins left, let's move discussion to the review please?
16:57:42 <dhellmann> yeah, and I would say we want debtcollector not depend on anything else, if we can help it, as bnemec pointed out
16:57:49 <dhellmann> dims_: ++
16:57:59 <harlowja_still_a> dhellmann,  ok, the review is fine then i think, chops stuff thats used out
16:58:43 <dims_> thanks everyone, let's continue on our irc channel
16:58:48 <dims_> #endmeeting