16:00:00 <dims> #startmeeting oslo
16:00:00 <openstack> Meeting started Mon Jun 22 16:00:00 2015 UTC and is due to finish in 60 minutes.  The chair is dims. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:03 <ozamiatin> o/
16:00:04 <bknudson> what's up?
16:00:05 <rpodolyaka1> o/
16:00:05 <openstack> The meeting name has been set to 'oslo'
16:00:05 <kragniz> o/
16:00:06 <jungleboyj> o/ Kind-of.
16:00:06 <kgiusti> o/
16:00:14 <harlowja_at_home> sup
16:00:30 <jecarey> o/
16:00:41 <amotoki> hi
16:00:50 <dims> hope you all had a good weekend, lets give it another minute
16:00:54 <bnemec> o/
16:01:38 <dims> #topic Red flags for/from liaisons
16:01:53 <bknudson> none for keystone
16:02:36 <dims> thanks bknudson
16:02:40 <kragniz> nothing from glance
16:03:02 <dims> thanks kragniz
16:03:11 <zzzeek> o.
16:03:13 <zzzeek> o/
16:03:15 <dims> bknudson: thanks for kicking the oslo.service tires
16:03:34 <bknudson> dims: seems to work and it removes 1000 loc from keystone
16:03:38 <dims> bknudson: we could use help with oslo.cache tests from some of the keystone folks
16:03:40 <dims> nice
16:03:58 <dims> switching
16:04:01 <dims> #topic Releases for this week
16:04:01 <dims> Do we neeed any releases? Here are the unreleased changes
16:04:01 <dims> #link http://paste.openstack.org/show/313420/
16:04:25 <harlowja_at_home> tooz
16:04:36 <dims> harlowja_at_home: y
16:04:37 <harlowja_at_home> that needs to finally happen i think :)
16:05:22 <harlowja_at_home> i'd like to get out https://review.openstack.org/#/q/status:open+project:openstack/futurist,n,z but i think its being made problematic by devstack integration?
16:05:33 * dhellmann ducks in the back late
16:05:42 <dims> harlowja_at_home: link please?
16:05:49 <harlowja_at_home> http://logs.openstack.org/82/193982/1/check/gate-tempest-dsvm-neutron-src-futurist/6461a55/logs/devstacklog.txt.gz
16:05:56 <harlowja_at_home> http://logs.openstack.org/82/193982/1/check/gate-tempest-dsvm-neutron-src-futurist/6461a55/logs/devstacklog.txt.gz#_2015-06-22_12_38_44_635
16:06:10 <harlowja_at_home> pretty sure thats killing its gate
16:06:29 <harlowja_at_home> i believe but not 100% sure that https://review.openstack.org/#/c/187373/ fixes that ?
16:06:43 <dims> harlowja_at_home: ok, will look after this meeting
16:06:47 <harlowja_at_home> k
16:07:02 <dims> dhellmann: do you plan to cut any libraries?
16:07:22 <dhellmann> dims: I was going to talk to you about turning that over to you this week.
16:07:39 <dhellmann> I'd like to get new versions of our libs with the "Drop use of 'oslo' namespace package" changes
16:07:45 * harlowja_at_home thinks we need a bot for that :-P
16:07:49 <stevemar> dims, i didn't get a chance to look @ the oslo.cache stuff over the weekend, but it's on my radar
16:08:11 <dims> dhellmann: ack, i will ping you later and we can go over which ones
16:08:15 <dhellmann> dims: also oslo.i18n with the change that removes the namespace package
16:08:17 <harlowja_at_home> a 'releasebot' for lack of better terms
16:08:19 <dhellmann> dims: sounds good
16:08:25 <dims> #action: dims to talk to dhellmann about taking over releases this week
16:08:30 <dims> harlowja_at_home: ++
16:08:33 <dims> stevemar: thanks
16:08:45 <dims> #topic New libraries and drivers - how is it going?
16:08:45 <dhellmann> harlowja_at_home: https://review.openstack.org/#/c/191193/
16:08:45 <dims> #link specs - http://specs.openstack.org/openstack/oslo-specs/
16:09:00 <ozamiatin> I need someone to look at this https://review.openstack.org/#/c/193502/
16:09:13 <dims> we've boot strapped various teams like oslo.service, oslo.cache, oslo.reports
16:09:22 <harlowja_at_home> new libraries going good, except for above current issue (with devstack?)
16:09:29 <harlowja_at_home> *from my side*
16:09:31 <dims> do we need more eyes on futurist and automaton?
16:10:00 <harlowja_at_home> sure, more eyes always welcome :-P
16:10:03 <dims> i talked to a few folks like dansmith as well if he needed addditional help
16:10:16 <dims> harlowja_at_home: need to find folks interested?
16:10:53 <harlowja_at_home> dims, possibly, i can poke an ironic guy to see if he wants to be in futurist-core, they are planning on using it there
16:11:01 <dims> harlowja_at_home: ++
16:11:09 <harlowja_at_home> via https://review.openstack.org/#/c/134303/
16:11:15 <dims> any other new library/driver issues?
16:11:34 <harlowja_at_home> * that spec and the bigger one @ https://review.openstack.org/#/c/191710/
16:12:12 <dims> harlowja_at_home: k starred both
16:12:27 <dims> #topic Ongoing work & Review priorities
16:12:28 <dims> #link https://etherpad.openstack.org/p/liberty-oslo-priorities-tracking
16:12:36 <harlowja_at_home> dims, cool, 134303 i  think is old, probably not relevant anymore ( 191710 is new hotness)
16:12:50 <dims> harlowja_at_home: ack
16:13:12 <dims> flaper87: sileht: ozamiatin: how's oslo.messaging?
16:13:29 <ozamiatin> dims, https://review.openstack.org/#/c/193502/
16:13:56 <dims> ozamiatin: yay
16:14:03 <ozamiatin> dims, spec is in progress https://review.openstack.org/#/c/187338/
16:14:27 <dims> ozamiatin: did the email threads die down?
16:14:38 <dims> and spec updated to reflect that discussion?
16:15:04 <ozamiatin> dims, not yet updated
16:15:16 <kgiusti> flaper87 and I are working on getting py3 support for amqp1.0 - proton upstream py3 just landed on master
16:15:18 <dims> ozamiatin: k please do that and ping us back
16:15:25 <ozamiatin> dims, ok
16:15:42 <dims> #action ozamiatin to update oslo.messaging spec and ask for approval
16:16:23 <dims> kgiusti: nice, did you create a the devstack plugin for testing?
16:16:49 <dims> like the one sdague did for zmq
16:17:04 <kgiusti> I've started one, yes: https://github.com/kgiusti/amqp1-devstack
16:17:13 <dims> kgiusti: ack.
16:17:14 <kgiusti> totally not working... yet
16:17:27 <dims> dhellmann: any thoughts on where we could host these plugins?
16:17:44 <dims> apparently it's repo per plugin at the moment
16:17:50 <dhellmann> dims: would it make sense to put them in the oslo.messaging repository?
16:17:52 <dhellmann> oh, ugh
16:18:02 <dims> i have to verify that with sdague
16:18:17 <dhellmann> if that's true, we'll need new repos, I guess
16:18:27 <dhellmann> otherwise it would be good to be able to put them in the messaging repo
16:18:56 <dims> #action dims to figure out repos for oslo.messaging driver devstack plugins
16:19:06 * ihrachyshka lurks...
16:19:18 <dims> zzzeek: rpodolyaka1: oslo.db doing ok?
16:19:41 <harlowja_at_home> should we also consider to have a common repo for 'setup-test-env-*.sh' files?
16:19:51 <harlowja_at_home> now that oslo.messaging has a few, tooz has some to
16:19:54 * harlowja_at_home just a thought
16:20:11 <dims> give yourself an action harlowja_at_home? :)
16:20:16 <harlowja_at_home> :-P
16:20:21 <harlowja_at_home> durn it, ha
16:20:22 <harlowja_at_home> ha
16:20:34 <harlowja_at_home> #action harlowja_at_home consider to have a common repo for 'setup-test-env-*.sh' files?
16:20:35 <bknudson> related to oslo.db -- the update to sqlalchemy version is breaking keystone -- https://review.openstack.org/#/c/190405/
16:20:59 <bknudson> the workaround is easy -- https://review.openstack.org/#/c/193741/
16:21:11 <dhellmann> harlowja_at_home: what are those files?
16:21:15 <bknudson> not sure if anyone else saw issues with it
16:21:20 <harlowja_at_home> dhellmann, top level of the repo
16:21:27 <rpodolyaka1> dims: from what I know, yes :) we could cut a new release of oslo.db this week
16:21:31 <dims> bknudson: so we need to cut a oslo.db with that
16:21:33 <harlowja_at_home> look for https://github.com/openstack/tooz (setup-.sh)
16:21:46 <zzzeek> dims: we r cool
16:21:49 <harlowja_at_home> in https://github.com/openstack/oslo.messaging (setup-test*.sh)
16:21:50 <bknudson> dims: the fix is in keystone
16:21:58 * zzzeek has a baby issue on this end, brb
16:22:09 <dims> #action dims to coordinate a oslo.db release
16:22:11 * harlowja_at_home the baby issue isn't me
16:22:13 <dims> bknudson: ok
16:22:20 <dhellmann> harlowja_at_home: hmm, ok. keeping those close to the source they're testing feels right, but maybe not the root directory
16:22:47 <harlowja_at_home> dhellmann, possibly, maybe premature (but i could see other projects wanting those same kind of setup*.sh files)
16:22:56 <dhellmann> harlowja_at_home: true
16:23:32 <dims> #action rpodolyaka1 to let dims know when a release can be cut from oslo.db HEAD
16:23:38 <dims> rpodolyaka1: ^^ :)
16:23:43 <rpodolyaka1> dims: ok
16:23:47 <dims> thanks
16:23:50 <rpodolyaka1> np
16:24:02 <dims> ok switching to open
16:24:03 <dims> #topic Open discussion
16:24:13 <dims> Any stuck reviews? or specs?
16:24:14 <epico> https://review.openstack.org/#/c/121459/
16:24:19 <harlowja_at_home> so i had some moose names,but i forgot them, lol
16:24:24 <harlowja_at_home> i swear! :)
16:24:27 <dims> harlowja_at_home: haha
16:24:52 <epico> what is the next step for the spec?
16:25:24 <harlowja_at_home> maybe we should just call it bullwinkle
16:25:25 <dhellmann> #info the next oslo.i18n release will remove the oslo namespace package
16:25:36 <harlowja_at_home> bullwinkle ftw :-P
16:25:39 <dims> harlowja_at_home: ++
16:25:50 <harlowja_at_home> https://en.wikipedia.org/wiki/Bullwinkle_J._Moose (for those who have no idea what that means)
16:26:00 <johnsom> Marty Moose
16:26:02 <bknudson> how many famous meese are there?
16:26:09 <epico> it is a spec for oslo.i18n.
16:26:26 <harlowja_at_home> lol @ https://en.wikipedia.org/wiki/Bullwinkle_J._Moose#Powers_and_abilities
16:26:47 <dhellmann> sileht, dims: it would be good if we could merge https://review.openstack.org/193340 quickly
16:26:49 <kgiusti> bullwinkle - one of my favorite actors
16:27:29 <jecarey> epico, I think the key question is if we should specify to pick up the plurals in each tox.ini or in the tool
16:27:31 <dims> dhellmann: ack
16:27:50 <dims> i believe sileht may be on vacation
16:28:05 <dims> ozamiatin: can you please look?
16:28:11 <ozamiatin> dims, ok
16:28:26 <harlowja_at_home> people and there vacations, jeez
16:28:30 <harlowja_at_home> no vacation allowed
16:28:34 <epico> jecarey, I think in the tool is easier, or we will change many tox.ini files.
16:28:37 <dhellmann> dims: ok, anyone could approve that, it's just a namespace package change to unblock some more releases
16:28:57 <dims> dhellmann: y already +2
16:29:03 <dhellmann> dims: ack, see that now
16:29:19 <epico> jecarey, but I am okay with both approach.
16:29:52 <jecarey> epico, my opinion is to do it in the tool ... but asked you to bring here to get opinion from dims, dhellmann
16:30:09 <epico> jecarey, thanks, I see.
16:30:14 <epico> dims, dhellmann, hi
16:30:26 <epico> could you please review it?
16:30:28 <dims> epico: starred it
16:30:32 <epico> https://review.openstack.org/#/c/121459/
16:30:34 <dims> will review after the meeting
16:30:43 <epico> okay
16:31:00 <dhellmann> epico: added to my queue
16:31:11 <epico> thanks! :)
16:31:43 <dims> anything else anyone?
16:31:55 <dims> i can give you back 30 mins :)
16:32:02 <dhellmann> epico: I feel like I asked once before, do we need versions of the new functions for different log levels?
16:32:12 <dhellmann> or are you assuming they will just be used for errors?
16:32:36 <ozamiatin> dims, dhellmann, may I approve this https://review.openstack.org/193340?
16:32:38 <johnsom> Thank you guys for the patchsets in our repos!
16:33:07 <dhellmann> ozamiatin: yes, it should be safe. It removes the *use* of namespace packages in other libs, but doesn't remove the namespace package from the messaging library
16:33:16 <dims> ozamiatin: yes
16:33:20 <ozamiatin> dims, dhellmann, my first approval :)
16:33:25 <dims> johnsom: yay
16:33:28 * dhellmann applauds ozamiatin
16:33:29 <dims> ozamiatin: congrats! :)
16:33:39 <dims> welcome to all the new cores btw :)
16:33:45 <epico> dhellmann, I think it is used for UI strings now, not introduced any new functions for log levels.
16:33:46 <ozamiatin> dims, dhellmann, thanks :)
16:33:50 * dhellmann is happy to see the team growing
16:33:57 <dhellmann> epico: ok, that makes sense
16:34:01 <epico> if needed, I can add new functions for logs.
16:34:03 <harlowja_at_home> moreeee cores!
16:34:15 <dhellmann> epico: let's wait and see; it's easier to add them later than to remove them
16:34:16 <harlowja_at_home> *and welcome*
16:34:39 <epico> dhellmann, sure
16:34:46 <dims> thanks everyone
16:34:49 <dims> #endmeeting