16:00:44 <dims_> #startmeeting oslo
16:00:44 <dims_> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dougwig, e0ne, flaper87, garyk, harlowja, haypo,
16:00:44 <dims_> courtesy ping for ihrachyshka, jd__, jecarey, jogo, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka,
16:00:44 <openstack> Meeting started Mon Jul 13 16:00:44 2015 UTC and is due to finish in 60 minutes.  The chair is dims_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:46 <dims_> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:48 <ihrachyshka> o/
16:00:49 <openstack> The meeting name has been set to 'oslo'
16:00:49 <zzzeek> o/
16:00:50 <bknudson> hi
16:00:52 <dhellmann> o/
16:00:55 <harlowja_at_home> sup
16:00:58 <droyal> hi
16:01:41 <kzaitsev_mb> 0/
16:01:46 <stevemar> dims_: o/
16:01:51 <ozamiatin> o/
16:02:33 <dims_> so, we have almost recovered from mock 1.1.0 release issues.
16:02:36 <dims_> #topic Red flags for/from liaisons
16:02:47 <bknudson> none for keystone that I can think of
16:03:12 <kragniz> o/
16:03:13 <jecarey> o/
16:03:21 <dims_> thanks bknudson
16:03:37 <dims_> any other liaisons around?
16:03:39 <ihrachyshka> none for neutron, pymysql unstable job is either killed or to be killed since known issues were fixed
16:03:55 <dims_> ihrachyshka: cool
16:04:16 <e0ne> hi
16:04:21 <dims_> hi e0ne
16:04:32 <jungleboyj> o/
16:04:46 <dims_> jungleboyj: e0ne: any red flags from last week?
16:05:05 <dims_> switching topics otherwise
16:05:09 <dims_> #topic py26 support and jobs
16:05:09 <dims_> #link http://markmail.org/message/eqcc7akocomipvrx
16:05:09 <e0ne> dims_: not from me. may be jungleboyj has something
16:05:20 <jungleboyj> dims_: I don't think so.  I need to tackle looking at the genconfig stuff.
16:05:27 <jungleboyj> Have that on the list for the next day or so.
16:05:27 <dims_> thanks jungleboyj e0ne
16:05:33 <jungleboyj> Carry on.
16:05:36 <jungleboyj> ;-)
16:05:50 <dims_> dhellmann: lifeless: are we going to nuke support right away?
16:05:53 <harlowja_at_home> so for futurist https://review.openstack.org/#/c/200313/ (py26 gone)
16:06:02 <harlowja_at_home> ^ just merged
16:06:11 <dims_> ref link about has an email thread from lifeless
16:06:19 <dhellmann> dims_: I may be behind on that thread, but I don't think we've established if that's safe.
16:06:48 <stevemar> jungleboyj: genconfig for cinder?
16:06:50 <dims_> dhellmann: what would be our concerns that we can take to the thread
16:06:54 <harlowja_at_home> what libraries are still supporting it? oslo.utils, oslo.serialization oslo.config?
16:07:13 <jungleboyj> stevemar: Yeah, getting the config generator to work properly.  We are still back on the old one.
16:07:15 <zzzeek> ihrachyshka: what links can I look at to learn about the specific resolutions for neutron + pymysql ?
16:07:22 <ihrachyshka> dhellmann, assuming we capped everything, we should be safe.
16:07:23 <jungleboyj> It aint working right.
16:07:24 <dhellmann> dims_: we have some oslo libs used in client libs, and so we really need to decide if it's safe to drop 2.6 support for the client libs in master
16:07:41 <dims_> so python-* will need to rip off 26 support first
16:07:48 <bknudson> keystoneclient still has a py26 job
16:07:50 <dims_> then we would be next
16:07:55 <bknudson> and it uses oslo libs
16:07:59 <dhellmann> and the answer to that depends on whether we expect people to be installing via pip, and if so how to ensure they know the latest version is not supported on 2.6 (major version bump)
16:07:59 <kzaitsev_mb> do we also disable py26 for clients? Last time I brought up this question in murano (we still test client in murano against 2.6) I was told, that clients are a special case, cause we want them to work on as diverse environments as possible
16:08:23 <dims_> kzaitsev_mb: y, that's the question in the email thread
16:08:25 <dhellmann> kzaitsev_mb: right, though that was before we had stable branches for the clients
16:08:38 <dhellmann> so the question is, are stable branch versions of the clients good enough for folks on 2.6?
16:09:15 <dims_> dhellmann: problem was that not all python clients have versions already cut from their stable branches that we can tell people to use
16:09:28 <dims_> if i remember right
16:09:45 <ihrachyshka> zzzeek, I think mostly it's https://review.openstack.org/#/c/191540/ , maybe armax@ or kevinbenton will be able to provide more links to patches for pymysql + neutron
16:09:56 <dhellmann> dims_: ok, that's solvable
16:10:48 <dims_> so, step 1) make releases from stable branches, 2) yank py26 jobs from python-* then 3) yank py26 jobs from oslo-*
16:10:56 <stevemar> jungleboyj: shouldn't be that bad!
16:10:57 <dims_> from what i can tell
16:11:17 <bknudson> new releases on stable/kilo?
16:11:23 <dims_> finally cleanup tox.inis
16:11:34 <dims_> bknudson: y
16:11:56 <bknudson> that would require a lot of backporting... not sure how much it would be for keystoneclient
16:12:01 <dims_> right
16:12:04 <dims_> that's the problem
16:12:16 <bknudson> maybe a new branch would be better
16:12:22 <dims_> we are far away from stable/liberty :)
16:12:38 <ihrachyshka> bknudson, stable/kilo is for backporting, what's the deal? I don't get
16:12:39 <bknudson> stable/26-eol
16:12:40 <dhellmann> dims_: we could remove all of the jobs at the same time, but yeah
16:13:12 <dhellmann> bknudson: stable branch names have to match, otherwise the code is tested against master
16:13:32 <dims_> k, let's chime in on the thread since this is a larger openstack discussion
16:13:45 <dims_> #topic Releases for this week
16:13:45 <dims_> Releases for this week. Here are the unreleased changes
16:13:45 <dims_> #link https://etherpad.openstack.org/p/library-releases
16:14:04 <dims_> dhellmann: once that oslo.log review lands, can i make releases for the week?
16:14:42 <dims_> harlowja_at_home: please help vet the version numbers since i gave a huge bump last week to a couple of libs :)
16:14:52 <harlowja_at_home> dims_,  ;)
16:15:17 <dhellmann> dims_: if the tests are passing, I think so
16:15:18 <harlowja_at_home> hehe, yes that :-P
16:15:23 <dims_> all, please look through those changes just in case there's something controversial
16:15:49 <harlowja_at_home> dims_,  for futurist, a couple reviews are merging (that had depends-on removal of 26) so i guess wait till those are in
16:16:16 <dims_> fyi, i am running unit tests with a handful of projects against oslo-* master here - https://travis-ci.org/dims/
16:16:49 <dims_> harlowja_at_home: k please ping me when they are in. i'll mark the ether pad saying i should wait for you
16:17:03 <harlowja_at_home> dims_, np, i marked etherpad
16:17:46 <dims_> harlowja_at_home: thanks, i added a warning on the top as well
16:17:50 <harlowja_at_home> kk
16:17:52 <harlowja_at_home> cool beans
16:18:01 <dims_> switching topics
16:18:04 <dims_> #topic New libraries and drivers - how is it going?
16:18:04 <dims_> #link specs - http://specs.openstack.org/openstack/oslo-specs/
16:18:04 <dims_> #link library audit - https://docs.google.com/spreadsheets/d/1eTR-pN2GD5cK_tHIMyKNL5vh4N8JtXTptcE1bLd2G3E/edit#gid=0
16:18:14 <ozamiatin> dims_: me and victors are working on zmq functional gate fixing in new driver
16:18:25 <ozamiatin> dims_: droyal works on unit tests
16:18:34 <dims_> ozamiatin: nice! thanks for coordinating the work
16:18:38 <ozamiatin> dims_: so, I'd like to thank them both for joining zmq driver development
16:18:47 <ozamiatin> droyal, victors: ^^ thanks guys
16:18:55 <droyal> happy to help
16:18:58 * harlowja_at_home closed launchpad stuff for futurist & automaton so should be good to go for those
16:19:07 <dims_> thanks droyal and victors
16:19:40 <dims_> ozamiatin: has the email thread died down about the architecture?
16:20:01 <ozamiatin> dims_: yeah I think so
16:20:08 <dims_> thanks
16:20:15 <Alec> there are a few email threads regarding the use of fanout in oslo messaging
16:20:16 <dims_> anyone from oslo.service/cache/reports?
16:20:37 <dims_> Alec: ack
16:20:46 <Alec> and one suggesting we put some work in fixing teh API documentation
16:21:10 <Alec> what is the best way to move forward there?
16:21:27 <dims_> Alec: ozamiatin: turn them into launchpad bugs so we don't forget?
16:21:48 <ozamiatin> dims_, Alec: ok
16:22:11 <dims_> bknudson: stevemar oslo.cache doing ok? i saw the new dict backend for nova go in
16:22:13 <Alec> ok i can help write down the issues that need to be fixed, just need to get started smewhere
16:22:35 <dims_> sounds good Alec
16:22:36 <bknudson> dims_: I've got a couple of changes proposed to oslo.cache that affect the public API
16:22:49 <stevemar> dims_: yeah, just a few minor change left
16:23:02 <dims_> bknudson: i added a dsvm job per dhellmann's suggestion
16:23:03 <stevemar> bknudson: oh did you want to talk about that region parameter?
16:23:08 <bknudson> dims_: and then I think it's ready to go... probably needs review of the docs if they're adequate
16:23:45 <dims_> bknudson: ack, i'll ask a few people to review docs
16:24:03 <dims_> #action Dims to request a few folks to go through oslo.cache docs
16:24:22 <bknudson> stevemar: I posted a review for dealing with the wacky region global -- https://review.openstack.org/#/c/199793/
16:24:39 <stevemar> bknudson: yeah, looking at it no
16:24:40 <stevemar> w
16:24:46 <stevemar> bknudson: it was in reply to: https://review.openstack.org/#/c/195873/14/keystone/backends.py right?
16:25:13 <dims_> harlowja_at_home: futurist and automaton picking up consumers?
16:25:13 <bknudson> stevemar: yes, that answers my comment in https://review.openstack.org/#/c/195873/14/keystone/backends.py
16:25:44 <stevemar> bknudson: otay
16:25:55 <dims_> switching topics
16:25:55 <harlowja_at_home> dims_, taskflow +automaton (removing old code) sputnik13 is working on, otherwise yup, so far so good
16:26:00 <dims_> cool
16:26:05 <dims_> #topic Ongoing work & Review priorities
16:26:05 <dims_> #link https://etherpad.openstack.org/p/liberty-oslo-priorities-tracking
16:26:30 <dims_> Any stuck reviews? or specs?
16:26:50 <harlowja_at_home> oh i think https://review.openstack.org/#/c/196338/ would be nice for folks
16:27:00 <harlowja_at_home> if anyone wants to look at ^
16:27:00 <dims_> i am periodically reviewing really old reviews
16:27:33 <stevemar> bknudson: dammit, now i have to change all my get_memoization_decorator calls :P
16:27:38 <dims_> starred it josh. will do
16:28:11 <dims_> k opening up the floow
16:28:12 <dims_> #topic Open discussion
16:28:20 <dims_> Anyone coming to keystone or nova mid-cycle?
16:28:27 <stevemar> me!
16:28:28 <dims_> i have moose stickers!
16:28:46 <morganfainberg> keystone needs a mascot :(
16:28:46 <stevemar> i'll take one of your meese stickers
16:28:50 <jungleboyj> :-)  Moose Stickers!
16:28:58 <dims_> printed a fresh set thanks to dhellmann's referral to moo.com
16:29:04 <jungleboyj> I will add it with the Cinder stickers on my office door.
16:29:23 <droyal> me an a few people from work will be at OSCON next week, if any of you will be there, and it's convenient, I'd like to meet face-to-face just to say hi
16:30:15 <dims_> we should have a party@openstack.org (apache.org has one!) for coordinating such stuff :)
16:30:25 <zzzeek> ihrachyshka: thanks
16:31:20 <stevemar> dims_: bknudson the oslo.cache patches are approved
16:31:34 <stevemar> think we're good for 0.2.0 ?
16:31:47 <dims_> stevemar: k will wait for those to land
16:32:17 <harlowja_at_home> jecarey, if u interested https://review.openstack.org/#/c/197668/ (not sure where this will end-up, ha)
16:32:39 <stevemar> dims_: oh we already had a 0.2.0!
16:32:40 <jecarey> harlowja_at_home, I'll take a look
16:33:23 <dims_> stevemar: added a note to wait to cut 0.3.0 - https://etherpad.openstack.org/p/library-releases
16:33:56 <dims_> i should probably ask people to add their vote there too :)
16:34:48 <dims_> typically i start a bunch of tests sat/sun and update that etherpad with new versions and SHA on mon morning
16:35:04 <harlowja_at_home> jecarey, coool, my comments on https://review.openstack.org/#/c/197668/7/nova/states.py i think still apply, but guess nikola not loooking at them right now, lol
16:35:31 <dims_> that's all i had. thanks everyone. we can continue on #openstack-oslo
16:35:33 <dims_> #endmeeting