16:00:15 <dhellmann> #startmeeting oslo
16:00:15 <dhellmann> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dougwig, e0ne, flaper87, garyk, harlowja, haypo,
16:00:15 <dhellmann> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka,
16:00:15 <dhellmann> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:00:17 <openstack> Meeting started Mon Jul 20 16:00:15 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:20 <openstack> The meeting name has been set to 'oslo'
16:00:21 <bknudson> hi
16:00:23 <ozamiatin> o/
16:00:23 <sileht> o/
16:00:24 <harlowja_at_home> yo yo
16:00:24 <jungleboyj> o/
16:00:26 <stevemar> o/
16:00:27 <e0ne> hi
16:00:30 <bnemec> o/
16:00:34 <kgiusti> o/
16:00:34 <jungleboyj> Happy Monday!
16:00:35 <kragniz> o/
16:00:37 <dhellmann> dims is traveling, so he asked for a substitute chair today
16:00:46 <jd__> o/
16:00:49 <rpodolyaka1> o/
16:00:53 <bknudson> dims is on his way
16:00:58 <dhellmann> ah, good
16:01:09 <dhellmann> #topic actions from last week
16:01:18 <johnsom> o/
16:01:20 <dhellmann> #action dims to request a few folks to go through oslo.cache docs
16:01:26 <kzaitsev_mb> o/
16:01:42 <dhellmann> I didn't see any open reviews, so I assume there's still work to be done there. Does anyone know different?
16:01:49 <harlowja_at_home> not sure
16:02:00 <jecarey> o/
16:02:03 * harlowja_at_home hasn't heard anything either on that one
16:02:04 <bknudson> I think we could still use someone to go through the docs.
16:02:31 <stevemar> bknudson had a few patches to update docs, but i think they are merged?
16:02:47 <toabctl> hi
16:02:56 <zzzeek> o/
16:03:00 <bknudson> I could probably make some more doc fixes, but maybe it's time for someone else to look.
16:03:03 <dhellmann> docs are on my todo list, and I should have more time now that the namespace package work is done
16:03:15 <harlowja_at_home> * http://docs.openstack.org/developer/oslo.cache/
16:03:18 <dhellmann> maybe we could schedule a sprint day
16:03:24 <dhellmann> to look at docs for all the libs
16:03:26 <harlowja_at_home> def
16:03:27 <harlowja_at_home> +2
16:03:33 <harlowja_at_home> http://docs.openstack.org/developer/oslo.cache/usage.html (needs some work, ha)
16:03:43 <dhellmann> does someone want to volunteer to organize that?
16:03:43 <bknudson> let's do it at the oslo midcycle meetup
16:03:55 <dhellmann> bknudson: are we having one?
16:04:01 <harlowja_at_home> oslo midcycle meetup? :-/
16:04:04 * dhellmann must have missed the memo
16:04:08 <bknudson> I don't know... everyone else is doing it
16:04:08 * harlowja_at_home too
16:04:12 <dhellmann> ah
16:04:18 <dhellmann> yeah, docs would be a good focus
16:04:35 <dhellmann> I'm not sure we have time to put something like that together for in person, though, so I was thinking a virtual sprint
16:05:01 <harlowja_at_home> +1 from me
16:05:19 <harlowja_at_home> i can help get something together, i've done a crap-load of docs, lol
16:05:27 <dhellmann> cool, thanks harlowja_at_home
16:05:35 <harlowja_at_home> sure
16:05:46 <dhellmann> #action harlowja_at_home to talk to dims about organizing a virtual sprint on documentation for the libraries
16:05:56 <harlowja_at_home> sounds good to me
16:06:23 <dhellmann> it would be good to flesh out some of the newer libs and standardize the way they are organized a bit
16:06:27 <dhellmann> ok, let's keep going
16:06:32 <dhellmann> #topic Red flags for/from liaisons
16:06:51 <bknudson> all green flags in keystone as far as I can tell
16:06:56 <dhellmann> we have the remaining 3 libraries dropping the namespace package to be released this week, as described in
16:06:57 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/070018.html
16:07:11 <dhellmann> watch for errors importing from "oslo" or mock.patch reporting "no such attribute"
16:07:26 <johnsom> I have been traveling, so nothing to report on LBaaS/Octavia front
16:07:51 <jungleboyj> No red flags from Cinder that I am aware of.
16:07:54 <dhellmann> no news is good news, during this section of the meeting :-)
16:08:00 <harlowja_at_home> :)
16:08:11 <jungleboyj> Been fun keeping up with the namespace changes on our internal repository.  :-)
16:08:23 <e0ne> jungleboyj: :)
16:08:27 <dhellmann> jungleboyj: that should all be done by the end of the week
16:08:34 * dhellmann is more relieved than anyone else
16:08:37 <jungleboyj> Hoooray!
16:09:07 <e0ne> jungleboyj: feel free to ask me if you need any help with oslo:)
16:09:14 <dhellmann> if there are no other issues, we'll keep going
16:09:20 <jungleboyj> e0ne: Will do.
16:09:27 <e0ne> thanks:)
16:09:29 <dhellmann> #topic Releases for this week
16:09:38 * harlowja_at_home noticed dims put up https://review.openstack.org/#/c/203686/
16:09:46 <dhellmann> dims has put together a list of the unreleased changes in
16:09:46 <dhellmann> #link https://etherpad.openstack.org/p/library-releases
16:10:03 <dhellmann> and the request for the releases in the patch harlowja_at_home just linked
16:10:16 <dhellmann> the releases planned are:
16:10:17 <dhellmann> #info oslo.messaging 10bc624 2.0.0
16:10:18 <dhellmann> #info oslo.config 1dad55f 2.0.0
16:10:18 <dhellmann> #info oslo.utils 8a25ca4 2.0.0
16:10:18 <dhellmann> #info oslo.reports 34f0982 0.3.0
16:10:18 <dhellmann> #info oslo.versionedobjects c6e6a55 0.6.0
16:10:19 <dhellmann> #info taskflow 03702c7 1.16.0
16:10:20 * harlowja_at_home just commented on that, one naming issue afaik
16:10:20 <dhellmann> #info tooz ae18004 1.19.0
16:11:05 <dhellmann> harlowja_at_home: good eye, thanks
16:11:13 <harlowja_at_home> dhellmann, this will be the new way releases are done right?
16:11:19 <harlowja_at_home> (for projects also?)
16:11:24 <dhellmann> yes, that's right
16:11:25 <harlowja_at_home> k
16:11:43 <dhellmann> it's semi-automated right now, and we'll be working on making it more automated over time
16:11:54 <bknudson> that's fancy
16:12:03 <dhellmann> for next week, expect a bunch more releases as we clear out all of the requirements updates
16:12:30 <dhellmann> this week we're trying to minimize things since we have 3 major version bumps
16:12:36 <dhellmann> questions?
16:12:46 <harlowja_at_home> seems ok to me
16:14:02 <dhellmann> let's keep going then
16:14:03 <dhellmann> #topic New libraries and drivers - how is it going?
16:14:13 <dhellmann> #link specs - http://specs.openstack.org/openstack/oslo-specs/
16:14:13 <dhellmann> #link library audit - https://docs.google.com/spreadsheets/d/1eTR-pN2GD5cK_tHIMyKNL5vh4N8JtXTptcE1bLd2G3E/edit#gid=0
16:14:16 <ozamiatin> dhellmann: I need some help with this https://review.openstack.org/#/c/202095/ in order to switch zmq-gate check on (non-voting for now)
16:15:37 <dhellmann> ozamiatin: ok, it looks like you replied to comments from the infra team there
16:15:37 <kgiusti> dhellmann: both I and flaper87 just returned from vacation - no change from last week
16:16:10 <dhellmann> kgiusti: ack
16:16:23 <harlowja_at_home> anyone know the best way to get 'bandit target in tox.ini' ?
16:16:32 <harlowja_at_home> ^ hopefully pretty simple ?
16:17:07 <dhellmann> that's a new one, I'm not sure what that is. Is that the security audit tool?
16:17:13 <bknudson> harlowja_at_home: you can see what we've done in keystone - http://git.openstack.org/cgit/openstack/keystone/tree/tox.ini#n95
16:17:18 <harlowja_at_home> k
16:17:27 <bknudson> bandit is for static security scanning
16:17:55 <harlowja_at_home> cool, thx bknudson looks relatively straight-forward
16:17:56 <bknudson> there might be a wiki page for it, too...
16:18:08 <harlowja_at_home> https://github.com/openstack/bandit#bandit i guess
16:18:27 <bknudson> #link https://wiki.openstack.org/wiki/Security/Projects/Bandit
16:18:33 <dhellmann> nice, so that should be a straightforward set of the same patch to all repos
16:18:42 <harlowja_at_home> ya
16:19:02 <bknudson> you'll need a bandit.yaml for each of the projects to define what tests to run
16:19:10 <bknudson> (kind of like hacking has its list of checks)
16:19:41 <dhellmann> I'll look at some of the other administrative stuff like readme files and launchpad milestones
16:20:05 * harlowja_at_home wonders if there could be a periodic bandit scan of repos and just post there results somewhere (vs manually setting it up)
16:20:30 <harlowja_at_home> *yahoo has some internal too (code ferrit i think is what its called) that does something similar (also security checks)
16:20:38 <bknudson> I don't want security bugs getting in to begin with.
16:20:42 <dhellmann> well, I assume the idea is to treat it like pep8/hacking and block bad changes in the first place
16:20:48 <harlowja_at_home> *code ferret
16:21:00 <harlowja_at_home> bknudson,  sure
16:21:45 <dhellmann> what else are folks working on? is https://etherpad.openstack.org/p/liberty-oslo-priorities-tracking up to date?
16:22:10 <harlowja_at_home> somewhat up to date, probably could use some changes
16:22:13 <bknudson> is oslo.service done?
16:22:20 <bknudson> we switched to it in keystone already.
16:22:47 <bknudson> it doesn't have a 1.0 release yet
16:23:12 <dhellmann> I would expect that a bit closer to the end of the cycle, but I don't see many open patches up right now
16:23:34 <harlowja_at_home> hmmm eezhova might know (although in #openstack-oslo)
16:23:35 <dhellmann> Does anyone know Elena's IRC nick?
16:23:45 <dhellmann> thanks, harlowja_at_home
16:24:25 <harlowja_at_home> np, seems not there
16:24:36 <dhellmann> ok, I'll let dims follow up with her
16:24:39 <harlowja_at_home> *not around
16:25:46 <dhellmann> it looks like each of the new libs has one or two reviews up right now, so maybe we can clear those this week and be in a good state before the L2 milestone next week
16:26:17 * harlowja_at_home found her
16:26:17 <dhellmann> speaking of L2...
16:26:24 <dhellmann> ah, good
16:26:51 <harlowja_at_home> eezhova, oh hi!
16:26:53 <dhellmann> hi, eezhova
16:27:01 <eezhova> hello!
16:27:04 <harlowja_at_home> :)
16:27:10 <dhellmann> we were just checking the status of the new libs, trying to make sure we knew if there were reviews to prioritize
16:27:27 <dhellmann> do you have anything critical to do that is blocking a 1.0 release?
16:27:50 <eezhova> dhellmann, no, there is nothing I know of
16:28:06 <dhellmann> ok, good, so we can talk with dims about a 1.0 release for next week then
16:28:13 <harlowja_at_home> the code is perfect, end of story :)
16:28:36 <eezhova> harlowja_at_home, too good to be true :)
16:28:40 <harlowja_at_home> :)
16:29:03 <dhellmann> heh
16:29:17 <dhellmann> so, back to L2...
16:29:20 <dhellmann> #topic Ongoing work & Review priorities
16:29:20 <dhellmann> #link https://etherpad.openstack.org/p/liberty-oslo-priorities-tracking
16:29:20 <dhellmann> Any stuck reviews? or specs?
16:29:40 <harlowja_at_home> although i still do wonder about https://github.com/openstack/oslo.service/blob/master/oslo_service/loopingcall.py#L158 (and the questions people will ask about using that vs using the retrying lib)
16:29:40 <dhellmann> there's nothing listed on the dashboard there
16:31:33 <dhellmann> yes, although it looks like we might not get the logging that the home-grown version gives us
16:32:24 <dhellmann> if no one has reviews to highlight, we can move on
16:32:26 <harlowja_at_home> dhellmann, yes, or some of the dynamic retry delay
16:32:33 <dhellmann> yeah
16:33:22 * harlowja_at_home but i predict a little confusion there by folks, but guess thats acceptable for now
16:34:30 * harlowja_at_home is fine with moving on
16:34:33 <harlowja_at_home> :-P
16:34:48 <dhellmann> ok, then
16:34:53 <dhellmann> #topic open discussion
16:34:58 <dhellmann> does anyone have anything else to raise this week?
16:35:13 <harlowja_at_home> soooo big tent + oslo representatives
16:35:25 <dhellmann> ?
16:35:27 <harlowja_at_home> how do we try to get better attendance/reprsentatiion/involvement
16:35:45 <harlowja_at_home> (always feels like we don't quite have super-great representation)
16:35:58 <harlowja_at_home> is there anything we can do there?
16:35:59 <dhellmann> at this meeting?
16:36:03 <harlowja_at_home> ya
16:36:05 <dhellmann> ah
16:36:28 <dhellmann> well, it would be interesting to cross-check the liaisons list with the attendees
16:36:39 <dhellmann> and find out which projects don't have liaisons at all and invite them to designate one
16:37:05 <harlowja_at_home> ya, probably i think is useful to do, people might not even know its a good idea
16:37:16 <dhellmann> other than handling graduations, I'm not sure we've had that much for liaisons to do this cycle
16:37:27 <dhellmann> it would be useful to get them involved in the oslo.context/oslo.log work, when that kicks off
16:37:30 <harlowja_at_home> show up, complain, blah blah, lol
16:37:50 <dhellmann> I assume if folks have trouble they show up to let us know :-)
16:38:15 <dhellmann> I do especially appreciate the regulars who participate even when there are no particular issues going on
16:38:21 <harlowja_at_home> agreed, me too
16:38:30 <harlowja_at_home> *proactive vs reactive i think is always better
16:38:45 * harlowja_at_home doesn't like being a firefighter, ha
16:39:00 <bknudson> I thought we were all firefighters.
16:39:02 <harlowja_at_home> lol
16:39:13 <harlowja_at_home> only on days that end with 'y'
16:39:18 <dhellmann> heh
16:39:58 * jungleboyj spends way more time fighting fires than I would like.
16:40:03 <harlowja_at_home> part of what i'm thinking, is that there is a bigger tent, lots more code being produced, and feels like we should have bigger increase in involvement around 'common' libraries (as the projects likely duplicate things they don't even know they are duplicating)
16:40:20 <harlowja_at_home> anddd a proactive involvement reduces that (vs reactive where people find it and extract it to oslo)
16:40:29 <dhellmann> jungleboyj: with oslo, or in general?
16:41:10 <dhellmann> harlowja_at_home: having projects propose some of their code to be shared would be a good initiative to bring out more collaboration
16:41:16 <harlowja_at_home> ya
16:41:31 <jungleboyj> dhellmann: In general.  Not oslo's fault.  :-)
16:41:34 <jungleboyj> Sorry.
16:41:39 <dhellmann> jungleboyj: ok, just making sure :-)
16:41:54 <bknudson> btw, with oslo.cache, we should also check that it works with auth_token middleware ( stevemar )
16:42:33 <dhellmann> bknudson: are you anticipating issues because of the way they might interact?
16:42:42 <harlowja_at_home> some kind of 'DRY logo' or something, idk, ha, some kind of proactive understanding that in the end more collaboration is good, and more shared code is good, and all that, especially as the tent gets to be a full on cirque duue soeil  tent
16:42:57 <harlowja_at_home> * Cirque du Soleil
16:43:03 <bknudson> dhellmann: auth_token middleware has its own in-memory cache, like was added to oslo.cache recently, but it was nova's version.
16:43:03 * harlowja_at_home isn't french, lol
16:43:07 <dhellmann> harlowja_at_home: maybe an oslo tag for the governance repo for the projects that participate regularly?
16:43:17 <harlowja_at_home> dhellmann,  possibly, ya
16:44:14 <harlowja_at_home> dhellmann, maybe the moose logo can be the tag, lol
16:44:19 <harlowja_at_home> u have been moose certified
16:44:21 <harlowja_at_home> lol
16:44:32 <harlowja_at_home> *your project has been moosed, lol
16:44:44 <jungleboyj> :-)
16:45:00 <harlowja_at_home> *or something better, may be to subjective :-P
16:45:09 <dhellmann> we should give some thought to what criteria might be useful for managing the tag
16:45:10 <jungleboyj> harlowja_at_home: You better check urban dictionary before using that anywhere.
16:45:17 <harlowja_at_home> jungleboyj, +10
16:45:33 <harlowja_at_home> dhellmann,  agreed
16:46:01 * dhellmann learned something new today
16:46:11 * jungleboyj did too ...
16:46:19 <jungleboyj> I am going to have to use that one.
16:46:21 * harlowja_at_home guess i should look at urban dictionary
16:46:24 <harlowja_at_home> lol
16:46:30 <dhellmann> well, that's something to think about for next week, but I like the idea of finding ways to increase involvement in general
16:46:31 <bknudson> I'm too scared to look at work.
16:46:48 <jungleboyj> bknudson: It is ok.  They didn't disconnect me.
16:47:02 <harlowja_at_home> lol
16:47:07 <bknudson> I'll wait until I get home and then I can moose all I want.
16:47:12 <dhellmann> if no one has anything else, we can stop 15 minutes early and spend the time reviewing patches
16:47:13 * harlowja_at_home yup, learned something new, ha
16:47:41 <jungleboyj> Or we can go get moosed.
16:47:47 <harlowja_at_home> lol
16:48:05 * harlowja_at_home may not get moosed right now
16:48:17 <harlowja_at_home> but u guys can
16:48:18 <harlowja_at_home> lol
16:48:21 <jungleboyj> Probably best.  We don't work in the days of Mad Men.
16:48:28 <dhellmann> heh
16:49:00 * jungleboyj derailed the meeting.  Sorry.
16:49:14 <dhellmann> np, I think we're done
16:49:19 <dhellmann> I'm going to call it a wrap for today
16:49:23 <dhellmann> thanks everyone!
16:49:25 <harlowja_at_home> :)
16:49:32 <jungleboyj> Thanks!
16:50:01 <dhellmann> #endmeeting