16:00:53 <dims> #startmeeting oslo
16:00:53 <dims> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dougwig, e0ne, flaper87, garyk, harlowja, haypo,
16:00:53 <dims> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka,
16:00:54 <openstack> Meeting started Mon Aug  3 16:00:53 2015 UTC and is due to finish in 60 minutes.  The chair is dims. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:55 <dims> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:56 <rpodolyaka1> o/
16:00:58 <ozamiatin> o/
16:00:58 <openstack> The meeting name has been set to 'oslo'
16:00:59 <harlowja_at_home> sup
16:00:59 <redrobot> o/
16:01:02 <droyal> hi
16:01:03 <bknudson> hi
16:01:03 <johnsom> o/
16:01:03 <e0ne> hi
16:01:04 <kgiusti> o/
16:01:28 <dims> hi all
16:01:32 <zzzeek> \o
16:02:02 <dims> let's get started :)
16:02:05 <dims> #topic actions from last week
16:02:05 <dims> #action Dims still has a TODO to organize a virtual doc sprint
16:02:37 <dims> will try to send out dates this week.
16:02:46 <dims> #topic Red flags for/from liaisons
16:03:02 <dims> any liaisons around?
16:03:20 <bknudson> nothing in keystone
16:03:51 <johnsom> Nothing to note from Octavia other than we want to get pyroute2 in requirements
16:04:05 <dims> johnsom: got a review in?
16:04:46 <dims> #topic Releases for this week
16:04:46 <dims> This week we release all of the rest of the libs that have requirements and/or translation updates so we're not out of sync with the rest of the projects. Here are the unreleased changes:
16:04:46 <dims> #link https://etherpad.openstack.org/p/library-releases
16:05:21 <johnsom> yes, just a second
16:05:26 <dims> please review version numbers ^^
16:05:35 <dims> thanks johnsom
16:06:11 <johnsom> My patchset is here: https://review.openstack.org/#/c/207671/ however there is another one here: https://review.openstack.org/#/c/168764/
16:07:07 <dims> johnsom: any interest from neutron or other folks in pyroute2?
16:07:22 <johnsom> It looks like my changes were merged into https://review.openstack.org/#/c/168764/ over the weekend.
16:07:55 <dims> johnsom: ack
16:08:01 <bknudson> we'll be able to use wsgi_scripts in keystone
16:08:22 <dims> bknudson: cool
16:08:23 <johnsom> dims mestery was positive on it when I asked if he had any concerns.  I think the old license was a problem but that has now been resolved.
16:08:33 <bknudson> (unless morganfainberg blocks it)
16:08:41 <dims> sounds good johnsom
16:08:46 <dims> ack bknudson
16:10:07 <dims> rpodolyaka1: zzzeek: seen this yet? https://bugs.launchpad.net/nova/+bug/1480698
16:10:07 <openstack> Launchpad bug 1480698 in OpenStack Compute (nova) "MySQL error - too many connections" [Undecided,New]
16:10:08 <uvirtbot> Launchpad bug 1480698 in nova "MySQL error - too many connections" [Undecided,New]
16:10:09 <uvirtbot> Launchpad bug 1480698 in nova "MySQL error - too many connections" [Undecided,New] https://launchpad.net/bugs/1480698
16:10:33 <zzzeek> dims: ive seen many occasions of that in various contexts, sure
16:10:57 <zzzeek> dims: in fact, the issue could be that the message is exactly accurate :)  and you need to raise mysql_max_connections
16:11:10 <dims> zzzeek: logstash query i think shows it cropping up more hits now i think
16:11:10 <rpodolyaka1> dims: not this one, will take a look
16:11:33 <dims> rpodolyaka1: thanks
16:11:42 <zzzeek> dims: nova only or others as well ?
16:11:54 <dims> zzzeek: saw a lot of neutron hits
16:11:55 <rpodolyaka1> but yeah, this might be caused by some other service using all the connections :P
16:12:23 <dims> ack
16:12:41 <dims> ozamiatin: kgiusti: how's the driver work going on?
16:12:53 <ozamiatin> dims: almost done with notifier https://review.openstack.org/#/c/207503
16:13:01 <ozamiatin> dims: got some unit-tests and refactoring from droyal https://review.openstack.org/#/c/204736/
16:13:09 <ozamiatin> dims: viktors was trying to run zmq + devstack. I will join him this week after the notifier get merged
16:13:23 <dims> ack thanks ozamiatin
16:13:31 <kgiusti> dims: the last blocker for proton 0.10 was submitted
16:13:47 <kgiusti> dims: but there's some disagreement whether it works or not.
16:13:56 <dims> kgiusti: ok
16:14:08 <kgiusti> dims: :P  So there may be a RC1 based on how that resolves.
16:14:54 <dims> cool
16:14:57 <dims> redrobot: droyal: e0ne: anything to share?
16:15:03 <zzzeek> dims: OK i commented, needs more research obviously
16:15:08 <droyal> nope
16:15:26 <dims> zzzeek: ack
16:15:29 <dims> #topic oslo.policy in Nova
16:15:29 <dims> #link http://markmail.org/message/klrvb4etjbvlah4b
16:15:55 <dims> wanted to check if anyone had an opinion on the topic...^^
16:16:03 <harlowja_at_home> ah, that one, adopt all the things!
16:16:20 <dims> esp folks working on oslo.policy
16:17:04 <bknudson> I guess it's up to nova to decide if they want to switch or not.
16:17:53 <bknudson> it's not passing jenkins so that would be a good reason not to merge it
16:18:07 <dims> bknudson: true
16:18:32 <dims> #topic New libraries and drivers - how is it going?
16:18:32 <dims> #link specs - http://specs.openstack.org/openstack/oslo-specs/
16:18:32 <dims> #link library audit - https://docs.google.com/spreadsheets/d/1eTR-pN2GD5cK_tHIMyKNL5vh4N8JtXTptcE1bLd2G3E/edit#gid=0
16:18:47 <dims> anyone here today working on new libraries?
16:19:16 * harlowja_at_home finished all my libraries, so negative, not me
16:19:57 <dims> harlowja_at_home: thanks
16:20:16 <dims> #topic Ongoing work & Review priorities
16:20:16 <dims> #link https://etherpad.openstack.org/p/liberty-oslo-priorities-tracking
16:20:16 <dims> Any stuck reviews? or specs?
16:20:54 <dims> guess nothing :)
16:20:56 <harlowja_at_home> sooo any interesting one
16:20:57 <harlowja_at_home> oh oh
16:20:59 <harlowja_at_home> https://review.openstack.org/#/c/203885/
16:21:19 <harlowja_at_home> ^ starts to make it possible to disconnect eventlet from all the things
16:21:25 <harlowja_at_home> but i wanted peoples thoughts on it
16:21:36 <harlowja_at_home> its similar to how the kazoo library handles different async models
16:21:50 <dims> harlowja_at_home: ack. i've starred it
16:22:12 <harlowja_at_home> it probably could be done a little differently, but it can be a way out of the eventlet for all the things mess
16:22:26 <harlowja_at_home> something to look over, i'm ok with doing it differently... (not strongly attached)
16:22:32 <harlowja_at_home> https://github.com/python-zk/kazoo/tree/master/kazoo/handlers (how kazoo does it)
16:23:10 <harlowja_at_home> so ya, anyone interested let me know
16:23:31 <dims> thanks harlowja_at_home
16:23:34 <dims> #topic Open discussion
16:23:34 <harlowja_at_home> np
16:23:46 <dims> harlowja_at_home: can you please run the meeting next week?
16:23:58 <harlowja_at_home> dims, u've been going to all the meetups recently ya
16:24:03 <harlowja_at_home> dims, sure
16:24:24 <harlowja_at_home> i'll be away 12th -> 23rd (or something like that) so can't run the meetings then
16:24:26 <dims> thanks harlowja_at_home
16:24:27 <harlowja_at_home> but next week is fine
16:24:36 <harlowja_at_home> anything intersting from all the midcycles that u've been to?
16:24:44 <harlowja_at_home> (oslo related or not)
16:25:13 <dims> harlowja_at_home: keystone and nova were the ones i went to. there were new initiatives in keystone, exciting
16:25:26 <harlowja_at_home> cool
16:25:48 <dims> harlowja_at_home: the dynamic policy demo was good for example
16:26:28 <harlowja_at_home> ah, yes i've heard about that, how does that affect the projects? sounds an awfully lot like dynamic config reloading, which i didn't think the projects handled without a sighup
16:26:46 <harlowja_at_home> *dynamic config reloading without software that knows how to do it == hard
16:26:52 <dims> harlowja_at_home: lookup the specs in keystone
16:26:56 <harlowja_at_home> k
16:27:57 <dims> harlowja_at_home: https://etherpad.openstack.org/p/keystone-liberty-midcycle-meetup
16:28:02 <harlowja_at_home> cool
16:28:12 <harlowja_at_home> dims, oh the other idea that i never think got talked about
16:28:21 <harlowja_at_home> an oslo tag (oslo-certified) for the TC?
16:28:27 <harlowja_at_home> (do not call it moosed)
16:28:45 <harlowja_at_home> might be nice to have that on projects as they get tagged or whatever
16:29:23 <harlowja_at_home> maybe tag called 'osloified' lol
16:29:46 <dims> hmm, will think about that.
16:30:00 <harlowja_at_home> k
16:30:07 <kzaitsev_mb> what should a project do to get such a tag then? +)
16:30:27 <harlowja_at_home> ya, thats a good question
16:31:06 <harlowja_at_home> be an active particpant in oslo, have a oslo-cooordiantor person
16:31:37 <dims> not sure what it would mean to an end operator
16:32:13 <harlowja_at_home> ya, something to think about
16:32:36 <dims> thanks harlowja_at_home.. let;s wrap this up for today
16:32:39 <harlowja_at_home> k
16:32:48 <dims> #endmeeting