16:00:53 <dims> #startmeeting oslo
16:00:53 <dims> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dougwig, e0ne, flaper87, garyk, harlowja, haypo,
16:00:53 <dims> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka,
16:00:54 <openstack> Meeting started Mon Aug 17 16:00:53 2015 UTC and is due to finish in 60 minutes.  The chair is dims. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:55 <dims> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:58 <openstack> The meeting name has been set to 'oslo'
16:01:03 <bknudson> hi
16:01:05 <rpodolyaka1> o/
16:01:09 <toabctl> hi
16:01:12 <zzzeek> \o
16:01:16 <jecarey> o/
16:01:31 <kragniz> o/
16:01:36 <jungleboyj> o/
16:01:49 <flaper87> o/ (kinda)
16:01:58 * flaper87 will get better at meetings
16:02:27 <dims> #topic actions from last week
16:02:28 <dims> #action Dims still has a TODO to organize a virtual doc sprint
16:02:35 <dims> i am way behind on that :)
16:02:55 <dims> at least i am back from vacation and catching up on things
16:02:57 <dims> #topic Red flags for/from liaisons
16:03:08 <bknudson> No red flags for keystone that I know of
16:03:27 <jungleboyj> No red flags from Cinder that I am aware of.
16:03:34 <dims> any other liaisons around? thanks bknudson and jungleboyj
16:04:08 <dims> #topic Releases
16:04:36 <dims> i have not yet made the list of releases for this week. planning to do this afternoon
16:05:31 <dims> Any other hot stuff from anyone? looks like we have to decide on oslo.windows spec
16:05:58 <dims> #link https://review.openstack.org/#/c/209193/
16:06:55 <dims> thoughts anyone? i am inclined to agree with dhellmann's notes
16:07:13 <johnsom> Me too
16:07:48 <dims> flaper87: agree?
16:08:02 <flaper87> dims: yup
16:08:29 <flaper87> that sounds like a better plan to me
16:08:46 <dims> cool. thanks
16:08:47 <flaper87> and to be fair, it helps keeping focus for the oslo team
16:08:53 <dims> right
16:09:10 <jungleboyj> Yeah, that makes sense.
16:09:27 <dims> cool
16:09:31 <dims> #topic New libraries and drivers - how is it going?
16:09:53 <kgiusti> Hey - back from vacation - proton 0.10 has been released!
16:09:58 <dims> anyone working on service, cache, reports etc here?
16:10:17 <dims> kgiusti: nice! so we should see green soon in our CI job?
16:10:52 <kgiusti> dims: I've got to port pyngus first, then we should get the WIP patches I've got updated and merged.
16:11:09 <kgiusti> dims: the good news is that I'm the only blocker from here out :D
16:11:15 <dims> kgiusti: sounds good
16:11:17 <dims> :)
16:11:37 * dhellmann is on a flight with bad wifi
16:11:43 <dims> hey dhellmann
16:11:49 <dims> no worries
16:11:54 <dims> Any stuck reviews? or specs?
16:11:54 <bknudson> I don't know what's left for oslo.cache ... needs other projects to use it and show that it's ok.
16:12:04 <dhellmann> I can talk to them about starting up a project team and shepherd them through the process
16:12:13 <bknudson> keystone and nova need to use it.
16:12:33 <dims> bknudson: i remember seeing a WIP for nova, and i had raised some questions, will dig it up later and share
16:12:45 <bknudson> also, I think keystonemiddleware is supposed to be a user.
16:13:36 <dims> ok
16:14:11 <dims> #topic Open discussion
16:14:30 <bknudson> I'm working on a change to use oslo.context in keystone -- https://review.openstack.org/#/c/213595/
16:14:36 <bknudson> so that the request ID gets logged.
16:14:51 <bknudson> for serviceability
16:15:15 <dims> ++
16:16:06 <dims> regarding the oslo.messaging issue with neutron - the switch from RuntimeError to warning has merged - https://review.openstack.org/#/c/213542/
16:16:33 <dhellmann> dims: thanks for picking that up
16:17:08 <dims> yw dhellmann
16:17:21 <dims> please do look at reviews - http://bit.ly/oslo-reviews
16:18:35 <dims> there's a handful with one +2 and needs another
16:19:22 * ihrachyshka lurks
16:20:33 <ihrachyshka> dims, speaking of that oslo.messaging vs. neutron issue mentioned on the -dev list. is it under control from oslo.messaging team side?
16:20:49 <ihrachyshka> or is neutron involvement needed? (I may be out of touch since I haven
16:20:55 * dhellmann will try to do some reviews if the wifi holds up on this flight
16:20:57 <ihrachyshka> 't looked at it with due care)
16:21:29 <dims> ihrachyshka: so, we adjusted oslo.messaging to log warning, but we need a lot of help on neutron side
16:21:56 <ihrachyshka> dims, ok, specific bug to track? or is it in the email?
16:21:57 <dims> especially how api_workers = 0 affects the way the threading stuff
16:22:13 <dims> ihrachyshka: i'll open a bug after this
16:22:15 <dims> meeting
16:22:26 <ihrachyshka> thanks. get me to subscribers at least.
16:22:36 <dims> ack will do
16:23:24 <dhellmann> ihrachyshka: we need to decide what to do about logging errors better in the neutron code
16:25:11 <dims> k if there's nothing else to chat...let's wrap up.
16:25:14 <dims> thanks everyone
16:25:18 <dims> #endmeeting